Subject: RE: [Hubmib] AD review of draft-ietf-hubmib-mau-mib-v3-02.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 17 Nov 2002 21:30:58 +0100

OK, what I got back when talking to IESG (Specifically 
Scott, since he is our process guru) is that in fact
Obsoleted and Historic are equivalent.

When a document obsoletes and earlier one, then that is 
effectively the same as making old one historic. The doc
normally just keeps the tag obsoleted.

When an old doc needs to be obsoleted, but we have no new 
document that actually replaces (obsoletes) such a doc, 
then we typically write a informational RFC in which we 
document and recommend why to make the old document historic.

So it seems that we do not need to make 2668 and such Historic.
What would be our motivation to do so?

Thanks,
Bert 

> -----Original Message-----
> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: zondag 17 november 2002 19:07
> To: Wijnen, Bert (Bert); John Flick (E-mail)
> Cc: Hubmib Mailing List (E-mail)
> Subject: RE: [Hubmib] AD review of draft-ietf-hubmib-mau-mib-v3-02.txt
> 
> 
> > 
> > - Sect 3.1 claims/states that rfc2668 will go to historic.
> >   Well, you can recommend that in this document, but the WG cannot
> >   just declare it. Maybe it is best to write a small doc that
> >   recommends this action, similar to the way it was done for
> >     draft-ietf-hubmib-1643-to-historic-01.txt
> >   And maybe at the same time you can ask to make 2239 Historic
> >   (instead of claiming so in sect 3.2) And are you also trying
> >   to get 1515 to historic per sect 3.3?
> 
> Cannot we avoid the need to issue two Internet-Drafts each 
> time when we release a document that obsoletes a previous RFC 
> to the point of making it Historical? Something like a clause 
> like 'Impact on other Standard Tracks Documents' in the 
> Internet-Draft?  The IESG could debate both actions by the 
> time they approve the new RFC.
> 
> Dan
> 
> > 
> 
_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "C. M. Heard" <[email-masked]>
Date: Tue, 19 Nov 2002 17:31:02 -0800 (PST)

> What would be our motivation to do so?

I think this was a carry-over from previous versions of the
MAU-MIB.  It's clearly not needed, since the document already
states that it obsoletes 2668 and 1515, and I would suggest
that the proper resolution is to remove the "will go to
Historic status" language.  It has not been present in any
other RFC I've seen that obsoletes an existing RFC.

Mike

---

From: "C. M. Heard" <[email-masked]>
Date: Tue, 19 Nov 2002 17:31:02 -0800 (PST)

Mike

---

From: John Flick <[email-masked]>
Date: Tue, 19 Nov 2002 19:16:02 -0800

> other RFC I've seen that obsoletes an existing RFC.

This text may have been an overreaction.  1515 should have been
obsoleted by 2239, but that somehow got lost in the process.  I
think we were trying to make it very explicit in the text of the
document so we didn't lose it this time.

John

---

From: John Flick <[email-masked]>
Date: Tue, 19 Nov 2002 19:16:02 -0800

John