Subject: RE: [Hubmib] Comments on draft-ietf-hubmib-efm-mib-02.txt

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 3 Mar 2005 16:34:49 +0200

Hmmm... I believe that the two Unsigned32 is kind of tolerated by the latest guidelines, so this case is not well defined. I would provide you a waiver to using the UNITS clause, and rather mention in the DESCRIPTION clauses that the combination of the two objects should be displayed as 'packets' for example. 
 
I am copying our friend Mike Heard - he may have a different opinion on this. 

Regards,

Dan

E11. I would strongly recommend to add UNITS clauses for all objects where these apply, especially for counters 

I added units for all of the normal things (bytes, frames, etc.).   How do I handle when a 64-bit quantity is split between two Unsigned32s?  Are both Unsigned32s the same unit thats being counted by the 64-bit quantity, or am i supposed to refer to the Hi/Lo 32-bits as different UNITs?  

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "C. M. Heard" <[email-masked]>
Date: Thu, 3 Mar 2005 08:57:47 -0800 (PST)

On Thu, 3 Mar 2005, Romascanu, Dan (Dan) wrote:
> Hmmm... I believe that the two Unsigned32 is kind of tolerated
> by the latest guidelines, so this case is not well defined. I
> would provide you a waiver to using the UNITS clause, and rather
> mention in the DESCRIPTION clauses that the combination of the
> two objects should be displayed as 'packets' for example.
>
> E11. I would strongly recommend to add UNITS clauses for all
> objects where these apply, especially for counters
> 
> I added units for all of the normal things (bytes, frames,
> etc.).  How do I handle when a 64-bit quantity is split between
> two Unsigned32s?  Are both Unsigned32s the same unit thats being
> counted by the 64-bit quantity, or am i supposed to refer to the
> Hi/Lo 32-bits as different UNITs?
> 

I think that the low and high parts do count different quantities
and so should have different units.  Taking as an example a "split"
octet counter, how about something like

  UNITS "Octets"

for the low-order 32 bits and

  UNITS "4294967296 Octets"
or
  UNITS "2^32 Octets"

for the high order 32 bits?

Mike