Subject: RE: [Hubmib] Response to EPON-MIB-04

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Sun, 22 Jan 2006 18:00:04 +0200

What is exactly the rationale for this request, David? 

The other MIB modules in the family are named EFM-COMMON-MIB and
EFM-CU-MIB. If we are to look for consistency, the names of the MIB
modules defined in this document should be EFM-EPON-MIB and
EFM-EPON-DEVICE-MIB.

Regards,

Dan

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: Friday, January 20, 2006 7:43 PM
> To: [email-masked]
> Cc: Romascanu, Dan (Dan); Hub MIB
> Subject: Re: [Hubmib] Response to EPON-MIB-04
> 
> HI,
> 
> Just saw one more small item. The MIB module is named 
> "DOT3-EFM-EPON-MIB". I suggest that the name "DOT3-EPON-MIB"
> be used instead.
> 
> Regards,
> /david t. perkins
> 
> 
> 

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "David T. Perkins" <[email-masked]>
Date: Sun, 22 Jan 2006 10:40:25 -0800 (PST)

HI,

First, I was pointing out an inconsistancy between the
module name and the descriptor for the the MODULE-IDENTITY.
In lior's lastest I-D, there are
   DOT3-EFM-EPON-MIB DEFINITIONS ::= BEGIN
    <<text deleted>>
   dot3EponMIB MODULE-IDENTITY

This is inconsistent. Thus, the module name should be
 DOT3-EPON-MIB
or the descriptor should be
 dot3EfmEponMIB

However, with regards to the naming scheme for the
collection of documents, I believe the that "EFM"
is not approapriate for the dot3 OAM MIB module
(since it applies to any dot3 technology),
and whether or not the EFM is part of the EPON or
CU MIB modules, this is something for the WG to decide.
However, it seems to me that EFM is a marketing term
and the dot3 is more appropriate. The 802.3ah
document calls the CU and EPON technology "Subscriber
access networks" in the document title, and then
and inside the document there are phrases like:
67.1 Overview
This clause provides information on building Ethernet subscriber
access networks, also referred to as "Ethernet in the First Mile",
or EFM networks. 

Given than "copper" when describing dot3 is ambiguous,
then an additional adjective is needed. But with EPON,
there is no ambiguity. Thus, I suggest the following
module names:
  DOT3-EPON-MIB (or DOT3-EFM-EPON-MIB)
  DOT3-EFM-CU-MIB
  DOT3-OAM-MIB 

Then have consistent descriptors for items defined in
the MIB modules. For the lastest OAM and EPON modules,
the prefixes are dot3Oam and dot3Epon (plus dot3Mpcp,
dot3OmpE, etc).
The CU module has prefixe emfCu.

Regards,
/david t. perkins