Subject: RE: [Hubmib] Review of EFM-04 I-D

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 11 May 2006 14:58:24 +0200

Ok, I did not link through to clause 4.4.1.
So then it seems that 0-63 are not valid values. Or is zero length 
a special case?

Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, May 11, 2006 13:46
> To: Wijnen, Bert (Bert)
> Cc: David T. Perkins; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Hubmib] Review of EFM-04 I-D
> 
> 
> Hi Bert,
> 
> I don't know if the following is what you were looking for in 
> IEEE Std 
> 802.3ah-2004 (please note that IEEE 802.3ah-2004 has been 
> superseded by 
> IEEE 802.3-2005 which I will quote from):
> 
> Subclause 30.3.6.1.8 'aOAMLocalPDUConfiguration' of IEEE Std 
> 802.3-2005 
> reads:
> 
> ATTRIBUTE
> APPROPRIATE SYNTAX:
> INTEGER
> BEHAVIOUR DEFINED AS:
> An eleven bit value corresponding to the Maximum OAMPDU Size 
> value within 
> the OAMPDU Configuration field (see Table 57–9) in the most recently 
> transmitted OAMPDU.;
> 
> 
> In Table 57-9 of IEEE Std 802.3-2005 'Maximum OAMPDU Size' is 
> described 
> as:
> 
> 11-bit field which represents the largest OAMPDU, in octets, 
> supported by 
> the DTE. This value is compared to the remote’s Maximum PDU 
> Size and the 
> smaller of the two is used. Prior to exchanging and agreeing upon a 
> Maximum OAMPDU Size, a DTE sends minFrameSize OAMPDUs. The 
> minimum value 
> is minFrameSize / 8. The maximum value is equal to 
> maxUntaggedFrameSize, 
> which is defined in 4.4.2. The OAMPDUs transmitted by a DTE 
> are limited by 
> both the local DTE’s Maximum OAMPDU size and the remote DTE's Maximum 
> OAMPDU size as indicated in received Information OAMPDUs. A 
> DTE is not 
> required to change the value transmitted in this field after 
> negotiation 
> to an agreed size as each end will dynamically.
> 
> Subclause 4.4.2 of IEEE Std 802.3-2005 'Allowable 
> implementations' defines 
> minFrameSize as 512 bits.
> 
> Hope this helps.
> 
> Regards,
>   David
> 
> 
> 
> "Wijnen, Bert (Bert)" <[email-masked]> wrote on 
> 11/05/2006 12:26:16:
> 
> > W.r.t.
> 
> > >
> > > 4) The syntax of object dot3OamMaxOamPduSize is specified
> > >     as "SYNTAX (0..1518)", but the text says values
> > >     1..63 are not allowed. So, why not
> > >     "SYNTAX (0 | 64..1518)
> > >
> 
> > Mmmm... which document are you looking at?
> > The   that I have says (on page 15)
> > dot3OamMaxOamPduSize OBJECT-TYPE
> > SYNTAX      Unsigned32 (64..1518)
> > UNITS       "octets"
> > MAX-ACCESS  read-only
> > STATUS      current
> > DESCRIPTION
> > "The largest OAMPDU that the OAM entity supports.  OAM
> > entities exchange maximum OAMPDU sizes and negotiate to use
> > the smaller of the two maximum OAMPDU sizes between the peers.
> > This value is determined by the local implementation.
> > "
> > REFERENCE   "[802.3ah], 30.3.6.1.8"
> > ::= { dot3OamEntry 4 }
> > 
> > So it does not have (0..1518) and the DESCRIPTION clause 
> also does not 
> tell
> > me what a value of zero would mean ??
> > I tried to find it in the 802.3ah spec, but have not found it (yet).
> 
> > Bert
> 
> > 
> > _______________________________________________
> > Hubmib mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/hubmib
> 

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: [email-masked]
Date: Thu, 11 May 2006 14:45:09 +0100

Hi Bert,

The following is just my personal view of what IEEE Std 802.3 states, but 
based on the text in Table 57-9 of IEEE Std 802.3-2005 that states that 
'The minimum value is minFrameSize / 8.' and subclause 4.4.2 defining 
minFrameSize as 512 bits the minimum value for Maximum OAMPDU Size is 64.

I therefore believe 0-63 inclusive are not valid, I don't see any special 
case for 0.

Regards,
  David