Subject: RE: [Hubmib] RE: WGLC -http://www.ietf.org/internet-drafts/draft-ietf-hubmib-rfc3636bis-03.txt

From: "C. M. Heard" <[email-masked]>
Date: Mon, 26 Jun 2006 06:36:34 -0700 (PDT)

On Mon, 26 Jun 2006, Edward Beili wrote:
> I've implemented most of the comments and submitted the -04
> draft of the rfc3636bis.

Unfortunately, there are problems with the new REFERENCE clauses
attached to the TCs in the IANA-MAU-MIB.  These should precede the
SYNTAX clause but instead are placed after it, and as a consequence
the MIB module does not compile.  I believe that this should be
fixed before the document goes to the IESG.

Also, regarding this:

> 1. Added 'Obsoletes: 3636, 2668, 1515 (if approved)' to the header.

I think that should probably just say 3636.  RFC 3636 has already
obsoleted 2668 and 1515, and if I am not mistaken, the custom is
that "Obsoletes: " lists are not cumulative.

Mike Heard

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "Edward Beili" <[email-masked]>
Date: Mon, 26 Jun 2006 09:57:42 +0300

Hi,

I've implemented most of the comments and submitted the -04 draft of the rfc3636bis.

Here is the list of all the changes from version -03:

1. Added 'Obsoletes: 3636, 2668, 1515 (if approved)' to the header.
2. Replaced all the appearances of 'this MIB' or 'the basic MIB' to 'the MAU-MIB' where appropriate.
3. Added a reference to 802.3-2005, which includes all the amendments and removed all the references to 802.3-2002.
4. Added the recommendation that IANA adds for each new MAU type approved following an Expert Review a short description of the MAU technology and wherever possible a reference to a publicly available specification
5. Removed altogether Sections 3.2, 3.3 and 3.4. Modify Section 8 (Acknowledgments) to convey exactly the same information as was in Sections 3.2, 3.3 and 3.4
6. Added a bit more info to the DESCRIPTION clauses for the new EFM MAU types. Note that the original unclear DESCRIPTIONs were quoted from the IEEE 802.3 standard.
7. Modified the Security consideration section to refer to both MAU-MIB and IANA-MAU-MIB, inserting text provided by Mike Heard (thanks Mike).
8. Corrected the year in the Copyright notice to 2006.
9. Aligned the IANAifMauMediaAvailable bit descriptions, relevant to the 2BASE-TL/10PASS-TS PHYs, to the text in EFM-CU-MIB.
10. Removed the word 'reference' in some 'REFERENCE' clauses.

See below the rebuttal for the comments submitted by Dan.

I've attached the .txt, .html versions of the -04 draft as well as both MIB modules.

Regards,
-E.  

>-----Original Message-----
>From: C. M. Heard [mailto:[email-masked]] 
>Sent: Saturday, June 24, 2006 20:18
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [Hubmib] RE: WGLC -http://www.ietf.org/internet-drafts/draft-ietf-hubmib-rfc3636bis-03.txt
>
>On Thu, 22 Jun 2006, Romascanu, Dan (Dan) wrote:
>> Please record the following comments: 
>> 
>> 1. The document should bear the header: 'Obsoleted RFC 3636 (when approved)

Done.

>> 2. s/in order to decrease re-issues of the basic MIB module./in order to decrease the need of updating the basic MAU MIB module./

Done.

>> 3. It would be good to point references for the EFM and 10GBASE-CX4 standards from the Introduction section.

Since the EFM and 10GBASE-CX4 as well as other amendments are now part of the base 802.3-2005 specification, I decided to leave the text as it is. Note that relevant references are given in the Overview section a few lines below the Introduction section.

>> 4. IANA Considerations - I would add the recommendation that IANA adds for each new MAU type approved following an Expert Review a short description of the MAU technology and wherever possible a reference to a publicly available specification

Done.

>> 5. Do we really need to carry 3.2, 3.3, and 3.4 in the body of the 
>> specification? Unless somebody tells me a good reason to keep them I 
>> would see those moved in an appendix
>
>Actually, all the information in 3.2, 3.3, and 3.4 is adequately covered in the Acknowledgments section, and rather than move these sections into an appendix I think it would be better just to drop them altogether.

Removed sections 3.2, 3.3 and 3.4 and modified the Acknowledgments section to convey exactly the same information.

>> 6. Some of the DESCRIPTION clauses for the new MAUs seem incomplete and or duplicated - for example dot3MauType100BaseBX10D and the following 100 and 100 MAUs

The DESCRIPTION clauses for the new EFM MAUs were taken as is from the IEEE 802.3-2005. While all the MAU types listed are correct and not duplicated, I've expanded the description a bit in a hope to enhance clarity.

>> 7. The Security Considerations section must slightly change its 
>> content as the document now deals with two MIB modules rather than one
>
>Here is a specific proposal from some text.
>
>(a) add some text to the effect that the IANA-MAU-MIB does not per se have any effect on the security of the Internet, as it contains only TCs and no managed objects.  I would suggest the following, added to the beginning of the Security Considerations section:
>
>   The IANA-MAU-MIB does not define any management objects.  Instead, it
>   defines a set of textual conventions which are used by the
>   MAU-MIB and may be used by other MIB modules to to define management
>   objects.  Meaningful security considerations can only be written for
>   MIB modules that define management objects.
>
>(b) retain the remainder of the current text with "this MIB module"
>replaced by "the MAU-MIB".

Done according to Mike's suggestion.

>> 8. The year in the copyright notice in the MIB modules text should be changes to 2006

Done.