Subject: [Hubmib] Re: PLS review BEFORE 10 Jan 2007 - IANA-MAU-MIB under mib-2 (rfc3636bis)

From: "C. M. Heard" <[email-masked]>
Date: Wed, 3 Jan 2007 07:18:09 -0800 (PST)

On Wed, 3 Jan 2007 12:23:15 +0100 Bert Wijnen wrote:
> draft-ietf-hubmib-rfc3636bis-05.txt is in the RFC-editor Queue
> and is in a stage where IANA wants to make the final
> registration for the IANA-MAU-MIB.
> During that step, we found that the document
>    draft-ietf-hubmib-rfc3636bis-05.txt
> suggest to put this new IANA-maintained MIB module under
>    ::= { mib-2 snmpDot3MauMgt(26) 7 } -- mauMod+1
> 
> It is not a (fatal) technical flaw, but...
> sofar, ALL IANA maintained MIB modules are located
> directly under mib-2. I missed this during my reviews.
> 
> The proposal now is to make this MIB module location inline
> with all other IANA maintained MIB modules and so to ask
> for assignment as follows:
>
>   IANA-MAU-MIB
>   .. snip ..
>   ianaMauMIB MODULE-IDENTITY
>    .. snip ..
>    ::= { mib-2 nnn } -- to be assigned by IANA
> 
> Pls speak up BEFORE 10 Jan 2007 if you see an issue with this
> (late) change.
> Silence will (this time) be interpreted as no-objection.

Here is some perspective from the MIB Doctor reviewer.

Although I recommended during my early reviews to put the
MODULE-IDENTITY value for the IANA-MAU-MIB under mib-2, I
also noted that it is not a technical flaw to have it
set to { mib-2 snmpDot3MauMgt(26) 7 }.  So I let it pass
as long as the assignment was noted with the appropriate
ASN.1 comments in the MAU-MIB, which "owns" the
{ mib-2 snmpDot3MauMgt(26) } OID branch, which was done.

I am frankly uneasy about making such last-minute changes
if they are not necessary to correct technical flaws, as
they tend to introduce errors or inconsistencies elsewhere.
If the WG does agree to make the change to the IANA-MAU-MIB
MODULE-IDENTITY assignment, then the following change also
needs to be made to the ASN.1 comments in the MAU-MIB:

OLD:
    -- the following OID is the MODULE-IDENTITY value
    -- for this MIB module:   { snmpDot3MauMgt 6 }

    -- the following OID is the MODULE-IDENTITY value
    -- for the IANA-MAU-MIB:  { snmpDot3MauMgt 7 }

NEW:
    -- the following OID is the MODULE-IDENTITY value
    -- for this MIB module:   { snmpDot3MauMgt 6 }

The text to be removed is at the bottom of p. 12 and the
top of p. 13 of draft-ietf-hubmib-rfc3636bis-05.txt.

Mike

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Tue, 16 Jan 2007 10:03:31 +0100

The only comment I have seen is that Mike feels a bit
uneasy about the change, because of a risk of messing up.
(not that I had stated that silence would be interpreted
as no objection). 

The good news is that Mike also included additional instructions
to make sure we do not mess up. Thanks Mike.

SO I interpret this as consensus to request IANA for the change.
So I will tell IANA that we want the change as follows:

Document draft-ietf-hubmib-rfc3636bis-05.txt suggests to put 
the new IANA-maintained IANA-MAU-MIB module under

It is not a (fatal) technical flaw, but...
sofar, ALL IANA maintained MIB modules are located directly under 
mib-2. I missed this during my reviews (as HUBMIB WG chair).
 
The WG has consensus to make this MIB module location inline 
with all other IANA maintained MIB modules and so we ask for 
assignment as  follows:

   IANA-MAU-MIB
   .. snip ..

Pls note that this also means that these comments need to
be changed (bottom of page 12, top of page 13) by the
RFC-Editor:
OLD:
    -- the following OID is the MODULE-IDENTITY value
    -- for this MIB module:   { snmpDot3MauMgt 6 }

NEW:

Bert Wijnen
HUBMIB WG chair

> -----Original Message-----
> From: C. M. Heard [mailto:[email-masked]] 
> Sent: woensdag 3 januari 2007 16:18
> To: Hub Mib
> Subject: [Hubmib] Re: PLS review BEFORE 10 Jan 2007 - 
> IANA-MAU-MIB under mib-2 (rfc3636bis)
> 
> > draft-ietf-hubmib-rfc3636bis-05.txt is in the RFC-editor 
> Queue and is 
> > in a stage where IANA wants to make the final registration for the 
> > IANA-MAU-MIB.
> > sofar, ALL IANA maintained MIB modules are located directly under 
> > mib-2. I missed this during my reviews.
> > 
> with all 
> > other IANA maintained MIB modules and so to ask for assignment as 
> > follows:
> >
> >   IANA-MAU-MIB
> >   .. snip ..
> also noted that it is not a technical flaw to have it set to 
> { mib-2 snmpDot3MauMgt(26) 7 }.  So I let it pass as long as 
> the assignment was noted with the appropriate
> ASN.1 comments in the MAU-MIB, which "owns" the { mib-2 
> snmpDot3MauMgt(26) } OID branch, which was done.
> 
> I am frankly uneasy about making such last-minute changes if 
> they are not necessary to correct technical flaws, as they 
> tend to introduce errors or inconsistencies elsewhere.
> The text to be removed is at the bottom of p. 12 and the top 
> of p. 13 of draft-ietf-hubmib-rfc3636bis-05.txt.
> 
> Mike
>