Subject: [hybi] updated HyBi BoF Agenda

From: Salvatore Loreto <[email-masked]>
Date: Tue, 03 Nov 2009 19:38:30 +0200

Hi there,

here an updated HyBi BoF Agenda :

Tuesday, November 10, 2009
1300-1500 Afternoon Session I
Cattleya 1 APP hybi BiDirectional or Server-Initiated HTTP BOF

5min - agenda bash (chairs)
5min - goal and purpose of the BoF (chairs)
5min - Design space (Peter Saint-Andre)
10min - charter proposal overview (chairs)
- technical contribution so far:
10min - short term and requirements input (Greg Wilkins)
- long term and requirements input :
15min - W3C / WebSocket prospective (Michael Smith)
15min - WebSocket protocol in IETF (Lisa Dusseault)
15min - alternative prospectives e.g. BWTP (Greg Wilkins)
20min - charter proposal & open discussion
10min - calling the question (chairs)

any comments, suggestions and proposals are very welcome!

Cheers
Salvatore Loreto
www.sloreto.com

---

From: Pieter Hintjens <[email-masked]>
Date: Tue, 3 Nov 2009 19:14:20 +0100

> 15min - alternative prospectives e.g. BWTP (Greg Wilkins)

Apologies for being pedantic, Salvatore, but you are positioning
WebSocket and BWTP as "alternatives", which is IMO inviting conflict.
Probably you want each of these in their own problem+solution space,
and then see how those fit the HyBi goals.

-Pieter

---

From: Salvatore Loreto <[email-masked]>
Date: Tue, 03 Nov 2009 20:28:07 +0200

Hi Pieter,

thanks for comment, I am the one that have to apologize,
it was not my intention to invite conflicting.
You are absolutely right, maybe alternative is not the right word,
I should have used something like "different" prospective or
even more explicitly "different problem/solution space"!

If you think that it sounds better, I'll correct it in the agenda!

/Sal

---

From: Pieter Hintjens <[email-masked]>
Date: Wed, 4 Nov 2009 11:07:40 +0100

> even more explicitly "different problem/solution space"!

What we have, I think, are a set of independent specification projects
in progress, each addressing part of the overall problem space.  That
leads us to questions of what exactly their problem spaces are, what
their status is in terms of implementation and proof, and what scope
there is for coordination, competition and/or interoperability.

Greg, Ian, does that sound right or am I being presumptuous here?

-Pieter

---

From: Greg Wilkins <[email-masked]>
Date: Wed, 04 Nov 2009 21:23:16 +1100

I don't think we should stress "independent" any more than
we should stress trying to find a one size fits all solution.

While there may be different use-cases, there is also a huge
amount of commonality between what any of the solutions needs
to achieve.

So maybe lets just say "other protocols & proposals".

Note - while my name is down against this section, I don't
want to monopolize the whole 15m.  If anybody anticipates
wanting to speak during this period - please contact me
and we can divide up the time - plus leave time for others
to speak from the floor... or move into the following
open discussion earlier than scheduled.

cheers

Pieter Hintjens wrote:
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi

---

From: Salvatore Loreto <[email-masked]>
Date: Thu, 05 Nov 2009 16:55:27 +0200

Hi there,

here the last updated HyBi BoF Agenda :

  15min  -    Other protocols and related use-cases (Greg Wilkins)
  30min  -    charter proposal & open discussion

Cheers
Salvatore Loreto
www.sloreto.com

---

From: John Fallows <[email-masked]>
Date: Fri, 6 Nov 2009 19:25:19 +0000

Salvatore,

I would be interested to present for 5-10mins from the perspective of
a WebSocket vendor about how customers are deploying our technology
today.

Kind Regards,
John Fallows.

-- 
>|< Kaazing Corporation >|<
John Fallows | CTO | +1.650.960.8148
888 Villa St, Ste 410 | Mountain View, CA 94041, USA