Subject: [hybi] WSTP? was: websocket WebSocket websockets Web Sockets ??????????

From: Greg Wilkins <[email-masked]>
Date: Sat, 27 Feb 2010 08:45:09 +0100

All,

I think we need to agree on a standard form of the name for this
protocol.

W3C api document uses "Web Sockets API".

The hixie draft uses "Web Socket protocol" in text, but
headers like "WebSocket-Protocol"  (not "Web-Socket-Protocol").

We should decide if it 1 word or two, singular or plural,
camel case or not etc.

Actually, for that matter, do we have to use the name web sockets
at all?   It strikes me that it is a little bit of a legacy name
and does not really reflect anything meaningful in the protocol
space.   A socket is after all an API concept and not a protocol
concept.

It also is out of line with all the other protocols names that
we have: HTTP, FTP, SMTP, BEEP, SPDY, BWTP, XMPP

I'm wondering if we should not pick a new name that both
encompasses both the history and more common naming practises

Why not WSTP?   which can stand for Web Socket Transport Protocol,
ie the protocol serves as a transport for the Web Socket API.

Sure this does not fix that "Socket" is not really meaningful
for a protocol.  But the WS will be used mostly and is no more
or less accurate than the HT in HTTP is.

cheers

---

From: KOMATSU Kensaku <[email-masked]>
Date: Sat, 27 Feb 2010 19:09:15 +0900

Hi Greg

I think "WSTP" is a good idea. This name involving part of HTTP, so
it also suggests that "this protocol has a relationship with HTTP" for
new comers. :-)
( That'll be very confortable when we present in some technical-seminar or so. )

BTW, protocol name is often used as schema name.
    HTTP => http://foo/bar, FTP => ftp://foo/bar2
So, in this scenario, I think specificaton has to change schema name, like other
protocols.
( ws => wstp, wss => wstps? )

Best regards
Kensaku
---
Kensaku KOMATSU
http://code.google.com/p/websocket-sample/

2010/2/27 Greg Wilkins <[email-masked]>:
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 1 Mar 2010 06:51:29 +0800

An argument for consistency could just as well be used to maintain the existing name.  Do you actually know what BEEP stands for?

I don't see the name as a particular problem - I've come to live with worse.  On the contrary, the name has a certain value.

--Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Greg Wilkins
> Sent: Saturday, 27 February 2010 6:45 PM
> To: [email-masked]
> Subject: [hybi] WSTP? was: websocket WebSocket websockets Web Sockets
> ??????????
> 
> 
> 
> All,
>