Subject: Re: [hybi] WSTP? was: websocket WebSocket websockets Web Sockets ??????????

From: Greg Wilkins <[email-masked]>
Date: Mon, 01 Mar 2010 09:02:09 +0100

Thomson, Martin wrote:
> An argument for consistency could just as well be used to maintain the existing name.  Do you actually know what BEEP stands for?
> 
> I don't see the name as a particular problem - I've come to live with worse.  On the contrary, the name has a certain value.

I'm not opposed to keeping the name.... but which one?

 Web Sockets
 WebSockets
 Web Socket
 WebSocket
 Websocket

I just though that WSTP would be a simpler way to avoid those
multiple names when precision is needed, but still allow
us to use any of the above in text.

cheers

---

From: Gurkan Erdogdu <[email-masked]>
Date: Mon, 1 Mar 2010 10:10:43 +0200

Hello;

I am a keen observer of this group.  I have started to work on similar
topics while implementing Bayeux Protocol over JMS Topics. (enough ad :)
back to topic!)

For name+1 for the WSTP. Web Socket Transport Protocol, it is a cool name!

--Gurkan Erdogdu
Apache OpenWebBeans PMC Chair
gurkanerdogdu.blogspot.com

2010/2/27 Greg Wilkins <[email-masked]>

>
>
> All,
>
> I think we need to agree on a standard form of the name for this
> protocol.
>
> W3C api document uses "Web Sockets API".
>
> The hixie draft uses "Web Socket protocol" in text, but
> headers like "WebSocket-Protocol"  (not "Web-Socket-Protocol").
>
> We should decide if it 1 word or two, singular or plural,
> camel case or not etc.
>
>
> Actually, for that matter, do we have to use the name web sockets
> at all?   It strikes me that it is a little bit of a legacy name
> and does not really reflect anything meaningful in the protocol
> space.   A socket is after all an API concept and not a protocol
> concept.
>
> It also is out of line with all the other protocols names that
> we have: HTTP, FTP, SMTP, BEEP, SPDY, BWTP, XMPP
>
>
> I'm wondering if we should not pick a new name that both
> encompasses both the history and more common naming practises
>
> Why not WSTP?   which can stand for Web Socket Transport Protocol,
> ie the protocol serves as a transport for the Web Socket API.
>
> Sure this does not fix that "Socket" is not really meaningful
> for a protocol.  But the WS will be used mostly and is no more
> or less accurate than the HT in HTTP is.
>
> cheers
>
>
>
>
>
>
>
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>

-- 
Gurkan Erdogdu
http://gurkanerdogdu.blogspot.com

---

From: Ian Hickson <[email-masked]>
Date: Mon, 1 Mar 2010 08:55:47 +0000 (UTC)

> I'm not opposed to keeping the name.... but which one?

The spec is intended to define how to open "a Web Socket", so that you can 
"use Web Sockets to implement" something. The protocol is thus the "Web 
Socket protocol". The DOM object that uses this is called "WebSocket", and 
for consistency I've used that camel case spelling for all other 
Web-Socket-related identifiers (such as the Upgrade keyword, or header 
names).

If there's an inconsistency in the spec, please let me know so I can fix 
it. If there's an inconsistency in e-mails or blog posts or whatnot... I 
don't think that really matters. :-)

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

---

From: Greg Wilkins <[email-masked]>
Date: Mon, 01 Mar 2010 10:35:48 +0100

Ian Hickson wrote:
> it.

Ian,

the spec is indeed inconsistent and uses  "Web Socket", "WebSocket"
and even "Websocket".

This is not just in the document, but on the wire as the
The Upgrade request uses "WebSocket", while the 101 response
uses "Web Socket".

If the normal name is "WebSocket" then the use of "Web Socket" should
be removed from the document and 101 response.

If the normal name is "Web Socket", then the upgrade should
be to "Web-Socket" and the headers "WebSocket-Protocol,
WebSocket-Origin and WebSocket-Location should all start
with "Web-Socket-".

There is also inconsistency with http://dev.w3.org/html5/websockets/
which uses the plural.

This kind of stuff is really important for avoiding bugs
and interoperability.  I've for years dealt with the fallout
from a similar oversight where JSESSIONID is the cookie, but
jsessionid is the URL parameter.

So do think there is a need to fix this consistency, and unfortunately
that will effect what goes on the wire (at least for the response
reason).

So if we are changing, then as with all naming changes,
they are easier the sooner you make them.  So if there
is a desire for a more significant name change - now is the time.

So, I raise the appropriateness of "Socket" in the name - specially now
that the API and protocol have been split.   The use of "Socket" makes
perfect sense for the API, as a socket is the end point.  But it makes
no sense for  a protocol.

If we were to switch to WSTP, we would:

  + be able to fix the inconsistencies in the current draft
  + save 6 bytes in headers and response lines (yipee!!!!)
  + look more like a "normal" protocol name
  + maintain an association with WebSocket API via the WS part
  + Have a clear on the wire distinction between implementations
    working on the current WHATWG WebSocket draft and those
    implementing the future IETF WSTP/1.0 standard.

Of course good implementations can be forgiving in what
they receive and can accept either WSTP/1.0 or Web Socket or WebSocket
at least for a while.  (Note that this was going to
have to happen once multiple versions occur anyway).

cheers

---

From: Maciej Stachowiak <[email-masked]>
Date: Mon, 01 Mar 2010 01:47:57 -0800

My suggestion: let's have the normal name be "WebSocket" in all  
contexts, in APIs, in protocols and in English. The experience of  
"HTML5" vs "HTML 5" makes me think that names differing only by a  
space will needlessly confuse people.

  - Maciej

On Mar 1, 2010, at 1:35 AM, Greg Wilkins wrote:

>>>> An argument for consistency could just as well be used to  
>>>> maintain the existing name.  Do you actually know what BEEP  
>>>> stands for?
>>>>
>>>> I don't see the name as a particular problem - I've come to live  
>>>> with worse.  On the contrary, the name has a certain value.

---

From: Ian Hickson <[email-masked]>
Date: Mon, 1 Mar 2010 09:52:24 +0000 (UTC)

On Mon, 1 Mar 2010, Greg Wilkins wrote:
> 
> the spec is indeed inconsistent and uses "Web Socket", "WebSocket" and 
> even "Websocket".
> 
> This is not just in the document, but on the wire as the The Upgrade 
> request uses "WebSocket", while the 101 response uses "Web Socket".

This is actually consistent with what I described in my previous e-mail.

On Mon, 1 Mar 2010, Maciej Stachowiak wrote:
> "HTML5" vs "HTML 5" makes me think that names differing only by a space 
> will needlessly confuse people.

Ok.

---

From: Greg Wilkins <[email-masked]>
Date: Mon, 01 Mar 2010 11:08:56 +0100

> This is actually consistent with what I described in my previous e-mail.

Ian

Must you always adopt the "it's already perfect" stance and then
fight everything every step of the way?

Even your email wasn't consistent:

 "I've used that camel case spelling for all other Web-Socket-related
  identifiers"

But I'll take your "OK" to Maciej as meaning that the draft will
be changed to use "WebSocket" in all contexts.  Great!

cheers

---

From: "Anne van Kesteren" <[email-masked]>
Date: Mon, 01 Mar 2010 11:12:55 +0100

>  "I've used that camel case spelling for all other Web-Socket-related

Isn't that just English grammar rules?

http://en.wikipedia.org/wiki/English_compound#Hyphenated_compound_adjectives

-- 
Anne van Kesteren
http://annevankesteren.nl/