Subject: Re: [hybi] Reliable message delivery (was Re: Technical feedback.)

From: Salvatore Loreto <[email-masked]>
Date: Sun, 07 Mar 2010 20:23:40 +0200

in the HyBi charter we clearly state:

   Wide browser support is a goal for the bidirectional communication
   mechanism, however the solution should also be suitable for clients
   other than Web Browsers.

so the protocol MUST support also non-browser clients.

/Sal

Salvatore Loreto
www.sloreto.com

On 02/03/2010 07:02 PM, Scott Ferguson wrote:
> Justin Erenkrantz wrote:
>    
>> On Wed, Feb 3, 2010 at 8:54 AM, Mridul Muralidharan<[email-masked]>  wrote:
>>
>>      
>>> Is hybi expected to be limited only to javascript or even browser based clients ?
>>> I was assuming other clients might also be interested in leveraging it ? (if nothing else, for async notifications on top of http).
>>>
>>>        
>> As I have mentioned before, I am certainly interested in non-browser
>> applications.  -- justin
>>
>>      
> We're using it for server to server messaging (using the binary packet
> encoding) as well as non-browser clients.
>
> -- Scott
>    
>> _______________________________________________
>> hybi mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/hybi
>>
>>
>>
>>
>>      
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>

---

From: Adam Barth <[email-masked]>
Date: Sun, 7 Mar 2010 10:34:48 -0800

> so the protocol MUST support also non-browser clients.

Doesn't that say "should" rather than "must"?

Adam

---

From: Salvatore Loreto <[email-masked]>
Date: Sun, 07 Mar 2010 20:43:55 +0200

> Doesn't that say "should" rather than "must"?
you are right Adam,  it is a should ...
but it is in some way more that a should if we consider
the following statement in the charter:

  The Working Group will work to standardize a
   generic solution that can work efficiently in as many of the deployed
   environments as possible and in particular in all the elements of the
   web infrastructure (e.g. web browser, generic HTTP client, HTTP server
   and HTTP-aware intermediaries like proxies, load balancers, caches,
   etc.) and it is not specific for just one.

in any case at moment we do not have any requirement about it;

do people think it would be better have a specific one
in the requirement draft?

/Sal

Salvatore Loreto
www.sloreto.com

---

From: Ian Hickson <[email-masked]>
Date: Mon, 8 Mar 2010 06:20:24 +0000 (UTC)

On Sun, 7 Mar 2010, Salvatore Loreto wrote:
>
> [regarding a requirement on non-browser clients being supported]
> 
> do people think it would be better have a specific one in the 
> requirement draft?

What would a protocol that _didn't_ satisfy this requirement look like?

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'