Subject: [hybi] IANA registrations from draft-ietf-hybi-thewebsocketprotocol

From: Joe Hildebrand <[email-masked]>
Date: Wed, 28 Jul 2010 15:12:06 +0200

It was just brought to our attention that when
draft-hixie-thewebsocketprotocol was republished as
draft-ietf-hybi-thewebsocketprotocol, the provisional IANA registrations
contained therein were not updated.  The Hybi chairs request IANA update the
references as soon as is practical.

TODO list:
- ws: URI scheme
- wss: URI scheme
- WebSocket HTTP Upgrade keyword
- Sec-WebSocket-Key1 and Sec-WebSocket-Key2 HTTP headers
- Sec-WebSocket-Location HTTP header
- Sec-WebSocket-Origin HTTP header
- Sec-WebSocket-Protocol HTTP header

Thanks!

-- 
Joe Hildebrand
(As HyBi chair)

---

From: Greg Wilkins <[email-masked]>
Date: Wed, 28 Jul 2010 23:16:37 +1000

> - Sec-WebSocket-Protocol HTTP header

Which begs the question.... what is the "Sec-" bit about?

---

From: Joe Hildebrand <[email-masked]>
Date: Wed, 28 Jul 2010 15:18:30 +0200

Removing IANA from the internal WG discussion.

-- 
Joe Hildebrand
(as chair)

---

From: "Anne van Kesteren" <[email-masked]>
Date: Wed, 28 Jul 2010 16:35:18 +0200

> Which begs the question.... what is the "Sec-" bit about?

It prevents them from being used by XMLHttpRequest.

-- 
Anne van Kesteren
http://annevankesteren.nl/

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 29 Jul 2010 23:30:37 +0000

Hi all,

> - WebSocket HTTP Upgrade keyword

See
http://www.iana.org/assignments/uri-schemes.html
http://www.iana.org/assignments/http-upgrade-tokens

> - Sec-WebSocket-Protocol HTTP header

cheers,

Amanda Baber
IANA