Subject: Re: [hybi] New Version Notification for draft-cridland-hybi-upgrade-connect-00

From: Dave Cridland <[email-masked]>
Date: Tue, 07 Dec 2010 16:52:29 +0000

FYI. Largely the same proposal, but written up a bit more.

On Tue Dec  7 16:47:59 2010, IETF I-D Submission Tool wrote:
> 
> A new version of I-D, draft-cridland-hybi-upgrade-connect-00.txt  
> has been successfully submitted by Dave Cridland and posted to the  
> IETF repository.
> 
> Filename:	 draft-cridland-hybi-upgrade-connect
> Revision:	 00
> Title:		 A WebSocket handshake proposal using Upgrade and CONNECT  
> masking
> Creation_date:	 2010-12-07
> WG ID:		 Independent Submission
> Number_of_pages: 5
> 
> Abstract:
> This document proposes a handshake design for WebSockets based on an
> Upgrade with a first-frame of a pseudo-request CONNECT.
> 
> 
> 
> The IETF Secretariat.
> 
> 
> 
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade

---

From: Joe Mason <[email-masked]>
Date: Wed, 8 Dec 2010 10:54:27 -0500

I'd really like to see some more discussion of this proposal from the people who were adamantly against CONNECT.  Does it overcome your objections?

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Dave Cridland
> Sent: Tuesday, December 07, 2010 11:52 AM
> To: Server-Initiated HTTP
> Subject: Re: [hybi] New Version Notification for draft-cridland-hybi-
> upgrade-connect-00
> 
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Julian Reschke <[email-masked]>
Date: Wed, 08 Dec 2010 17:01:09 +0100

> I'd really like to see some more discussion of this proposal from the people who were adamantly against CONNECT.  Does it overcome your objections?

Technically, it's not CONNECT, as far as I understand, so it should 
overcome those objections by definition.

Best regards, Julian