Subject: [hybi] how to better document FAQ and other stuff

From: Salvatore Loreto <[email-masked]>
Date: Thu, 24 Feb 2011 17:26:58 +0200

(as co-chair)

Hi there,

after reading the last two days mails,
I think that it would be good have a FAQ where newcomers can find some 
information,
to understand a little better the rational behind some choice and other 
stuff,
without be forced to go through all the HyBi mail archives... (more the 
6000mails)
or put on the editor and wg main contributors shoulders the 
responsibility to provide the information.

I have created a wiki page, within the IETF website, where we can start 
to collect info:
http://trac.tools.ietf.org/wg/hybi/trac/wiki/FAQ

in order to update the page you need to login,
if you do not have a login/pw you can get one from here: 
http://trac.tools.ietf.org/tools/loginmgr/newlogin

anyone can contribute to build the FAQ.
I have already received mails from people interested to contribute,
so people interested/eager to contribute
can start to contribute and just notify the HyBi ml when they do some 
change.

About the possibility to also document more information within a draft,
I don't think draft-ietf-hybi-thewebsocketprotocol is the right document 
for that;
instead we can use the 
http://tools.ietf.org/html/draft-ietf-hybi-design-space
as I have been suggested by Stefano Salsano

cheers
/Sal

-- 
Salvatore Loreto
www.sloreto.com

---

From: Bruce Atherton <[email-masked]>
Date: Thu, 24 Feb 2011 13:28:40 -0800

I've added a section on how the decision for masking was achieved. 
Hopefully it will clarify some things being discussed. I've tried to 
represent the majority of opinions expressed during the debates several 
months ago, but if someone feels I've misrepresented a position or left 
out something important, please edit it to make it more representative 
of the history.

On 24/02/2011 7:26 AM, Salvatore Loreto wrote:
> to understand a little better the rational behind some choice and 
> other stuff,
> without be forced to go through all the HyBi mail archives... (more 
> the 6000mails)
> I have created a wiki page, within the IETF website, where we can 
> start to collect info:
> I don't think draft-ietf-hybi-thewebsocketprotocol is the right 
> document for that;
> instead we can use the

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 24 Feb 2011 23:06:15 +0100

2011/2/24 Bruce Atherton <[email-masked]>:
> I've added a section on how the decision for masking was achieved. Hopefully
> it will clarify some things being discussed. I've tried to represent the
> majority of opinions expressed during the debates several months ago, but if
> someone feels I've misrepresented a position or left out something
> important, please edit it to make it more representative of the history.

I strongly appreciate it. I'm reading it right now and it's a really
BIG help to understand current point of the specification.

This is the way (rather than having to navigate through 2000 old
mails). Really thanks a lot for your effort.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Takeshi Yoshino <[email-masked]>
Date: Fri, 25 Feb 2011 13:18:37 +0900

I've copied my note to the wiki.

Takeshi

On Fri, Feb 25, 2011 at 06:28, Bruce Atherton <[email-masked]> wrote:

> months ago, but if someone feels I've misrepresented a position or left out
> something important, please edit it to make it more representative of the
> history.
>
>
>> or put on the editor and wg main contributors shoulders the responsibility
>> to provide the information.
>>
>> I have created a wiki page, within the IETF website, where we can start to
>> collect info:
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>