Subject: [hybi] RFC 6455 WebSockets Frame to Message assembly

From: Scott Morgan <[email-masked]>
Date: Fri, 8 Mar 2013 18:29:37 -0600

Hi Again,

   Again I am sorry if these comments are in the wrong place (email list).

I have been reading;
http://webtide.intalio.com/2012/10/jetty-9-updated-websocket-api/

I have been wondering how multiple multiple frame messages would share a
connection and get reassembled.   The specification doen't seem to mention
this;
Ie
Fancy multithreaded Client Sends 2 messages over a single socket;
    Frame A, part One of 20,000 leagues under the sea
    Frame B, part One of The Hobbit
    Frame C, part Two of 20,000 leagues under the sea
    Frame D, part Two of the Hobbit yea

How should the frames be identified as belonging to the Hobbit?
I suggest we use the masking key as a id, however I am not sure if it would
be unique enough.

Cheers,
Scott

---

From: Joakim Erdfelt <[email-masked]>
Date: Fri, 8 Mar 2013 17:35:39 -0700

You can't interleave websocket messages like that over a single websocket
connection.

You have to finish all the frames for one websocket message before you can
start another websocket message.

--
Joakim Erdfelt <[email-masked]>
webtide.com <http://www.webtide.com/>
Developer advice, services and support
from the Jetty & CometD experts
eclipse.org/jetty - cometd.org

On Fri, Mar 8, 2013 at 5:29 PM, Scott Morgan <[email-masked]> wrote:

> I suggest we use the masking key as a id, however I am not sure if it
> would be unique enough.
>
>
> Cheers,
> Scott
>
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>
>

---

From: "John A. Tamplin" <[email-masked]>
Date: Fri, 8 Mar 2013 20:17:56 -0500

> I suggest we use the masking key as a id, however I am not sure if it

You would need to add your own message layer above WebSocket, or use the
mux extension which is under development.

-- 
John A. Tamplin