Subject: Re: [hybi] Reference Implementation of draft-ietf-hybi-permessage-compression-07 ?

From: Takeshi Yoshino <[email-masked]>
Date: Mon, 1 Apr 2013 23:48:05 +0900

We are going to implement it on pywebsocket soon, and then Chrome. I'll
tell you here when they're ready.

Takeshi

On Fri, Mar 29, 2013 at 2:18 AM, Joakim Erdfelt <[email-masked]> wrote:

> Is there a reference implementation of this draft of
> permessage-compression?
> I'd like to figure out what is wrong with our use of the Java built-in
> deflate libraries (as we could never quite get x-deflate-frame to work with
> chrome)
>
> --
> Joakim Erdfelt <[email-masked]>
> webtide.com <http://www.webtide.com/>
> Developer advice, services and support
> from the Jetty & CometD experts
> eclipse.org/jetty - cometd.org
>
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>
>

---

From: Takeshi Yoshino <[email-masked]>
Date: Thu, 25 Apr 2013 23:16:13 +0900

Hi Joakim,

permessage-compress is now implemented on echo_client.py of pywebsocket.
You can do simple send/receive test using --use-permessage-deflate
parameter.

Chrome is also going to support it behind a flag soon.

Takeshi

On Mon, Apr 1, 2013 at 11:48 PM, Takeshi Yoshino <[email-masked]>wrote:

> On Fri, Mar 29, 2013 at 2:18 AM, Joakim Erdfelt <[email-masked]>wrote:
>