Subject: [hybi] Permessage-deflate draft 11 implimentation

From: Peter Thorson <[email-masked]>
Date: Fri, 12 Jul 2013 18:00:34 -0500

WebSocket++ now implements the permessage-deflate draft 11 as a client and server with all parameters.
Code is available on the permessage-deflate branch at https://github.com/zaphoyd/websocketpp/tree/permessage-deflate
The scratch_server example of that branch is an echo server that will accept whatever permessage-deflate offer the client makes.

I have successfully tested this implementation with Chrome Canary, pywebsocket, and Autobahn (permessage-deflate branch) and the basics seem to work.

If anyone else has implementations ready for testing I'd love to try them out. If anyone else is interested in testing with WebSocket++ or finds any interoperability issues I'd be happy to help get tests set up or answer any questions.

---

From: Takeshi Yoshino <[email-masked]>
Date: Fri, 26 Jul 2013 16:21:12 +0900

Thanks. After getting tested by 1 or 2 more servers, and finalizing the
spec, we'd like make it enabled by default on Chromium.

----

So, we have
AutoBahn
https://github.com/tavendo/AutobahnTestsuite/tree/permessage_deflate
WebSocket++ https://github.com/zaphoyd/websocketpp/tree/permessage-deflate
pywebsocket
Chromium

Do you have other implementation of permessage-deflate?

Takeshi

On Sat, Jul 13, 2013 at 8:00 AM, Peter Thorson <[email-masked]>wrote:

> Code is available on the permessage-deflate branch at
> https://github.com/zaphoyd/websocketpp/tree/permessage-deflate
> The scratch_server example of that branch is an echo server that will
> accept whatever permessage-deflate offer the client makes.
>
> I have successfully tested this implementation with Chrome Canary,
> pywebsocket, and Autobahn (permessage-deflate branch) and the basics seem
> to work.
>
> If anyone else has implementations ready for testing I'd love to try them
> out. If anyone else is interested in testing with WebSocket++ or finds any
> interoperability issues I'd be happy to help get tests set up or answer any
> questions.
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>

---

From: Takeshi Yoshino <[email-masked]>
Date: Fri, 26 Jul 2013 23:12:02 +0900

> Do you have other implementation of permessage-deflate?
Sorry, I was not clear. I'm asking everyone on the list.