Subject: [hybi] I-D Action: draft-ietf-hybi-websocket-multiplexing-11.txt

From: [email-masked]
Date: Tue, 02 Jul 2013 05:02:56 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the BiDirectional or Server-Initiated HTTP Working Group of the IETF.

	Title           : A Multiplexing Extension for WebSockets
	Author(s)       : John A. Tamplin
                          Takeshi Yoshino
	Filename        : draft-ietf-hybi-websocket-multiplexing-11.txt
	Pages           : 42
	Date            : 2013-07-02

Abstract:
   The WebSocket Protocol [RFC6455] requires a new transport connection
   for every WebSocket connection.  This presents a scalability problem
   when many clients connect to the same server, and is made worse by
   having multiple clients running in different tabs of the same user
   agent.  This extension provides a way for separate logical WebSocket
   connections to share an underlying transport connection.

   Please send feedback to the [email-masked] mailing list.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-hybi-websocket-multiplexing

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-hybi-websocket-multiplexing-11

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-hybi-websocket-multiplexing-11

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Takeshi Yoshino <[email-masked]>
Date: Tue, 2 Jul 2013 21:11:24 +0900

- Removed delta encoding and Enc field
- 1 multiplex control block per 1 message
-- removed length fields from multiplex control blocks
- Added usecase note
- Reordered multiplexed connections section
- Specified how to determine multiplex or not
- Removed MUSTs from texts not for interoperability
- Removed pronouns if possible

Takeshi

On Tue, Jul 2, 2013 at 9:02 PM, <[email-masked]> wrote:

> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>