Subject: [hybi] websockets 1002 error

From: Jason Ricles <[email-masked]>
Date: Wed, 3 Dec 2014 08:50:03 -0500

Hi I have a question about a 1002 protocol error I am getting with
websockets, can anyone here help me to debug why this error is
occurring?

---

From: Peter Thorson <[email-masked]>
Date: Thu, 4 Dec 2014 14:29:28 -0500

Hi Jason,

Can you be more specific? In general, the 1002/protocol error is returned whenever one of the WebSocket endpoints does something that does not conform to the spec set out in RFC6455.

If you are working with third party software I would get in touch with its authors/official support channels. If you are working on your own implementation I’d suggest running the Autobahn test suite against it and take a careful look at the RFC6455 sections referencing the tests that fail.

Peter

> On Dec 3, 2014, at 08:50 , Jason Ricles <[email-masked]> wrote:
> 
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi