Subject: Re: [hybi] I-D Action: draft-ietf-hybi-permessage-compression-28.txt

From: Salvatore Loreto <[email-masked]>
Date: Tue, 1 Sep 2015 13:31:25 +0000

IMO it is ready for approval

br
Salvatore

On 28 Aug 2015, at 06:30, Takeshi Yoshino <[email-masked]<mailto:[email-masked]>> wrote:

+salvatore explicitly

Takeshi

On Fri, Aug 28, 2015 at 4:43 AM, Barry Leiba <[email-masked]<mailto:[email-masked]>> wrote:
Document shepherd:
Is version -28 ready for approval?  Or are any other changes needed?

Barry

On Mon, Aug 24, 2015 at 7:28 AM, Takeshi Yoshino <[email-masked]<mailto:[email-masked]>> wrote:
> Fixed one editorial issue pointed out by Ben.
>
> Takeshi
>
> On Mon, Aug 24, 2015 at 8:25 PM, <[email-masked]<mailto:[email-masked]>> wrote:
>>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>>  This draft is a work item of the BiDirectional or Server-Initiated HTTP
>> Working Group of the IETF.
>>
>>         Title           : Compression Extensions for WebSocket
>>         Author          : Takeshi Yoshino
>>         Filename        : draft-ietf-hybi-permessage-compression-28.txt
>>         Pages           : 32
>>         Date            : 2015-08-24
>>
>> Abstract:
>>    This document defines a framework for creating WebSocket extensions
>>    that add compression functionality to the WebSocket Protocol.  An
>>    extension based on this framework compresses the payload data portion
>>    of WebSocket data messages on a per-message basis using parameters
>>    negotiated during the opening handshake.  This framework provides a
>>    general method for applying a compression algorithm to the contents
>>    of WebSocket messages.  Each compression algorithm has to be defined
>>    in a document defining the extension by specifying parameter
>>    negotiation and payload transformation algorithm in detail.  This
>>    document also specifies one specific compression extension using the
>>    DEFLATE algorithm.
>>
>>    Please send feedback to the [email-masked]<mailto:[email-masked]> mailing list.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-hybi-permessage-compression/
>>
>> There's also a htmlized version available at:
>> https://tools.ietf.org/html/draft-ietf-hybi-permessage-compression-28
>>
>> A diff from the previous version is available at:
>>
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-hybi-permessage-compression-28
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission
>> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> hybi mailing list
>> [email-masked]<mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/hybi
>
>
>
> _______________________________________________
> hybi mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hybi
>

---

From: Barry Leiba <[email-masked]>
Date: Tue, 1 Sep 2015 10:13:26 -0400

> IMO it is ready for approval

Great; I've checked it too, and I agree.  I've approved it, and you
should see the announcement soon.

The working group will remain open until the RFC is published, after
which I'll close the working group, but leave the mailing list open
for continued related discussion (such as Anne's recent question).

Barry

---

From: Tobias Oberstein <[email-masked]>
Date: Sun, 13 Sep 2015 22:44:17 +0200

> should see the announcement soon.

Awesome! The WebSocket compression extension is of great practical value.

> which I'll close the working group, but leave the mailing list open

Regarding the closing of the working group, I would like to ask what is 
required to recharter the WG to work on a specific WebSocket subprotocol.

The current WG charter has this to say:

"""
The working group will also serve as a discussion venue for
subprotocols.  However, no subprotocol is currently chartered as a
deliverable, and the WG must be rechartered to work on any
subprotocols.
""" http://datatracker.ietf.org/doc/charter-ietf-hybi/

The subprotocol I would like to start working on is:

"The Web Application Messaging Protocol (WAMP)"

http://wamp.ws/
https://github.com/tavendo/WAMP/
http://www.iana.org/assignments/websocket/websocket.xml#subprotocol-name

WAMP was the 3rd WebSocket subprotocol officially registered at IANA, 
has gone through 3+ years of development, has nearly two dozen 
independent and interoparable implementations, and an active community.

I have asked on the WAMP implementors mailing list if there is interest 
in working on a RFC for WAMP, and multiple responses indicate that there 
is indeed interest:

https://groups.google.com/forum/#!topic/wampws/LlKjMF3ZJf8

I am original author of WAMP, and have been active during the 
development of WebSocket and the WebSocket compression extension on the 
Hybi working group.

I also created and maintain the Autobahn WebSocket testsuite - an 
automated testsuite for WS used by most implementors.

http://autobahn.ws/testsuite/

Apart from that I wrote a couple of WebSocket implementations in 
different languages.

However, I never wrote an RFC nor do I know a lot about IETF processes 
and such.

Hence my naive question: what's required to start working on WAMP within 
the context of this WG?

Cheers,
/Tobias

---

From: Takeshi Yoshino <[email-masked]>
Date: Mon, 14 Sep 2015 18:05:34 +0900

Thanks so much, Sal, Barry for your support.

> for continued related discussion (such as Anne's recent question).

Great!

---

From: Takeshi Yoshino <[email-masked]>
Date: Mon, 14 Sep 2015 18:11:15 +0900

> Awesome! The WebSocket compression extension is of great practical value.

Thank you, Tobias for your continued contribution including discussion and
building the reliable and comprehensive test suites.

> required to recharter the WG to work on a specific WebSocket subprotocol.

I also wonder what we'll lose and what we won't (in addition to the mailing
list) after WG close. I was worried that we might lose the mailing list too.

I guess at least we'll be unable to raise I-Ds as WG items while the WG is
closed.

> WAMP was the 3rd WebSocket subprotocol officially registered at IANA, has
> gone through 3+ years of development, has nearly two dozen independent and
> interoparable implementations, and an active community.
>
> I have asked on the WAMP implementors mailing list if there is interest in
> working on a RFC for WAMP, and multiple responses indicate that there is
> indeed interest:
>
> I am original author of WAMP, and have been active during the development
> of WebSocket and the WebSocket compression extension on the Hybi working
> group.
>
> Apart from that I wrote a couple of WebSocket implementations in different
> languages.
>
> However, I never wrote an RFC nor do I know a lot about IETF processes and
> such.
>
> [email-masked]

---

From: Salvatore Loreto <[email-masked]>
Date: Mon, 14 Sep 2015 10:44:26 +0000

Hi Tobia

In order for the wg to be recharted / resurrected
It is necessary to be enough interest in the work from several peoples/companies on the items
Other then a clear technical proposal(s)

At moment it seems that people are more interested to evolve HTTP2 then in WebSocket.

Br
Salvatore

From: Takeshi Yoshino [mailto:[email-masked]]
Sent: den 14 september 2015 11:11
To: Tobias Oberstein
Cc: Barry Leiba; Salvatore Loreto; [email-masked]
Subject: Re: [hybi] I-D Action: draft-ietf-hybi-permessage-compression-28.txt

On Mon, Sep 14, 2015 at 5:44 AM, Tobias Oberstein <[email-masked]<mailto:[email-masked]>> wrote:
Great; I've checked it too, and I agree.  I've approved it, and you
should see the announcement soon.

Thank you, Tobias for your continued contribution including discussion and building the reliable and comprehensive test suites.

Regarding the closing of the working group, I would like to ask what is required to recharter the WG to work on a specific WebSocket subprotocol.

I also wonder what we'll lose and what we won't (in addition to the mailing list) after WG close. I was worried that we might lose the mailing list too.

I guess at least we'll be unable to raise I-Ds as WG items while the WG is closed.

"""

http://wamp.ws/

WAMP was the 3rd WebSocket subprotocol officially registered at IANA, has gone through 3+ years of development, has nearly two dozen independent and interoparable implementations, and an active community.

I have asked on the WAMP implementors mailing list if there is interest in working on a RFC for WAMP, and multiple responses indicate that there is indeed interest:

I am original author of WAMP, and have been active during the development of WebSocket and the WebSocket compression extension on the Hybi working group.

I also created and maintain the Autobahn WebSocket testsuite - an automated testsuite for WS used by most implementors.

Apart from that I wrote a couple of WebSocket implementations in different languages.

However, I never wrote an RFC nor do I know a lot about IETF processes and such.

Hence my naive question: what's required to start working on WAMP within the context of this WG?

Cheers,
/Tobias

---

From: Tobias Oberstein <[email-masked]>
Date: Mon, 14 Sep 2015 13:29:37 +0200

Hi Salvatore,

> peoples/companies on the items

I figured that, and asked around in the WAMP community:

For your convenience, here is the summary up to now:

- Konstantin Burkalev, Atlantis communications, Russia
- Elvis Stansvik, KTH Royal Inst. of Tech., Schweden
- Francesco Longo, University of Messina, Italy
- David Chappelle,Topology LP, Canada
- Emile Cormier, Butterfly Energy Systems, Canada
- Tobias Oberstein, Tavendo, Germany

Among those, there are 4 WAMP implementors (have written and maintain 
one or more WAMP implementations). There are multiple companies and 
academia represented.

I will DM more implementors and users .. I am pretty sure there is interest.

How "much" interest is needed? How should we "proof"? Should I ask all 
to speak up on this mailing list?

> Other then a clear technical proposal(s)

So do we need a draft RFC written _before_ we can request to recharter 
the WG?

> At moment it seems that people are more interested to evolve HTTP2 then

Not sure, maybe there is a misunderstanding: what we would like to work 
on is a specific WebSocket _subprotocol_: an application layer protocol 
on top of WebSocket. We don't want to work on a WebSocket V2.0 or such.

Apart from that: HTTP2 interest/uptake compared to WebSocket - we could 
of course have a discussion about that, but is that relevant for the 
_WebSocket_ WG? I mean: WebSocket _does_ have significant uptake, 
interest and use on the street. It has an RFC.

Are you saying we should discontinue WebSocket just because there is 
HTTP2? I definitely would NOT buy that view, and I'd have some arguments 
(technical and other) to support that. But I'd like rather avoid getting 
into such discussions anyway (unproductive). HTTP2 does what it does - 
or not. But this is the WebSocket WG, which I would have assumed 
represents the interests and continues innovation in WS - not?

Please excuse if I don't understand the right way to approach this under 
IETF traditions / wording .. or miss something. Not intended.

Cheers,
/Tobias

>
> Br
>
> Salvatore
>
> *From:*Takeshi Yoshino [mailto:[email-masked]]
> *Sent:* den 14 september 2015 11:11
> *To:* Tobias Oberstein
> *Cc:* Barry Leiba; Salvatore Loreto; [email-masked]
> *Subject:* Re: [hybi] I-D Action:
> draft-ietf-hybi-permessage-compression-28.txt
>
> On Mon, Sep 14, 2015 at 5:44 AM, Tobias Oberstein
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Thank you, Tobias for your continued contribution including discussion
> and building the reliable and comprehensive test suites.
>
>
>     Regarding the closing of the working group, I would like to ask what
>     is required to recharter the WG to work on a specific WebSocket
>     subprotocol.
>
> I also wonder what we'll lose and what we won't (in addition to the
> mailing list) after WG close. I was worried that we might lose the
> mailing list too.
>
>     WAMP was the 3rd WebSocket subprotocol officially registered at
>     IANA, has gone through 3+ years of development, has nearly two dozen
>     I have asked on the WAMP implementors mailing list if there is
>     interest in working on a RFC for WAMP, and multiple responses
>     indicate that there is indeed interest:
>
>     development of WebSocket and the WebSocket compression extension on
>     the Hybi working group.
>
>     [email-masked] <mailto:[email-masked]>

---

From: Barry Leiba <[email-masked]>
Date: Mon, 14 Sep 2015 09:20:31 -0400

> I figured that, and asked around in the WAMP community:
...
> How "much" interest is needed? How should we "proof"? Should I ask all to
> speak up on this mailing list?

It's hard to put a number on it, but there needs to be enough interest
and commitment to participate that we can rely on progressing
documents and getting meaningful review.  We have been having a lot of
trouble with that over the past couple of *years*, so it's not just a
moderate slowdown.

That said, if we really *do* have enough commitment, I'm willing to
recharter the working group.  I can't speak for the chairs about
whether they're willing to continue, but perhaps we could get new
chairs to take it forward -- Salvatore and Gabriel have chaired this
working group for a long time now.

> So do we need a draft RFC written _before_ we can request to recharter the
> WG?

We don't *need* it, though a draft and some reviews of it would be
some evidence that there's enough interest.

> Not sure, maybe there is a misunderstanding: what we would like to work on
> is a specific WebSocket _subprotocol_: an application layer protocol on top
> of WebSocket. We don't want to work on a WebSocket V2.0 or such.

The point is that implementors are less interested in implementing
websocket things, now that http/2 is here.  Layering things on
websockets might not be very useful if implementors are moving to
http/2 instead, for such functions in the future.

But, again, if there really is enough interest in implementing new
function on websockets, and we can see that interest in commitment to
work on the specs, then that might be fine.

Barry

---

From: Константин Буркалев <[email-masked]>
Date: Mon, 14 Sep 2015 19:57:31 +0300

Hi, Barry, Salvatore and all!

My name is Konstantin, i’m a software architect in telecommunication company, 
also i’m author and maintainer of 3 WAMP implementations.

Just want to say, that from my point of view there is enough interest in WAMP libraries, 
which, of course, are based on WAMP protocol. 
I am already involved in development of WAMP spec, and i’m willing to continue work on WAMP as RFC.

I know different cases of WAMP usage, among them there are:
* IoT devices and systems, I’m also working on a subject. And right now small chips and devices (for ex. ESP8266) support only http/1.1.
* Mobile applications, based on JavaScript engines and platforms like React Native
And so on. 

We (i mean WAMP implementators, like Tobias or Emile) are already doing a big work in developing WAMP specification and fulfilling the gaps, and there are more and more 
people, involved in WAMP community. Just check the WAMP mailing list (https://groups.google.com/forum/#!forum/wampws <https://groups.google.com/forum/#!forum/wampws>)

> 14 сент. 2015 г., в 16:20, Barry Leiba <[email-masked]> написал(а):
> 

With best regards, KOsTIK
[email-masked]

---

From: Tobias Oberstein <[email-masked]>
Date: Mon, 14 Sep 2015 23:23:55 +0200

> trouble with that over the past couple of *years*, so it's not just a

Thanks for explaining and background. I now understand that real world 
usage and takeup is only one factor, but enough interest to do the 
concrete work on a spec document is what counts. Makes sense. To get a 
high quality spec, there needs to be peer review and discussion. It's 
part of the IETF mantra I guess, and I totally buy that.

> recharter the working group.  I can't speak for the chairs about

Awesome! Would you give us a bit time to organize enough commitment and 
write a draft? Some weeks before closing the WG (if we can't deliver)?

> some evidence that there's enough interest.

Ok, we can prepare a draft according to RFC style from this spec 
document ("WAMP basic profile") that we have:

https://github.com/tavendo/WAMP/blob/master/spec/basic.md

That spec has been extensively discussed and has gone through many 
iterations from Mar 2012 to now.

Discussion is on GitHub (94 closed, 67 open issues right now) and the 
WAMP mailing list (171 threads, 151 subscribers).

> http/2 instead, for such functions in the future.

FWIW, WAMP originally could only run on top of WebSocket. And it's still 
the most used "transport". But WAMP nowerdays can _also_ run over 
RawSocket (essentially, minimally framed TCP with some handshake sugar) 
and HTTP-Longpoll, and don't see why we couldn't specify a HTTP/2 
"transport binding" (that's WAMP lingo for defining a mapping of WAMP to 
an underlying transport).

WAMP-over-WebSocket is definitely the most important one, as it is the 
only thing that (today) can run right into all browsers. It is also the 
only transport that provides full, transparent payload compresssion - 
thanks to the WebSocket compression extension.

> work on the specs, then that might be fine.

Thanks! Please give us some time before closing the WG. Once the WG 
would have closed, I guess the bar would be much higher .. and where 
should we take it then? I have skimmed through the different IETF art 
areas, and the WGs and charters for the "Applications and Real-Time 
Area" in particular, and it appears to me, that WAMP would fit the 
Hybi-WG's mission ..

Cheers,
/Tobias

---

From: Matt Bonneau <[email-masked]>
Date: Wed, 16 Sep 2015 13:09:44 -0400

Hi Barry and Tobias,

I would be willing to help out with the RFC process on WAMP.

I have made pretty significant investments of time in creating
implementations and working with the spec and also use WAMP regularly. I
would welcome further development through the RFC process.

Regards,
Matt Bonneau

On Mon, Sep 14, 2015 at 5:23 PM, Tobias Oberstein <
[email-masked]> wrote:

> usage and takeup is only one factor, but enough interest to do the concrete
> work on a spec document is what counts. Makes sense. To get a high quality
> spec, there needs to be peer review and discussion. It's part of the IETF
> mantra I guess, and I totally buy that.
>
> Ok, we can prepare a draft according to RFC style from this spec document
> ("WAMP basic profile") that we have:
>
> Discussion is on GitHub (94 closed, 67 open issues right now) and the WAMP
> mailing list (171 threads, 151 subscribers).
>
> the most used "transport". But WAMP nowerdays can _also_ run over RawSocket
> (essentially, minimally framed TCP with some handshake sugar) and
> HTTP-Longpoll, and don't see why we couldn't specify a HTTP/2 "transport
> binding" (that's WAMP lingo for defining a mapping of WAMP to an underlying
> transport).
>
> Thanks! Please give us some time before closing the WG. Once the WG would
> have closed, I guess the bar would be much higher .. and where should we
> take it then? I have skimmed through the different IETF art areas, and the
> WGs and charters for the "Applications and Real-Time Area" in particular,
> and it appears to me, that WAMP would fit the Hybi-WG's mission ..
>
> Cheers,
> /Tobias
>
>