Subject: [hybi] [Technical Errata Reported] RFC6455 (5498)

From: RFC Errata System <[email-masked]>
Date: Fri, 14 Sep 2018 07:57:43 -0700 (PDT)

The following errata report has been submitted for RFC6455,
"The WebSocket Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5498

--------------------------------------
Type: Technical
Reported by: Registration of Websocket Upgrade token should have been websocket <[email-masked]>

Section: 11.2

Original Text
-------------

   Name of token
      WebSocket

Corrected Text
--------------

   Name of token
      webSocket

Notes
-----
The HTTP bootstrap request is required to use an upgrade token of all lowercase "websocket" - 

   5.   The request MUST contain an |Upgrade| header field whose value
        MUST include the "websocket" keyword.

The registration is for "Websocket" (capital W). In practice "websocket" is used.

Although the interpretation of that is defined case insensitively for this RFC (which conflicts with general HTTP semantics where this is case sensitive). As part of RFC 8441, the IANA registry has been updated to also include "websocket" with a reference to 6455 and 8441

imo this errata should be held for update and the reference to "Websocket" removed at that time.

See also https://www.rfc-editor.org/errata/eid5453

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6455 (draft-ietf-hybi-thewebsocketprotocol-17)
--------------------------------------
Title               : The WebSocket Protocol
Publication Date    : December 2011
Author(s)           : I. Fette, A. Melnikov
Category            : PROPOSED STANDARD
Source              : BiDirectional or Server-Initiated HTTP APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Adam Rice <[email-masked]>
Date: Mon, 17 Sep 2018 21:13:37 -0700

I think "Name of token" should be "websocket", not "webSocket".

On Fri, 14 Sep 2018 at 08:03, RFC Errata System <[email-masked]>
wrote:

> Although the interpretation of that is defined case insensitively for this
> RFC (which conflicts with general HTTP semantics where this is case
> sensitive). As part of RFC 8441, the IANA registry has been updated to also
> include "websocket" with a reference to 6455 and 8441
>
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 20 Sep 2018 13:26:06 +0100

> I think "Name of token" should be "websocket", not "webSocket".
You are right, I will correct.

> 
> On Fri, 14 Sep 2018 at 08:03, RFC Errata System <rfc-editor@rfc-
> editor.org> wrote:>> The following errata report has been submitted for RFC6455,
>>  Reported by: Registration of Websocket Upgrade token should have
>>  been websocket <[email-masked]>>> 
>>  Section: 11.2
>> 
>>  Original Text
>>  -------------
>> 
>>     Name of token
>>        WebSocket
>> 
>>  Corrected Text
>>  --------------
>> 
>>     Name of token
>>        webSocket
>> 
>>  Notes
>>  -----
>>  The HTTP bootstrap request is required to use an upgrade token of
>>  all lowercase "websocket" ->> 
>>     5.   The request MUST contain an |Upgrade| header field whose
>>          value>>          MUST include the "websocket" keyword.
>> 
>>  The registration is for "Websocket" (capital W). In practice
>>  "websocket" is used.>> 
>>  Although the interpretation of that is defined case insensitively
>>  for this RFC (which conflicts with general HTTP semantics where
>>  this is case sensitive). As part of RFC 8441, the IANA registry has
>>  been updated to also include "websocket" with a reference to 6455
>>  and 8441>> 
>>  imo this errata should be held for update and the reference to
>>  "Websocket" removed at that time.>> 
>>  This erratum is currently posted as "Reported". If necessary, please>>  use "Reply All" to discuss whether it should be verified or
>>  can log in to change the status and edit the report, if necessary.>>

---

From: Patrick McManus <[email-masked]>
Date: Thu, 20 Sep 2018 21:12:09 -0400

yes - sorry about that.