Subject: [I18ndir] Fwd: Update to IDNA parameters registry of derived property values

From: "Patrik Fältström" <[email-masked]>
Date: Fri, 15 Mar 2019 07:49:27 +0900

FYI

Forwarded message:

> From: IESG Secretary <[email-masked]>
> To: [email-masked]
> Cc: [email-masked], [email-masked]
> Subject: Update to IDNA parameters registry of derived property values
> Date: Thu, 14 Mar 2019 14:27:25 -0700
>
> IANA,
>
> The IESG asks that IANA update the IDNA Parameters registry of derived property values to align with what is described in draft-faltstrom-
> unicode11, after the expert reviewer validates that the derived property values are calculated correctly.
>
> Best regards,
> IESG Secretary

---

From: "Patrik Fältström" <[email-masked]>
Date: Fri, 15 Mar 2019 08:02:52 +0900

I was asked to work on unicode12:

> Hi Patrick,
>
> On 13 Mar 2019, at 21:47, Patrik Fältström <[email-masked]> wrote:
>
> So replace with -12 is what I should do?
>
> After my exchange with John yesterday, I think updating unicode12-00 would be better.
>
> Thank you,
> Alexey

> unicode11, after the expert reviewer validates that the derived property values are calculated correctly.

Alexey, I need some clarity on what I should do.

My preference would be that this note from IESG was a typo, and that IESG in reality have the same view as Alexey, that IANA should follow draft-faltstrom-unicode12, that you approve posting of draft-faltstrom-unicode12 (I can send you a current version, or however the posting works) that reviews things up to and including Unicode 12.0.0 and we move on.

   Patrik

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 14 Mar 2019 23:26:32 +0000

Hello Patrik,

My understanding from all the mail I read and the datatracker was that 
IANA would update to 11.0.0 now.

But we would work on draft-faltstrom-unicode12, and when that was done, 
IANA would then update to 12.0.0.

That way, we wouldn't loose time on getting the word out that we are 
getting unstuck, while also giving us a little bit more time to have 
another close look at the new characters in 12.0.0, and getting your 
document into even better shape (and through another last call). So 
please send an updated draft to Alexey.

And please make sure you get enough rest.

Regards,   Martin.

---

From: John C Klensin <[email-masked]>
Date: Thu, 14 Mar 2019 20:07:27 -0400

FWIW, my view of this is identical to Martin's, i.e., the tables
for Unicode 11.0 go to IANA now and we start working toward
draft-faltstrom-unicode12-01, including both getting the
document right and doing both sets of code point reviews (and,
to the extent needed, sort out the "future updates" issues and
others so that the text in draft-faltstrom-unicode12 can be both
correct and clear.  That means we treat
draft-faltstrom-unicode12-XX as superceding
draft-faltstrom-unicode11-YY and just move forward.

And, please, let's not do any of that, other maybe than getting
the Unicode 11.0-based table to IANA if you have time, until you
have had time to get back to Sweden and recover and the rest of
us have had time to catch our respective breaths.  I hope that
everyone who has been observing the very significant
improvements in document quality since
draft-faltstrom-unicode11-07 understands that the pace several
of us have had to keep to accomplish that is just not
sustainable for anyone who has other significant commitments and
will therefore cut us a bit of slack.

 best,
    john

--On Thursday, March 14, 2019 23:26 +0000 "Martin J. Dürst"
<[email-masked]> wrote:

> Hello Patrik,
> 
> My understanding from all the mail I read and the datatracker
> was that  IANA would update to 11.0.0 now.
> 
> But we would work on draft-faltstrom-unicode12, and when that
> was done,  IANA would then update to 12.0.0.
> 
> That way, we wouldn't loose time on getting the word out that
> we are  getting unstuck, while also giving us a little bit
> more time to have  another close look at the new characters in
> 12.0.0, and getting your  document into even better shape (and
> through another last call). So  please send an updated draft
> to Alexey.
> 
>>> Subject: Update to IDNA parameters registry of derived
>>> property values Date: Thu, 14 Mar 2019 14:27:25 -0700
>>> 
>>> IANA,
>>> 
>>> The IESG asks that IANA update the IDNA Parameters registry
>>> of derived property values to align with what is described
>>> in draft-faltstrom- unicode11, after the expert reviewer
>>> validates that the derived property values are calculated
>>> correctly.
>>> 
>>> Best regards,
>>> IESG Secretary
>> 
>> My preference would be that this note from IESG was a typo,
>> and that IESG in reality have the same view as Alexey, that
>> IANA should follow draft-faltstrom-unicode12, that you
>> approve posting of draft-faltstrom-unicode12 (I can send you
>> a current version, or however the posting works) that reviews
>> things up to and including Unicode 12.0.0 and we move on.
>> 
>>     Patrik

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 15 Mar 2019 10:26:04 +0900

Thanks!

   Patrik - just bought ticket to Shinkansen, in a machine...first for me :-)

> On 15 Mar 2019, at 09:07, John C Klensin <[email-masked]> wrote:
>

---

From: Asmus Freytag <[email-masked]>
Date: Thu, 14 Mar 2019 19:13:09 -0700

On 3/14/2019 6:26 PM, Patrik Fältström wrote:
> I hope that

Indeed.

A./

---

From: "Alexey Melnikov" <[email-masked]>
Date: Fri, 15 Mar 2019 07:13:10 -0400

> IANA would then update to 12.0.0.

Exactly this.

> And please make sure you get enough rest.

Yes, please.

---

From: "Patrik Fältström" <[email-masked]>
Date: Fri, 15 Mar 2019 21:21:45 +0900

Thanks!

   paf

---

From: "Patrik Fältström" <[email-masked]>
Date: Thu, 21 Mar 2019 21:51:54 +0100

Hi,

I have checked the files you did send me and compared the XML files with the same files I have produced.

As I do not see any differences, I hereby say I do not see any problems with having IANA making the tables with the derived property values available.

The review is based on the normative algorithm defined by IDNA2008, and based on RFC6452 and draft-faltstrom-unicode11-08.txt no backward compatible changes are to be made in the cases when changes in the Unicode Standard have lead to non-backward compatible changes in the derived property values when Unicode 6.0.0 and 11.0.0 was introduced.

   Patrik

On 21 Mar 2019, at 18:27, Amanda Baber via RT wrote:

> Hi Patrik,
>
> When we were discussing these in June (subject line [IANA #1113325]), we sent drafts of the registries for 7.0.0, 8.0.0, 9.0.0, 10.0.0, and 11.0.0, and you said that you would be OK with posting those after the situation with the I-D was resolved. Would you be able to check these again and confirm that they're still OK to use, provided that we update the date at the top of each registry?
>
> thanks,
> Amanda
>
> On Thu Mar 21 16:03:05 2019, [email-masked] wrote:
>> On 21 Mar 2019, at 16:20, Patrik Fältström wrote:
>>
>>> 2. I do the same (I have done so), which I have done, and I send you
>>> a pointer to my result
>>
>> Here is my data in the format you earlier wanted. If you want a
>> different format, let me know.
>>
>> <https://stupid.domain.name/stuff/iana-11.0.0.csv>
>>
>> Patrik

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 23 Mar 2019 06:39:45 +0100

Amanda, Michelle, can you let me know you have received this?

   Patrik

> On 21 Mar 2019, at 21:51, Patrik Fältström <[email-masked]> wrote:
> 
> Hi,
>

---

From: "Patrik Fältström" <[email-masked]>
Date: Sat, 23 Mar 2019 11:17:33 +0100

On 23 Mar 2019, at 11:04, Michelle Cotton via RT wrote:

> Hello Patrik,
>
> Apologies for the delayed response, I was on a plane.

Makes sense :-D

> Yes we have received this message and the tables have been updated.

Thank you very much!

   Patrik

> Please see:
> https://www.iana.org/assignments/idna-tables-11.0.0/idna-tables-11.0.0.xhtml
>
> Please let us know if there are any questions or concerns about the postings.
> Thank you!
>
> Michelle
>
>
> On Sat Mar 23 05:40:27 2019, [email-masked] wrote:
>>> As I do not see any differences, I hereby say I do not see any
>>> problems with having IANA making the tables with the derived property
>>> values available.
>>>
>>> The review is based on the normative algorithm defined by IDNA2008,
>>> and based on RFC6452 and draft-faltstrom-unicode11-08.txt no backward
>>> compatible changes are to be made in the cases when changes in the
>>> Unicode Standard have lead to non-backward compatible changes in the
>>> derived property values when Unicode 6.0.0 and 11.0.0 was introduced.
>>>
>>> Patrik
>>>
>>>> When we were discussing these in June (subject line [IANA
>>>> #1113325]), we sent drafts of the registries for 7.0.0, 8.0.0,
>>>> 9.0.0, 10.0.0, and 11.0.0, and you said that you would be OK with
>>>> posting those after the situation with the I-D was resolved. Would
>>>> you be able to check these again and confirm that they're still OK
>>>> to use, provided that we update the date at the top of each
>>>> registry?
>>>>
>>>> thanks,
>>>> Amanda
>>>>

---

From: Martin J. Dürst <[email-masked]>
Date: Sun, 24 Mar 2019 02:03:13 +0000

Hello Michelle, Patrik, others,

>> Yes we have received this message and the tables have been updated.

Many thanks!

This looks really good, including the note at the top with links which says:

Note
This registry is based on Unicode 11.0.0. Older versions of this registry:
[Unicode 5.2.0], [Unicode 6.0.0], [Unicode 6.1.0], [Unicode 6.2.0], 
[Unicode 6.3.0],
[Unicode 7.0.0], [Unicode 8.0.0], [Unicode 9.0.0], [Unicode 10.0.0]

>> Please let us know if there are any questions or concerns about the postings.

I'd make two suggestions for improvement.

First, when going to older versions, e.g.
https://www.iana.org/assignments/idna-tables-9.0.0/idna-tables-9.0.0.xml, 
it contains the same note, but only with links to even older version. If 
possible, it would be great to also have links to newer versions, or to 
a place that shows the newest version (or all versions).

Second, I think the entries on the https://www.iana.org/protocols page 
(please search for "IDNA Parameters") can be improved. There are 
currently 6 "IDNA Contextual Rules" entries and 6 "IDNA Derived 
Properties" entries, but they are not distinguished at all. The lists 
are not complete. The order is 6.3.0, 9.0.0, 8.0.0, 11.0.0, 7.0.0, 
10.0.0; at least it's the same for both kinds of entries. It also misses 
the entries for 5.2.0, Unicode 6.0.0, 6.1.0, and 6.2.0. I think the best 
thing (given that the https://www.iana.org/protocols page is already too 
long anyway) would be to only have one entry, to the latest version 
(currently 11.0.0), or to a list of versions, and clearly say so. The 
alternative is to list all versions, in a consistent order.

Regards,   Martin.

-- 
Prof. Dr.sc. Martin J. Dürst
Department of Intelligent Information Technology
College of Science and Engineering
Aoyama Gakuin University
Fuchinobe 5-1-10, Chuo-ku, Sagamihara
252-5258 Japan