Subject: [I18ndir] draft-faltstrom-unicode12 and draft-faltstrom-unicode11

From: John C Klensin <[email-masked]>
Date: Mon, 11 Mar 2019 20:39:00 -0400

Patrik and Alexey,

Just a question to save wasted effort.  

>From a scan of the table of contents and a quick diff,
draft-faltstrom-unicode12-00 appears to have the same contents
as draft-faltstrom-unicode11-08 with the Unicode 12 material
added.  Is the plan to cancel the review process on
draft-faltstrom-unicode11 and initiate one (soon although I hope
with a little time for others to review the Unicode 12.0 stuff)
on draft-faltstrom-unicode12?   

If the plan is to go ahead, finish the review process, and
publish draft-faltstrom-unicode11, then shouldn't
draft-faltstrom-unicode12 contain _only_ the information about
transition between Unicode 11.0 and Unicode 12.0?  Publishing
both in the current form of the I-Ds would seem to me to be an
invitation to massive confusion.  

While the argument is probably buried in other messages, there
has already been a bit of discussion to the effect that, if we
are trying to avoid confusion by having the IANA tables
correspond to an obsolete version of Unicode, publishing tables
for Unicode 11.0 after 12.0 has been announced and published
almost certainly does no one any favors.

     john

---

From: "Patrik Fältström" <[email-masked]>
Date: Tue, 12 Mar 2019 09:46:11 +0900

On 12 Mar 2019, at 9:39, John C Klensin wrote:

> draft-faltstrom-unicode12-00 appears to have the same contents as draft-faltstrom-unicode11-08 with the Unicode 12 material added.  Is the plan to cancel the review process on
> draft-faltstrom-unicode11 and initiate one (soon although I hope with a little time for others to review the Unicode 12.0 stuff)

I did publish both as I have seen discussions around this question BUT I have not seen any answer.

I wanted to have things published before the deadline, and of course I should have posted three different drafts:

1. What is now unicode11
2. What is now unicode12
3. The unicode12 that would be posted if unicode11 is what is chosen

I did not have time for [3].

And with that, yes, I agree that question of yours should be answered.

   Patrik