Subject: [I18ndir] Fwd: [new-work] Proposed W3C Charters: HTML Working Group; Internationalization (i18n) Working Group and Interest Group (until 2019-05-03)

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 12 Apr 2019 11:30:45 -0500

Passing this along in case people haven't seen it in other fora...

-Ben

On Mon, Apr 08, 2019 at 04:24:35PM -0400, Coralie Mercier wrote:
> Hello,
> 
> The W3C Advisory Committee Representatives received a Proposal to review the following draft charters:
> 
>  * HTML Working Group:
>    https://www.w3.org/2018/12/html.html
> 
>  * Internationalization (i18n) Working Group:
>    https://www.w3.org/2019/04/proposed-i18n-wg-charter.html
> 
>  * Internationalization (i18n) Interest Group Charter:
>    https://www.w3.org/2019/04/proposed-i18n-ig-charter.html
> 
> 
> As part of ensuring that the community is aware of proposed work at W3C, this draft charter is public during the Advisory
> Committee review period.
> 
> W3C invites public comments through 2019-05-03 on the proposed charter. Please send comments to <[email-masked]>, which has a public archive:
>    http://lists.w3.org/Archives/Public/public-new-work/
> 
> 
> Other than comments sent in formal responses by W3C Advisory Committee Representatives, W3C cannot guarantee a response to comments. If you work for a W3C Member [1], please coordinate your comments with your Advisory Committee Representative. For example, you may wish to make public comments via this list and have your Advisory Committee Representative refer to it from his or her formal review comments.
> 
> If you should have any questions or need further information, please contact Wendy Seltzer <[email-masked]>, or Philippe Le Hegaret <[email-masked]>.
> 
> 
> Thank you,
> Coralie Mercier, Head of W3C Marketing & Communications
> 
> 
> [1] http://www.w3.org/Consortium/Member/List
> 
> --
> Coralie Mercier  -  W3C Marketing & Communications -  https://www.w3.org
> mailto:[email-masked] +337 810 795 22 https://www.w3.org/People/Coralie/
> 
> 
> 
> 
> 
> 
> _______________________________________________
> new-work mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/new-work
> 
> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
> wiki: http://tools.ietf.org/area/sec/trac/wiki/SecDirReview

---

From: John C Klensin <[email-masked]>
Date: Fri, 12 Apr 2019 12:59:55 -0400

Ben,

Thanks.

AFAIK, Martin still chairs the i18n Interest Group.   I'm fairly
active in the I18n Working Group and I believe Peter and Barry
are still considered members although they have not been active
of late.

I don't want to say "we've got it covered", because that
assertion would be a bit questionable, but most of the work I
see is fairly web-specific and fully-consistent with agreements
reached years ago about division of responsibilities between
IETF and W3C (I don't know if the group that reached those
agreements still exists; I certainly hope that the appropriate
ADs do and that, if it doesn't, how to swiftly reconstitute it
if needed). 

During the time that it was unclear whether the directorate
would actually be pulled together, I did informally raise the
question of whether the I18n "core" WG would be interested in
taking more review responsibility for IETF work that was not
web-focused, such an IDNA reviews for new Unicode versions and
got responses that might be described in terms of the number of
10 foot poles that might be needed.  

The notice may hide a more important issue but it is only
slightly an i18n one: while the IETF and W3C decided that HTML
should be the latter's responsibility, actual design
responsibility for HTML seems to be shifting to WHATWG, an
organization that is far less open, transparent, or based on
broad consensus than either W3C or IETF.  Whether that is a
problem or not probably depends on one's perspective.  I do know
I'm trying very hard to keep it from ending up on my problem
list, but I hope the IESG is at least aware of it.

best,
    john

--On Friday, April 12, 2019 11:30 -0500 Benjamin Kaduk
<[email-masked]> wrote:

>> The W3C Advisory Committee Representatives received a
>> Proposal to review the following draft charters:
>> 
>>  * HTML Working Group:
>> As part of ensuring that the community is aware of proposed
>> work at W3C, this draft charter is public during the Advisory
>> Committee review period.
>> 
>> W3C invites public comments through 2019-05-03 on the
>> proposed charter. Please send comments to
>> <[email-masked]>, which has a public archive:
>> Other than comments sent in formal responses by W3C Advisory
>> Committee Representatives, W3C cannot guarantee a response to
>> comments. If you work for a W3C Member [1], please coordinate
>> your comments with your Advisory Committee Representative.
>> For example, you may wish to make public comments via this
>> list and have your Advisory Committee Representative refer to
>> it from his or her formal review comments.
>> 
>> If you should have any questions or need further information,
>> please contact Wendy Seltzer <[email-masked]>, or Philippe
>> Le Hegaret <[email-masked]>.
>> 
>> 
>> Thank you,
>> Coralie Mercier  -  W3C Marketing & Communications -
>> https://www.w3.org mailto:[email-masked] +337 810 795 22
>> https://www.w3.org/People/Coralie/
>> 
>> 
>> 
>> 
>> 
>>

---

From: Martin J. Dürst <[email-masked]>
Date: Sat, 13 Apr 2019 10:16:13 +0000

Hello Everybody,

On 2019/04/13 01:59, John C Klensin wrote:
> Ben,
> 
> Thanks.
> 
> AFAIK, Martin still chairs the i18n Interest Group.

Confirmed. The i18n Interest Group these days mostly works through task 
forces, and most if not all of these task forces these days work on 
typography and layout issues for various scripts and regions of the 
world. This work feeds into requirements for CSS and layout engines in 
browser implementations.

> I'm fairly

I think I'm also still a mostly silent member of the I18N WG.

One thing that may be worth a look at for people on this list is the 
list of checking points for specification writers, at
https://www.w3.org/International/techniques/developing-specs. Many 
things don't apply to most IETF specs, but some do.

> 10 foot poles that might be needed.

The main reason for this is that the members of the I18N WG already are 
doing a lot of reviews of W3C work so it's kind of understandable that 
they don't want to do more of (almost) the same.

> broad consensus than either W3C or IETF.

At its core, it's a small insider group of highly motivated individuals 
working for some of the main browser vendors. Around that is a wide 
range of people who provide input and participate in discussions.

> Whether that is a

In my view, the main problem at the moment and going forward for HTML is 
not the WHATWG, but the fact that we are again (as in the late 1990ies) 
towards something close to an implementation monoculture.
(see e.g. 
https://www.computerworld.com/article/3388640/microsoft-previews-full-chromium-edge-for-the-first-time.html 
for the latest news).

Regards,   Martin.

-- 
Prof. Dr.sc. Martin J. Dürst
Department of Intelligent Information Technology
College of Science and Engineering
Aoyama Gakuin University
Fuchinobe 5-1-10, Chuo-ku, Sagamihara
252-5258 Japan