Subject: [I2nsf] 答复: New draft on access use cases for I2NSF

From: Zhenghewen <[email-masked]>
Date: Tue, 4 Nov 2014 01:41:49 +0000

"My son is allowed to access Facebook from 18:30 to 20:00"
Good use case not only in access network but also in enterprises’ private networks, especially security policies spread across many branches. Many human efforts contribute to keep consistent.

In current practice from enterprises, e.g., banks and insurance co., close-to-natural-language sentences seems more convenient, efficient than vendor-specific implicit commands.

发件人: I2nsf [mailto:[email-masked]] 代表 DIEGO LOPEZ GARCIA
发送时间: 2014年10月28日 3:57
收件人: [email-masked]
主题: [I2nsf] New draft on access use cases for I2NSF

Just uploaded...

A new version of I-D, draft-pastor-i2nsf-access-usecases-00.txt
has been successfully submitted by Diego R. Lopez and posted to the
IETF repository.

Name:
draft-pastor-i2nsf-access-usecases
Revision:
00
Title:
Access Use Cases for an Open OAM Interface to Virtualized Security Services
Document date:
2014-10-25
Group:
Individual Submission
Pages:
9
URL:            http://www.ietf.org/internet-drafts/draft-pastor-i2nsf-access-usecases-00.txt
Status:         https://datatracker.ietf.org/doc/draft-pastor-i2nsf-access-usecases/
Htmlized:       http://tools.ietf.org/html/draft-pastor-i2nsf-access-usecases-00

Abstract:
  This document describes the use cases for providing network security
  as a service in the access network environment.  It considers both
  mobile and residential access.

--
PLEASE NOTE MY NEW EMAIL ADDRESS
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 5 Nov 2014 23:09:05 +0000

He Wen,

Is your first sentence intended to describe a use case of  “policy” being requested by UE? Please check this use case by China Mobilehttps://datatracker.ietf.org/doc/draft-qi-i2nsf-access-network-usecase/ . Does it cover what you want ?

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Zhenghewen
Sent: Monday, November 03, 2014 7:42 PM
To: DIEGO LOPEZ GARCIA; [email-masked]
Subject: [I2nsf] 答复: New draft on access use cases for I2NSF

发件人: I2nsf [mailto:[email-masked]] 代表 DIEGO LOPEZ GARCIA
发送时间: 2014年10月28日 3:57
收件人: [email-masked]<mailto:[email-masked]>
主题: [I2nsf] New draft on access use cases for I2NSF

Just uploaded...

Name:

Abstract:

Dr Diego R. Lopez
Telefonica I+D

---

From: Zhenghewen <[email-masked]>
Date: Thu, 6 Nov 2014 01:07:16 +0000

Linda,

The policy come from not User DEVICE but USER. China Mobile’s I-D provides another use case for access network, especially about the choice of security functions and configurations for User. In my understanding, the case from China Mobile think that the users on access devices are skilled on security technology and requirements, it should be the fact for SME customers sometimes.

Hewen
发件人: Linda Dunbar
发送时间: 2014年11月6日 7:09
收件人: Zhenghewen; DIEGO LOPEZ GARCIA; [email-masked]; [email-masked]; 'xiaojun'
主题: RE: New draft on access use cases for I2NSF

He Wen,

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Zhenghewen
Sent: Monday, November 03, 2014 7:42 PM
To: DIEGO LOPEZ GARCIA; [email-masked]<mailto:[email-masked]>
Subject: [I2nsf] 答复: New draft on access use cases for I2NSF

Just uploaded...

Name:

Abstract:

Dr Diego R. Lopez
Telefonica I+D

---

From: "Minpeng Qi" <[email-masked]>
Date: Thu, 6 Nov 2014 10:41:09 +0800

Hi Hewen,

I think you trigger a quite good discuss on the policy. Here are two key points.

The first key point is: How the policy is stated on the interface. 

Is it presented as natural language like  what you said “My son is allowed to access Facebook from 18:30 to 20:00”, or specified protocol based language like “Source: my son’s cell phone, Target: Facebook, Time: 18:30-20:00, Access policy:OK ”? 

It would bring natural language processing if the policy define as former style on the interface. It would be quite convenient for human but I’m afraid it would bring a lot of complexity for machine to understand it. 

If it is latter one, it would be a guide book to indicate how to translate natural language into protocol based language. Or it would be better to prepare a local UI that can help user change their natural language as protocol-based language.

The second key point is : Is the policy equal to network command? 

In our draft the answer is not. When the network is received such policy/requirement/any other kind of statement, it should do a lot of work to translate the request into a series command to trigger/add/update related security functions. The command is transparent to the user device.

BRs,

Minpeng

发件人: I2nsf [mailto:[email-masked]] 代表 Zhenghewen
发送时间: 2014年11月6日 9:07
收件人: Linda Dunbar; DIEGO LOPEZ GARCIA; [email-masked]; [email-masked]; 'xiaojun'
主题: [I2nsf] 答复: New draft on access use cases for I2NSF

Linda,

Hewen

发件人: Linda Dunbar 
发送时间: 2014年11月6日 7:09

He Wen, 

Linda

 

Just uploaded... 

Name:

00
Title:

2014-10-25
Group:

Individual Submission
Pages:

9
URL:             <http://www.ietf.org/internet-drafts/draft-pastor-i2nsf-access-usecases-00.txt> http://www.ietf.org/internet-drafts/draft-pastor-i2nsf-access-usecases-00.txt
Status:          <https://datatracker.ietf.org/doc/draft-pastor-i2nsf-access-usecases/> https://datatracker.ietf.org/doc/draft-pastor-i2nsf-access-usecases/
Htmlized:        <http://tools.ietf.org/html/draft-pastor-i2nsf-access-usecases-00> http://tools.ietf.org/html/draft-pastor-i2nsf-access-usecases-00

Abstract:

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

  _____

---

From: Zhenghewen <[email-masked]>
Date: Thu, 6 Nov 2014 03:02:35 +0000

Hi Minpeng

Agree with you.

The first key point is essentially what UI acts like, natural language (text, voice [e.g. Microsoft Bing, Apple Siri]), Graphical surface or traditional dialogue menu/box. I think that natural language is better. It becomes feasible as the artificial intelligence approaches.

The second key point is essentially about what “policy” looks like. Each person, even each device has different knowledge about it, for example, policy structure, policy component, policy grammar etc. What should policy language be across different security devices, different vendor?

If I2NSF can provide one interface of both key points, it would be successful without doubt.

Best regards,
Hewen
发件人: Minpeng Qi [mailto:[email-masked]]
发送时间: 2014年11月6日 10:41
收件人: Zhenghewen; Linda Dunbar; 'DIEGO LOPEZ GARCIA'; [email-masked]; 'xiaojun'
主题: 答复: [I2nsf] 答复: New draft on access use cases for I2NSF

Hi Hewen,

BRs,
Minpeng

发件人: I2nsf [mailto:[email-masked]] 代表 Zhenghewen
发送时间: 2014年11月6日 9:07
收件人: Linda Dunbar; DIEGO LOPEZ GARCIA; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'xiaojun'
主题: [I2nsf] 答复: New draft on access use cases for I2NSF

Linda,

Hewen
发件人: Linda Dunbar
发送时间: 2014年11月6日 7:09
收件人: Zhenghewen; DIEGO LOPEZ GARCIA; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'xiaojun'
主题: RE: New draft on access use cases for I2NSF

He Wen,

Linda

Just uploaded...

Name:

Abstract:

Dr Diego R. Lopez
Telefonica I+D

---

From: "Minpeng Qi" <[email-masked]>
Date: Thu, 6 Nov 2014 12:01:55 +0800

Hi Hewen,

For first point, I have a little different opinion. I agree natural language is better for end user. However, natural language is usually ambiguity. It could be complex and difficult to translate it to accurate, clear statement for device. If we involve such work into i2nsf, it may cause significant delay to work out a feasible system. IMHO, the better way is to make such UI or natural language processing as a black box for I2NSF.

For the second point, I agree with you. And it would be an important issue that I2NSF should solve. And it is related to use case. That’s why we investigate all use cases at this stage. We need to know what kinds of devices, network servers and what network connectivity this interface could involves. As a result, we could define what policy we should have.

BRs,

Minpeng

发件人: I2nsf [mailto:[email-masked]] 代表 Zhenghewen
发送时间: 2014年11月6日 11:03
收件人: Minpeng Qi; Linda Dunbar; 'DIEGO LOPEZ GARCIA'; [email-masked]; 'xiaojun'
主题: [I2nsf] 答复: 答复: New draft on access use cases for I2NSF

Hi Minpeng

Agree with you.

Best regards,

Hewen

Hi Hewen,

BRs,

Minpeng

Linda,

Hewen

发件人: Linda Dunbar 
发送时间: 2014年11月6日 7:09

He Wen, 

Linda

 

Just uploaded... 

Name:

00
Title:

2014-10-25
Group:

Individual Submission
Pages:

9

Abstract:

Dr Diego R. Lopez
Telefonica I+D

 

  _____

---

From: Melinda Shore <[email-masked]>
Date: Wed, 05 Nov 2014 19:10:32 -0900

On 11/5/14 7:01 PM, Minpeng Qi wrote:
> If we involve such work into
> i2nsf, it may cause significant delay to work out a feasible system.

I would suggest that a configuration *language* is completely
out of scope, anyway.  Encoding for transmission is another
matter entirely.  Think in terms of network protocols.

If you're developing a policy language (and I think you
probably shouldn't, at least not without looking at things
like Keynote, IPSP, and so on), think about whether you're
interested in a predicate logic-based approach, a
configuration language, etc.

But, so far I'm not hearing anything peculiar to outsourced
security services on the one hand or multitenanted services
on the other.

Melinda

---

From: Zhenghewen <[email-masked]>
Date: Thu, 6 Nov 2014 04:12:12 +0000

Hi Minpeng

Actually, the second point is more closer and feasible, especially for a BOF.

Best regards,
Hewen
发件人: Minpeng Qi [mailto:[email-masked]]
发送时间: 2014年11月6日 12:02
收件人: Zhenghewen; Linda Dunbar; 'DIEGO LOPEZ GARCIA'; [email-masked]; 'xiaojun'
主题: Re: [I2nsf] New draft on access use cases for I2NSF

Hi Hewen,

BRs,
Minpeng

发件人: I2nsf [mailto:[email-masked]] 代表 Zhenghewen
发送时间: 2014年11月6日 11:03
收件人: Minpeng Qi; Linda Dunbar; 'DIEGO LOPEZ GARCIA'; [email-masked]<mailto:[email-masked]>; 'xiaojun'
主题: [I2nsf] 答复: 答复: New draft on access use cases for I2NSF

Hi Minpeng

Agree with you.

Best regards,
Hewen
发件人: Minpeng Qi [mailto:[email-masked]]
发送时间: 2014年11月6日 10:41
收件人: Zhenghewen; Linda Dunbar; 'DIEGO LOPEZ GARCIA'; [email-masked]<mailto:[email-masked]>; 'xiaojun'
主题: 答复: [I2nsf] 答复: New draft on access use cases for I2NSF

Hi Hewen,

BRs,
Minpeng

Linda,

Hewen
发件人: Linda Dunbar
发送时间: 2014年11月6日 7:09

He Wen,

Linda

Just uploaded...

Name:

Abstract:

Dr Diego R. Lopez
Telefonica I+D

---

From: "Minpeng Qi" <[email-masked]>
Date: Thu, 6 Nov 2014 18:54:06 +0800

Hi Hewen,

Yes. That’s also what I want to say.

BRs,

Minpeng

发送时间: 2014年11月6日 12:12

Hi Minpeng

Best regards,

Hewen

Hi Hewen,

BRs,

Minpeng

Hi Minpeng

Agree with you.

Best regards,

Hewen

Hi Hewen,

BRs,

Minpeng

Linda,

Hewen

发件人: Linda Dunbar 
发送时间: 2014年11月6日 7:09

He Wen, 

Linda

 

Just uploaded... 

Name:

00
Title:

2014-10-25
Group:

Individual Submission
Pages:

9

Abstract:

Dr Diego R. Lopez
Telefonica I+D

 

  _____