Subject: [I2nsf] Barry Leiba's No Objection on charter-ietf-i2nsf-00-01: (with COMMENT)

From: "Barry Leiba" <[email-masked]>
Date: Sat, 29 Aug 2015 09:03:44 -0700

Barry Leiba has entered the following ballot position for
charter-ietf-i2nsf-00-01: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-i2nsf/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The substance of the charter seems fine to me.  I just have some
editorial comments.

In the first sentence, I think you mean to change "and" to "or" -- that
is, one NSF does at least one of the things listed, not all of them.

In the second sentence, I don't know what it means for a *function* to be
"consumed".  Can you find better wording than "consumed" for this?

Please fix the artifact of MS Word's "smart quoting" that's resulted in
invalid characters ("???Functional Implementation???", "clients???
security policies", and "The I2NSF WG???s deliverables").

What are "Capability layer comments"?  (It's the "comments" part that I
don't follow (so I guess it's good that translating to them is out of
scope).)

We need a blank line after the bullet list (after the "Capability layer
comments" sentence), or else the "However" sentence needs to be merged
into the bullet.  (I'm thinking you mean the latter.)

I always prefer that "working group" be spelled out, so I suggest a
global change of "WG" to "working group", but take that as Barry's
preference and do as you like with it.

On "Working group re-charter or close: Charter time + 24 months", I'm
generally not thrilled with that sort of statement.  If what you want to
do is set a time limit, I think something more clear and explicit would
be better.  Something like, "The working group must have the above
deliverables completed within 24 months.  The responsible AD will close
the working group at that time if they are not completed or close to
completion.  The working group may be closed earlier if substantial
progress is not being made."  If something like that isn't what's meant,
then what *is* meant?

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 31 Aug 2015 20:36:40 +0000

Barry, 

Thank you very much for the comments. Reply are inserted below:

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of Barry Leiba
Sent: Saturday, August 29, 2015 11:04 AM
To: The IESG
Cc: [email-masked]
Subject: [I2nsf] Barry Leiba's No Objection on charter-ietf-i2nsf-00-01: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

The substance of the charter seems fine to me.  I just have some editorial comments.

In the first sentence, I think you mean to change "and" to "or" -- that is, one NSF does at least one of the things listed, not all of them.
[Linda] very good catch. You are correct. I've changed it in the I2NSF Wiki. 

In the second sentence, I don't know what it means for a *function* to be "consumed".  Can you find better wording than "consumed" for this?
[Linda] The intent is to describe "NSF" being used (or utilized), and NSFs becoming a resource that is available for consumption to build a security service

How about changing to the following wording? 

"NSFs are provide and utilized in increasingly diverse environment.  Users could consume network security services enforced by NSFs hosted by one or more providers, which may be their own enterprise, service providers, or a combination of both."

Please fix the artifact of MS Word's "smart quoting" that's resulted in invalid characters ("???Functional Implementation???", "clients???
security policies", and "The I2NSF WG???s deliverables").
[Linda] I don't see the "???...???" at this link anymore.   https://datatracker.ietf.org/wg/i2nsf/charter/. 

What are "Capability layer comments"?  (It's the "comments" part that I don't follow (so I guess it's good that translating to them is out of
scope).)

[Linda] It is supposed to be "Capability layer commands" 

We need a blank line after the bullet list (after the "Capability layer comments" sentence), or else the "However" sentence needs to be merged into the bullet.  (I'm thinking you mean the latter.)

[Linda] the paragraph starting with "However..." is intended to be next bullet because it continues the further clarification of the "Service Layer". 

I always prefer that "working group" be spelled out, so I suggest a global change of "WG" to "working group", but take that as Barry's preference and do as you like with it.
[Linda] OK. 

On "Working group re-charter or close: Charter time + 24 months", I'm generally not thrilled with that sort of statement.  If what you want to do is set a time limit, I think something more clear and explicit would be better.  Something like, "The working group must have the above deliverables completed within 24 months.  The responsible AD will close the working group at that time if they are not completed or close to completion.  The working group may be closed earlier if substantial progress is not being made."  If something like that isn't what's meant, then what *is* meant?

[Linda] I will let Kathleen decide on this change then. 

Thank you very much. 

Linda

_______________________________________________
I2nsf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2nsf

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 31 Aug 2015 17:39:20 -0400

Thanks for the comments Barry and to Linda for the quick response.
Updates have been made as agreed.

-- 

Best regards,
Kathleen