Subject: [I2nsf] comments on I2NSF charter

From: Alia Atlas <[email-masked]>
Date: Mon, 24 Aug 2015 17:27:00 -0400

I took a look at the charter at
https://sites.google.com/site/interface2nsf/home .
In general, this looks plausible.  I do have a few comments.

First, could you consider and add clarity around whether I2NSF is assuming
single-headed control (as is common in network management systems or
controllers) or is assuming multi-headed control (as I2RS does)?

Second, I'd propose the following minor modification:

Replace:
"However, I2NSF will provide a forum for Informational drafts on data
models, APIs, etc. that demonstrate how more complex Service Layer policies
and formats may be translated to Capability Layer functions."
With
"However, I2NSF will provide a discussion forum for Informational drafts on
data models, APIs, etc. that demonstrate how more complex Service Layer
policies and formats may be translated to Capability Layer functions.  Such
documents would be pursued outside the WG."

Otherwise, it looks reasonable.

Thanks,
Alia

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 24 Aug 2015 17:25:03 -0500

Thank Alia for the useful comment.

IMHO, I2NSF should focus on Single-headed control first.

With I2RS one step ahead  in debating/specifying the proper mechanism to
ensure the network integrity with multi-headed control, I2NSF can breathe a
bit. I hope that I2NSF can borrow or simply refer to the multi-headed
control mechanism defined by I2RS when it is finalized.

Thank you for the suggested wording change. I like it. If I don’t hear any
objection, I will change the wiki by tomorrow.

Linda

On Mon, Aug 24, 2015 at 4:27 PM, Alia Atlas <[email-masked]> wrote:

> "However, I2NSF will provide a discussion forum for Informational drafts
> on data models, APIs, etc. that demonstrate how more complex Service Layer
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Tue, 25 Aug 2015 03:44:05 +0000

I agree with Linda, single-headed control should be our reasonable assumption currently. In the future, following the specification already in I2RS should also be feasible.

Another point I want to mention is about the NSF’s reporting interface. This interface may be a little bit complex since it needs to report different kinds of information, such as: action results of security functions, statistics information of the flows or network, the sharing security intelligences, etc.

B.R.
Frank

发件人: I2nsf [mailto:[email-masked]] 代表 Linda Dunbar
发送时间: 2015年8月25日 6:25
收件人: Alia Atlas
抄送: [email-masked]; Kathleen Moriarty
主题: Re: [I2nsf] comments on I2NSF charter

With I2RS one step ahead  in debating/specifying the proper mechanism to ensure the network integrity with multi-headed control, I2NSF can breathe a bit. I hope that I2NSF can borrow or simply refer to the multi-headed control mechanism defined by I2RS when it is finalized.

Thank you for the suggested wording change. I like it. If I don’t hear any objection, I will change the wiki by tomorrow.

Linda

On Mon, Aug 24, 2015 at 4:27 PM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:
I took a look at the charter at https://sites.google.com/site/interface2nsf/home .
In general, this looks plausible.  I do have a few comments.

First, could you consider and add clarity around whether I2NSF is assuming single-headed control (as is common in network management systems or controllers) or is assuming multi-headed control (as I2RS does)?

Replace:
"However, I2NSF will provide a forum for Informational drafts on data models, APIs, etc. that demonstrate how more complex Service Layer policies and formats may be translated to Capability Layer functions."
With
"However, I2NSF will provide a discussion forum for Informational drafts on data models, APIs, etc. that demonstrate how more complex Service Layer policies and formats may be translated to Capability Layer functions.  Such documents would be pursued outside the WG."

Thanks,
Alia

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

---

From: <[email-masked]>
Date: Tue, 25 Aug 2015 09:39:15 +0000

I agree, I don’t think it’s necessary to consider multi-headed control at this point and would support re-using the good work i2rs is doing if/when we do require it.

I also agree with Alia’s suggested wording change to focus the scope.

Thanks,
Joe

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: 24 August 2015 23:25
To: Alia Atlas <[email-masked]>
Cc: [email-masked]; Kathleen Moriarty <[email-masked]>
Subject: Re: [I2nsf] comments on I2NSF charter

Linda

Replace:

Thanks,
Alia

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 25 Aug 2015 11:04:45 -0500

Alia,

All the comments/replies (including operators) from the I2NSF mailing list
support I2NSF focusing on the single headed control first and support your
suggested changes.

So I updated the I2NSF charter on the I2NSF wiki :
https://sites.google.com/site/interface2nsf/home

To make it easier for your review, here is the wording I changed for
"single headed control":

*"Controlling and monitoring aspects of NSFs include the ability to specify
rules (by a single controller at the first phase), query, and monitor NSFs
by one or more management entities.  The initial phase of I2NSF will only
consider one single controller that can specify or change rules to NSFs
because multi-headed control requires the coordination to avoid potential
conflict of rules. The NSFs can be monitored by multiple entities, but the
Database update and synchronization among multiple management entities are
out of the I2NSF scope."*

Thank you very much.

Linda

---

From: Alia Atlas <[email-masked]>
Date: Tue, 25 Aug 2015 12:43:16 -0400

Looks good - thank you!

Alia

On Tue, Aug 25, 2015 at 12:04 PM, Linda Dunbar <[email-masked]>
wrote:

> *"Controlling and monitoring aspects of NSFs include the ability to
> specify rules (by a single controller at the first phase), query, and
> monitor NSFs by one or more management entities.  The initial phase of
> I2NSF will only consider one single controller that can specify or change
> rules to NSFs because multi-headed control requires the coordination to
> avoid potential conflict of rules. The NSFs can be monitored by multiple
> entities, but the Database update and synchronization among multiple
> management entities are out of the I2NSF scope."*
>
>
>
> Thank you very much.
>
> Linda
>
>> First, could you consider and add clarity around whether I2NSF is
>> assuming single-headed control (as is common in network management systems
>> or controllers) or is assuming multi-headed control (as I2RS does)?
>>

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 25 Aug 2015 17:15:26 -0400

Joe, Linda and all: 

I2RS considered multi-headed control in order to deal with the error case of two I2RS clients trying to write to the same node in a data model.  

We are in the midst of discussing in the I2RS finalizing of requirements for I2RS revision to NETCONF can handle this error case. As long as you realize where the problem is, you can make a lot of progress by focusing on other issues before you come back to this point. 

Sue Hares 

I2RS co-chair

From: I2nsf [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, August 25, 2015 5:39 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [I2nsf] comments on I2NSF charter

Thanks,

Joe

Linda

I took a look at the charter at  <https://sites.google.com/site/interface2nsf/home> https://sites.google.com/site/interface2nsf/home .

Replace:

With

Thanks,

Alia

---

From: "Zarny, Myo" <[email-masked]>
Date: Tue, 25 Aug 2015 21:19:42 -0400

I agree. Just as we’ve chosen to focus on the Capability Layer first, we should focus on the single-controller use case first. And we’ll have the benefit of leveraging I2RS’s work on multi-headed control later. Of course whatever solution I2NSF comes up for the single controller case mustn’t preclude the multi-controller case.

From: I2nsf [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: 25 August 2015 5:15 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [I2nsf] comments on I2NSF charter

Joe, Linda and all:

Sue Hares
I2RS co-chair

From: I2nsf [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, August 25, 2015 5:39 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [I2nsf] comments on I2NSF charter

Thanks,
Joe

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: 24 August 2015 23:25
To: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>
Subject: Re: [I2nsf] comments on I2NSF charter

Linda

Replace:

Thanks,
Alia

---

From: Shaibal Chakrabarty <[email-masked]>
Date: Wed, 26 Aug 2015 13:09:58 -0500

Folks:

Would highly recommend the consensus opinion of starting with single-headed
control initially.
regards, shaibal