Subject: Re: [I2nsf] could you please address comments from Diego Lopez on draft-kumar-i2nsf-client-facing-interface-req-00 and revise the draft accordingly?

From: Rakesh Kumar <[email-masked]>
Date: Wed, 28 Sep 2016 23:30:29 +0000

Hi Linda,

I have communicated earlier through private channel to folks who provided comments that we would create a new revision but I am still waiting on inputs from couple of other folks. I wanted to combine all the comments into one update, avoid unnecessary cycles and save time.

Thanks & Regards,
Rakesh

From: Linda Dunbar <[email-masked]>
Date: Wednesday, September 28, 2016 at 2:23 PM
To: Rakesh Kumar <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: could you please address comments from Diego Lopez on draft-kumar-i2nsf-client-facing-interface-req-00 and revise the draft accordingly?

Rakesh,

Searching through the mailing list achieve, I find the comments from Diego Lopez on your draft hasn’t been addressed nor reflect in your draft. Can you address them and revise the draft accordingly?

Thank you very much.

Linda

https://mailarchive.ietf.org/arch/search/?email_list=i2nsf&f_from=diego.r.lopez%40telefonica.com

Re: [I2nsf] New Version Notification for draft-kumar-i2nsf-client-facing-interface-req-00.txt

"Diego R. Lopez" <[email-masked]> Tue, 09 August 2016 17:37 UTCShow header<https://mailarchive.ietf.org/arch/msg/i2nsf/nKbb546VyxO7fOD46Pf3QKf5G5s>
From: "Diego R. Lopez" <[email-masked]>
To: Rakesh Kumar <[email-masked]>
Date: Tue, 9 Aug 2016 17:36:22 +0000
Accept-Language: en-US
spamdiagnosticoutput: 1:99
spamdiagnosticmetadata: NSPM
Archived-At: <https://mailarchive.ietf.org/arch/msg/i2nsf/nKbb546VyxO7fOD46Pf3QKf5G5s>
Cc: "[email-masked]" <[email-masked]>, Anil Lohiya <[email-masked]>, "[email-masked]" <[email-masked]>, "Long, Xiaobo" <[email-masked]>
Subject: Re: [I2nsf] New Version Notification for draft-kumar-i2nsf-client-facing-interface-req-00.txt
Hi Rakesh,

A few replies inline below. I’ve trimmed a little bit the text to make the whole message more readable…

On 4 Aug 2016, at 06:32 , Rakesh Kumar <[email-masked]<mailto:[email-masked]>> wrote:

H1) I would prefer other terms to refer to the actors described in the introduction (and elsewhere) While the term “vendor” is clear and generally accepted, I’d prefer to use “developer” (as it is done in the framework draft) to incorporate as well NSFs provided by open-source communities and developed in-house, to name a couple of additional sources for them. Going further, the term “end-customer” is completely misleading, as in the networking environment is usually employed to refer to the people or organizations who are using the network services. I’d rather use “network operator”, or “NSF operator”, or even “security manager” if you do not like to use the term “operator”.
[Rakesh] Sure.  Is there any other better term for “ vendor” (I have not seen developer term being used in the context of vendor)?
Instead of “end-customer”, we can use “Security Admin” .

DRL> I know the traditional name for the provider of hardware and software is “vendor” and it is constantly (and consistently) used elsewhere, but I think it would be interesting to reflect the new trends in the industry, especially when it comes to open source projects and in-house tailored developments, and therefore I’d prefer to start changing the term into the more neutral “developer”, that considers in a better way these other scenarios.

DRL> Regarding the “security admin” term, I am more than happy with it.

2) Regarding the term "user-intent”, and in order to avoid misinterpretations in despite of the clarification statement at the end of the introduction, I wonder whether another term could be used. I’d suggest “policy expressions”…
[Rakesh] Let me think about this.

DRL> OK. What I’d like to avoid is a clash with the other ongoing activities around other interpretations of the term, and spare all of us the need of providing explanations once and again.

3) It is not clear to me what section 3.2 has to do with the rest of the document, as it deals with southbound interface deployment. I’d suggest to delete it, as it can be misinterpreted as a deployment recommendation and introduces a new element (the agent) that is not part of the I2NSF framework
[Rakesh] The reason we put this, was to articulate that client interface are independent of how a security controller interact with NSF.  Basically client interface remain the same, independent of  deployment model. The I2NSF only deals with client interface (northbound side) and NSF interface (southbound), everything else is implementation dependent and outside the scope of I2NSF.  It is  hard to make this point without any pictorial context since not everyone may be well versed with all the concepts.

DRL> A possible away would be to clearly state we are talking about exemplary deployments styles, and merge the discussion with other sections, so it becomes clear there are no specific recommendations on particular southbound implementation or deployment patterns.

4) In section 4 I see a very disparate set of requirements, ranging from identifying some role-based objects for RBAC (in 4.1) to listing potential data sources for telemetry (in 4.7), without a clear identification of what are the specific requirements in the style I have seen in many other IETF requirements documents. I am confident we will make the draft evolve in that direction in successive versions.
[Rakesh] I think we added details in each one but please let us know if you want add some more or put it in different format.

DRL> The problem I see is that the level of detail and the depth of the requirements are somehow not completely aligned among them and in particular with other IETF requirements documents (as a couple of examples pointing in the direction of my comment, have a look at https://datatracker.ietf.org/doc/draft-mglt-sfc-security-environment-req/ or https://datatracker.ietf.org/doc/draft-ietf-i2rs-security-environment-reqs/) As I said, I am rather sure the document will evolve in this direction so it was more a remark on the desired path to follow than anything else.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 30 Sep 2016 08:13:40 +0000

Hi,

I will be happy to look at this new revision and consider it for adoption. In the meantime, I find the current -00 not mature enough.

Be goode,

On 29 Sep 2016, at 01:30 , Rakesh Kumar <[email-masked]<mailto:[email-masked]>> wrote:

Hi Linda,

Thanks & Regards,
Rakesh

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 28, 2016 at 2:23 PM
To: Rakesh Kumar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: could you please address comments from Diego Lopez on draft-kumar-i2nsf-client-facing-interface-req-00 and revise the draft accordingly?

Rakesh,

Thank you very much.

Linda

"Diego R. Lopez" <[email-masked]<mailto:[email-masked]>> Tue, 09 August 2016 17:37 UTCShow header<https://mailarchive.ietf.org/arch/msg/i2nsf/nKbb546VyxO7fOD46Pf3QKf5G5s>

From: "Diego R. Lopez" <[email-masked]<mailto:[email-masked]>>
To: Rakesh Kumar <[email-masked]<mailto:[email-masked]>>
Date: Tue, 9 Aug 2016 17:36:22 +0000
Accept-Language: en-US
spamdiagnosticoutput: 1:99
spamdiagnosticmetadata: NSPM
Archived-At: <https://mailarchive.ietf.org/arch/msg/i2nsf/nKbb546VyxO7fOD46Pf3QKf5G5s>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Anil Lohiya <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Long, Xiaobo" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [I2nsf] New Version Notification for draft-kumar-i2nsf-client-facing-interface-req-00.txt
Hi Rakesh,

On 4 Aug 2016, at 06:32 , Rakesh Kumar <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>> wrote:

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

Dr Diego R. Lopez
Telefonica I+D