Subject: [I2nsf] Summary of the I2NSF Hackathon

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 18 Nov 2016 13:19:25 +0900

Dear IETF Chairman Jari Arkko,
This Paul from SKKU, one of the winners this IETF-97 Hackathon.

My team (SKKU, KT, and ETRI) demonstrated the feasibility of a data-driven
I2NSF framework
with two security services, such as firewall for web-filtering and DPI for
VoIP/VoLTE
security services. We proved the design validity of the two interfaces
(e.g., Consumer-facing interface
and NSF-facing interface) in the I2NSF interfaces.

This I2NSF Hackathon used open sources, such as Confd for NETCONF,
OpenDaylight
for SDN Controller, Mininet for SDN Network, and RestAPI for I2NSF
Interface.

In this I2NSF Hackathon, more than 20 people actively participated from
SKKU, ETRI, KT, Konkun University, and Huawei.
That is why we got the Best Group Work award this time :-)

My students at SKKU and I were very excited to have an impressive
experience in this Hackathon
and also be able to contribute to IETF with a working open code along with
Internet Drafts for I2NSF WG.

My team would like to keep contributing to I2NSF WG by participating in
future Hackathons.

Here is the presented slides for I2NSF Hackathon in I2NSF WG session this
IETF 97
meeting having more information:
https://www.ietf.org/proceedings/97/slides/slides-97-i2nsf-i2nsf-hackathon-report-01.pdf

Here is the GitHub link having the I2NSF Hackathon source code and
documents:
 https://github.com/kimjinyong/i2nsf-framework

Thanks for your sincere service in IETF.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 23 Nov 2016 15:33:07 +0200

Thanks for this. I was very impressed about the efforts, and am also planning to put something about this in the IETF blog series.

Jari

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 23 Nov 2016 22:43:22 +0900

Dear Jari,
Thanks for your encouraging reply :-)
Our SKKU team will keep working for I2NSF WG.

Sincerely Yours,
Paul

2016. 11. 23. 오후 10:33에 "Jari Arkko" <[email-masked]>님이 작성:

> Thanks for this. I was very impressed about the efforts, and am also
> planning to put something about this in the IETF blog series.
>
> Jari
>
>