Subject: [I2nsf] Invitation to IETF-97 I2NSF Hackathon

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 7 Nov 2016 22:46:45 +0900

Hi I2NSFers,

My coworkers and I are planning to champion an I2NSF project
at the Hackathon in IETF-97 Seoul Meeting (
https://www.ietf.org/hackathon/97-hackathon.html)
to work on the implementation of security services in the I2NSF framwork.

We added our Hackathon description for the I2NSF framework project:
https://www.ietf.org/registration/MeetingWiki/wiki/97hackathon

My team are providing the basic code as an open source in Github
for the I2NSF framework having SDN networks.
Based on this code, Hackathon participants and my team will create
and test the firewall and deep packet inspection (DPI) modules
for VoIP/VoLTE security services in the I2NSF framework.

Skills that will help you:
- C/C++
- OS: Ubuntu
- Netconfd
- Mininet
- OpenDaylight
- MySQL
- Apache2
- PHP

Please join us at IETF-97 I2NSF Hackathon.

Best Regards,
Jaehoon Paul Jeong

------------------------------------------------------------------------------------
Interface to Network Security Functions (I2NSF) Framework
https://www.ietf.org/registration/MeetingWiki/wiki/97hackathon

Interface to Network Security Functions (I2NSF) Framework

* Champion(s)
  - Jaehoon Paul Jeong [email-masked]
  - Jinyong Tim Kim [email-masked]
  - Jung-Soo Park [email-masked]
  - Tae-Jin Ahn [email-masked]

* Project(s)
  - I2NSF Framework for provisioning Network Security Functions (NSFs)
  - Firewall in I2NSF Framework using Software-Defined Networking (SDN)
  - Deep Packet Inspection (DPI) for VoIP-VoLTE Security Service in I2NSF
Framework
  - Working Group Drafts
    > https://tools.ietf.org/html/draft-ietf-i2nsf-framework-04
    > https://tools.ietf.org/html/draft-hares-i2nsf-capability-data-model-00
    >
https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-00
    > https://tools.ietf.org/html/draft-jeong-i2nsf-sdn-security-services-05
    >
https://tools.ietf.org/html/draft-kim-i2nsf-security-management-architecture-03
https://tools.ietf.org/html/draft-kim-i2nsf-consumer-facing-interface-dm-00
    > https://tools.ietf.org/html/draft-hyun-i2nsf-nsf-triggered-steering-00
    >
https://tools.ietf.org/html/draft-hyun-i2nsf-registration-interface-im-00
https://tools.ietf.org/html/draft-ahn-i2nsf-communications-security-use-case-01

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 7 Nov 2016 16:17:00 +0000

Paul,

Thank you very much for championing the I2NSF Hackathon in IETF-97.
I will be there.

Do you know if it is possible for remote people to participate in the Hackathon?

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: 2016年11月7日 7:47
To: [email-masked]
Cc: Myung-Ki Shin <[email-masked]>; 김익균 <[email-masked]>; JungSoo Park <[email-masked]>; [email-masked]; Tae-Jin Ahn <[email-masked]>; 김영수 <[email-masked]>; Se-Hui Lee <[email-masked]>
Subject: [I2nsf] Invitation to IETF-97 I2NSF Hackathon

Hi I2NSFers,

My coworkers and I are planning to champion an I2NSF project
at the Hackathon in IETF-97 Seoul Meeting (https://www.ietf.org/hackathon/97-hackathon.html)
to work on the implementation of security services in the I2NSF framwork.

Best Regards,
Jaehoon Paul Jeong

* Champion(s)
  - Jaehoon Paul Jeong [email-masked]<mailto:[email-masked]>
  - Jinyong Tim Kim [email-masked]<mailto:[email-masked]>
  - Jung-Soo Park [email-masked]<mailto:[email-masked]>
  - Tae-Jin Ahn [email-masked]<mailto:[email-masked]>

* Project(s)
  - I2NSF Framework for provisioning Network Security Functions (NSFs)
  - Firewall in I2NSF Framework using Software-Defined Networking (SDN)
  - Deep Packet Inspection (DPI) for VoIP-VoLTE Security Service in I2NSF Framework
  - Working Group Drafts

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 8 Nov 2016 09:48:01 +0900

Hi Linda,
Sure it will be possible.

I2NSFers,
If some of you are willing to work remotely, please let me know.
We can work together through Skype meeting.

Thanks.

Best Regards,
Paul

On Tue, Nov 8, 2016 at 1:17 AM, Linda Dunbar <[email-masked]>
wrote:

> *From:* I2nsf [mailto:[email-masked]] *On Behalf Of *Mr. Jaehoon
> Paul Jeong
> *Sent:* 2016年11月7日 7:47
> *To:* [email-masked]
> *Cc:* Myung-Ki Shin <[email-masked]>; 김익균 <[email-masked]>;
> JungSoo Park <[email-masked]>; [email-masked];
> Tae-Jin Ahn <[email-masked]>; 김영수 <[email-masked]>; Se-Hui Lee <
> [email-masked]>
> *Subject:* [I2nsf] Invitation to IETF-97 I2NSF Hackathon
>
>
>
> Hi I2NSFers,
>
>
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 11 Nov 2016 11:28:42 +0000

Hi Paul,

I think the participation in the hackathon is a great idea, though I am afraid I won’t make it to Seoul, and given the time difference remote participation seems really complicated to me. But I’d definitely be interested in whatever comes out of this!

Be goode,

On 8 Nov 2016, at 01:48 , Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>> wrote:

Hi Linda,

I2NSFers,

Thanks.

Best Regards,
Paul

On Tue, Nov 8, 2016 at 1:17 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Paul,

Linda

From: I2nsf [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: 2016年11月7日 7:47
To: [email-masked]<mailto:[email-masked]>
Cc: Myung-Ki Shin <[email-masked]<mailto:[email-masked]>>; 김익균 <[email-masked]<mailto:[email-masked]>>; JungSoo Park <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Tae-Jin Ahn <[email-masked]<mailto:[email-masked]>>; 김영수 <[email-masked]<mailto:[email-masked]>>; Se-Hui Lee <[email-masked]<mailto:[email-masked]>>
Subject: [I2nsf] Invitation to IETF-97 I2NSF Hackathon

Hi I2NSFers,

Best Regards,
Jaehoon Paul Jeong

* Champion(s)

* Project(s)

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Sat, 12 Nov 2016 00:42:24 +0900

Hi Diego,
Thanks for your interest.
We will let you know what results are obtained from this IETF Hackathon.

Thanks.

Best Regards,
Paul

On Fri, Nov 11, 2016 at 8:28 PM, Diego R. Lopez <
[email-masked]> wrote:

> Hi Paul,
>
> I think the participation in the hackathon is a great idea, though I am
> afraid I won’t make it to Seoul, and given the time difference remote
> participation seems really complicated to me. But I’d definitely be
> interested in whatever comes out of this!
>
> Be goode,
>
> On 8 Nov 2016, at 01:48 , Mr. Jaehoon Paul Jeong <[email-masked]>
> wrote:
>
> Hi Linda,
>> Tae-Jin Ahn <[email-masked]>; 김영수 <[email-masked]>; Se-Hui Lee
>> <[email-masked]>
> [email-masked]