Subject: [I2nsf] Oct 20 Discussion Minutes on the consistency between Data Model and Information Model

From: Linda Dunbar <[email-masked]>
Date: Fri, 20 Oct 2017 18:17:37 +0000

Many thanks to people, especially the ones from Asia staying up to 1am,  participating in this meeting.
Here is the recording of the Interim meeting: https://ietf.webex.com/ietf/ldr.php?RCID=568242edccfb24986f6d129648cf5e83

Here is my rough notes. Please add more if I miss something.

Minutes of the Interim Meeting on
Discussing consistency between Data Model and Information Model

Participants: John Strassner; Diego Lopez;  Jinyong Kim; Frank Xia; Dyhyun Hyun; Sangwon Hyun, Cataldo Basile; Dong Jin Hong; Yoav Nir; Linda Dunbar; and Kathleen Moriarty

Time: Oct 20, 2017 12pm EST - 1: 15pm EST

Key Points from the discussion:
draft-kim-i2nsf-nsf-facing-interface-data-model-03:
Section 4: Should not use "Event/Condition/Action Policy", Should use "Event/Condition/Event Clause" instead.
Change the wording to
This subsection is to describe the condition clause. Condition clause is used to describe the set of attributes for "Condition Clause"...

Section 4.5: it is not "Resolution Strategy Policy". Instead, "Resolution Strategy" is the mechanism to ensure the integrity of the rules, especially when there are rules which conflict among them. It is the formal algebra to express how to detect the conflicts and how to resolve conflicts.

Section 5: add an introduction stating that the data model structure descrpbed in this section can be mapped to draft-ietf-i2nsf-capability"
Section 5.2:
The three attributes "use-sec-event-content", "usr-se-event-format", and "usr-sec-event-type" appeared in multiple places (under "usr-event", "dev-event" and "sys-event"). It is better to combine those three attributes as one "Identity" so that only one "Identity" is appearing 3 times. In case there are changes to any of one of those attributes, the reference identity stay the same.

Section 5.3:
Should reference the "address types" already defined by https://datatracker.ietf.org/doc/draft-ietf-netmod-acl-model/  such as:
yang:mac-address
inet: ipv6-prefix
inet: ipv4-prefix,
inet: dicp
etc.

draft-xia-i2nsf-security-policy-object-01
Frank stated that this draft is meant to define the abstract types to be further used by nsf-facing-dm draft. For example, "Address Objects" and "service Object" can be defined clearly, so that other Data Model drafts can simply use those objects instead of re-defining them in multiple places.
Frank will work with the Data model drafts authors to clear out what is defined on where.

Thank you very much.
Linda & Yoav

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Sat, 21 Oct 2017 19:36:50 +0900

Hi Linda, Yoav, and Kathleen,
Thanks for your coordination on this meeting.

My SKKU team will address all of the comments from the discussion
on two data model drafts and submit the revised drafts by the submission
due:
https://tools.ietf.org/html/draft-hares-i2nsf-capability-data-model-04
https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-
interface-data-model-03

Specially, I appreciate detailed comments on our data models from the
authors of
the capability information model, such as John, Frank, Diego, and Cataldo.

Thanks.

Best Regards,
Paul

On Sat, Oct 21, 2017 at 3:17 AM, Linda Dunbar <[email-masked]>
wrote:

> Here is the recording of the Interim meeting:
> https://ietf.webex.com/ietf/ldr.php?RCID=568242edccfb24986f6d129648cf5e83
>
>
>
> *Minutes of the Interim Meeting on*
>
> *Discussing consistency between Data Model and Information Model*
>
>
>
> *Participants: *John Strassner; Diego Lopez;  Jinyong Kim; Frank Xia;
> Dyhyun Hyun; Sangwon Hyun, Cataldo Basile; Dong Jin Hong; Yoav Nir; Linda
> Dunbar; and Kathleen Moriarty
>
>
>
> *Time:* Oct 20, 2017 12pm EST – 1: 15pm EST
>
>
>
> *Key Points from the discussion: *
>
> *draft-kim-i2nsf-nsf-facing-interface-data-model-03:*
>
> Section 4: Should not use “Event/Condition/Action Policy”, Should use
> “Event/Condition/Event Clause” instead.
>
> Change the wording to
>
> *This subsection is to describe the condition clause. Condition clause is
> used to describe the set of attributes for “Condition Clause”…*
>
>
>
> Section 4.5: it is not “Resolution Strategy Policy”. Instead, “Resolution
> Strategy” is the mechanism to ensure the integrity of the rules, especially
> when there are rules which conflict among them. It is the formal algebra to
> express how to detect the conflicts and how to resolve conflicts.
>
>
>
> Section 5: add an introduction stating that the data model structure
> descrpbed in this section can be mapped to draft-ietf-i2nsf-capability”
>
> Section 5.2:
>
> The three attributes “use-sec-event-content”, “usr-se-event-format”, and
> “usr-sec-event-type” appeared in multiple places (under “usr-event”,
> “dev-event” and “sys-event”). It is better to combine those three
> attributes as one "Identity" so that only one "Identity" is appearing 3
> times. In case there are changes to any of one of those attributes, the
> reference identity stay the same.
>
>
>
>
>
> Section 5.3:
>
> Should reference the “address types” already defined by
> https://datatracker.ietf.org/doc/draft-ietf-netmod-acl-model/  such as:
>
> yang:mac-address
>
> inet: ipv6-prefix
>
> inet: ipv4-prefix,
>
> inet: dicp
>
> etc.
>
>
>
>
>
> *draft-xia-i2nsf-security-policy-object-01*
>
> Frank stated that this draft is meant to define the abstract types to be
> further used by nsf-facing-dm draft. For example, “Address Objects” and
> “service Object” can be defined clearly, so that other Data Model drafts
> can simply use those objects instead of re-defining them in multiple
> places.
>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>