Subject: [I2nsf] Request for WG Adoption Call for I2NSF Data Model Drafts

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 31 Oct 2017 10:24:12 +0900

Dear Linda and Yoav,
Could you start the WG adoption call for the following three data model
drafts?

1. I2NSF Capability YANG Data Model
(draft-hares-i2nsf-capability-data-model-05 )
https://tools.ietf.org/html/draft-hares-i2nsf-capability-data-model-05

2. I2NSF Network Security Functions-Facing Interface YANG Data Model
(draft-kim-i2nsf-nsf-facing-interface-data-model-04)
https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-
interface-data-model-04

3. I2NSF Consumer-Facing Interface YANG Data Model
(draft-jeong-i2nsf-consumer-facing-interface-dm-04)
https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-
facing-interface-dm-04

We address all the discussions last meetings for the synchronization between
the information models and data models.

Thanks for your coordination.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 31 Oct 2017 16:22:27 +0000

Paul,

Got your request.

For I2NSF Consumer-Facing Interface YANG Data Model, I think it is better to be called together with
draft-kumar-i2nsf-client-facing-interface-im-04. Do you think draft-kumar-i2nsf-client-facing-interface-im-04 is ready?

Linda

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Monday, October 30, 2017 8:24 PM
To: Linda Dunbar <[email-masked]>; Yoav Nir <[email-masked]>
Cc: [email-masked]; SecCurator_Team <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: Request for WG Adoption Call for I2NSF Data Model Drafts

Dear Linda and Yoav,
Could you start the WG adoption call for the following three data model drafts?

2. I2NSF Network Security Functions-Facing Interface YANG Data Model
(draft-kim-i2nsf-nsf-facing-interface-data-model-04)
https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04

3. I2NSF Consumer-Facing Interface YANG Data Model
(draft-jeong-i2nsf-consumer-facing-interface-dm-04)
https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

Best Regards,
Paul
--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: John Strassner <[email-masked]>
Date: Tue, 31 Oct 2017 10:26:19 -0700

Wouldn't it be ore prudent to first have the design team meet to discuss
alignment issues, and then proceed from the results of that?

regards,
John

On Tue, Oct 31, 2017 at 9:22 AM, Linda Dunbar <[email-masked]>
wrote:

> draft-kumar-i2nsf-client-facing-interface-im-04. Do you think
> draft-kumar-i2nsf-client-facing-interface-im-04 is ready?
>
>
>
> Linda
>
>
>
>
>
> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
> *Sent:* Monday, October 30, 2017 8:24 PM
> *To:* Linda Dunbar <[email-masked]>; Yoav Nir <
> [email-masked]>
> *Cc:* [email-masked]; SecCurator_Team <skku_secu-brain_all@
> googlegroups.com>; Mr. Jaehoon Paul Jeong <[email-masked]>
> *Subject:* Request for WG Adoption Call for I2NSF Data Model Drafts
>
>
>
> Dear Linda and Yoav,
>
> Office: +82-31-299-4957 <+82%2031-299-4957>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

-- 
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 1 Nov 2017 10:01:11 +0900

Hi Linda,
Yes, we want to request the WG adoption call for the IM and DM documents
together.

1. Information Model for Consumer-Facing Interface to Security Controller
(draft-kumar-i2nsf-client-facing-interface-im-04)
https://tools.ietf.org/html/draft-kumar-i2nsf-client-facing-interface-im-04
2. I2NSF Consumer-Facing Interface YANG Data Model
(draft-jeong-i2nsf-consumer-facing-interface-dm-04)
https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

When draft-kumar-i2nsf-client-facing-interface-im-04 is adopted as a WG
document,
its name will be draft-i2nsf-i2nsf-consumer-facing-interface-im-00, because
client-facing interface is consumer-facing interface in our I2NSF framework
document.

Though draft-jeong-i2nsf-consumer-facing-interface-dm-04 is based on
draft-kumar-i2nsf-client-facing-interface-im-03,
it is overall synchronized with
draft-kumar-i2nsf-client-facing-interface-im-04 with ECA policy model.
When the DM is adopted as a WG document, we will be able to make these two
IM and DM completely synchronized.

Thanks.

Best Regards,
Paul

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 1 Nov 2017 10:13:36 +0900

Hi John,
You are right. :-)

Actually, the authors of IM and DM documents for the client-facing
interface
had a teleconference with Linda last September (9/27/2017).
We discussed how to correct the IM and how to synchronize these two IM and
DM documents.

I joined the IM document as a co-author to synchronize them.

The current DM has the ECA policy model, but I need to modify something to
synchronize them completely.
I think this synchronization is not a big deal because our IM is not so
complicated and our DM is structured to
accommodate the IM.
During the WG adoption call, I will make these two IM and DM documents
completely synchronized.

Thanks for your good suggestion.

Best Regards,
Paul

On Wed, Nov 1, 2017 at 2:26 AM, John Strassner <[email-masked]> wrote:

>> *Cc:* [email-masked]; SecCurator_Team <skku_secu-brain_all@googlegro
>> ups.com>; Mr. Jaehoon Paul Jeong <[email-masked]>