Subject: [I2nsf] Is "remote attestation" applicable to TEEP (Trusted Execution environment to allow secure updates) or SUIT (Software Update for Internet of things)?

From: Linda Dunbar <[email-masked]>
Date: Thu, 7 Dec 2017 16:29:32 +0000

Antonio, Diego, and Adrian

IETF 100 has those two BOFs:

*        TEEP: Trusted Execution Environment to allow secure updates

*        SUIT: Software Update for Internet of Things (current scope limited to firmware updates)
There are Considerable interest from Microsoft (including Dave Thaler as co-chair for both BoFs).

Is "remote attestation" applicable to TEEP or SUIT?

Linda

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 19 Dec 2017 18:56:38 +0000

Hi Linda,

Trying to catch up with highly delayed emails. In principle, the techniques applicable for TEEP (and probably SUIT, not sure about the details in this case) should be the same related to remote attestation. This is one of the reasons why Henk and yours friendly are advocating for a list (and probably a WG) focused on it.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------
On 07/12/2017, 17:29, "Linda Dunbar" <[email-masked]<mailto:[email-masked]>> wrote:

·         TEEP: Trusted Execution Environment to allow secure updates

·         SUIT: Software Update for Internet of Things (current scope limited to firmware updates)
There are Considerable interest from Microsoft (including Dave Thaler as co-chair for both BoFs).

Linda

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição