Subject: Re: [I2nsf] Calling for IETF101 I2NSF WG session agenda request. If you need remote presentations, please let us know as soon as possible

From: 양현식 <[email-masked]>
Date: Mon, 5 Mar 2018 02:23:07 +0900

Dear I2NSF WG

I am Hyunsik Yang at Soongsil Univeersity.

I submitted one personal draft about a how I2NSF framework adopted to NFV.

Could i have a one slot for this draft? 10-15min?

If i have chance, i wanna introduce this draft and discuss about it.

Thanks

--------------------------------------------------------------------------------------

A new version of I-D, draft-yang-i2nsf-nfv-architecture-01.txt
has been successfully submitted by Hyunsik Yang and posted to the
IETF repository.

Name:           draft-yang-i2nsf-nfv-architecture
Revision:       01
Title:          I2NSF on the NFV Reference Architecture
Document date:  2018-03-03
Group:          Individual Submission
Pages:          13
URL:            https://www.ietf.org/internet-drafts/draft-yang-i2nsf-nfv-
architecture-01.txt
Status:         https://datatracker.ietf.org/doc/draft-yang-i2nsf-nfv-
architecture/
Htmlized:       https://tools.ietf.org/html/draft-yang-i2nsf-nfv-
architecture-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-yang-i2nsf-nfv-
architecture-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-yang-i2nsf-nfv-
architecture-01

Abstract:
     This document describes the adoption of I2NSF Framework onto the
     Network Functions Virtualization (NFV) Reference Model. In this
     document, we explain the I2NSF Framework adopted to NFV reference
     architecture with each corresponding component.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

*Sent with Shift
<https://tryshift.com/?utm_source=SentWithShift&utm_campaign=Sent%20with%20Shift%20Signature&utm_medium=Email%20Signature&utm_content=General%20Email%20Group>*

2018-02-28 2:52 GMT+09:00 Linda Dunbar <[email-masked]>:

> I2NSF WG session will be Wed march 21 9:30am~12pm.
>
> Please let us know if you need presentation slot, and how long is your
> presentation.
>
> If you need remote presentation, please let us know as soon as possible.
>
>
>
> Thanks, Linda & Yoav
>
>
> -----Original Message-----
> From: WGChairs [mailto:[email-masked]
> <[email-masked]>] On Behalf Of Meetecho IETF support
> Sent: Monday, February 26, 2018 9:27 AM
> To: [email-masked]
> Subject: Cutoff date for requesting remote presentations support at IETF101
>
> Dear chairs,
>
> as usual, please book your remote *presentation* slots at IETF101 by
> filling out the following form:
>
>     https://ietf101.conf.meetecho.com/index.php/Remote_presentations
>
> *The cutoff date is March 16, 2018.*
>
> You can also check scheduled remote presentations here:
>
>     https://ietf101.conf.meetecho.com/list.php
>
> Thanks,
> the Meetecho team
>
>
>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>
>

-- 

*-------------------------------------------------------------------*

*Hyunsik Yang (Ph. D candidate)*

*DCN laboratory / School of Electronic Engineering*

*Soongsil University *

*511 Sangdo-dong Dongjak-gu*

*Seoul, 156-743 Korea*

*TEL : (+82)-2-820-0841 *

*M.P: (+82)-10-9005-7439*

*Sent with Shift
<https://tryshift.com/?utm_source=SentWithShift&utm_campaign=Sent%20with%20Shift%20Signature&utm_medium=Email%20Signature&utm_content=General%20Email%20Group>*

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 8 Mar 2018 15:22:32 +0900

Hi Linda and Yoav,
I would like to request timeslots for IETF-101 I2NSF WG Session as below:

1. IETF-101 Hackathon I2NSF Project
 - Presenter: Jaehoon Paul Jeong
 - Time: 5 min

2. Applicability of Interfaces to Network Security Functions to
Network-Based Security Services
 - draft-ietf-i2nsf-applicability-02
 - Presenter: Jaehoon Paul Jeong
 - Time: 10 min

3. I2NSF Consumer-Facing Interface YANG Data Model
 - draft-ietf-i2nsf-consumer-facing-interface-dm-00
 - Presenter: Jaehoon Paul Jeong
 - Time: 10 min

4. I2NSF Network Security Function-Facing Interface YANG Data Model
 - draft-ietf-i2nsf-nsf-facing-interface-dm-00
 - Presenter: Jinyong Tim Kim
 - Time: 10 min

5. I2NSF Capability YANG Data Model
 - draft-hares-i2nsf-capability-data-model-06
 - Presenter: Jinyong Tim Kim
 - Time: 10 min

6. YANG Data Model for Monitoring I2NSF Network Security Functions
 - draft-hong-i2nsf-nsf-monitoring-data-model-02
 - Presenter: Jaehoon Paul Jeong (or Henk Birkholz)
 - Time: 10 min

7. I2NSF Registration Interface Information Model and YANG Data Model
 - draft-hyun-i2nsf-registration-interface-im-04
 - draft-hyun-i2nsf-registration-interface-dm-03
 - Presenter: Jaehoon Paul Jeong
 - Time: 10 min

8. Service Function Chaining-Enabled I2NSF Architecture
 - draft-hyun-i2nsf-nsf-triggered-steering-05
 - Presenter: Jaehoon Paul Jeong
 - Time: 10 min

Thanks for your coordination.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 8 Mar 2018 15:31:48 +0900

Hi Linda and Yoav,
I support the presentation of this draft because
this draft deals with an important subject about
the implementation guideline of our I2NSF framework
in an NFV environment based on the ETSI NFV reference architecture.

Thanks.

Best Regards,
Paul

On Mon, Mar 5, 2018 at 2:23 AM, 양현식 <[email-masked]> wrote:

> Status:         https://datatracker.ietf.org/doc/draft-yang-i2nsf
> -nfv-architecture/
> Htmlized:       https://tools.ietf.org/html/draft-yang-i2nsf
> -nfv-architecture-01
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-yang-i2nsf
> -nfv-architecture-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-yang-i2nsf
> -nfv-architecture-01
>
> Abstract:

---

From: Yoav Nir <[email-masked]>
Date: Thu, 8 Mar 2018 20:09:12 +0200

Hi, Paul

That’s a total of 75 minutes, 70 of them for various drafts. So what is the intent here?

Last time we had a whole bunch of presentations that were pretty much a primer on what this draft is about. Working group sessions are supposed to be about discussion, and the attendees are assumed (perhaps naïvely) to have read the drafts.  I don’t want another round of primers. If the point is a status update, we can make an 8-slide deck with a quick status for each draft and run through that in 10-15 minutes.

Can you give me an outline of what things are to be discussed?

Thanks

Linda and Yoav

> On 8 Mar 2018, at 8:22, Mr. Jaehoon Paul Jeong <[email-masked]> wrote:
> 
> Hi Linda and Yoav,
> 2. Applicability of Interfaces to Network Security Functions to Network-Based Security Services
> Email: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <http://cpslab.skku.edu/people-jaehoon-jeong.php>
> 
> On Wed, Feb 28, 2018 at 2:52 AM, Linda Dunbar <[email-masked] <mailto:[email-masked]>> wrote:
> Please let us know if you need presentation slot, and how long is your presentation.
> 
> From: WGChairs [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Meetecho IETF support
> To: [email-masked] <mailto:[email-masked]>
> as usual, please book your remote *presentation* slots at IETF101 by filling out the following form:
> 
>     https://ietf101.conf.meetecho.com/index.php/Remote_presentations <https://ietf101.conf.meetecho.com/index.php/Remote_presentations>
> 
>     https://ietf101.conf.meetecho.com/list.php <https://ietf101.conf.meetecho.com/list.php>
> 
> Thanks,
> the Meetecho team
> 
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i2nsf <https://www.ietf.org/mailman/listinfo/i2nsf>
> 
>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 9 Mar 2018 17:05:47 +0900

Yoav,
I totally agree with you that we should focus on the updates and discussion
for important issues.

As you know, my SKKU team have revised the drafts along with our SKKU open
source project in Github for I2NSF:
https://github.com/kimjinyong/i2nsf-framework

According to your guideline, we will prepare for the slides with status
update and next steps so that each draft can be
presented for 2~5 minutes and discussed for 5~10 minutes.

For the report of IETF-101 Hackathon I2NSF project, I would like to present
the progress and next plan in 5 minutes.
The contents of this Hackathon I2NSF project are as follows:
1) The Support of RESTCONF for Consumer-Facing Interface according to the
lastest Consumer-Facing Interface YANG Data Model.
2) Dynamic Selection for NSFs at Security Controller according to
high-level security policy delivered via Consumer-Facing Interface.
3) SFC Support using OpenDaylight's OVS SFC Implementation for SFC-based
Traffic Steering according to I2NSF Capabilities Information Model.

For the I2NSF Applicability WG document, I will report the updates and next
steps:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-applicability/
I hope to let this WG document be under WG Last Call after this IETF-101 WG
meeting according to our WG milestones:
https://datatracker.ietf.org/wg/i2nsf/about/

As you know, my SKKU team are working on three I2NSF interfaces, such as
Consumer-Facing Interface, NSF-Facing Interface,
and Registration Interface with information and YANG data model experts,
such as Sue Hares, Frank Xia, and Henk Birkholz.

Especially, the two YANG data models of  Consumer-Facing Interface and
NSF-Facing Interface have become
our WG documents through the WG adoption calls with comments from John
Strassner, an  information model expert.
I will report the comments during the WG adoption calls and the
corresponding resolutions in this WG meeting.
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-consumer-facing-interface-dm/
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/

I believe that the information model draft of Consumer-Facing Interface is
ready for WG adoption call
because the mirrored Consumer-Facing Interface YANG data model WG document
is well-synchronized with it.
That is why I requested a WG adoption call for the information model draft
of Consumer-Facing Interface:
https://datatracker.ietf.org/doc/draft-kumar-i2nsf-client-facing-interface-im/

I believe that the NSF capability YANG data model draft is ready for WG
adoption call
because it is well-synchronized with the NSF-Facing Interface YANG data
model WG document
and it is revised with John Strassner's comments during the WG adoption
call for
the NSF-Facing Interface YANG data model draft:
https://datatracker.ietf.org/doc/draft-hares-i2nsf-capability-data-model/

In this IETF-101 WG meeting, I would like to briefly present the updates
and next steps for these data models and
let our WG members discuss them.

In addition, I would like to present the updates and next steps of
Registration Interface and then
listen to the WG's opinion to decide whether my SKKU team need to continue
to work for this Registration Interface:
https://datatracker.ietf.org/doc/draft-hyun-i2nsf-registration-interface-im/
https://datatracker.ietf.org/doc/draft-hyun-i2nsf-registration-interface-dm/

For other drafts, such as NSF monitoring data model and SFC-based traffic
triggered, I would like to show the brief updates:
https://datatracker.ietf.org/doc/draft-hong-i2nsf-nsf-monitoring-data-model/
https://datatracker.ietf.org/doc/draft-hyun-i2nsf-nsf-triggered-steering/

The NSF monitoring data model draft was revised by Henk's suggested data
model and also
he joined the work of this draft as a new author.

As WG chairs, Linda and you can prioritize the drafts and allocate
appropriate timeslots for them
according to our WG milestones and your WG management policy.

Thanks.

Best Regards,
Paul

On Fri, Mar 9, 2018 at 3:09 AM, Yoav Nir <[email-masked]> wrote:

> Last time we had a whole bunch of presentations that were pretty much a
> primer on what this draft is about. Working group sessions are supposed to
> be about discussion, and the attendees are assumed (perhaps naïvely) to
> have read the drafts.  I don’t want another round of primers. If the point
> is a status update, we can make an 8-slide deck with a quick status for
> each draft and run through that in 10-15 minutes.
>