Subject: [I2nsf] comments to draft-ietf-i2nsf-applicability-03

From: Linda Dunbar <[email-masked]>
Date: Thu, 18 Oct 2018 16:24:56 +0000

Paul, et al,

In the Figure 3 of your draft, you have an interface of SFF between NSF and Switch Controller.
SFF is Service Function Forwarder, more like a switch or router. Why does it need to interface with Switch Controller? What kind of information exchange will be between them?

Thanks, Linda

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Sat, 20 Oct 2018 13:25:07 +0900

Hi Linda,
That's a good comment.
The current interface between an NSF and Switch Controller is misleading.
Actually, this links are data channels.

As you said, SFF is usually a switch (as an OVS) in an SDN network. We will
modify the figure such that the SFF will be relocated in the box of the SDN
network.

In our scenario with I2NSF, SDN and SFC,
SFF has an NSF-facing interface with Security Controller that asks Security
Controller to update an SFP for a traffic flow (needing another security
service as an NSF) and then trigger the SFP update SFC Classifier (as
another OVS) that puts an SFP for the traffic flow via NSF-facing interface.

We will submit the revised I-D having this figure update and clarification
before next Monday.

Thanks.

Best Regards,
Paul

2018년 10월 19일 (금) 오전 1:25, Linda Dunbar <[email-masked]>님이 작성:

> SFF is Service Function Forwarder, more like a switch or router. Why does
> it need to interface with Switch Controller? What kind of information
> exchange will be between them?
>
>
>
>
>
>
>
>
>
> Thanks, Linda
>
>
>