Subject: Re: [I2nsf] Request for WG Adoption Call on I2NSF Security Policy Translation Draft

From: Gabriel Lopez <[email-masked]>
Date: Mon, 1 Apr 2019 12:15:26 +0200

Hi Paul.

I support the WG adoption of this draft, and encourage authors to test the IPsec use case, which we think fits in this framework.

Best regards, Gabi.

> El 27 mar 2019, a las 12:31, Mr. Jaehoon Paul Jeong <[email-masked]> escribió:
> 
> Linda and Yoav,
> I would like to request a WG adoption call on our Security Polity Translation:
> 
> Our security policy translation draft specifies the architecture and 
> functionality of the Security Controller in terms of security policy 
> manipulation and translation.
> https://tools.ietf.org/html/draft-yang-i2nsf-security-policy-translation-03 <https://tools.ietf.org/html/draft-yang-i2nsf-security-policy-translation-03>
> 
> As we addressed during this WG meeting, our draft is similar to the case 
> of RFC 8075 in CORE WG:
> Guidelines for Mapping Implementations: 
> HTTP to the Constrained Application Protocol (CoAP)
> https://tools.ietf.org/html/rfc8075 <https://tools.ietf.org/html/rfc8075>
> 
> RFC 8075 is an implementation guideline for connecting an HTTP client 
> to CoAP Servers as IoT devices. This RFC is about translation as an 
> essential feature of the CORE WG for IoT. This RFC specifies a mapping 
> procedure and examples to provide guidance to developers who want to 
> implement the translation between HTTP and CoAP along with source code
> in the document:
> https://tools.ietf.org/html/rfc8075#page-35 <https://tools.ietf.org/html/rfc8075#page-35>
>  
> As a result, this document could succeed in being published even as 
> a standard-track RFC.
> 
> We authors believe our draft for Security Policy Translation will be 
> quite useful to design and implement Security Controller that is a core 
> entity in the I2NSF Framework.  Also, we provide this source code 
> as an open source project that was demonstrated in the last three IETF Hackathon Projects:
> https://github.com/kimjinyong/i2nsf-framework <https://github.com/kimjinyong/i2nsf-framework> 
>  
> Through our draft, the industry will be able to easily adopt and implement I2NSF interface standards.
> We authors aim at publishing this draft as an Informational RFC.
> 
> Thanks.
> 
> Best Regards,
> Paul
> -- 
> ===========================
> Mr. Jaehoon (Paul) Jeong, Ph.D.
> Associate Professor
> Department of Software
> Sungkyunkwan University
> Office: +82-31-299-4957
> Email: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <http://cpslab.skku.edu/people-jaehoon-jeong.php>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf

-----------------------------------------------------------
Gabriel López Millán
Departamento de Ingeniería de la Información y las Comunicaciones
University of Murcia
Spain
Tel: +34 868888504
Fax: +34 868884151
email: [email-masked]

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 1 Apr 2019 21:14:22 +0900

Hi Gabriel,
Thanks for your support.

I think we can collaborate to run IPsec with either IKE or IKEless case.

My Ph.D student, Jingyong (Tim) Kim, will contact you to get your IPsec
code
for our I2NSF Systen with Security Policy Translator.

Thanks.

Paul

On Mon, Apr 1, 2019 at 7:15 PM Gabriel Lopez <[email-masked]> wrote:

> Hi Paul.
>
> I support the WG adoption of this draft, and encourage authors to test the
> IPsec use case, which we think fits in this framework.
>
> Best regards, Gabi.
>
> https://tools.ietf.org/html/draft-yang-i2nsf-security-policy-translation-03
>
> https://tools.ietf.org/html/rfc8075
>
> https://tools.ietf.org/html/rfc8075#page-35
>
> https://github.com/kimjinyong/i2nsf-framework
>
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
> email: [email-masked] <[email-masked]>
>
>
>
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>