Subject: [I2nsf] WG scope follow-up

From: Roman Danyliw <[email-masked]>
Date: Thu, 25 Jul 2019 20:45:05 +0000

Hello!

During today's F2F meeting, we discussed the need to check the charter scope of the work proposed in draft-yang-i2nsf-security-policy-translation.  Making no value judgement on the utility of the work, in my review of the current charter, this class of work is not in scope.  The current charter doesn't currently cover standardization activity inside the NSF/DMS/controller.

If the WG wants to re-charter, by all means, let's have that conversation.

Roman

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 25 Jul 2019 20:56:49 +0000

Hi Roman,

I'd not go for a re-chartering unless other work items on security management (and related to the I2NSF model) are identified. I'd say the WG has been successful in achieving its original goals, and results like this, while valuable, should be directed to another initiative, like the current YANG-NextGen being discussed. A similar case would be some work on attestation, that was somehow at the origin of RATS, and probably will end there.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 25/07/2019, 16:45, "I2nsf on behalf of Roman Danyliw" <[email-masked] on behalf of [email-masked]> wrote:

    Hello!

    Roman

    _______________________________________________
    I2nsf mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/i2nsf

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Thu, 25 Jul 2019 21:02:55 +0000

+1

--------------------------------------------------
夏靓 Frank
Mobile: +86-13913840549<tel:+86-13913840549>/+86-18651800549<tel:+86-18651800549>
Email: [email-masked]<mailto:[email-masked]>
发件人：Diego R. Lopez <[email-masked]>
收件人：Roman Danyliw <[email-masked]>;[email-masked] <[email-masked]>
时间：2019-07-25 16:57:18
主 题：Re: [I2nsf] WG scope follow-up

Hi Roman,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

    Hello!

    Roman

---

From: John Strassner <[email-masked]>
Date: Thu, 25 Jul 2019 15:38:45 -0700

+1

regards,
John

On Thu, Jul 25, 2019 at 2:08 PM Xialiang (Frank, Network Standard & Patent
Dept) <[email-masked]> wrote:

> Mobile: +86-13913840549/+86-18651800549
> Email: [email-masked]
> *发件人：*Diego R. Lopez <[email-masked]>
> *收件人：*Roman Danyliw <[email-masked]>;[email-masked] <[email-masked]>
> *时间：*2019-07-25 16:57:18
> *主 题：*Re: [I2nsf] WG scope follow-up
>
> Hi Roman,
>
> I'd not go for a re-chartering unless other work items on security
> management (and related to the I2NSF model) are identified. I'd say the WG
> has been successful in achieving its original goals, and results like this,
> while valuable, should be directed to another initiative, like the current
> YANG-NextGen being discussed. A similar case would be some work on
> attestation, that was somehow at the origin of RATS, and probably will end
> there.
>
> Be goode,
>
> --
> On 25/07/2019, 16:45, "I2nsf on behalf of Roman Danyliw" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Hello!
>
>     During today's F2F meeting, we discussed the need to check the charter
> scope of the work proposed in
> draft-yang-i2nsf-security-policy-translation.  Making no value judgement on
> the utility of the work, in my review of the current charter, this class of
> work is not in scope.  The current charter doesn't currently cover
> standardization activity inside the NSF/DMS/controller.
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição

-- 
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 25 Jul 2019 23:40:08 -0400

Hi Roman and I2NSF WG,
Though the system components of the I2NSF system (e.g., security policy
translator) are not in the scope of
I2NSF WG, key components such as I2NSF User, Security Controller, and
Developer's Management System (DMS)
need standard documents to let developers and operators grasp what
information and parameters are required and
exchanged among those components.

Those documents can be published as Informational RFCs to provide the
developers and operators with
the guidelines to build their own components interoperable with other
components in the I2NSF system.

For an example, the security policy translation draft provides the audience
with such guidelines
in terms of the design of implementation of their own security policy
translator.
https://tools.ietf.org/html/draft-yang-i2nsf-security-policy-translation-04

To let the security policy translator perform security policy translation,
it requires
the relationship between the consumer-facing interface and the nsf-facing
interface data models.
This document explains such relationship (or mapping) between the two
interfaces.
With the explicit representation of such a mapping, the developers need to
figure it out.
It will be time-consuming and may mislead them.

It also explains what information (e.g., IP addresses of a user's devices
and website URLs) should
be populated into the NSF database for security policy translation in the
Security Controller.
This information needs to delivered from the I2NSF User to the Security
Controller.
Assuming that the I2NSF User and the Security Controller are developed by
two different operators and vendors,
an interface between them should be standardized for interoperability.
As said during today's WG session, this security policy translation draft
will target at an Informational RFC.

For another example, the draft of I2NSF on NFV reference architecture
provides the operators and
developers with the guidelines of how to build the I2NSF system on the NFV
architecture.
https://tools.ietf.org/html/draft-yang-i2nsf-nfv-architecture-05

The draft explains the initial configuration procedure in NFV architecture.
When a proper NSF is not activated yet in the I2NSF system, the Security
Controller
sends an NSF initiation request to the DMSs which has (or may have) the
required NSF,
as shown in Figure 2 in the draft.
In this case, the DMS sends an NSF initiation request  to the VNF Manager
(VNFM) using the Ve-Vnfm interface
that is an ETSI NFV interface. This DMS NSF initiation request should be
specified by
the I2NSF system. This draft will describe the contents and format of the
request in
the next revision. Thus, this will help the vendors and operators easily
implement the I2NSF
in the NSF architecture.

During the last 9 I2NSF hackathon projects, my team recognized the
necessity of
the drafts for the functionality and parameters of the I2NSF system
components.
I believe that these drafts will accelerate the development and development
of
I2NSF in the real world.

I think our I2NSF WG needs to recharter toward the second phase.

Thanks.

Best Regards,
Paul

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: 양현식 <[email-masked]>
Date: Sun, 28 Jul 2019 23:10:10 +0900

+1 
Hi. I am Hyunsik Yang. I joined I2NSF hackathon from IETF102 to IETF105  and I am an author of NFV draft. 

I agree with Paul's opinion based on my experience of I2NSF Hackathon.

 In order to use I2NSF in a real environment, I think we should  provide a document for guidelines on how to use it in addition to the basic framework. Although the document couldn't reflect all use cases, I think we can provide a basic direction to user who use I2NSF Framework. Therefore,  security policy translator draft also can be a good guideline.

 In addition, from an implementation point of view, I think current interface is not enough since it only deal with internal interface. We also need to define additional interfaces or information model to use I2NSF in real world such as interface for VNFM and SFC controller. I knew that this is not part of the current I2NSF WG scope, but, if I2NSF WG is going to re-chartering phase, I think it is necessary to add those item to re-chartering.

> 2019. 7. 26. 오후 12:40, Mr. Jaehoon Paul Jeong <[email-masked]> 작성:
> 
> Hi Roman and I2NSF WG,
> Though the system components of the I2NSF system (e.g., security policy translator) are not in the scope of 
> I2NSF WG, key components such as I2NSF User, Security Controller, and Developer's Management System (DMS) 
> need standard documents to let developers and operators grasp what information and parameters are required and 
> Those documents can be published as Informational RFCs to provide the developers and operators with
> the guidelines to build their own components interoperable with other components in the I2NSF system. 
> 
> For an example, the security policy translation draft provides the audience with such guidelines
> in terms of the design of implementation of their own security policy translator.
> https://tools.ietf.org/html/draft-yang-i2nsf-security-policy-translation-04 <https://tools.ietf.org/html/draft-yang-i2nsf-security-policy-translation-04>  
>  
> To let the security policy translator perform security policy translation, it requires 
> the relationship between the consumer-facing interface and the nsf-facing interface data models.
> This document explains such relationship (or mapping) between the two interfaces.
> With the explicit representation of such a mapping, the developers need to figure it out. 
> It also explains what information (e.g., IP addresses of a user's devices and website URLs) should 
> be populated into the NSF database for security policy translation in the Security Controller.
> This information needs to delivered from the I2NSF User to the Security Controller.
> Assuming that the I2NSF User and the Security Controller are developed by two different operators and vendors,
> As said during today's WG session, this security policy translation draft will target at an Informational RFC.
> 
> For another example, the draft of I2NSF on NFV reference architecture provides the operators and 
> developers with the guidelines of how to build the I2NSF system on the NFV architecture.
> https://tools.ietf.org/html/draft-yang-i2nsf-nfv-architecture-05 <https://tools.ietf.org/html/draft-yang-i2nsf-nfv-architecture-05>  
> 
> When a proper NSF is not activated yet in the I2NSF system, the Security Controller 
> sends an NSF initiation request to the DMSs which has (or may have) the required NSF, 
> In this case, the DMS sends an NSF initiation request  to the VNF Manager (VNFM) using the Ve-Vnfm interface 
> that is an ETSI NFV interface. This DMS NSF initiation request should be specified by 
> the I2NSF system. This draft will describe the contents and format of the request in 
> the next revision. Thus, this will help the vendors and operators easily implement the I2NSF
> in the NSF architecture.
> 
> During the last 9 I2NSF hackathon projects, my team recognized the necessity of 
> the drafts for the functionality and parameters of the I2NSF system components. 
> I believe that these drafts will accelerate the development and development of 
> I2NSF in the real world.
> 
> On Thu, Jul 25, 2019 at 4:45 PM Roman Danyliw <[email-masked] <mailto:[email-masked]>> wrote:
> Hello!
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i2nsf <https://www.ietf.org/mailman/listinfo/i2nsf>
> 
> 
> -- 
> Email: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 30 Jul 2019 09:05:35 +0000

Hi,

I am not objecting to the work in the translating support techniques (what would be, in my opinion, the part of the work suitable to an IETF document), but to having it within a re-chartered I2NSF. I think those techniques should be general enough to constitute one of the essential aspects of the new work being considered for YANG, and therefore I’d like to see this activity directed there. You can count on my full support for that goal.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 28/07/2019, 16:08, "I2nsf on behalf of 양현식" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

+1

2019. 7. 26. 오후 12:40, Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>> 작성:

Hi Roman and I2NSF WG,

Thanks.

Best Regards,
Paul

On Thu, Jul 25, 2019 at 4:45 PM Roman Danyliw <[email-masked]<mailto:[email-masked]>> wrote:
Hello!

Roman

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf