Subject: [I2nsf] WGLC and IPR poll for draft-ietf-i2nsf-nsf-facing-interface-dm-08

From: Linda Dunbar <[email-masked]>
Date: Tue, 3 Dec 2019 22:23:20 +0000

Hello Working Group,

Many thanks to the authors of draft-ietf-i2nsf-nsf-facing-interface-dm to address all the comments from YANG Doctor review.

This email starts a three weeks Working Group Last Call on draft-ietf-i2nsf-nsf-facing-interface-dm-08
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-i2nsf-nsf-facing-interface-dm%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C9bcce04caea74f6b257508d778356660%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637110043059543710&sdata=IPm4dDBvEfO8Wf6HpSOQCrB%2Fta1zB7E0TX8XMvWmTuA%3D&reserved=0>

This poll runs until Jan 6, 2020 (considering many people taking Christmas to New Year off).

We are also polling for knowledge of any undisclosed IPR that applies to this Document, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
If you are listed as an Author or a Contributor of this Document, please respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR. The Document won't progress without answers from all the Authors and Contributors.

If you are not listed as an Author or a Contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Thank you.

Linda & Yoav

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 4 Dec 2019 04:03:59 -0500

I have no knowledge of IPR related to this document. 

Cheerily, Susan Hares 

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Tuesday, December 3, 2019 5:23 PM
To: [email-masked]
Cc: Yoav Nir
Subject: [I2nsf] WGLC and IPR poll for
draft-ietf-i2nsf-nsf-facing-interface-dm-08

Hello Working Group, 

Many thanks to the authors of draft-ietf-i2nsf-nsf-facing-interface-dm to
address all the comments from YANG Doctor review. 

This email starts a three weeks Working Group Last Call on
draft-ietf-i2nsf-nsf-facing-interface-dm-08

<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrack
er.ietf.org%2Fdoc%2Fdraft-ietf-i2nsf-nsf-facing-interface-dm%2F&data=02%7C01
%7Clinda.dunbar%40futurewei.com%7C9bcce04caea74f6b257508d778356660%7C0fee8ff
2a3b240189c753a1d5591fedc%7C1%7C0%7C637110043059543710&sdata=IPm4dDBvEfO8Wf6
HpSOQCrB%2Fta1zB7E0TX8XMvWmTuA%3D&reserved=0>
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/ 

This poll runs until Jan 6, 2020 (considering many people taking Christmas
to New Year off). 

We are also polling for knowledge of any undisclosed IPR that applies to
this Document, to ensure that IPR has been disclosed in compliance with IETF
IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as an Author or a Contributor of this Document, please
respond to this email and indicate whether or not you are aware of any
relevant undisclosed IPR. The Document won't progress without answers from
all the Authors and Contributors.

If you are not listed as an Author or a Contributor, then please explicitly
respond only if you are aware of any IPR that has not yet been disclosed in
conformance with IETF rules.

Thank you. 

Linda & Yoav

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 4 Dec 2019 20:34:34 +0900

Hi I2NSF WG,
I am aware of the following IPR disclosure on NSF-Facing Interface YANG
Data
Model that was submitted on June 25, 2019 by my university, Sungkyunkwan
University:
https://datatracker.ietf.org/ipr/3603/

Licensing information, comments, notes, or URL for further information:
If this standard is adopted, Sungkyunkwan University (SKKU) will not assert
any patents owned or controlled by SKKU against any party for making,
using,
selling, importing or offering for sale a product that implements the
standard,
provided, however that SKKU retains the right to assert its patents
(including
the right to claim past royalties) against any party that asserts a patent
it
owns or controls (either directly or indirectly) against SKKU or any of
SKKU's
affiliates or successors in title or against any products of SKKU or any
products of any of SKKU's affiliates either alone or in combination with
other
products; and SKKU retains the right to assert its patents against any
product
or portion thereof that is not necessary for compliance with the standard.
Royalty-bearing licenses will be available to anyone who prefers that
option.

Thanks.

Best Regards,
Paul

On Wed, Dec 4, 2019 at 7:23 AM Linda Dunbar <[email-masked]>
wrote:

> This email starts a three weeks Working Group Last Call
> on draft-ietf-i2nsf-nsf-facing-interface-dm-08
>
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-i2nsf-nsf-facing-interface-dm%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C9bcce04caea74f6b257508d778356660%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637110043059543710&sdata=IPm4dDBvEfO8Wf6HpSOQCrB%2Fta1zB7E0TX8XMvWmTuA%3D&reserved=0>
>
>
>
>
> this Document, to ensure that IPR has been disclosed in compliance with
> IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>
> If you are not listed as an Author or a Contributor, then please
> explicitly respond only if you are aware of any IPR that has not yet been
> disclosed in conformance with IETF rules.
>
>
>
> Thank you.
>
>
>
> Linda & Yoav
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: 박정수 <[email-masked]>
Date: Fri, 13 Dec 2019 02:54:34 +0000

Dear all

I want to express about IPR issue as the co-author of the NSF-facing-interface document.
"I have no knowledge of IPR related to this document."

Merry Christmas and happy new year.
Thanks.

From JungSo, PARK

보낸 사람: 재훈 정 <[email-masked]>
날짜: 2019년 12월 13일 금요일 오전 10:29
받는 사람: 가나다 Park <[email-masked]>, Qiushi Lin <[email-masked]>
참조: Susan Hares <[email-masked]>, "Jingyong (Tim) Kim" <[email-masked]>, 재훈 정 <[email-masked]>
주제: Fwd: [I2nsf] WGLC and IPR poll for draft-ietf-i2nsf-nsf-facing-interface-dm-08

Hi Jung-Soo and Qiushi,
Could you express your knowledge about the IPR related to our I2NSF Draft
because you are a coauthor this draft?

I think you can say "I have no knowledge of IPR related to this document."

My university, Sungkyunkwan University (SKKU), has filed up a patent about this draft and disclosed the IPR as follows:

------------------------------------------------------------------------------------------------------------
https://datatracker.ietf.org/ipr/3603/

Licensing information, comments, notes, or URL for further information:
If this standard is adopted, Sungkyunkwan University (SKKU) will not assert
any patents owned or controlled by SKKU against any party for making, using,
selling, importing or offering for sale a product that implements the standard,
provided, however that SKKU retains the right to assert its patents (including
the right to claim past royalties) against any party that asserts a patent it
owns or controls (either directly or indirectly) against SKKU or any of SKKU's
affiliates or successors in title or against any products of SKKU or any
products of any of SKKU's affiliates either alone or in combination with other
products; and SKKU retains the right to assert its patents against any product
or portion thereof that is not necessary for compliance with the standard.
Royalty-bearing licenses will be available to anyone who prefers that option.
------------------------------------------------------------------------------------------------------------

Thanks for your cooperation.

Best Regards,
Jaehoon (Paul) Jeong

---------- Forwarded message ---------
From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Wed, Dec 4, 2019 at 7:23 AM
Subject: [I2nsf] WGLC and IPR poll for draft-ietf-i2nsf-nsf-facing-interface-dm-08
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: Yoav Nir <[email-masked]<mailto:[email-masked]>>

Hello Working Group,

Thank you.

Linda & Yoav
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 13 Dec 2019 03:07:10 +0000

Hi WG,
I support the WGLC of this draft, which is one of the very basic output of this working group.

Thanks!

B.R.
Frank

This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

发件人: I2nsf [mailto:[email-masked]] 代表 Linda Dunbar
发送时间: 2019年12月4日 6:23
收件人: [email-masked]
抄送: Yoav Nir <[email-masked]>
主题: [I2nsf] WGLC and IPR poll for draft-ietf-i2nsf-nsf-facing-interface-dm-08

Hello Working Group,

Thank you.

Linda & Yoav

---

From: Hyoungshick Kim <[email-masked]>
Date: Fri, 13 Dec 2019 18:30:38 +0900

I fully support this draft.

Best regards,

Hyoungshick Kim

On Wed, Dec 4, 2019 at 8:35 PM Mr. Jaehoon Paul Jeong
<[email-masked]> wrote:
>
> Hi I2NSF WG,
> I am aware of the following IPR disclosure on NSF-Facing Interface YANG Data
> Model that was submitted on June 25, 2019 by my university, Sungkyunkwan University:
> On Wed, Dec 4, 2019 at 7:23 AM Linda Dunbar <[email-masked]> wrote:
>>
>>
>>
>> Hello Working Group,
>>
>>
>>

-- 
_______________________________
Hyoungshick (Hyoung) Kim,

Department of Software
College of Software
Office 27324, 2066 Seobu-Ro, Jangan-gu, Suwon, Gyeonggi-do 440-746, Korea
+82-31-299-4324 (mobile: +82-10-5557-3081)
[email-masked]
http://seclab.skku.edu/people/hyoungshick-kim/

---

From: 윤빈영 <[email-masked]>
Date: Fri, 13 Dec 2019 10:11:33 +0000

Hi all,

As the person that I have been involved in their work during several hackathon meetings,
I fully support the draft.

Best regards,
Bin

On Wed, Dec 4, 2019 at 8:35 PM Mr. Jaehoon Paul Jeong <[email-masked]> wrote:
>
> Hi I2NSF WG,
> I am aware of the following IPR disclosure on NSF-Facing Interface 
> YANG Data Model that was submitted on June 25, 2019 by my university, Sungkyunkwan University:
> If this standard is adopted, Sungkyunkwan University (SKKU) will not 
> assert any patents owned or controlled by SKKU against any party for 
> making, using, selling, importing or offering for sale a product that 
> implements the standard, provided, however that SKKU retains the right 
> to assert its patents (including the right to claim past royalties) 
> against any party that asserts a patent it owns or controls (either 
> directly or indirectly) against SKKU or any of SKKU's affiliates or 
> successors in title or against any products of SKKU or any products of 
> any of SKKU's affiliates either alone or in combination with other 
> products; and SKKU retains the right to assert its patents against any product or portion thereof that is not necessary for compliance with the standard.
> Email: [email-masked], [email-masked] Personal Homepage: 
> http://iotlab.skku.edu/people-jaehoon-jeong.php

Department of Software
College of Software

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 14 Dec 2019 19:39:53 -0000

Hi,

This is a long document and I can't say I have read it in detail. But what I
have seen looks reasonable. I don't object to publication.

A couple of things to note:

I suggest putting in an RFC Editor Note to ask that all instances of
"draft-ietf-i2nsf-capability" including those in YANG reference clauses are
updated to the RFC that the draft will become before this document reaches
RFC. The reason for suggesting this is that those mentions don't appear as
square bracket references so might get missed. There are some others drafts
in the same situation, but I don't know if they'll become RFCs first.

The reference draft-ietf-supa-generic-policy-info-model is probably a bad
idea. I think the draft is dead. The only mention is in section 3, and here
you seem to have copied the relevant text anyway. Maybe just include that
text as your own definitions, and move on?

Idnits has a lot to say. You should sort it out.

https://www6.ietf.org/tools/idnits?url=https://www.ietf.org/archive/id/draft
-ietf-i2nsf-nsf-facing-interface-dm-08.txt

The 'standard' way of handling references from with the YANG model, where
you can't include square brackets, is to put a piece of text at the top
(outside the model) that says: "This model makes reference to [foo], [bar],
and [fishcake]."

You can easily delete section 2.

It would be nice if the figures were directly referenced from the text.
Instead of "This YANG tree diagram shows." say "The YANG tree diagram in
Figure x shows."

Best,

Adrian

From: I2nsf <[email-masked]> On Behalf Of Linda Dunbar
Sent: 03 December 2019 22:23
To: [email-masked]
Cc: Yoav Nir <[email-masked]>
Subject: [I2nsf] WGLC and IPR poll for
draft-ietf-i2nsf-nsf-facing-interface-dm-08

Hello Working Group, 

Thank you. 

Linda & Yoav

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 16 Dec 2019 11:58:26 +0900

Hi Adrian,
I sincerely appreciate your valuable comments.
We authors will reflect your comments on the revision.

Thanks.

Best Regards,
Paul

On Sun, Dec 15, 2019 at 4:40 AM Adrian Farrel <[email-masked]> wrote:

> Hi,
>
>
>
> This is a long document and I can’t say I have read it in detail. But what
> I have seen looks reasonable. I don’t object to publication.
>
>
>
> I suggest putting in an RFC Editor Note to ask that all instances of “draft-ietf-i2nsf-capability”
> including those in YANG reference clauses are updated to the RFC that the
> draft will become before this document reaches RFC. The reason for
> suggesting this is that those mentions don’t appear as square bracket
> references so might get missed. There are some others drafts in the same
> situation, but I don’t know if they’ll become RFCs first.
>
>
>
> https://www6.ietf.org/tools/idnits?url=https://www.ietf.org/archive/id/draft-ietf-i2nsf-nsf-facing-interface-dm-08.txt
>
> The ‘standard’ way of handling references from with the YANG model, where
> you can’t include square brackets, is to put a piece of text at the top
> (outside the model) that says: “This model makes reference to [foo], [bar],
> and [fishcake].”
>
> Instead of “This YANG tree diagram shows…” say “The YANG tree diagram in
> Figure x shows…”
>
>
>
> Best,
>
> Adrian
>
>
>
> *From:* I2nsf <[email-masked]> *On Behalf Of *Linda Dunbar
> *Sent:* 03 December 2019 22:23
> *To:* [email-masked]
> *Cc:* Yoav Nir <[email-masked]>
> *Subject:* [I2nsf] WGLC and IPR poll for

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 25 Dec 2019 16:17:38 +0000

Hi,

I support the publication of the document.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

Hello Working Group,

Thank you.

Linda & Yoav

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição