Subject: [I2nsf] Éric Vyncke's Discuss on draft-ietf-i2nsf-capability-data-model-12: (with DISCUSS and COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Mon, 21 Sep 2020 02:19:10 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-i2nsf-capability-data-model-12: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability-data-model/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for the work put into this document.

While I do appreciate that a data model (this document) is derived from an
information model, I am concerned that the information model is an expired
draft whereas I would expect the information model being published first. Else,
what is the use of the information model ? What was the WG reasoning behind
'putting the cart before the horses' ? My concern is that by publishing the
YANG model, there is nearly no way to change the information model anymore.

Please find below a couple of non-blocking COMMENT points but also a couple of
blocking DISCUSS points around IPv6. They should be easy to resolve. I would
hate to have NSF having basic IPv6 capabilities that cannot be configured by
using the YANG model of this document.

I hope that this helps to improve the document,

Regards,

-éric

== DISCUSS ==

-- Section 4.1 --

It is quite common to apply conditions based on the whole IPv6 extension header
chain (i.e., presence of destination option header or wrong order of the
extension headers). Why is there no such capabilities in this YANG module ? The
only one is 'identity ipv6-next-header' that applies only to the first
extension header.

What is the difference between 'identity ipv6-protocol' and 'identity
ipv6-next-header' ? There is no 'protocol' field in the IPv6 header.

While fragmented IPv4 packets are part of the conditions ('identity
ipv4-fragment-flags'), there is no equivalent in IPv6.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

-- Section 4.1 --
May be am I misreading the YANG tree, but, I see no 'sctp-capability' in the
set of 'condition-capabilities' (even is SCTP is not heavily used).

Is there a real reason to have two related containers ?
generic-nsf-capabilities and advanced-nsf-capabilities. Why not a single one ?

Unsure what is meant by 'range' in 'identity range-ipv*-address'. Usually,
addresses are filtered/matched by using a prefix length and not a range (that
is difficult to implement in hardware).

Is there a reason why ICMP(v6) codes are not part of the conditions ?

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 21 Sep 2020 15:53:19 -0400

Eric: 

Just a little bit of history - some of the past ADs suggested that informational models were optional.  Therefore, pushing forward with the information was difficult. 

In this case, the information model was helpful in distilling the key components for a capability model.  If you wish additional history, please let me know.  

Susan Hares 

-----Original Message-----
From: Éric Vyncke via Datatracker [mailto:[email-masked]] 
Sent: Monday, September 21, 2020 5:19 AM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; Linda Dunbar; [email-masked]
Subject: Éric Vyncke's Discuss on draft-ietf-i2nsf-capability-data-model-12: (with DISCUSS and COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

While I do appreciate that a data model (this document) is derived from an information model, I am concerned that the information model is an expired draft whereas I would expect the information model being published first. Else, what is the use of the information model ? What was the WG reasoning behind 'putting the cart before the horses' ? My concern is that by publishing the YANG model, there is nearly no way to change the information model anymore.

Please find below a couple of non-blocking COMMENT points but also a couple of blocking DISCUSS points around IPv6. They should be easy to resolve. I would hate to have NSF having basic IPv6 capabilities that cannot be configured by using the YANG model of this document.

Regards,

-éric

== DISCUSS ==

-- Section 4.1 --

It is quite common to apply conditions based on the whole IPv6 extension header chain (i.e., presence of destination option header or wrong order of the extension headers). Why is there no such capabilities in this YANG module ? The only one is 'identity ipv6-next-header' that applies only to the first extension header.

What is the difference between 'identity ipv6-protocol' and 'identity ipv6-next-header' ? There is no 'protocol' field in the IPv6 header.

While fragmented IPv4 packets are part of the conditions ('identity ipv4-fragment-flags'), there is no equivalent in IPv6.

-- Section 4.1 --
May be am I misreading the YANG tree, but, I see no 'sctp-capability' in the set of 'condition-capabilities' (even is SCTP is not heavily used).

Unsure what is meant by 'range' in 'identity range-ipv*-address'. Usually, addresses are filtered/matched by using a prefix length and not a range (that is difficult to implement in hardware).

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 21 Sep 2020 23:08:42 +0000

Hi,

If I can shed a little bit more of light on the story, let me say the original capability model was based on a policy expression calculus suitable for manipulating high-level policy expressions, but not for a network management protocol. The data model evolved in parallel and, at a certain point, overtook the original information model. A couple of proposals for realignment were made, but they were reflected on the data model and not totally on the information model.

Given the historical context Sue mentions, the information model was implicitly withdrawn, having served its purpose of kickstarting the data model.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 21/09/2020, 21:53, "I2nsf on behalf of Susan Hares" <[email-masked] on behalf of [email-masked]> wrote:

    Eric:

    Susan Hares

    -----Original Message-----
    From: Éric Vyncke via Datatracker [mailto:[email-masked]]
    Sent: Monday, September 21, 2020 5:19 AM
    To: The IESG
    Cc: [email-masked]; [email-masked]; [email-masked]; Linda Dunbar; [email-masked]
    Subject: Éric Vyncke's Discuss on draft-ietf-i2nsf-capability-data-model-12: (with DISCUSS and COMMENT)

    Regards,

    -éric

    == DISCUSS ==

    -- Section 4.1 --

    -- Section 4.1 --

    _______________________________________________
    I2nsf mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/i2nsf

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 22 Sep 2020 13:41:44 +0900

Hi Eric,
I will try to reflect your comments about IPv6 capabilities in DISCUSS and
other capabilities in COMMENT on the revision as an editor of this draft.

Thanks.

Best Regards,
Paul

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 22 Sep 2020 07:10:45 +0000

Paul, thank you in advance. I will obviously clear my DISCUSS once it is done.

Susan and Diego, thank you for the added history about the information and data models document. I appreciate the time taken to provide us with the history.

-éric

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tuesday, 22 September 2020 at 06:42
To: Eric Vyncke <[email-masked]>
Cc: The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Linda Dunbar <[email-masked]>, "[email-masked]" <[email-masked]>, "Mr. Jaehoon Paul Jeong" <[email-masked]>
Subject: Re: [I2nsf] Éric Vyncke's Discuss on draft-ietf-i2nsf-capability-data-model-12: (with DISCUSS and COMMENT)

Hi Eric,

Thanks.

Best Regards,
Paul

On Mon, Sep 21, 2020 at 6:19 PM Éric Vyncke via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Éric Vyncke has entered the following ballot position for
draft-ietf-i2nsf-capability-data-model-12: Discuss

Regards,

-éric

== DISCUSS ==

-- Section 4.1 --

-- Section 4.1 --

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>