Subject: [I2nsf] I-D Action: draft-ietf-i2nsf-nsf-monitoring-data-model-04.txt

From: [email-masked]
Date: Mon, 07 Sep 2020 22:16:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interface to Network Security Functions WG of the IETF.

        Title           : I2NSF NSF Monitoring YANG Data Model
        Authors         : Jaehoon Paul Jeong
                          Patrick Lingga
                          Susan Hares
                          Liang Xia (Frank)
                          Henk Birkholz
	Filename        : draft-ietf-i2nsf-nsf-monitoring-data-model-04.txt
	Pages           : 80
	Date            : 2020-09-07

Abstract:
   This document proposes an information model and the corresponding
   YANG data model for monitoring Network Security Functions (NSFs) in
   the Interface to Network Security Functions (I2NSF) framework.  If
   the monitoring of NSFs is performed in a comprehensive way, it is
   possible to detect the indication of malicious activity, anomalous
   behavior, the potential sign of denial of service attacks, or system
   overload in a timely manner.  This monitoring functionality is based
   on the monitoring information that is generated by NSFs.  Thus, this
   document describes not only an information model for monitoring NSFs
   along with a YANG data diagram, but also the corresponding YANG data
   model for monitoring NSFs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-model/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-i2nsf-nsf-monitoring-data-model-04
https://datatracker.ietf.org/doc/html/draft-ietf-i2nsf-nsf-monitoring-data-model-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2nsf-nsf-monitoring-data-model-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 8 Sep 2020 14:25:20 +0900

Hi Linda and Yoav,
As you know, the I2NSF NSF monitoring draft is the last YANG data model in
our I2NSF under our current I2NSF charter.

Could you ask a YANG doctor to review this draft before the WG last call?
https://tools.ietf.org/html/draft-ietf-i2nsf-nsf-monitoring-data-model-04

Thanks.

Best Regards,
Paul

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, Sep 8, 2020 at 2:17 PM
Subject: [I2nsf] I-D Action:
draft-ietf-i2nsf-nsf-monitoring-data-model-04.txt
To: <[email-masked]>
Cc: <[email-masked]>

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Interface to Network Security Functions WG
of the IETF.

Abstract:

_______________________________________________
I2nsf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2nsf

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 8 Sep 2020 14:23:15 +0000

Paul,

YANG Doctor Review Request has been sent.  We can do WGLC afterwards.

Thanks, Linda

From: Mr. Jaehoon Paul Jeong <[email-masked]>
Sent: Tuesday, September 8, 2020 12:25 AM
To: Linda Dunbar <[email-masked]>; Yoav Nir <[email-masked]>
Cc: [email-masked]; skku-iotlab-members <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: Request for YANG Doctor Review on I2NSF NSF Monitoring YANG Data Model Draft

Hi Linda and Yoav,
As you know, the I2NSF NSF monitoring draft is the last YANG data model in our I2NSF under our current I2NSF charter.

Could you ask a YANG doctor to review this draft before the WG last call?
https://tools.ietf.org/html/draft-ietf-i2nsf-nsf-monitoring-data-model-04<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620480889&sdata=DOw1YsCdvqBEHB7Qn0VQUGxwzafzIWLxjDEo6yFsI%2B8%3D&reserved=0>

Thanks.

Best Regards,
Paul

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Sep 8, 2020 at 2:17 PM
Subject: [I2nsf] I-D Action: draft-ietf-i2nsf-nsf-monitoring-data-model-04.txt
To: <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-model/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620480889&sdata=APvA%2BINsGHfwV9MXSxnhYnaVZM%2BR1qUkFXmJZPo0Jgo%3D&reserved=0>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-i2nsf-nsf-monitoring-data-model-04<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620490888&sdata=KqSUiv04sysghw42Qz%2BhAiSDS5Z7LKL4mKwfYuU6hho%3D&reserved=0>
https://datatracker.ietf.org/doc/html/draft-ietf-i2nsf-nsf-monitoring-data-model-04<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620490888&sdata=p6qktgxd2WbUUWfQxi87X6MIrlrIpunPqHU%2BrQpWMQc%3D&reserved=0>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2nsf-nsf-monitoring-data-model-04<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620500881&sdata=Gvdc6if7Yl6Ubg6xD8h1WdpVRcV6amumf%2F%2B470ANrIo%3D&reserved=0>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620510873&sdata=8ayWh4mCuD2%2FoTxCmN0oLDi6nkjW40n5Yu8ybyPBnDw%3D&reserved=0>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://nam11.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620510873&sdata=WLHkYNvqatfV%2FgByZrqCCc6JERQxZZkgUcMCsV2KyrM%3D&reserved=0>

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fi2nsf&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620520871&sdata=W1DASOqNPsDQoEzsVgDg19MUlfTLUpFxDsbDrXsrM1M%3D&reserved=0>

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fcpslab.skku.edu%2Fpeople-jaehoon-jeong.php&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620520871&sdata=MeUJUxfsrCMlI7NmRIdI8GrjKOaQviFUjII1dLiYKuY%3D&reserved=0>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 9 Sep 2020 09:37:05 +0900

Hi Linda,
Thanks for your help.

Best Regards,
Paul

On Tue, Sep 8, 2020 at 11:23 PM Linda Dunbar <[email-masked]>
wrote:

> *From:* Mr. Jaehoon Paul Jeong <[email-masked]>
> *Sent:* Tuesday, September 8, 2020 12:25 AM
> *To:* Linda Dunbar <[email-masked]>; Yoav Nir <
> [email-masked]>
> *Cc:* [email-masked]; skku-iotlab-members <
> [email-masked]>; Mr. Jaehoon Paul Jeong <
> [email-masked]>
> *Subject:* Request for YANG Doctor Review on I2NSF NSF Monitoring YANG
> Data Model Draft
>
>
>
> Hi Linda and Yoav,
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620480889&sdata=DOw1YsCdvqBEHB7Qn0VQUGxwzafzIWLxjDEo6yFsI%2B8%3D&reserved=0>
>
>
>
> Thanks.
>
>
>
> Best Regards,
>
> Paul
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620480889&sdata=APvA%2BINsGHfwV9MXSxnhYnaVZM%2BR1qUkFXmJZPo0Jgo%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620490888&sdata=KqSUiv04sysghw42Qz%2BhAiSDS5Z7LKL4mKwfYuU6hho%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620490888&sdata=p6qktgxd2WbUUWfQxi87X6MIrlrIpunPqHU%2BrQpWMQc%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-i2nsf-nsf-monitoring-data-model-04&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620500881&sdata=Gvdc6if7Yl6Ubg6xD8h1WdpVRcV6amumf%2F%2B470ANrIo%3D&reserved=0>
>
>
> until the htmlized version and diff are available at tools.ietf.org
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620510873&sdata=8ayWh4mCuD2%2FoTxCmN0oLDi6nkjW40n5Yu8ybyPBnDw%3D&reserved=0>
> .
>
> <https://nam11.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620510873&sdata=WLHkYNvqatfV%2FgByZrqCCc6JERQxZZkgUcMCsV2KyrM%3D&reserved=0>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fi2nsf&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620520871&sdata=W1DASOqNPsDQoEzsVgDg19MUlfTLUpFxDsbDrXsrM1M%3D&reserved=0>
>
>
>
>
> --
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fcpslab.skku.edu%2Fpeople-jaehoon-jeong.php&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdbc367f54ec5434f784b08d853b7ab30%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637351395620520871&sdata=MeUJUxfsrCMlI7NmRIdI8GrjKOaQviFUjII1dLiYKuY%3D&reserved=0>
>