Subject: [I2nsf] I-D Action: draft-ietf-i2nsf-capability-data-model-16.txt

From: [email-masked]
Date: Mon, 08 Mar 2021 06:10:17 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interface to Network Security Functions WG of the IETF.

        Title           : I2NSF Capability YANG Data Model
        Authors         : Susan Hares
                          Jaehoon (Paul) Jeong
                          Jinyong (Tim) Kim
                          Robert Moskowitz
                          Qiushi Lin
	Filename        : draft-ietf-i2nsf-capability-data-model-16.txt
	Pages           : 78
	Date            : 2021-03-08

Abstract:
   This document defines an information model and the corresponding YANG
   data model for the capabilities of various Network Security Functions
   (NSFs) in the Interface to Network Security Functions (I2NSF)
   framework to centrally manage the capabilities of the various NSFs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability-data-model/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-i2nsf-capability-data-model-16
https://datatracker.ietf.org/doc/html/draft-ietf-i2nsf-capability-data-model-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2nsf-capability-data-model-16

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 9 Mar 2021 00:03:22 +0900

Hi IESG,
I have addressed all the comments from the IESG for the I2NSF Capability
YANG Data Model Draft:
https://tools.ietf.org/html/draft-ietf-i2nsf-capability-data-model-16

I attach the revision letters that were sent to the commenters.

Could you move this draft forward?

Thanks.

Best Regards,
Paul

On Mon, Mar 8, 2021 at 11:12 PM <[email-masked]> wrote:

> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 9 Mar 2021 01:18:03 +0000

Hello Paul!

Thanks for these document updates.

The brief answer to “can this draft proceed” is yes, but it first needs to go through WGLC, AD Review, IETC LC and return to the telechat for IESG review.

The longer explanation is that this document was initially on the Sept-24-2020 telechat, but early IESG reviews suggested significant enough issues that it was deferred initially to the Oct-8-2020 telechat.  After discussion on the I2NSF list about how to handle this feedback, the scope was determined to be significant enough that it needed be returned to back to the WG for revisions.  The full history is at https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability-data-model/history/.  The highlights are as follows:

2020-09-16        12         Cindy Morgan    Placed on agenda for telechat - 2020-09-24

<various DISCUSS positions noted>

2020-09-24        12          Cindy Morgan    Telechat date has been changed to 2020-10-08 from 2020-09-24

2020-09-28        12         Roman Danyliw               IESG state changed to I-D Exists from IESG Evaluation – Defer

(this moved the document back to the WG)

2020-09-28        12         Roman Danyliw
Based on preliminary feedback from the IESG in preparation for the September 24, 2020 telechat, this document was initially deferred (from this telechat).  After further discussion between the AD+I2NSF chairs, this document is being sent back to the WG to determine how to best resolve the dependency on the capabilities information model (i.e., draft-ietf-i2nsf-capability).

(summary feedback in the datatracker)

(discussed/announced on I2NSF list: https://mailarchive.ietf.org/arch/msg/i2nsf/4D8JZgqgMNQkWGdUfsSTy7tnUik/)

From a document progression perspective, all of the reviews that occur from WGLC on must be repeated.

Regards,
Roman

From: iesg <[email-masked]> On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Monday, March 8, 2021 10:03 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; skku-iotlab-members <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>; Susan Hares <[email-masked]>
Subject: Re: [I2nsf] I-D Action: draft-ietf-i2nsf-capability-data-model-16.txt

Hi IESG,
I have addressed all the comments from the IESG for the I2NSF Capability YANG Data Model Draft:
https://tools.ietf.org/html/draft-ietf-i2nsf-capability-data-model-16

Thanks.

Best Regards,
Paul

On Mon, Mar 8, 2021 at 11:12 PM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 9 Mar 2021 15:41:10 +0900

Hi Roman, Linda, and Yoav,
As you may observe, the authors have addressed all the comments from the
IESG through the merging with
the NSFs Capabilities Information Model Draft.

I think that Linda and Yoav can do WGLC on the latest version and submit it
to Roman for AD review.

Thanks.

Best Regards,
Paul

On Tue, Mar 9, 2021 at 10:18 AM Roman Danyliw <[email-masked]> wrote:

> The brief answer to “can this draft proceed” is yes, but it first needs to
> go through WGLC, AD Review, IETC LC and return to the telechat for IESG
> review.
>
>
>
> The longer explanation is that this document was initially on the
> Sept-24-2020 telechat, but early IESG reviews suggested significant enough
> issues that it was deferred initially to the Oct-8-2020 telechat.  After
> discussion on the I2NSF list about how to handle this feedback, the scope
> was determined to be significant enough that it needed be returned to back
> to the WG for revisions.  The full history is at
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability-data-model/history/.
> The highlights are as follows:
>
>
>
> 2020-09-28        12         Roman Danyliw               IESG state
> changed to I-D Exists from IESG Evaluation – Defer
>
>
>
> Based on preliminary feedback from the IESG in preparation for the
> September 24, 2020 telechat, this document was initially deferred (from
> this telechat).  After further discussion between the AD+I2NSF chairs, this
> document is being sent back to the WG to determine how to best resolve the
> dependency on the capabilities information model (i.e.,
> draft-ietf-i2nsf-capability).
>
>
>
> (discussed/announced on I2NSF list:
> https://mailarchive.ietf.org/arch/msg/i2nsf/4D8JZgqgMNQkWGdUfsSTy7tnUik/)
>
>
>
> *From:* iesg <[email-masked]> *On Behalf Of * Mr. Jaehoon Paul
> Jeong
> *Sent:* Monday, March 8, 2021 10:03 AM
> *To:* The IESG <[email-masked]>
> *Cc:* [email-masked]; skku-iotlab-members <
> [email-masked]>; Mr. Jaehoon Paul Jeong <
> [email-masked]>; Susan Hares <[email-masked]>
> *Subject:* Re: [I2nsf] I-D Action:
> draft-ietf-i2nsf-capability-data-model-16.txt
>
>
>
> Hi IESG,
>