Subject: [I2nsf] Request for Help for I2NSF WG Work

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 27 Oct 2021 23:54:09 +0900

Hi Linda and Yoav,

I would like to ask you as I2NSF WG chairs to help me to proceed with our
I2NSF WG work.

Could you ask Roman to push the Capability Draft, NSF-Facing Interface
Draft, and NSF Monitoring Draft into the IESG?

https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability-data-model/
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-model/

Also, could you do WGLC for the Consumer-Facing Interface Draft and
Registration Interface Draft during
this IETF-112 hackathon and meeting weeks?

https://datatracker.ietf.org/doc/draft-ietf-i2nsf-consumer-facing-interface-dm/
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-registration-interface-dm/

My SKKU team have reflected all the comments from Roman Danyliw and Tom
Petch for all the five YANG drafts.
These five YANG drafts are well-synchronized and proved through the IETF
I2NSF hackathon projects.

BTW, as we had an interim meeting on December in 2020, my SKKU team are
working for the Re-chartering of I2NSF WG,
including the Security Management Automation, Application Interface, and
Security Policy Translation:

https://datatracker.ietf.org/doc/draft-jeong-i2nsf-security-management-automation/
https://datatracker.ietf.org/doc/draft-lingga-i2nsf-application-interface-dm/
https://datatracker.ietf.org/doc/draft-yang-i2nsf-security-policy-translation/

I hope our I2NSF WG makes Re-chartering to work on those new work items
so that I2NSF framework and interfaces can be used in the industry.

Thanks.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department Head
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 29 Oct 2021 18:12:07 +0000

Hi Paul and WG!

Thanks for your patience.

From: I2nsf <[email-masked]> On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Wednesday, October 27, 2021 10:54 AM
To: Linda Dunbar <[email-masked]>; Yoav Nir <[email-masked]>
Cc: [email-masked]; skku-iotlab-members <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: [I2nsf] Request for Help for I2NSF WG Work

Hi Linda and Yoav,

I would like to ask you as I2NSF WG chairs to help me to proceed with our I2NSF WG work.

Could you ask Roman to push the Capability Draft, NSF-Facing Interface Draft, and NSF Monitoring Draft into the IESG?

[Roman] Thanks for the substantial edits in -17 to -20 in response to my AD review.  I’m most of the way through a second review and would expect the share any blockers, if any, to IETF LC before IETF 112.

[Roman] I see the additional edits -13 to 15 in response to my follow-up to the original AD review.  Thanks.  I plan to re-review -15 next.

[Roman] I see the edits in -09 to -11 in response to my AD review.  This will be the last ones I review.

[Roman] I will commit to re-reviewing all three drafts no later than November 19th (given the upcoming IETF 112 meeting).

[snip]

BTW, as we had an interim meeting on December in 2020, my SKKU team are working for the Re-chartering of I2NSF WG,
including the Security Management Automation, Application Interface, and Security Policy Translation:

[Roman] I strongly encourage continued WG discussion on the evolution of I2NSF.  However, I will repeat what I said in November 2020 (https://mailarchive.ietf.org/arch/msg/i2nsf/FBzpXwPUaY5PkcgvKpWnHAAanp4/) -- for me to support a re-charter, I would have to see a renewed demonstration of energy and support for these new items.  Such energy would include not only a demonstration of parties interested in working on the drafts themselves, but also additional (independent) parties volunteering to review these new drafts and some signal that there are parties (beyond the draft authors/organizations) willing to adopt (implement) this work.  This is demonstration is needed for any WG re-charter, but in particular for I2NSF, as I have concerns that energy has dropped in this WG below a threshold to take on new work.  Unless something radical changes, I see the WG continuing to steward the existing work items submitted to the IESG for publication, and then close when these work items are passed to the RFC Editor.

I acknowledge that assessing WG energy level is subjective so I’m basing my conclusion on the following:

** The WG has not convened at an official “F2F” IETF meeting since IETF 105 (July 2019) – well before the pandemic.  Since this last F2F meeting, there was a single interim meeting (in Dec 2020, almost a year ago) solely to talk about re-chartering (see next bullet).  I2NSF is again not meeting at IETF 112.

** Re-chartering has been brought up on the mailing list three separate times in the last year (to include at the interim meeting in 2020-12):
--  Nov 2020 thread -- https://mailarchive.ietf.org/arch/msg/i2nsf/z-EIzlcrgURu6hLygbTxd4GsYW8/
-- Dec 2020 thread -- https://mailarchive.ietf.org/arch/msg/i2nsf/emK5lGoG2PdBwMoVMB2ewlgYyTI/
-- Feb 2021 thread -- https://mailarchive.ietf.org/arch/msg/i2nsf/5hQCJagFY29uL8FznfxHQmu6hB4/

In all instances, the follow-up to these threads generated almost not non-administrative discussion, and very little support.

** There is no organic discussion of new or existing I2NSF work on the mailing list.  A quick review of the last year (back to October 2010) shows the list traffic to be almost  exclusively from the co-chairs, document authors, IESG review, and LC feedback (to include directorate reviews).

Thanks,
Roman

Thanks.

Best Regards,
Paul
--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department Head
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Sat, 30 Oct 2021 10:51:00 +0900

Hi Roman,
I sincerely appreciate your commitment to the three YANG drafts and advice
on the re-chartering.

I believe that our I2NSF WG will have much energy for the re-chartering to
enable our I2NSF work to be widely used in the industry.

Thanks.

Best Regards,
Paul

On Sat, Oct 30, 2021 at 3:12 AM Roman Danyliw <[email-masked]> wrote:

> *From:* I2nsf <[email-masked]> *On Behalf Of * Mr. Jaehoon Paul
> Jeong
> *Sent:* Wednesday, October 27, 2021 10:54 AM
> *To:* Linda Dunbar <[email-masked]>; Yoav Nir <
> [email-masked]>
> *Cc:* [email-masked]; skku-iotlab-members <
> [email-masked]>; Mr. Jaehoon Paul Jeong <
> [email-masked]>
> *Subject:* [I2nsf] Request for Help for I2NSF WG Work
>
>
>
> Hi Linda and Yoav,
>
>
>
> [Roman] Thanks for the substantial edits in -17 to -20 in response to my
> AD review.  I’m most of the way through a second review and would expect
> the share any blockers, if any, to IETF LC before IETF 112.
>
>
>
> [Roman] I see the additional edits -13 to 15 in response to my follow-up
> to the original AD review.  Thanks.  I plan to re-review -15 next.
>
>
>
>
> [Roman] I will commit to re-reviewing all three drafts no later than
> November 19th (given the upcoming IETF 112 meeting).
>
>
>
>
>
> [snip]
>
>
>
> [Roman] I strongly encourage continued WG discussion on the evolution of
> I2NSF.  However, I will repeat what I said in November 2020 (
> https://mailarchive.ietf.org/arch/msg/i2nsf/FBzpXwPUaY5PkcgvKpWnHAAanp4/)
> -- for me to support a re-charter, I would have to see a renewed
> demonstration of energy and support for these new items.  Such energy would
> include not only a demonstration of parties interested in working on the
> drafts themselves, but also additional (independent) parties volunteering
> to review these new drafts and some signal that there are parties (beyond
> the draft authors/organizations) willing to adopt (implement) this work.
> This is demonstration is needed for any WG re-charter, but in particular
> for I2NSF, as I have concerns that energy has dropped in this WG below a
> threshold to take on new work.  Unless something radical changes, I see the
> WG continuing to steward the existing work items submitted to the IESG for
> publication, and then close when these work items are passed to the RFC
> Editor.
>
>
>
> ** The WG has not convened at an official “F2F” IETF meeting since IETF
> 105 (July 2019) – well before the pandemic.  Since this last F2F meeting,
> there was a single interim meeting (in Dec 2020, almost a year ago) solely
> to talk about re-chartering (see next bullet).  I2NSF is again not meeting
> at IETF 112.
>
>
>
> ** Re-chartering has been brought up on the mailing list three separate
> times in the last year (to include at the interim meeting in 2020-12):
>
> --  Nov 2020 thread --
> https://mailarchive.ietf.org/arch/msg/i2nsf/z-EIzlcrgURu6hLygbTxd4GsYW8/
>
> -- Dec 2020 thread --
> https://mailarchive.ietf.org/arch/msg/i2nsf/emK5lGoG2PdBwMoVMB2ewlgYyTI/
>
> -- Feb 2021 thread --
> https://mailarchive.ietf.org/arch/msg/i2nsf/5hQCJagFY29uL8FznfxHQmu6hB4/
>
>
>
> In all instances, the follow-up to these threads generated almost not
> non-administrative discussion, and very little support.
>
>
>
> ** There is no organic discussion of new or existing I2NSF work on the
> mailing list.  A quick review of the last year (back to October 2010) shows
> the list traffic to be almost  exclusively from the co-chairs, document
> authors, IESG review, and LC feedback (to include directorate reviews).
>
>
>
> Thanks,
>
> Roman
>
>
>
> Thanks.
>
>
>
> Best Regards,
>
> Paul
>
> --
>