Subject: Re: [I2nsf] Request for Help for I2NSF WG Work

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 17 Nov 2021 22:56:56 +0900

Hi Linda and Yoav,
As you can see, the revisions of the three data model drafts are posted:

https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability-data-model/
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-model/

Two of them will be evaluated by the IESG in the next IESG telechat.

Could you start the WGLC of the other two data model drafts?

https://datatracker.ietf.org/doc/draft-ietf-i2nsf-consumer-facing-interface-dm/
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-registration-interface-dm/

Thanks.

Best Regards,
Paul

On Wed, Oct 27, 2021 at 11:54 PM Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

> Hi Linda and Yoav,
>
> I would like to ask you as I2NSF WG chairs to help me to proceed with our
> I2NSF WG work.
>
> Could you ask Roman to push the Capability Draft, NSF-Facing Interface
> Draft, and NSF Monitoring Draft into the IESG?
>
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability-data-model/
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/
>
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-model/
>
> Also, could you do WGLC for the Consumer-Facing Interface Draft and
> Registration Interface Draft during
> this IETF-112 hackathon and meeting weeks?
>
>
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-consumer-facing-interface-dm/
>
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-registration-interface-dm/
>
> My SKKU team have reflected all the comments from Roman Danyliw and Tom
> Petch for all the five YANG drafts.
> These five YANG drafts are well-synchronized and proved through the IETF
> I2NSF hackathon projects.
>
> BTW, as we had an interim meeting on December in 2020, my SKKU team are
> working for the Re-chartering of I2NSF WG,
> including the Security Management Automation, Application Interface, and
> Security Policy Translation:
>
>
> https://datatracker.ietf.org/doc/draft-jeong-i2nsf-security-management-automation/
>
> https://datatracker.ietf.org/doc/draft-lingga-i2nsf-application-interface-dm/
>
> https://datatracker.ietf.org/doc/draft-yang-i2nsf-security-policy-translation/
>
> I hope our I2NSF WG makes Re-chartering to work on those new work items
> so that I2NSF framework and interfaces can be used in the industry.
>
> Thanks.
>
> Best Regards,
> Paul
> --
> ===========================
> Mr. Jaehoon (Paul) Jeong, Ph.D.
> Associate Professor
> Department Head
> Department of Computer Science and Engineering
> Sungkyunkwan University
> Office: +82-31-299-4957
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
>

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 17 Nov 2021 14:32:37 +0000

Hi!

From: I2nsf <[email-masked]> On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Wednesday, November 17, 2021 8:57 AM
To: Linda Dunbar <[email-masked]>; Yoav Nir <[email-masked]>
Cc: [email-masked]; skku-iotlab-members <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: Re: [I2nsf] Request for Help for I2NSF WG Work

Hi Linda and Yoav,

[Roman] To clarify, these document are not yet at the next telechat.  Their status is as follows:

* draft-ietf-i2nsf-nsf-facing-interface-dm-16 = is in IETF Last Call until November 23.
* draft-ietf-i2nsf-capability-data-model-21 = is in IETF Last Call until November 29
* draft-ietf-i2nsf-monitoring-data-model = just went back to me for AD follow up this morning

After a document clears AD review, it goes into IETF Last Call for community review.  This process also triggers final directorate reviews.  IETF Last Call typically last two week.  However, since I requested the call during the IETF week, the call will run a little longer (to allow a full two weeks that does not overlap with IETF meeting week).  If any comments arise during IETF LC, they need to be resolved before they can progress to the IESG telechat.  Documents also need to placed on the agenda 1 week in advance.  As the capability-data-model is such a key dependency for the others, I will advance it in concurrently with other data model  documents (or send it first).  As a practical matter, the next telechat (Dec- 2) is already full (i.e., the IESG sets a limit on the number a documents which can be handled per telechat).  Assuming everything from IETF LC is handled, I believe the first likely telechat window for any I2NSF document is December 16.

For visibility, which documents are scheduled at an upcoming telechats can be tracked by either checking either the formal telechat agenda page (https://datatracker.ietf.org/iesg/agenda/documents/) or by checking the individual document status in the data tracker (i.e., document that are on the telechat will have the status “IESG Evaluation” and an “IESG Telechat: 2021-xx-xx” annotation).

Regards,
Roman

Thanks.

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 18 Nov 2021 07:45:44 +0900

Hi Roman,
Thanks for your kind clarification on the three I2NSF data model drafts.

Best Regards,
Paul

2021년 11월 17일 (수) 오후 11:32, Roman Danyliw <[email-masked]>님이 작성:

> Hi!
>
>
>
> *From:* I2nsf <[email-masked]> *On Behalf Of * Mr. Jaehoon Paul
> Jeong
> *Sent:* Wednesday, November 17, 2021 8:57 AM
> *To:* Linda Dunbar <[email-masked]>; Yoav Nir <
> [email-masked]>
> *Cc:* [email-masked]; skku-iotlab-members <
> [email-masked]>; Mr. Jaehoon Paul Jeong <
> [email-masked]>
> *Subject:* Re: [I2nsf] Request for Help for I2NSF WG Work
>
>
>
> Hi Linda and Yoav,
>
> After a document clears AD review, it goes into IETF Last Call for
> community review.  This process also triggers final directorate reviews.
> IETF Last Call typically last two week.  However, since I requested the
> call during the IETF week, the call will run a little longer (to allow a
> full two weeks that does not overlap with IETF meeting week).  If any
> comments arise during IETF LC, they need to be resolved before they can
> progress to the IESG telechat.  Documents also need to placed on the agenda
> 1 week in advance.  As the capability-data-model is such a key dependency
> for the others, I will advance it in concurrently with other data model
> documents (or send it first).  As a practical matter, the next telechat
> (Dec- 2) is already full (i.e., the IESG sets a limit on the number a
> documents which can be handled per telechat).  Assuming everything from
> IETF LC is handled, I believe the first likely telechat window for any
> I2NSF document is December 16.
>
>
>
> For visibility, which documents are scheduled at an upcoming telechats can
> be tracked by either checking either the formal telechat agenda page (
> https://datatracker.ietf.org/iesg/agenda/documents/) or by checking the
> individual document status in the data tracker (i.e., document that are on
> the telechat will have the status “IESG Evaluation” and an “IESG Telechat:
> 2021-xx-xx” annotation).
>
>
>
> Regards,
>
> Roman
>
>
>