Subject: [i2rs] I2RS interim 5/27 10:00am - 11:30am EDT (Webex)

From: "Susan Hares" <[email-masked]>
Date: Tue, 26 May 2015 17:13:59 -0400

The I2RS interim is schedule for Wednesdsay 5/27 10:00am – 11:30am. The interim schedule opens 30 minutes early to allow speakers to check their mike and make sure there slides are ready. 

There are two topics on the agenda: 

1)      I2RS Protocol requirements  with discussion on the following drafts  

a.       https://datatracker.ietf.org/doc/draft-haas-i2rs-ephemeral-state-reqs/  (WG adoption 5/26 to 6/9/2015) 

b.      http://datatracker.ietf.org/doc/draft-haas-i2rs-netmod-netconf-requirements (WG adoption 5/26 to 6/9/2015)

c.       http://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/ ( WG LC 5/26 to 6/9/2015) 

d.      http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/  WG LC 5/26 to 6/9/2015) 

These set of requirements are intent as a group of requirements to pass to the netmod/netconf WG on 6/10. 

The 6/10 I2RS interim will review the discussions on the email list, and finalize the set of documents passed to netconf/netmod for review. 

2)      Announcement of I2RS Design team for FB-RIB documents 

a.       Review of draft  <http://datatracker.ietf.org/doc/draft-kini-i2rs-fb-fib-info-model/> draft-kini-i2rs-fb-fib-info-model-00 

b.      Review of Yang models proposed 

                                                               i.      Generic FB-RIB-info-model 

                                                             ii.      Rules specific to individual RIB-forwarding 

This meeting is to provide verbal discussions as a prelude to the I2RS mail list discussions on the protocol, and to inform the WG regarding the FB-RIB models in order to aid the WG on the protocol discussion. 

We apologize for the reminder of the meeting time, and the web-ex meeting. 

Sue Hares and Jeff Haas 

From: I2RS Working Group [mailto:[email-masked]] 
Sent: Tuesday, May 26, 2015 4:34 PM
To: [email-masked]
Subject: WebEx meeting scheduled: I2RS interim 5/27

Hi, I2RS Working Group, 

You are the host for this WebEx meeting. 

Host key: 487042 (Use this to reclaim host privileges.) 

I2RS interim 5/27 

Wednesday, May 27, 2015 

9:30 am  |  Eastern Daylight Time (New York, GMT-04:00)  |  2 hrs 

 <https://ietf.webex.com/ietf/j.php?MTID=m70918adad686cacc341500c2d75e34c4> Join WebEx meeting 

Meeting number: 

646 391 150 

Meeting password:

jeff.is.wise

Join by phone

1-877-668-4493 Call-in toll free number (US/Canada)

1-650-479-3208 Call-in toll number (US/Canada)

Access code: 646 391 150

 <http://www.webex.com/pdf/tollfree_restrictions.pdf> Toll-free calling restrictions

 <https://ietf.webex.com/ietf/j.php?MTID=md9ce0014625f6a78854c759a20ef6050> Add this meeting to your calendar.

Can't join the meeting?  <https://ietf.webex.com/ietf/mc> Contact support. 

IMPORTANT NOTICE: Please note that this WebEx service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. You should inform all meeting attendees prior to recording if you intend to record the meeting.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 27 May 2015 07:41:48 +0200

> b.      http://datatracker.ietf.org/doc/draft-haas-i2rs-netmod-netconf-requirements (WG adoption 5/26 to 6/9/2015)

I can't make it to this meeting. My suggestion is to merge the above
two I-Ds into one I-D. There is already overlap. It also seems that
a. goes quite a bit into solution space, so calling it a requirements
document may be a bit of a stretch. (But that said, we need to start
talking about solutions since we already have a document full of
requirements.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 27 May 2015 09:55:12 -0400

> On May 27, 2015, at 1:41 AM, Juergen Schoenwaelder <[email-masked]> wrote:
> 
> two I-Ds into one I-D. There is already overlap.

I believe I’d prefer to not adopt the netmod-netconf draft.  Its goal, as explained during the last netconf WG session that I presented it in, is to simply use it as the placeholder “TODO” list for the actual drafts covering the work.  However, there was strong pressure to have adopted WG items to cover the contents.  The state draft is another piece of that.

I believe this leaves authentication requirements as the only meaningful content.  A last draft covering that may perhaps be spun out or not as the WG desires.  After that, the netmod-netconf requirements draft can die.

> It also seems that

The actual requirements have been stalled since before the NYC interim: We need ephemeral state.  The implications of any given solution space are too important to draft requirements in the absence of some understanding of the likely solution.

I’m happy to rename the draft something that doesn’t contain the word “requirements” if you have a better suggestion.

— Jeff