Subject: [i2rs] l3-topology-attributes in RFC8346

From: Benoit Tremblay <[email-masked]>
Date: Sat, 22 Sep 2018 19:24:40 +0000

Hello all,

(resending as the first one apparently did not made it through)

Has anyone noticed that the network object has an attribute called l3-topology-attribute?
Shouldn't that be l3-network-attrtibutes?
This clashes with any other objects in the RFC that have a l3-<object>-attributes : l3-node-attributes, l3-link-attributes, l3-termination-point-attributes.

This also clashes with the draft for l2-topology (draft-ietf-i2rs-yang-l2-network-topology-05) that augments network with l2-network-attributes.

Any motivation for this difference?

Regards,
Benoit

--

[logo]
Benoit Tremblay
Directeur R&D
+1 514 452-0966

*** Notice de confidentialité ***
Ce message et tout fichier attaché sont confidentiels. Si vous n'êtes pas le destinataire visé ou son mandataire chargé de lui transmettre ce document, soyez avisé qu'il est expressément interdit d'en divulguer la teneur, de le copier ou de le distribuer. Si vous avez reçu cette communication par erreur, veuillez en informer immédiatement l'expéditeur par courriel et détruire le présent message.

*** Disclaimer ***
This message and any attachments are confidential. If you are not the intended recipient or his authorized agent, please be advised that copying, distributing or revealing the contents of this message is expressly prohibited. If you are not the intended recipient, kindly notify the sender immediately by return e-mail, and delete this message from your system.

---

From: Alexander Clemm <[email-masked]>
Date: Mon, 24 Sep 2018 22:14:21 +0000

Hi Benoit,

the names are what they are.  The attributes contained in l3-topology-attributes are related to l3 topology, and are introduced in module “ietf-l3-unicast-topology.  So, I think you can argue that the name does make sense.  Could one have made a different decision?  This is probably a moot point by now.  If you are concerned that the l2-network-topology draft is introducing a similar container but naming it differently, this is something that might be discussed with the authors of the other draft.

--- Alex

From: i2rs [mailto:[email-masked]] On Behalf Of Benoit Tremblay
Sent: Saturday, September 22, 2018 12:25 PM
To: [email-masked]
Subject: [i2rs] l3-topology-attributes in RFC8346

Hello all,

Regards,
Benoit

--
[logo]
Benoit Tremblay
Directeur R&D
+1 514 452-0966

*** Disclaimer ***