Subject: Re: [i2rs] Magnus Westerlund's Discuss on draft-ietf-i2rs-yang-l2-network-topology-14: (with DISCUSS)

From: Qin Wu <[email-masked]>
Date: Fri, 11 Sep 2020 01:01:16 +0000

Thanks Tom for feedback and clarification, not actually familiar with IEEE process and just thought IEEE 802.1 is assigned to do the formal job. Maybe I missed anything and will check my AD.
If you have any suggestion, please also let us know, thanks!

-Qin
-----邮件原件-----
发件人: tom petch [mailto:[email-masked]] 
发送时间: 2020年9月11日 0:12
收件人: Qin Wu <[email-masked]>; Magnus Westerlund <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; 'Martin Vigoureux' <[email-masked]>; [email-masked]
主题: Re: Magnus Westerlund's Discuss on draft-ietf-i2rs-yang-l2-network-topology-14: (with DISCUSS)

From: i2rs <[email-masked]> on behalf of Qin Wu <[email-masked]>
Sent: 10 September 2020 15:02

Hi, Magnus and Rob:
Thanks to Sue for helping reaching IEEE community, we have received IEEE802.1 Feedback on draft-ietf-i2rs-yang-l2-network-topology-15

<tp>
Well yes, but as the chain of e-mails makes clear this is informal feedback from an individual in IEEE 802.1 YANGsters group and not a formal liaison response (which I expect is fine).  My sense is that the IEEE has a somewhat different view of Bridge ID and VLAN ID to that which I held beforehand from IETF I-D and will look at other uses of VLAN ID, in particular, in a different light as a result.  Perhaps it is time I re-read 802.1Q!

Tom Petch

https://mailarchive.ietf.org/arch/msg/i2rs/NtnhmhouhLbSv6nU2xX_wFw0to8/
and address them in v-17 and v-18
https://mailarchive.ietf.org/arch/msg/i2rs/NzDVHfaWhSgt167AXf-ay_pqRH8/
The latest update is available at:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/
Let us know if you can clear the DISCUSS now, thanks.

-Qin (on behalf of authors)
-----邮件原件-----
发件人: Magnus Westerlund [mailto:[email-masked]]
发送时间: 2020年7月10日 1:25
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Magnus Westerlund's Discuss on draft-ietf-i2rs-yang-l2-network-topology-14: (with DISCUSS)

Hi,

Sue, I raised a discuss on this just to ensure that IESG would discuss the issue today. I raised it based on the Glenn Parsons request on the IEEE-IETF mailing list and that there where apparently some confusion.

So I don't really know which failures did occur in this case. I think it would be good to analyze it. I would suspect a combination of issues. Likely including that turn over among AD makes people loose history and process.

>From my personal perspective, I as AD would appreciate a WG chairs that 
>reach
out to the AD when they thing there might be need for coordination with external bodies. I understand that for this document they might not be as clear.

Cheers

Magnus Westerlund

> -----Original Message-----
> From: Susan Hares <[email-masked]>
> Sent: den 9 juli 2020 16:28
> To: Magnus Westerlund <[email-masked]>; 'The IESG'
> <[email-masked]>
> Cc: [email-masked]; 
> [email-masked]; [email-masked]
> Subject: RE: Magnus Westerlund's Discuss on 
> draft-ietf-i2rs-yang-l2-network-
> topology-14: (with DISCUSS)
>
> Magnus:
>
> Thank you for raising this process discuss.
>
> The authors and I strong desire the I2RS model to be a NM management 
> model that imports the appropriate things from IEEE.
>
> I have two points you should add to your process discuss:
>
> 1) Where did the coordination instructions change for the WG chair?
>
> In the midst of the discussion within the IESG would you please 
> consider how to provide better instructions for the lowly chair and authors on this
> topic.   In
> the past, the IESG sent information to IEEE-IETF.    (I was scribe during
> the
> first meeting of the IETF-IESG over the TRILL issue).   I was the TRILL
> chair for
> the last years of the TRILL WGs life.   I have participated in the IEEE
> 802.1 and
> IETF during the TRILL issue when we were trying to resolve a common
> management for TRILL between IEEE and IETF.   During that time, it was
> important that a few focused voices discussed issues regarding TRILL.  
> It would help me to understand when this transitioned to chairs being 
> able to send requests to the IEEE-IETF coordination list.
>
> We also asked for numerous reviews by Yang Doctors who were 
> knowledgeable regarding IETF.  I delayed publication request several times
> until it appeared all issues were resolved.   This "sudden" surprise is
> indeed
> amazing since the L2 is 5 years old.  It is older than the 
> 8021Qcp-2018 official models.
>
>
> 2) Why are I2RS topology models are not seen as Network Management by 
> the IEEE.
>
> These are virtual topology models used by open source platforms for 
> management.  (E.g. Open Daylight).
>
> Sue
>
> -----Original Message-----
> From: Magnus Westerlund via Datatracker [mailto:[email-masked]]
> Sent: Thursday, July 9, 2020 7:44 AM
> To: The IESG
> Cc: [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Magnus Westerlund's Discuss on 
> draft-ietf-i2rs-yang-l2-network-
> topology-14: (with DISCUSS)
>
> Magnus Westerlund has entered the following ballot position for
> draft-ietf-i2rs-yang-l2-network-topology-14: Discuss
>
> When responding, please keep the subject line intact and reply to all 
> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
>
>
> Please refer to 
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topol
> ogy/
>
>
>
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
>
> This is a process discuss.
>
> There apparently have been a failure to coordinate this with IEEE per 
> discussion on the IETF-IEEE mailing list.
>
> Glenn Parsons requested that this was deferred to give IEEE time to 
> review it at their plenary next week. I think this time should be 
> given before approving this document.
>
>
>
>
>

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: tom petch <[email-masked]>
Date: Fri, 11 Sep 2020 11:22:10 +0000

________________________________________
From: Qin Wu <[email-masked]>
Sent: 11 September 2020 02:01
To: tom petch; Magnus Westerlund; Rob Wilton (rwilton); [email-masked]
Cc: [email-masked]; [email-masked]; 'Martin Vigoureux'; [email-masked]
Subject: RE: Magnus Westerlund's Discuss on draft-ietf-i2rs-yang-l2-network-topology-14: (with DISCUSS)

<tp>
Qin
The e-mail that caught my eye was from Glenn Parsons 26aug20 to the I2RS list pointing out that we were getting informal feedback from an individual (which I think is fine) but it does, for me, have a subtext that the IEEE commonly has more formal procedures than the IETF, and wants us to recognise that this is informal and that we could request a formal response via a liaison if the IETF wanted to.  So I think it fine to incorporate the information that Don has provided but it would be going too far to say 'This is what the IEEE says' because the IEEE has not said anything in this exchange of e-mail, only put us in touch with an individual.  Equally I would think it wrong to ascribe comments to the IEEE, rather to Don.

It was Eric that raised the issue of IEEE involvement back in July so he is one that needs to know this while Benjamin also raised questions of how IEEE 802.1Q handled some unusual looking objects and Sue mentioned the possibility of a Liaison and Alvaro then said that a formal liaison was not needed so I see those as the key actors who need to know we took the informal route.

Technically I have not caught up with all the detail that Don provided and will likely have to read IEEE 802.1Q before I do ie we will likely have an RFC published before I get there!

Tom Petch 

-Qin
-----邮件原件-----
发件人: tom petch [mailto:[email-masked]]
发送时间: 2020年9月11日 0:12
收件人: Qin Wu <[email-masked]>; Magnus Westerlund <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; 'Martin Vigoureux' <[email-masked]>; [email-masked]
主题: Re: Magnus Westerlund's Discuss on draft-ietf-i2rs-yang-l2-network-topology-14: (with DISCUSS)

Hi, Magnus and Rob:

<tp>

Tom Petch

-----邮件原件-----
发件人: Magnus Westerlund [mailto:[email-masked]]
发送时间: 2020年7月10日 1:25
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Magnus Westerlund's Discuss on draft-ietf-i2rs-yang-l2-network-topology-14: (with DISCUSS)

Hi,

Cheers

Magnus Westerlund

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 11 Sep 2020 11:45:18 +0000

Hi All,

This was on the agenda to be discussed in the IEEE Yangsters meeting on Weds 9th, but unfortunately that meeting was cancelled at short notice.  I'm hopefully that this can be discussed in next week's Yangsters meeting (16th).
	
My hope is for an agreement in that meeting that sufficient review has been down and any necessary changes have been made, such that the document can continue to progress in IETF without requiring any formal liaison statement between IEEE and IETF.

I attend the Yangsters meetings on a semi-regular basis anyway, plan to attend next week, and was intending to feedback the meeting conclusions via Martin.

Regards,
Rob

> From: tom petch <[email-masked]>
> Sent: 11 September 2020 12:22
> To: Qin Wu <[email-masked]>; Magnus Westerlund
> <[email-masked]>; Rob Wilton (rwilton)
> <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked];
> 'Martin Vigoureux' <[email-masked]>; [email-masked]
> Subject: Re: Magnus Westerlund's Discuss on draft-ietf-i2rs-yang-l2-
> network-topology-14: (with DISCUSS)
> 
> 
> 
> Thanks Tom for feedback and clarification, not actually familiar with IEEE
> process and just thought IEEE 802.1 is assigned to do the formal job.
> Maybe I missed anything and will check my AD.
> The e-mail that caught my eye was from Glenn Parsons 26aug20 to the I2RS
> list pointing out that we were getting informal feedback from an
> individual (which I think is fine) but it does, for me, have a subtext
> that the IEEE commonly has more formal procedures than the IETF, and wants
> us to recognise that this is informal and that we could request a formal
> response via a liaison if the IETF wanted to.  So I think it fine to
> incorporate the information that Don has provided but it would be going
> too far to say 'This is what the IEEE says' because the IEEE has not said
> anything in this exchange of e-mail, only put us in touch with an
> individual.  Equally I would think it wrong to ascribe comments to the
> IEEE, rather to Don.
> 
> It was Eric that raised the issue of IEEE involvement back in July so he
> is one that needs to know this while Benjamin also raised questions of how
> IEEE 802.1Q handled some unusual looking objects and Sue mentioned the
> possibility of a Liaison and Alvaro then said that a formal liaison was
> not needed so I see those as the key actors who need to know we took the
> informal route.
> 
> Technically I have not caught up with all the detail that Don provided and
> will likely have to read IEEE 802.1Q before I do ie we will likely have an
> RFC published before I get there!
> 
> Tom Petch
> 
> -Qin
> -----邮件原件-----
> 收件人: Qin Wu <[email-masked]>; Magnus Westerlund
> <[email-masked]>; Rob Wilton (rwilton)
> <[email-masked]>; [email-masked]
> 抄送: [email-masked]; [email-masked];
> 'Martin Vigoureux' <[email-masked]>; [email-masked]
> Thanks to Sue for helping reaching IEEE community, we have received
> IEEE802.1 Feedback on draft-ietf-i2rs-yang-l2-network-topology-15
> 
> <tp>
> Well yes, but as the chain of e-mails makes clear this is informal
> feedback from an individual in IEEE 802.1 YANGsters group and not a formal
> liaison response (which I expect is fine).  My sense is that the IEEE has
> a somewhat different view of Bridge ID and VLAN ID to that which I held
> beforehand from IETF I-D and will look at other uses of VLAN ID, in
> particular, in a different light as a result.  Perhaps it is time I re-
> read 802.1Q!
> 
> Tom Petch
> 
> 
> 
> 
> 
> 
> 
> Sue, I raised a discuss on this just to ensure that IESG would discuss the
> issue today. I raised it based on the Glenn Parsons request on the IEEE-
> IETF mailing list and that there where apparently some confusion.
> 
> So I don't really know which failures did occur in this case. I think it
> would be good to analyze it. I would suspect a combination of issues.
> Likely including that turn over among AD makes people loose history and
> process.
> 
> out to the AD when they thing there might be need for coordination with
> external bodies. I understand that for this document they might not be as
> clear.
> 
> Cheers
> 
> Magnus Westerlund
> 
> 
>