Subject: [Ianaplan] IANA Functions Contract

From: Bernard Aboba <[email-masked]>
Date: Tue, 9 Sep 2014 10:24:05 -0700

"The IETF responses are not well-formulated in my opinion.  There isn't any
reference to the IANA Functions contract."

[BA] Note sure that those references are needed, but in case they are, here
they are:

References

[1] NTIA RFP:
http://www.ntia.doc.gov/files/ntia/publications/sa1301-12-rp-0043-_final_04.16.2012.pdf

[2] Amendment 001 to the RFP (May 17, 2012):
http://www.ntia.doc.gov/files/ntia/publications/amendment_0001_sa1301-12-rp-0043-05.17.12_-final.pdf

[3] NTIA-ICANN contract (July 2, 2012):
http://www.ntia.doc.gov/files/ntia/publications/sf_26_pg_1-2-final_award_and_sacs.pdf

[4] Contract Amendment Modification 0001 (October 1, 2012):
http://www.ntia.doc.gov/files/ntia/publications/sa1301-12-cn-0035_mod_0001_-_deliverable_schedule.pdf

[5] Contract Amendment Modification 0002 (April 30, 2013):
http://www.ntia.doc.gov/files/ntia/publications/sa1301-12-cn-0035001.pdf

[6] ICANN proposal:
http://www.ntia.doc.gov/other-publication/2012/icann-proposal

Other relevant links

IANA functions purchase order:

http://www.ntia.doc.gov/page/iana-functions-purchase-order

MOU, SLA and other relevant IETF documents:

http://www.ietf.org/iana/iproc.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Sep 2014 08:14:17 +1200

> reference to the IANA Functions contract."

I believe that it's quite irrelevant. The way the protocol parameters
registries, including the technical parts of the address and domain
name registries, have worked for the last 15 years was unaffected by
the NTIA contract, and there is nothing in our view of the future of
those registries that will be affected by the absence of that contract.

   Brian

> ------------------------------------------------------------------------
> 
> _______________________________________________
> Ianaplan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ianaplan

---

From: S Moonesamy <[email-masked]>
Date: Tue, 09 Sep 2014 14:48:35 -0700

Hi Bernard,
At 10:24 09-09-2014, Bernard Aboba wrote:
>"The IETF responses are not well-formulated in my opinion.  There 
>isn't any reference to the IANA Functions contract."
>
>[BA] Note sure that those references are needed, but in case they 
>are, here they are:

[snip]

>[3] NTIA-ICANN contract (July 2, 
>2012):http://www.ntia.doc.gov/files/ntia/publications/sf_26_pg_1-2-final_award_and_sacs.pdf

Thanks for the links.  The (ICG) Request for Proposals references the 
above link.

Regards,
S. Moonesamy

---

From: manning bill <[email-masked]>
Date: Tue, 9 Sep 2014 15:06:15 -0700

dipping the toe backing to the maelstrom …

NTIA asserted authority over the IANA functions with contractual structures.  The actual “customers” of the IANA functions,  the DNS operators, RIRs, and the IETF were too disorganized
in 1998/1999 to put up much of a fuss and ICANN seems to have done a fair job of executing the IANA Functions.   HOWEVER.   With NTIA stepping away,  the use of the phrase “IANA Functions
Contract” suggests that a contractual structure in put into place between the IETF and the party it wishes to execute the IANA functions that are relevant to the IETF.  Similarly, the DNS operators and
the RIRs would have contractual structures for the eventual IANA Functions to sign - thus retaining the facts of the existence of one or more IANA Functions Contracts.

Thats what the landscape looks like from here.   

/bill
Neca eos omnes.  Deus suos agnoscet.

On 9September2014Tuesday, at 14:48, S Moonesamy <[email-masked]> wrote:

>> "The IETF responses are not well-formulated in my opinion.  There isn't any reference to the IANA Functions contract."
>> 
>> [BA] Note sure that those references are needed, but in case they are, here they are:
> 
> [snip]
> 
>> [3] NTIA-ICANN contract (July 2, 2012):http://www.ntia.doc.gov/files/ntia/publications/sf_26_pg_1-2-final_award_and_sacs.pdf
> 
> Thanks for the links.  The (ICG) Request for Proposals references the above link.
> 
> Regards,
> S. Moonesamy

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Sep 2014 10:54:43 +1200

Sorry, WG Chairs, this is probably out of scope but I think
we need a solid basis of fact to work on.

On 10/09/2014 10:06, manning bill wrote:
> in 1998/1999 to put up much of a fuss

I can't speak for the DNS ops and RIR sides of the house, but the IETF/IAB side
of the house wasn't disorganised. We met with Ira Magaziner during IETF 40,
and it was an IAB topic throughout the following year including the horrible
period around Jon's death. But the circumstances, including the financial
situation for future funding of IANA, were such that a US-based ICANN with
a contract with Commerce was really the only viable alternative. We started
work on the IETF/ICANN agreement as soon as ICANN was stable enough to
allow it. The first full draft was sent to the poisson WG list with copies
to Esther Dyson, Mike Roberts, Joyce Reynolds and Zita Wenzel at
"Date: Tue, 15 Dec 1998 17:33:31 +0000".

> and ICANN seems to have done a fair job of executing the IANA Functions.   HOWEVER.   With NTIA stepping away,  the use of the phrase “IANA Functions
> Contract” suggests that a contractual structure in put into place between the IETF and the party it wishes to execute the IANA functions that are relevant to the IETF. 

We already have that in place, since March 2000. As you can see, it took
about 15 months to negotiate (which is why I for one am not anxious
to do it over).

   Brian

> Similarly, the DNS operators and

---

From: David Conrad <[email-masked]>
Date: Tue, 9 Sep 2014 16:01:25 -0700

Brian,

On Sep 9, 2014, at 3:54 PM, Brian E Carpenter <[email-masked]> wrote:
> But the circumstances, including the financial
> a contract with Commerce was really the only viable alternative.

Matter of opinion. I know of at least two RIRs (and I believe several NIRs) that were more than willing to pay (and did!) to support the IANA (I signed one of the checks myself). While I am sure there were political reasons that justified the approach taken, I dispute “a contract with Commerce was really the only viable alternative."

Water under the bridge of course.

Regards,
-drc

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Sep 2014 11:27:11 +1200

One last word and I will drop the topic:

> Matter of opinion. I know of at least two RIRs (and I believe several NIRs) that were more than willing to pay (and did!) to support the IANA (I signed one of the checks myself). While I am sure th…

Well, money was only one of the circumstances, for sure, and avoiding a fight
with the White House was another. I'm just reporting on how it looked from
the IAB's viewpoint at that time, to correct the assertion that we weren't
organised.

> Water under the bridge of course.

Yes.

    Brian

---

From: S Moonesamy <[email-masked]>
Date: Tue, 09 Sep 2014 22:54:15 -0700

Hi Bill,
At 15:06 09-09-2014, manning bill wrote:
>NTIA asserted authority over the IANA functions 
>with contractual structures.  The actual 
>“customers” of the IANA functions,  the DNS 
>operators, RIRs, and the IETF were too disorganized
>in 1998/1999 to put up much of a fuss and ICANN 
>seems to have done a fair job of executing the 
>IANA Functions.   HOWEVER.   With NTIA stepping 
>away,  the use of the phrase “IANA Functions
>Contract” suggests that a contractual structure 
>in put into place between the IETF and the party 
>it wishes to execute the IANA functions that are 
>relevant to the IETF.  Similarly, the DNS operators and
>the RIRs would have contractual structures for 
>the eventual IANA Functions to sign - thus 
>retaining the facts of the existence of one or more IANA Functions Contracts.
>

I read about the 1998 discussions a few months 
ago.  I also read the relevant 
documentation.  The description used by the 
United States Department of Commerce is "legacy authority".

One definition of the word "contract" is "a legal 
document that states and explains a formal 
agreement between two different people or groups, 
or the agreement itself".  At this stage of the 
discussion it is difficult to assess whether a 
contract or anything new is required to replace 
the existing IANA Functions Contract.

Regards,
S. Moonesamy

---

From: manning bill <[email-masked]>
Date: Tue, 9 Sep 2014 23:29:32 -0700

/bill
PO Box 12317
Marina del Rey, CA 90295
310.322.8102

On 9September2014Tuesday, at 22:54, S Moonesamy <[email-masked]> wrote:

> I read about the 1998 discussions a few months ago.  I also read the relevant documentation.  The description used by the United States Department of Commerce is "legacy authority".
> 
> One definition of the word "contract" is "a legal document that states and explains a formal agreement between two different people or groups, or the agreement itself".  At this stage of the discussion it is difficult to assess whether a contract or anything new is required to replace the existing IANA Functions Contract.
> 

if ntia/doc, as the contracting party, terminates that agreement,  whom would be the parties to new contract(s) and on what basis would such a contract(s) rest?

---

From: "Richard Hill" <[email-masked]>
Date: Wed, 10 Sep 2014 10:13:06 +0200

Dear Brian,

Could you clarify to which group of people you refer when you state below
"there is nothing in *our* view of the future of those registries that will
be affected by the absence of that contract"? (emphasis added)

Thanks and best,
Richard

> -----Original Message-----
> From: Ianaplan [mailto:[email-masked]]On Behalf Of Brian E
> Carpenter
> Sent: mardi, 9. septembre 2014 22:14
> To: Bernard Aboba
> Cc: [email-masked]
> Subject: Re: [Ianaplan] IANA Functions Contract
>
>
http://www.ntia.doc.gov/files/ntia/publications/sa1301-12-rp-0043-_final_04.
16.2012.pdf
> [2] Amendment 001 to the RFP (May 17, 2012):
http://www.ntia.doc.gov/files/ntia/publications/amendment_0001_sa1301-12-rp-
0043-05.17.12_-final.pdf
> [3] NTIA-ICANN contract (July 2, 2012):
http://www.ntia.doc.gov/files/ntia/publications/sf_26_pg_1-2-final_award_and
_sacs.pdf
> [4] Contract Amendment Modification 0001 (October 1, 2012):
http://www.ntia.doc.gov/files/ntia/publications/sa1301-12-cn-0035_mod_0001_-
_deliverable_schedule.pdf

---

From: S Moonesamy <[email-masked]>
Date: Wed, 10 Sep 2014 01:22:18 -0700

Hi Bill,
At 23:29 09-09-2014, manning bill wrote:
>if ntia/doc, as the contracting party, terminates that 
>agreement,  whom would be the parties to new contract(s) and on what 
>basis would such a contract(s) rest?

 From RFC 6220 [1]:

   "The IAOC is responsible for identifying a potential vendor in a
    manner of their choosing, based on IAB consultation, and for
    managing the various aspects of the relationships with that
    vendor."

The list of members of the IAOC is at 
http://iaoc.ietf.org/members.html  The IAOC may be able to provide a 
good answer to the above question.

The document at 
http://iaoc.ietf.org/documents/2014-ICANN-IETF-MoU-Supplemental-Agreement-Executed.pdf 
is listed under "contracts".  The two parties are ICANN and the 
IAOC.  I do not know the answer to the second part of the question.

Regards,
S. Moonesamy

1. http://www.rfc-editor.org/rfc/rfc6220.txt

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 Sep 2014 08:40:46 +1200

> be affected by the absence of that contract"? (emphasis added)

The IETF. This is an IETF WG list. And of course there is an implied
IMHO on everything here except when it's the WG Chairs calling consensus
or the ADs announcing an IESG decision.

   Brian

> .