Subject: [Ianaplan] I-D Action: draft-ietf-ianaplan-icg-response-03.txt

From: [email-masked]
Date: Fri, 14 Nov 2014 15:24:29 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Planning for the IANA/NTIA Transition Working Group of the IETF.

        Title           : Draft Response to the Internet Coordination Group Request for Proposals on the IANA protocol parameters registries
        Authors         : Eliot Lear
                          Russ Housley
	Filename        : draft-ietf-ianaplan-icg-response-03.txt
	Pages           : 29
	Date            : 2014-11-14

Abstract:
   This document contains the a response to a request for proposals from
   the IANA Stewardship Transition Coordination Group regarding the
   protocol parameters registries.  It is meant to be included in an
   aggregate proposal that also includes contributions covering domain
   names and numbering resources that will be submitted from their
   respective operational communities.  The IETF community is invited to
   comment and propose changes to this document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ianaplan-icg-response/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ianaplan-icg-response-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-ianaplan-icg-response-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Richard Hill" <[email-masked]>
Date: Sat, 15 Nov 2014 15:00:45 +0100

Thanks for this.

In the next version, please remove my name from the "acknowledgements"
section.

Best,
Richard

> -----Original Message-----
> From: Ianaplan [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: samedi, 15. novembre 2014 00:24
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Ianaplan] I-D Action: draft-ietf-ianaplan-icg-response-03.txt
>
>
>
>         Title           : Draft Response to the Internet
> Coordination Group Request for Proposals on the IANA protocol
> parameters registries
>         Authors         : Eliot Lear
>                           Russ Housley
> _______________________________________________
> Ianaplan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ianaplan
>

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 15 Nov 2014 16:18:25 +0100

> On 15 nov 2014, at 15:00, Richard Hill <[email-masked]> wrote:
> 
> Thanks for this.
> 

Personally, I think as is normal for I-D's that it should be transparent who has been working on a document and because of that that names should be included.

Is there a specific reason why you want your name removed?

I just want to understand the situation that of course happens now and then. I.e. you are not the first that asks for your name to be removed from an I-D, although it is not happening often.

   Best, Patrik

---

From: "Richard Hill" <[email-masked]>
Date: Sat, 15 Nov 2014 16:20:29 +0100

> From: Ianaplan [mailto:[email-masked]]On Behalf Of Patrik
> Faltstrom
> Sent: samedi, 15. novembre 2014 16:18
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Ianaplan] I-D Action:
> draft-ietf-ianaplan-icg-response-03.txt
>
>
>
> Personally, I think as is normal for I-D's that it should be
> transparent who has been working on a document and because of
> that that names should be included.
>

Yes.  The draft does not reflect any of my inputs, so I do not wish to be
associated with it.

>
> I just want to understand the situation that of course happens
> now and then. I.e. you are not the first that asks for your name
> to be removed from an I-D, although it is not happening often.
>
>    Best, Patrik
>
> > Best,
> > Richard
> >

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 15 Nov 2014 16:21:56 +0100

> On 15 nov 2014, at 16:20, Richard Hill <[email-masked]> wrote:
> 

Aha, ok, makes sense (of course).

Thanks for the clarification, and sorry for asking. There are so many parallell discussions and threads it is hard to keep them separated.

   Best, Patrik

---

From: Miles Fidelman <[email-masked]>
Date: Sat, 15 Nov 2014 10:52:11 -0500

> Yes.  The draft does not reflect any of my inputs, so I do not wish to be

I make the same request (to be removed from the acknowledgements), for 
roughly the same reason.  I'll go on to elaborate just a bit:

The document purports to be a "Response to the Internet Coordination 
Group Request for Proposals," and the preamble goes on to say
"The IETF community is invited to comment and propose changes to this 
document."

However:

- the document is the output of a WG charted to focus only on technical 
aspects of the proposal

- issues related to legal and contractual matters have largely been 
punted to the IAOC as out-of-scope for the WG

- without such issues being addressed, fully, the document represents an 
incomplete, unresponsive response to the RFP (if I were a reviewer of 
such a proposal, I'd reject it out-of-hand, as incomplete and 
unresponsive) -- These days, I write proposals for a living; I'd never 
let the current document anywhere near the door. As such, I don't wish 
my name associated with the draft in it's current form.

- there is no defined process by which such legal and contractual 
matters are to be addressed and incorporated into the document that goes 
to the ICG

- as my comments (and those of several others) have largely been 
dismissed as out of scope for the WG, and as there is no vehicle defined 
for making comments about portions of the proposal outside of the WG's 
limited scope -- I can't see it's appropriate to acknowledge my input.

Miles Fidelman

-- 
In theory, there is no difference between theory and practice.
In practice, there is.   .... Yogi Berra

---

From: Eric Burger <[email-masked]>
Date: Sat, 15 Nov 2014 06:02:47 -1000

On Nov 15, 2014, at 5:52 AM, Miles Fidelman <[email-masked]> wrote:
> [snip]
> I make the same request (to be removed from the acknowledgements), for roughly the same reason.  I'll go on to elaborate just a bit:
> 
> The document purports to be a "Response to the Internet Coordination Group Request for Proposals," and the preamble goes on to say
> "The IETF community is invited to comment and propose changes to this document."
> 
> However:
> 
> - the document is the output of a WG charted to focus only on technical aspects of the proposal
> 
> - issues related to legal and contractual matters have largely been punted to the IAOC as out-of-scope for the WG
> 
> - without such issues being addressed, fully, the document represents an incomplete, unresponsive response to the RFP (if I were a reviewer of such a proposal, I'd reject it out-of-hand, as incomplete and unresponsive) -- These days, I write proposals for a living; I'd never let the current document anywhere near the door. As such, I don't wish my name associated with the draft in it's current form.

I believe the confusion comes because the ICG overloaded the word ‘proposal.’ The ‘RFP’ issued is really a Request for *Information*, or RFI. Think of it this way, of the 29 pages of text, precisely two cover the IETF's ‘proposal’ response.

I think the other 15 pages of text capture what we do, why we do it, what we need, and, as almost an aside, what we ‘propose.’

I am fine with it as it is.

---

From: John C Klensin <[email-masked]>
Date: Sat, 15 Nov 2014 11:26:16 -0500

--On Saturday, November 15, 2014 16:21 +0100 Patrik Fältström
<[email-masked]> wrote:

>> Yes.  The draft does not reflect any of my inputs, so I do
>> not wish to be associated with it.
> 
> Thanks for the clarification, and sorry for asking. There are
> so many parallell discussions and threads it is hard to keep
> them separated.

Richard,

Having been dead-center in one of the discussions Patrik refers
to in general terms, let me elaborate a bit on his position.
The acknowledgment should clearly not imply that the document
reflects your particular inputs or that you agree with the
results unless both are true.  However, we do have a strong
principle about acknowledging contributions even when those
contributions only stimulated others to think about issues or
write text differently than they would have otherwise.  If I
made a comment about a technical specification and the reaction
of the WG and editor were "perhaps the most stupid idea I've
ever heard of, but we should add some text to protect against it
and even more stupid ideas", normal IETF procedures and
precedents would require that my contribution be acknowledged.
If I felt strongly enough, it would always be appropriate for me
to try to negotiate the text to avoid any implication of
endorsement and I would expect the WG and editor(s) to be
generous to my position in that negotiation.  But removing a
name is another issue entirely.   We generally give authors and
editors a lot of discretion about the needed contribution or
impact level that require acknowledgment of someone by name and
practices differ widely between WGs, but I think the above is a
reasonable summary of the principle.

Analogies to the ISO/IEC practice of listing those who were
involved in technical development of a standard with, if needed,
a disclaimer about endorsement may be useful here.  I suppose
the general guideline might be stated as "if you don't want to
risk being acknowledged in some way, don't participate to the
level of making comments or suggesting text".

best,
    john

---

From: Miles Fidelman <[email-masked]>
Date: Sat, 15 Nov 2014 11:26:58 -0500

> I am fine with it as it is.

It's most assuredly not an RFI.  It's not a matter of volume.  What we 
propose is the only part that's actually meaningful to the transition 
process.  And, the part we seem to be avoiding dealing with in a 
substantive manner.

Obviously, I'm NOT fine with it as it is.

---

From: "Richard Hill" <[email-masked]>
Date: Sat, 15 Nov 2014 17:27:50 +0100

Dear John,

Thank you for these clarifications.

I insist that my name be removed.

Best,
Richard

> From: John C Klensin [mailto:[email-masked]]
> Sent: samedi, 15. novembre 2014 17:26
> To: Patrik Fältström; [email-masked]
> Cc: [email-masked]

---

From: Eric Burger <[email-masked]>
Date: Sat, 15 Nov 2014 06:45:12 -1000

I cannot believe we are even discussing whether or not Richard’s name is in the acknowledgements section. Editors need to be cited because we need to know who to blame for their errors. They also need to be heralded because they did the editing work.

This is not a Patent where neglecting to disclose an inventor invalidates the Patent.

This is not an academic paper where one must acknowledge everybody’s contributions, and signing (today, in most journals) includes an explicit endorsement of the contents.

This is not a political declaration, where we have to have tons of people “signing on” to show broad support.

This is not an academic paper where leaving someone off who wants to be in is seen as a faux pas at best and academic misconduct at worse.

If someone does not want their name to appear in the acknowledgements, I do not see how it is possible to say anything other than “Why?" at first (to get at the issue(s)) and "Thank You, you can be assured your name will not appear in the acknowledgements” after that. Four message protocol. Period.

---

From: Milton L Mueller <[email-masked]>
Date: Sun, 16 Nov 2014 12:19:49 +0000

Eric
I am on the ICG and when we wrote "proposal" in the RFP, we meant proposal. 
And when the NTIA asked for a proposal, they meant a proposal. 
The charter of the ICG also states very clearly that " The IANA stewardship transition coordination
Group (ICG) has one deliverable: a proposal to the U.S. Commerce Department (NTIA)...."

All told there are about 50 places in the charter and the RFP where we could have asked for information but did not, and asked for proposals instead.

Bottom line: if justifying one's position on this ianaplan draft requires one to completely invert the clear meaning of our task, one should perhaps revisit one's position.

--MM

> From: Ianaplan [mailto:[email-masked]] On Behalf Of Eric Burger
> Sent: Saturday, November 15, 2014 11:03 AM
> To: [email-masked]
> Subject: Re: [Ianaplan] I-D Action: draft-ietf-ianaplan-icg-response-03.txt
> 
> > Group Request for Proposals," and the preamble goes on to say "The IETF
> community is invited to comment and propose changes to this document."
> >
> > However:
> >
> incomplete, unresponsive response to the RFP (if I were a reviewer of such a
> proposal, I'd reject it out-of-hand, as incomplete and unresponsive) -- These
> days, I write proposals for a living; I'd never let the current document
> anywhere near the door. As such, I don't wish my name associated with the
> draft in it's current form.
> 
> I believe the confusion comes because the ICG overloaded the word
> 'proposal.' The 'RFP' issued is really a Request for *Information*, or RFI.
> Think of it this way, of the 29 pages of text, precisely two cover the IETF's
> 'proposal' response.
> 
> I think the other 15 pages of text capture what we do, why we do it, what we
> need, and, as almost an aside, what we 'propose.'
>

---

From: Seun Ojedeji <[email-masked]>
Date: Sun, 16 Nov 2014 14:10:35 +0100

Hi Richard,

I presume this document is still in draft state and if you have further
concern, will it not be in order to mention them?.

Here you are talking about removing your name, as a participant on this
list I wonder whether it's even appropriate to add any name in the first
place. This is not technical rfc, it's purely beyond the normal IETF
processes and participants so those culture of acknowledgments should not
happen; Maybe it was inappropriate to have started this is an IETF WG
format in the first place. Even someone who writes just 1 mail on this list
has contributed... the best compromise would have been to acknowledge all
list subscriber.

My 2 cents.

Regards

sent from Google nexus 4
kindly excuse brevity and typos.

---

From: Miles Fidelman <[email-masked]>
Date: Sun, 16 Nov 2014 09:47:13 -0500

> Bottom line: if justifying one's position on this ianaplan draft requires one to completely invert the clear meaning of our task, one should perhaps revisit one's position.

Milton,

 From your perspective, sitting on the ICG:

What do you think will happen if the ICG receives an incomplete and 
unresponsive "proposal" from a major community, specifically the IETF?  
Throw it on the floor? Reject it and request a revised proposal?  Ask 
for more?

And by extension, what impact would this have on the overall process and 
outcome?

And.. do you have any sense of whether the other major communities are 
doing any better of a job in preparing their responses?

Perhaps it might be time for the ICG to provide some formal guidance to 
the communities?

Miles Fidelman