Subject: Re: [Ianaplan] Time frame inquiry

From: "Leslie Daigle (ThinkingCat)" <[email-masked]>
Date: Mon, 01 Jun 2015 09:39:01 -0400

I think the result is shaping up well, and the response should be sent.  
On the question of who signs it:  As I have stated elsewhere — I think 
it’s great to get the IETF’s input on the response, but I don’t 
see the IANAPLAN WG as having an operational position to commit the IETF 
on such matters as timeframes for implementation.

And if it’s not a WG matter, I don’t understand why the WG Chairs 
would sign it.

(That’s not a repudiation of content of message, that’s a question 
of role, IMO).

Leslie.

—

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------
On 29 May 2015, at 11:49, Russ Housley wrote:

> Thanks for pulling all of the pieces together.  I t looks good to me.
>
> I think it should be signed by the IANAPLAN WG Chairs.  They were the 
> ones that received the letter.
>
> Russ
>
> P.S.  Should we put the letter and the response in the liaison system 
> to make them easy to find?
>
>
> On Wed, May 27, 2015 at 10:15 PM, Jari Arkko <[email-masked]> 
> wrote:
> Eliot:
>
>> I like the text below modulo one issue: the IANAPLAN proposal did not 
>> specify how the IAOC would implement the requested changes (whether 
>> through the SLA or another side agreement).  I would prefer that we 
>> stuck to that approach and not name which agreement the changes go 
>> into (SLA or a one-time supplemental agreement).
>
> Ok.
>
> Trying to take this and Ted’s comments into account:
>
> “The IETF is ready today to take the next steps in the
> implementation of the transition of the stewardship.
> In our case, most of the necessary framework is already
> in place and implemented in preceding years.
>
> The remaining step is an updated agreement with
> ICANN which addresses two issues. These issues are
> outlined in Section 2.III in the Internet Draft
> draft-ietf-ianaplan-icg-response-09.txt:
>
> o  The protocol parameters registries are in the public domain.  It
>    is the preference of the IETF community that all relevant parties
>    acknowledge that fact as part of the transition.
>
> o  It is possible in the future that the operation of the protocol
>    parameters registries may be transitioned from ICANN to subsequent
>    operator(s).  It is the preference of the IETF community that, as
>    part of the NTIA transition, ICANN acknowledge that it will carry
>    out the obligations established under C.7.3 and I.61 of the
>    current IANA functions contract between ICANN and the NTIA
>    [NTIA-Contract] to achieve a smooth transition to subsequent
>    operator(s), should the need arise.  Furthermore, in the event of
>    a transition it is the expectation of the IETF community that
>    ICANN, the IETF, and subsequent operator(s) will work together to
>    minimize disruption in the use the protocol parameters registries
>    or other resources currently located at iana.org.
>
> The IETF Administrative Oversight Committee (IAOC) has
> decided to use an update of our yearly IETF-ICANN Service Level
> Agreement (SLA) as the mechanism for this updated
> agreement. They have drafted the update and from our
> perspective it could be immediately executed. Once the updated
> agreement is in place, the transition would be substantially
> complete, with only the NTIA contract lapse or termination
> as a final step.
>
> Of course, we are not alone in this process. Interactions
> with other parts of the process may bring additional
> tasks that need to be executed either before or
> after the transition. First, the ICG, the RIRs,
> and IETF have discussed the possibility of aligning
> the treatment of IANA trademarks. The IETF Trust
> has signalled that it would be willing to do this, if
> asked. We are awaiting to coordination on this
> to complete, but see no problem in speedy
> execution once the decision is made. From our
> perspective this is not a prerequisite for the transition,
> however.
>
> In addition, the names community has proposed the
> creation of a 'Post Transition IANA' (PTI).  If the existing
> agreements between the IETF and ICANN remain in place
> and the SLAs discussed above are not affected, the IETF​
> ransition would take place as described above.  That is
> our preference.  If the final details of the PTI plan require
> further action from the IETF, more work and community
> agreement would be required.  The timeline for that work
> cannot be set until the scope is known.”
>
> Jari
> _______________________________________________
> Ianaplan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ianaplan

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 02 Jun 2015 08:22:55 +1200

Hi Leslie,
On 02/06/2015 01:39, Leslie Daigle (ThinkingCat) wrote:
> 
> I think the result is shaping up well, and the response should be sent.  On the question of who signs it:  As I have stated
> elsewhere — I think it’s great to get the IETF’s input on the response, but I don’t see the IANAPLAN WG as having an operational
> position to commit the IETF on such matters as timeframes for implementation.
> 
> And if it’s not a WG matter, I don’t understand why the WG Chairs would sign it.

Concur. If the IETF Chair, the IAB Chair, the IAOC Chair and the Trust Chair
would co-sign it, we'd be in good shape.

   Brian

> 
> (That’s not a repudiation of content of message, that’s a question of role, IMO).
> 
> Leslie.
> 
> —
> 
>> I think it should be signed by the IANAPLAN WG Chairs.  They were the ones that received the letter.
>>
>> Russ
>>
>> P.S.  Should we put the letter and the response in the liaison system to make them easy to find?
>>
>>
>> On Wed, May 27, 2015 at 10:15 PM, Jari Arkko <[email-masked]> wrote:
>> Eliot:
>>
>>> I like the text below modulo one issue: the IANAPLAN proposal did not specify how the IAOC would implement the requested
>>> changes (whether through the SLA or another side agreement).  I would prefer that we stuck to that approach and not name
>>> which agreement the changes go into (SLA or a one-time supplemental agreement).
>>
>> Ok.
>>

---

From: Benson Schliesser <[email-masked]>
Date: Mon, 1 Jun 2015 17:38:26 -0400

On Mon, Jun 1, 2015 at 4:22 PM, Brian E Carpenter <
[email-masked]> wrote:

> On the question of who signs it:  As I have stated
> > elsewhere — I think it’s great to get the IETF’s input on the response,
> but I don’t see the IANAPLAN WG as having an operational
I've been considering this topic, and I think Leslie's perspective and
Brian's proposal are reasonable. But to be honest, I'm comfortable with any
one of the approaches that have been proposed.

My earlier agreement with Russ' proposal stems from the understanding that
the ianaplan chairs were the recipients of the question. As such it makes
sense that they should sign this statement. But the IETF chair is the best
person to indicate IETF consensus. The IAOC chair is the best person to
indicate specific plans around the contracts etc. And the Trust chair (me)
is the best person to indicate our willingness regarding the trademarks etc.

That being said, 5 signatories is getting to the point of being silly. I'd
be equally happy to simply have Jari sign it on our behalf. It doesn't seem
worth laboring over - if there is consensus either way, then Jari has the
mandate as far as I'm concerned.

Cheers,
-Benson

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 02 Jun 2015 10:33:56 +1200

> mandate as far as I'm concerned.

I would certainly not object to that. A slightly pernickety point is the
original MoU with ICANN was signed by the IETF Chair (Fred Baker) and
co-signed by the IAB Chair (me). That was to avoid any discussion about
where the authority lay on our side. (The IAB charter says "The IAB must
approve the appointment of an organization to act as IANA on behalf of
the IETF. The IANA takes technical direction on IETF protocols from the IESG.")

    Brian

---

From: Jari Arkko <[email-masked]>
Date: Thu, 4 Jun 2015 15:03:36 +0300

I wouldn’t worry too much about the signatories that is perhaps more of a practical
matter than anything else. In general, reducing the reliance on persons in official
roles and highlighting the role of the community is important in this and many
other topics.

But being clear about the status of any opinion is important, and we
didn’t make that yet clear in the previous text.

I plan to send this note to the ICG later today unless someone screams
otherwise. I also plan to send a copy to the CWG list for information,
given our reference relating to the PTI arrangements.

—

This is a response to a query regarding transition finalisation and
implementation time frames, sent to the IANAPLAN working
group list by the chairs of the IANA Transition Coordination
Group (ICG) on May 27th.

While I am carrying this response back to the ICG, the substance
of this response has been discussed in the IANAPLAN working
group and the relevant parts of IETF leadership. I believe this
response represents the (rough) consensus opinion that
emerged in the discussion, as well as the current state
of IANA arrangement updates that our leadership bodies
have been working on.

The IETF is ready today to take the next steps in the
implementation of the transition of the stewardship.
In our case, most of the necessary framework is already
in place and implemented in preceding years.

     minimize disruption in the use of the protocol parameters registries

Of course, we are not alone in this process. Interactions
with other parts of the process may bring additional
tasks that need to be executed either before or
after the transition. First, the ICG, the RIRs,
and IETF have discussed the possibility of aligning
the treatment of IANA trademarks and domains. The
IETF Trust has signalled that it would be willing to do this,
if asked. We are awaiting coordination on this
to complete, but see no problem in speedy
execution once the decision is made. From our
perspective this is not a prerequisite for the transition,
however.

In addition, the names community has proposed the
creation of a 'Post Transition IANA' (PTI).  If the existing
agreements between the IETF and ICANN remain in place
and the SLAs discussed above are not affected, the IETF​ 
transition would take place as described above.  That is
our preference.  If the final details of the PTI plan require
further action from the IETF, more work and community
agreement would be required.  The timeline for that work
cannot be set until the scope is known.

Jari Arkko, IETF Chair
(reporting his summary of the situation)

---

From: Jefsey <[email-masked]>
Date: Fri, 05 Jun 2015 13:31:30 +0200

Dear Jari,
I will not scream. This was when the IETF still existed as a sovereign entity…

----

Two-days ago, at the French IGF plenary:

1. which congratulated itself over the NTIA ICANN transition process,

2. and consensually felt it was too early to apply the FIFA metaphor to ICANN,

3. I asked about the added value of ICANN:

3.1. brought to the use of the 1974 catenet, pursued by the Internet 
IEN 48 1978 project, status-quoed in 1986 within NSA-compatibility by 
the creation of the IETF and the closing of Tymnet Extended Services 
and its EuroLab,

3.2. now the IAB has lifted the NSA requirement on Nov 14, 2014 
<https://www.iab.org/2014/11/14/iab-statement-on-internet-confidentiality/>https://www.iab.org/2014/11/14/iab-statement-on-internet-confidentiality/, 
leading to a "permissionless innovation" consensual paradigm already 
introduced by the RFC 6852.

3.2.1. I was surprised by the silence, followed by several 
contradictory responses by ICANN BoD level/equivalent leaders.
3.2.2. The consensual echoes that I further received from the 
attendants confirmed that it was acknowledged that ICANN only managed 
an "internet semantic spectrum", which is something partly similar to 
what I call a VGN and RFCs name a CLASS, while the IAB/IETF has never 
considered how a multispectrum internet works.

----

I only note here that the IESG seems to be gone, and you now govern 
intuitu personæ (so there is no more risk of appeals, thank you for that):
- after having enfeoffed  the IETF to the USG 
<http://www.ietf.org/blog/2015/01/taking-a-step-towards-iana-transition/>http://www.ietf.org/blog/2015/01/taking-a-step-towards-iana-transition/
- you do the same, enfeoffing the Internet to the USG through the PTI 
political trick.

This only leads me to extend my question about value-added IAB/IETF 
will now bring to the various internet variants and to the users' catenet.
I, myself, understand that the IETF is now one of the RFC 6852 "ICANN 
global community's" technical contributors.

jfc

At 14:03 04/06/2015, Jari Arkko wrote:
>I wouldnâ€™t worry too much about the signatories that is perhaps 
>more of a practical
>didnâ€™t make that yet clear in the previous text.
>
>and the SLAs discussed above are not affected, the IETFâ€‹