Subject: Re: [Iasa20] I-D Action: draft-hall-iasa20-workshops-report-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Mar 2017 02:29:33 +1300

Hi,

Thanks for this report, very useful for those who couldn't attend
the workshops. Here are some personal thoughts, picking on a few points.

>    o  The line between the IETF and ISOC is not organizationally clear-
>       cut, 

Better get used to it. Since the IETF is intentionally not incorporated
and intentionally run by a rough consensus process, that line will never
be clear-cut.

> which has led to issues around transparency, 

Why has the lack of a clear line done that? I'm not saying there are
no transparency issues, but I don't understand why they are caused by
the unclear "line".

> allocation of staff time and priorities, 

Are you saying that the IAD doesn't get enough staff support *due
to* the unclear line?

> budgeting,

Again, why is that  due to the unclear line? The IETF has no budget,
since it isn't incorporated. The ISOC holds our budget and it's
run by the IAD. I don't see the lack of clarity here.

> and clarity of who is responsible for what.

Yes, I agree that the line between volunteer and staff effort can be
unclear - that's a classical (and insoluble) problem in non-profits.

>    o  Having ISOC represent the IETF to sponsors and donors -
> 
>       *  creates confusion about why the IETF does not represent itself,

Actually I think the issue is a bit more contorted. I don't think that
companies are at all confused. It's just that they have mixed motivations.
The technical managers want influence in the IETF; the engineers want
to help the IETF; the marketing people want publicity. 

But indeed, the IETF leadership needs to work hand in glove with
ISOC on this. I'm not sure what it has to do directly with IASA, though.
IASA's job description doesn't include PR.

>       *  yields questions about why ISOC does not instead increase its
>          IETF support

I have no sympathy with that. The IETF would be very mistaken to think
of ISOC as a cash cow and drop its own involvement in fund-raising.

>                       and how donations can be guaranteed to be
>          dedicated to the IETF, and

That seems like a trivial accounting matter.

>       *  can result in those soliciting sponsorships and donations
>          having a lack of familiarity with IETF work.

See above re hand-in-glove.

>    For example, participants noted some items are branded
>    IETF, like the IETF Journal, are ISOC driven and funded, and are not
>    directed by the IETF community.

Really? When it started, the IETF Chair (me) reviewed the contents.
I'm a bit shocked if that is no longer the case.

...
>    A commentor mentioned that this sounded like a
>    branding issue at times: while the IETF Trust holds IETF trademarks,
>    is the IETF brand and the contours of what it encompasses clear?

I'm puzzled by this. It seems entirely clear to me: the Trust decides who
can use the brand, and ISOC clearly uses it when describing IETF activities.

>    The
>    commentor further asked: who defines the contents of ISOC activities
>    that are visible to the outside world?

ISOC of course. Who else? ISOC's role is far broader than the IETF.

>    ...for example, if the IETF community
>    wants to change the structure of relationships with sponsors, who has
>    the authority to make that decision?  IESG?  IAOC?  Community
>    consensus?  This participant felt that this is unclear.

IAOC. From RFC4071:
  "The IAD and IAOC are responsible for making all business decisions
   regarding the IASA.  In particular, the ISOC Board of Trustees shall
   not have direct influence over the choice of IASA contractors or IETF
   meeting sponsors.  This restriction is meant to enforce the
   separation between fund-raising and the actual operation of the
   standards process."
But of course we expect the IAOC to seek community input, as in the
current discussion about meetings policy.

...
>    The IAOC only goes to the
>    community for specific policy questions - e.g., the privacy policy or
>    changes to the trust legal provisions - but does not get general
>    "please do this" feedback from the community.

That is not the IAOC's fault. Look at how little feedback the IAOC gets
in plenary, where the detailed IAOC report has been dropped by popular
request.

>    Another workshop participant felt
>    that there was a lack of clarity around even where some questions
>    should be asked (e.g. "how many logos do we want on our badges?" or
>    "who drives/has responsibility for some specific functions?").

Did they try asking the IAD?

>    That
>    commentor felt that an important question is whether or not the IETF
>    community wants a "thin" IAOC that has mostly oversight of the IAD or
>    a "thick" IAOC that has administrative responsibilities - i.e. "who
>    is driving the bus?"

Now that's a good question. The "O" in IAOC stands for "oversight". The theory
is that staff should do everything and the IAOC should watch. I don't think
that's reality. The *intended* answer was that the IAD drives the bus.

>    Some felt that the lack of rigid formality in the organization and
>    structure was not necessarily a bad thing.

To a large extent it's an excellent thing. But even so, responsiibilities
for decisions need to be clear. In the limit, the IAOC oversees, hires
and fires the IAD. But reality is more complex.

>    ...working to improve IASA could make the IETF more structured and thus
>    less appealing to some kinds of contributors. 

That's confusing. The IASA is meant to be a professional administration,
serving the rest of the community. That does *not* mean that an improved
IASA implies a more structured IETF as a whole.

>    ...we do ourselves a disservice by this long-
>    standing confusion about whether IETF is an organization; they felt
>    that people within the community know what is meant by the IETF and
>    that more formality is not necessary.  

I am totally unaware of this confusion. In fact, it confuses me.

...
>    o  Relying heavily on meeting-based revenue is somewhat at odds with
>       the fact that much of the IETF's work takes place outside of in-
>       person meetings.

Possibly. But relying on, say, membership fees would be completely at odds
with the IETF's volunteer and rough consensus ethos. Relying on vendor
sponsorship has its own obvious problems.

>    ...A workshop
>    participant felt that the IETF needs to be able to clearly state what
>    it is asking for, and what the relevance is for the potential
>    sponsor.

As mentioned above, the relevance is wildly different for different employees
of a sponsor (engineers, engineering management, marketing).

>    ...IASA has lagged progress of groups like the IESG,
>    who have made agendas and meetings open.  
...
>    Hotel contracts aren't shown due to confidentiality agreements,...

In my experience some years ago, a large proportion of IAOC (and sub-committee)
discussions were very unsuitable for open access. Contracts and personnel issues
came up a lot. If meetings were made open, a lot more business would be discussed
outside the meetings. I'm all for transparent reporting but in this case I just
don't see open meetings being viable.

>    One suggestion was for the IAOC to hold information sessions or
>    office hours at meetings,

Surely the IAOC has been making its office at IETF sites open for drop-ins
for years? As for info sessions, see the remarks about why the IAOC no longer
parades in plenary. Very few people actually seem to care.

>    o  IAD workload is (much) more than a full-time job, but we have one
>       staff person allocated to it.

Um, perhaps we can stop the problem description right there?

Relying on volunteers to make professional admin work better seems
highly unlikely to succeed.

>    A participant said that, although IAOC committees are listed on the
>    IAOC website (https://iaoc.ietf.org/committees.html), there is a lack
>    of documentation about how the committee participants are chosen.

And so what? If the IAD and IAOC don't have the right to co-opt their own
subcommittees as needed, we are in a funny place. I seem to have seen
calls for volunteers from time to time.

>    A Workshop participant noted that, in order to understand how the
>    committees work, one needs to understand...

I don't understand the point of this. Why does the community need to
understand how the subcommittees work? They don't answer to the
community, they answer to the IAOC.

Regards
   Brian Carpenter

Regards
   Brian Carpenter

On 14/03/2017 03:28, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Report from the IASA 2.0 Virtual Workshops
>         Authors         : Joseph Lorenzo Hall
>                           A. Jean Mahoney
> 	Filename        : draft-hall-iasa20-workshops-report-00.txt
> 	Pages           : 17
> 	Date            : 2017-03-13
> 
> Abstract:
>    This is the Workshop Report for the IETF Administrative Support
>    Activity 2.0 (IASA 2.0) Virtual Workshops, held on 28 February 2017
>    at 1100 UT and 1600 UT.  The original IETF Administrative Support
>    Activity (IASA) was created ten years ago, and since has been subject
>    to some reflection.  In the intervening years, there has been
>    considerable change in the necessary tasks of IETF administration and
>    in the world around the IETF, and in how the IETF raises funds and
>    finances its work.  The IASA 2.0 process seeks to address which
>    administrative arrangements will best support the IETF going forward.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-hall-iasa20-workshops-report/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-hall-iasa20-workshops-report-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Mon, 20 Mar 2017 09:54:17 -0400

Hi Brian,

> the workshops. Here are some personal thoughts, picking on a few points.

Thank you, I'll try and point out places where we might want to change
the text of the report to reflect your feedback (obviously, only part

> and intentionally run by a rough consensus process, that line will never

(a number of places you respond to where the report is quoting slides
presented at the workshop, let me know if that's not clear)

> I'm a bit shocked if that is no longer the case.

It would be helpful to know if this is still the case and we could
mention that fact in the text.

> current discussion about meetings policy.

Seems like it would be good to add this reference to the text.

> don't see open meetings being viable.

This is something we had not yet heard and might be good to put into
the text of the report here.

> community, they answer to the IAOC.

I don't think this commentor said that the community *needs* to
understand how this works, but that when a community member finds
themselves needing to understand some part of it for their role (e.g.,
imagine a new IAOC member trying to make sense of it all), it can be a
challenge.

best, Joe

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

Tech Prom, CDT's Annual Dinner, is April 20, 2017! https://cdt.org/annual-dinner

---

From: Matthew Ford <[email-masked]>
Date: Mon, 20 Mar 2017 14:40:05 +0000

> On 20 Mar 2017, at 13:54, Joseph Lorenzo Hall <[email-masked]> wrote:
> 
>>> 

FWIW, I choked a little on the text Brian quoted above too. The Editorial Board for the Journal (which includes both IETF and IAB chairs) has the opportunity to review content for each issue. Both chairs (plus the IRTF chair) provide columns in each issue, and I regularly solicit articles from WG chairs and anyone else I run into that seems like they’d have something interesting and relevant to write about. We also pretty frequently ask the community for suggestions for articles, or offers to author material for the Journal.

Mat

(Editor, IETF Journal)

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 20 Mar 2017 16:19:06 -0400

Hi Brian,

Some responses to your comments below. These are directed at the general discussion topics for the list, not meant to be funneled into edits to the workshop report.

> On Mar 20, 2017, at 9:29 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

You seem to be assuming constraints about what changes may or may not be made as a result of this IASA 2.0 discussion. You might not want the present organizational arrangements to change or you might be of the opinion that they will never change, but that doesn’t mean that such changes are off the table. The present phase is one of problem identification. I don’t think any solution options are off the table, and I wouldn’t say “never” about any particular change at this point.

> Why has the lack of a clear line done that?

One reason (of several) is the fact that the IAD is an ISOC employee means that we end up relying on a multitude of ISOC staff and resources solely for the purpose of administering the IETF, and much of that reliance is not described or accounted for anywhere. If you asked the average IETF participant how many ISOC staff the IAD consults with or relies on for support of various kinds, what do you think the answer would be? I can tell you that until a few weeks ago my guess would have been way low. Their work in support of the IETF isn’t documented anywhere, which is natural within the internal context of ISOC because they are co-workers who are working with their co-worker who happens to be the IAD. But because of the organizational blurriness, their work is not transparent to the community.

> I'm not saying there are

The point of this is not that the IAD doesn’t get enough support (that’s a different valid point), but that who is deciding about allocations and priorities is not clear and perhaps not optimal. Again just to take an example, after several years of having Greg Wood help out with IETF communications, during which time I’m not sure how clear it was to anyone who was deciding how much time he should spend on that or what he should be devoting that time to, we for the first time have a specific time allocation from him, specific budget, and specific priorities he is working towards, with agreement from his management at ISOC. And his case is far ahead in terms of clarity and agreement between the IETF and ISOC as compared to some other ISOC staff and programs, I would say.

> run by the IAD. I don't see the lack of clarity here.

If this is really your position, would you argue that the IETF shouldn’t be publishing its own budgets and financial statements at all (as it’s been doing for a dozen years)? If your view is that there is no confusion because it’s all ISOC’s money anyway, there is no point in publishing separate budgets and financial statements for the IETF.

I think the confusion arises because there are items that are in direct support of the IETF that are not accounted for in the IETF budget, and there are ISOC-affiliated activities which relate to the IETF but for which there is not clarity in the ISOC budget. We are working on getting more clarity around both of these, but right now they’re not clear.

> companies are at all confused.

We have heard from potential donors and from those soliciting donations that they are, indeed, confused about why they are being pitched by one entity to give money to another “entity," albeit not a legally separate one.

> It's just that they have mixed motivations.

I would be interested to know whose job description in the IETF leadership does include PR, in your view. The IETF Chair has taken on some of this responsibility in the natural course of sponsor/donor relations, but it’s not obvious to me that that is actually specified clearly anywhere in a way that matches reality or the workload that the chair can realistically bear. 

> That seems like a trivial accounting matter.

Again here I would be interested to understand better how you see this working. The IETF does not have a bank account open for accepting donations independent of ISOC. Rules of procedure and governance have been created to reassure donors that funds will be directed to the IETF, but ultimately the responsibility for adhering to those rules (and not changing them in the future), lies with the ISOC Board, to which the IETF community appoints a minority of members. 

> ISOC of course. Who else? ISOC's role is far broader than the IETF.

I believe the point here was about ISOC’s IETF-related activities. For example, the fellows programs or the sponsorship pitches.

> I am totally unaware of this confusion. In fact, it confuses me.

I would say it’s highly unusual to find an SDO — or really any organization of the size and complexity of the IETF — that is not a legal entity or was not created by a contract of some sort. People who have a passing familiarty with the IETF or are just getting to know the IETF assume that it is a legal entity. Unless one has a specific reason to know, it wouldn’t usually be people's first guess that the IETF is actually just an activity of another organization.

> community, they answer to the IAOC.

The committees are comprised in part of community members, and part of the point of having them is to have more community members able to provide direct input into the IETF’s administration. If most participants don’t understand the committees, it’s hard to find people who can contribute to them.

Best,
Alissa

> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Mar 2017 11:31:34 +1300

> You seem to be assuming constraints about what changes may or may not be made as a result of this IASA 2.0 discussion. You might not want the present organizational arrangements to change or you mi…

Fair enough that nothing is off the table, but I'd be prepared to take a side bet about this aspect ;-)

> One reason (of several) is the fact that the IAD is an ISOC employee means that we end up relying on a multitude of ISOC staff and resources solely for the purpose of administering the IETF, and much of that reliance is not described or accounted for anywhere. If you asked the average IETF participant how many ISOC staff the IAD consults with or relies on for support of various kinds, what do you think the answer would be? 

Extrapolating from my out of date experience, I would guess at least 20 (but of course only for a fraction of their time). But I don't think that has much to do with the lack of a clear line. IASA is *supposed* to be professional, so surely we always expected the IAD to call on professional help. Of course, I expect a lot of this is invisible in the budget.

> I can tell you that until a few weeks ago my guess would have been way low. Their work in support of the IETF isn’t documented anywhere, which is natural within the internal context of ISOC because they are co-workers who are working with their co-worker who happens to be the IAD. But because of the organizational blurriness, their work is not transparent to the community.

Yes, that I certainly agree with.

> The point of this is not that the IAD doesn’t get enough support (that’s a different valid point), but that who is deciding about allocations and priorities is not clear and perhaps not optimal. Ag…

Understood. More light on this would be valuable.

> If this is really your position, would you argue that the IETF shouldn’t be publishing its own budgets and financial statements at all (as it’s been doing for a dozen years)? If your view is that t…

No, not at all, of course they should be published. But the IETF accounts *are* the IASA accounts and that's a subset of the ISOC accounts. 

> I think the confusion arises because there are items that are in direct support of the IETF that are not accounted for in the IETF budget, and there are ISOC-affiliated activities which relate to t…

If some labour costs incurred by ISOC staff are not being accounted as an in-kind contribution to IASA, that could be fixed in the accounts, by all means. But it will not change anything in reality, except maybe make the ISOC Board scrutinise the details.

> We have heard from potential donors and from those soliciting donations that they are, indeed, confused about why they are being pitched by one entity to give money to another “entity," albeit not…

Right. That should be explained in the first paragraph of the pitch.

> I would be interested to know whose job description in the IETF leadership does include PR, in your view. The IETF Chair has taken on some of this responsibility in the natural course of sponsor/do…

I fully agree. But the fact is, and I bet every past chair will confirm it, the outside world sees the IETF Chair as the figurehead, however hard one tries to avoid it. So you are kind of stuck with it, like it or not. And also, as noted in the workshop report, it's essential that whoever does the PR is technically competent. Yet PR does need professional support too, especially the fund-raising part. So this isn't easy to get right. I have no easy answer.

> Again here I would be interested to understand better how you see this working. The IETF does not have a bank account open for accepting donations independent of ISOC. Rules of procedure and govern…

Yes. If we can't trust the ISOC on this, we are in trouble. But that's not new; this is a large part of why ISOC was created.

> I believe the point here was about ISOC’s IETF-related activities. For example, the fellows programs or the sponsorship pitches.

If so, yes, this gets back to my hand-in-glove comment. So we can say
(1) Outreach, PR & fundraising are not part of IASA's defined role
(2) They need both professional support (presumably from ISOC) and IETF leadership input
(3) The outside world must not see any gap between the ISOC and IETF parts of this.
I can see that there's work to do on this.

> I would say it’s highly unusual to find an SDO — or really any organization of the size and complexity of the IETF — that is not a legal entity or was not created by a contract of some sort. People…

Yes, the IETF is highly unusual in this regard; IMHO it's the IETF's greatest strength in resisting capture by vested interests. But it isn't actually hard to discover for newcomers, is it? It's stated at the bottom of the home page, and the newcomer's page, the Tao (and RFC2028, cited in the Tao) should clarify things.

> The committees are comprised in part of community members, and part of the point of having them is to have more community members able to provide direct input into the IETF’s administration. If mos…

True. If most participants don't read https://iaoc.ietf.org/committees.html, they won't understand the committees, but whose fault is that, actually, and what more can we do than publish the information?

Rgds
   Brian

---

From: Randy Bush <[email-masked]>
Date: Tue, 21 Mar 2017 10:36:17 -0500

> One reason (of several) is the fact that the IAD is an ISOC employee
> means that we end up relying on a multitude of ISOC staff and
> resources solely for the purpose of administering the IETF, and much
> of that reliance is not described or accounted for anywhere. If you
> asked the average IETF participant how many ISOC staff the IAD
> consults with or relies on for support of various kinds, what do you
> think the answer would be? I can tell you that until a few weeks ago
> my guess would have been way low. Their work in support of the IETF
> isn’t documented anywhere, which is natural within the internal
> context of ISOC because they are co-workers who are working with their
> co-worker who happens to be the IAD. But because of the organizational
> blurriness, their work is not transparent to the community.

to me, this is one of the few critical points.  i think the ietf
benefits greatly by not having employees, directly handling cash, etc.
to do so would put us in a very different world.  the tradeoff is a
complex relationship with the isoc or whatever fronts for us.  if we
de-fuzz and clean up that interface, it will be less uncomfortable and
more transparent.

another is the nomcom process, which has a bit of rationality as
opposed to the popularity contests in organizations such as nanog.
but i hope we're not reviewing that area of our structure in this
pass.

randy

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 21 Mar 2017 15:42:17 +0000

> but i hope we're not reviewing that area of our structure in this

I think I agree with Randy.

I do think this process might change the set of, or
the descriptions of, roles for which we ask nomcoms
to select people, but I do not think this process
is intended to or ought try change how nomcoms are
selected/operate etc.

S.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 21 Mar 2017 08:55:34 -0700

Randy,

> On Mar 21, 2017, at 8:36 AM, Randy Bush <[email-masked]> wrote:
> 

I agree, it looks to be getting better.  I note in the IETF 2017 Budget at

https://iaoc.ietf.org/documents/IETF-Budget-2017-28Sep16-FINAL.pdf

there is a large section called "ISOC Support Services”.  This apparently is accounting for what ISOC provides, and is more specific than what was done in earlier years.

Bob

---

From: Dave Crocker <[email-masked]>
Date: Tue, 21 Mar 2017 09:06:52 -0700

> and intentionally run by a rough consensus process, that line will never

The premise that the IETF's lack of incorporation somehow dictates 
ambiguous lines of authority and/or management makes no sense.  The 
latter are dictated by clarity of organization structure and crispness 
of task and personnel management, not legal status.

Incorporated organizations hire unincorporated individuals all the time. 
  Unincorporated individuals hire Incorporated organizations. 
Individuals hire individuals.

Each of these can be done with good or poor definition and operation of 
lines of responsibility and lines of authority.

There is no reason the IETF/ISOC relationship necessarily has the 
ambiguities we've operated with.

Rather, it is lack of resolve to make things clear and operate 
accordingly.  We are quite lucky that everyone involved is committed to 
making things work, but perhaps contrarily that luck serves to obfuscate 
the problems here.  (It does not help that the IETF's operation came out 
of the 'daddy pays' funding and operations model, since that created the 
foundation for this continuing administrative confusion.)

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Randy Bush <[email-masked]>
Date: Tue, 21 Mar 2017 11:09:58 -0500

> I agree, it looks to be getting better.  I note in the IETF 2017

i look forward to the time when the report for past year(s) is properly
called an income statement as opposed to a budget, and it reconciles
with the isoc's income statement.

randy

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 21 Mar 2017 11:26:00 -0500

This isn't the right mailing list for follow-ups, so I'll stop now, after
saying

On Tue, Mar 21, 2017 at 10:42 AM, Stephen Farrell <[email-masked]
> wrote:

> selected/operate etc..

If "this process" is IASA 2.0, I couldn't agree more.

The right place for follow-ups is, if I understand correctly,
https://www.ietf.org/mailman/listinfo/ietf-nomcom.

Alissa can change that any time after next Wednesday, of course :-)

Spencer

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 22 Mar 2017 06:26:58 +1300

Hi Dave,

> of task and personnel management, not legal status.

That's not quite what I was getting at; and I do believe that responsibilities
can and should be well-defined. My point was that, having observed the IETF
and various other organisations with a mixture of professional and volunteer
effort, there is *always* a lack of crispness about what actually gets done
by the volunteers as opposed to staff. That's just a result of human nature
and the motivations and incentives that are at work. I'm not saying it's a
bad thing, either, but it's life.

   Brian

---

From: Dave Crocker <[email-masked]>
Date: Tue, 21 Mar 2017 10:48:00 -0700

On 3/21/2017 10:26 AM, Brian E Carpenter wrote:
> by the volunteers as opposed to staff.

Brian,

Sorry for my confusion, but since you only cited the legal distinction 
and said nothing about paid/volunteer status, well...

And would that your clarification made your assessment more compelling, 
but alas, you are still quite wrong.

Volunteer-vs-Paid role confusion is equally due to lack of crisp 
structure and operations clarity, although sometimes also mixed with a 
lack of respect.  The sad fact is that volunteer-based organizations are 
often run quite badly, in spite of their lofty intentions.

FWIW, this isn't an abstract issue for me.  I was recently on a regional 
American Red Cross committee looking at volunteer (dis)satisfaction and 
this point was key, especially for the (mis)handling of senior 
volunteers. This has been dramatically improved by changes in culture 
and clarity (and respect), not changes in incorporation, payment, or any 
other formal attribute.  (Well, other than the formal change in 
employment some paid staff, replacing a few who had no respect for 
volunteers by others who are entirely constructive...)

> That's just a result of human nature

I've no idea what 'human nature' you are referring to.

Problems with structure and role confusion are due to lack of 
decision-making by management, insisting on crisp, clear structures, 
roles and operations.  And, yes, it's that simple.  Not easy, but simple.

> bad thing, either, but it's life.

Well, "incentives" could well be an interesting line of discussion.

d/

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 21 Mar 2017 18:40:08 +0000

Hiya,

> bad thing, either, but it's life.

I think we ought analyse and improve even though perfection
is unattainable.

When I first looked over the list of IAOC cttes and their
members this was one of the first things that struck me. I
couldn't figure out who on which ctte does what from outside,
not who really calls the shots.

I happen to think ending up in that kind of situation after
10 years of operating is not at all strange, in fact it's
entirely understandable.

I'd not suggest we invent one rule to rule them all type of
arrangement for all cttes, but just that someone tries to
characterise, for each ctte, how different volunteer/staff
roles are handled now.

I'd bet a beer we discover stuff we'd like to change if we
do do that.

Cheers,
S.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 21 Mar 2017 11:47:04 -0700

Stephen,

> On Mar 21, 2017, at 11:40 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

To me this falls into the category that the IAOC needs to communicate a lot more about how they are currently doing their work.  The plenaries isn’t the way to do this, they need to find other mechanisms.

To some level it’s documented at iaoc.ietf.org, but I think we need more than that.

Thanks,
Bob

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 21 Mar 2017 19:01:19 +0000

Hiya,

> To some level it’s documented at iaoc.ietf.org, but I think we need more than that.

Putting it on the web site would be fine. I guess at [1].
Or maybe something allowing version control (an I-D or
git repo) might be better, not sure.

And indeed I see the meetings ctte is now split into staff
and volunteer member lists which is a good start. (I forget
if that split is new or not.)

But even in that case, it's not clear who does what. I can
imagine (but am guessing) that kind of thing might have
contributed to some of the IAOC related mega-discussions
we've had on lists when things do go a bit wrong, e.g. if
a scenario occurred where staff feel they can't be the ones
who respond on lists, but volunteers haven't got the right
information (or don't explain it well because it's third
hand).

Cheers,
S.

[1] https://iaoc.ietf.org/committees.html

---

From: Dave Crocker <[email-masked]>
Date: Tue, 21 Mar 2017 12:04:51 -0700

> But even in that case, it's not clear who does what. I can

Clarifying these, and ensuring that ongoing efforts conform to those 
clarifications, is certainly appropriate to do.

But I believe it will have almost no effect on confusion about 
authority, roles and accountability, between the IETF and ISOC.

That involves inter-organization clarity (between IETF and ISOC), not 
within-organization (IETF) committee clarification.

d/

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 21 Mar 2017 19:07:26 +0000

> within-organization (IETF) committee clarification.

I agree these are different tasks. And they're not the only
two separable things worth doing as part of the work here.

S.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 21 Mar 2017 12:13:04 -0700

> On Mar 21, 2017, at 12:04 PM, Dave Crocker <[email-masked]> wrote:
> 
> Clarifying these, and ensuring that ongoing efforts conform to those clarifications, is certainly appropriate to do.
> 
> But I believe it will have almost no effect on confusion about authority, roles and accountability, between the IETF and ISOC.
> 
> That involves inter-organization clarity (between IETF and ISOC), not within-organization (IETF) committee clarification.

As well as with AMS and other contractors.

Bob

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 21 Mar 2017 16:10:43 -0400

> On Mar 20, 2017, at 6:31 PM, Brian E Carpenter <[email-masked]> wrote:
> 
>> 
>>> 
> Extrapolating from my out of date experience, I would guess at least 20 (but of course only for a fraction of their time). But I don't think that has much to do with the lack of a clear line.

But if the line were clear(er), this wouldn’t be a problem. Just to come back to the communications example for convenience, if there were staff on the IETF “side” whose specified responsibilities included communications, we never would have been in a situation where an ISOC staff person just naturally started taking on those responsibilities, because they would have been taken care of by the IETF. Instead, we sort of slid gradually into a situation where ISOC staff was doing it and it wasn’t being accounted for anywhere.

> IASA is *supposed* to be professional, so surely we always expected the IAD to call on professional help.

There is an additional problem with this model, which is that it assumes that ISOC’s priorities and resources will always be available and aligned with whatever the IAD feels he needs to get the job done. It seems like that does not actually work seamlessly in practice without a lot of coordination between ISOC management and the IAOC. For example, let’s say there are 20 ISOC employees who spend some part of their time supporting the IETF, some of whom do it because the IAD comes and asks them for help — is that reflected in those people’s performance goals and evaluations? Is input collected from the IAOC or the committees so that those people’s managers can assess how well they’re doing in those functions? If not, is that fair to them? As new people are hired by ISOC to meet the growing workload required to support both the IETF and ISOC’s other activities, does anyone on the IETF side have any input into those hiring processes? Should they?

> If some labour costs incurred by ISOC staff are not being accounted as an in-kind contribution to IASA, that could be fixed in the accounts, by all means. But it will not change anything in reality…

Per my comments above, I think it could change a lot in reality. We could decide that we’d rather contract out some of these functions that previously were not accounted for anywhere, or that we need more full-time ISOC staff to support the IETF. On the ISOC side, they could decide to incorporate IETF-related work into people’s performance goals, or to reorganize their own personnel to better accommodate the workload/expense that they are putting in.

> Yes. If we can't trust the ISOC on this, we are in trouble.

But this isn’t about “us” (depending how you define it), it’s about potential new sponsors and donors having that trust.

> But that's not new; this is a large part of why ISOC was created.
> 
>> 
>>> 

For some folks on the other end of a sponsorship pitch, the Tao is not really a suitable place to start.

Alissa

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 22 Mar 2017 09:41:51 +1300

Excuse front posting, but this is kind of a general comment on this whole discussion. Alissa wrote:

> We could decide that we’d rather contract out some of these functions that previously were not accounted for anywhere, or that we need more full-time ISOC staff to support the IETF.

Who is "we"? That decision seems dead centre in IASA's responsibility, overseen by the IAOC.

Let me repeat: I'm all for clarifying the administrative boundaries and costs, and adjusting things as appropriate. But that seems like part of the job we delegated to IASA 10 years ago. It seems to me that from the IETF point of view, our main concern should be whether IASA (=IAD+IAOC+Trust) is constituted in the best way for current & future conditions. For example, I'm sympathetic to the point that the IAOC skill-set is different from the Trust skill-set.

One new thing that I've seen is the need to clarify responsibilities for PR/fund-raising, which was definitely *not* delegated to IASA.

Regards
   Brian