Subject: [Iasa20] Call for volunteers: IASA 2.0 design team

From: Alissa Cooper <[email-masked]>
Date: Tue, 9 May 2017 13:56:50 -0700

I think the community is at a point in the IASA 2.0 discussions where we are ready to form a design team to start evaluating options for the path forward. We have a good articulation of the set of problems we are facing in draft-hall-iasa20-workshops-report and draft-daigle-iasa-retrospective. We have some sense of the outcome properties that people are looking for here, based on list discussion. So I'd like to task a design team to go examine potential solutions to the problem set that fit the outcome properties, and come back to the community with recommended solutions. The scope of the solutions to be explored would include:

- Structural and organizational changes, both externally (with ISOC and contractors) and internally (within the IAOC and subcommittees)
- Changes to personnel resources, both volunteer and paid
- Transparency changes

For now, changes to the funding model would be out of scope to the extent they fall outside the categories above, although the design team's work should be informed by the prior discussion of funding challenges. The IAOC sponsorship committee is currently in the process of getting off the ground and I think it would make sense to have some of that discussion start there before merging it back in with the administrative discussion. And I think the administrative problems are articulated well enough for a team to get going with that focus.

My hope is that the design team would have something (even an interim something) ready for community discussion around the time frame of IETF 99. From there we can figure out what a logical next step would be.

If you’re interested in volunteering and willing to dedicate time to this work over the next several months, please send me email off-list by May 17, 2017 and I’ll sort out the team composition. 

Thanks,
Alissa

---

From: Ted Hardie <[email-masked]>
Date: Tue, 9 May 2017 14:53:03 -0700

Howdy,

On Tue, May 9, 2017 at 1:56 PM, Alissa Cooper <[email-masked]> wrote:

> I think the community is at a point in the IASA 2.0 discussions where we
> are ready to form a design team to start evaluating options for the path
> forward. We have a good articulation of the set of problems we are facing
> in draft-hall-iasa20-workshops-report and draft-daigle-iasa-retrospective.
> We have some sense of the outcome properties that people are looking for
> here, based on list discussion. So I'd like to task a design team to go
> examine potential solutions to the problem set that fit the outcome
> properties, and come back to the community with recommended solutions.

So, I find it somewhat surprising that we are the "form a design team"
phase, as I would have assumed that the next phase was "charter a working
group".  You have an active mailing list, a couple of good -00 drafts, and
a problem to solve.  Writing a charter and going to the community with the
plan and timelines and getting confirmation seems like the next step.

Refreshing my memory with the minutes of the meeting:

https://www.ietf.org/proceedings/98/minutes/minutes-98-iasa20-00.txt

There was no charter discussed and no workplan set out.

> The scope of the solutions to be explored would include:
>
> - Structural and organizational changes, both externally (with ISOC and
> contractors) and internally (within the IAOC and subcommittees)
> For now, changes to the funding model would be out of scope to the extent
> they fall outside the categories above, although the design team's work
> should be informed by the prior discussion of funding challenges. The IAOC
> sponsorship committee is currently in the process of getting off the ground
> and I think it would make sense to have some of that discussion start there
> before merging it back in with the administrative discussion. And I think
> the administrative problems are articulated well enough for a team to get
> going with that focus.
>

My hope is that the design team would have something (even an interim
> something) ready for community discussion around the time frame of IETF 99.
> From there we can figure out what a logical next step would be.
>
> Perhaps I'm totally misunderstanding this.  Is this design team is
preparing a 2nd BoF or a charter for consideration at IETF 99? If so, I am
very supportive.

If the design team, to be picked by the middle of next week, is to be
working on proposals for substantive changes to the IETF structure based on
where the IASA conversations are right now, I think you have to define how
the community consideration of those will take place.  A plenary discussion
at IETF 99 will take us from 77 people at the last IASA 2.0 meeting to a
room of many hundreds; more structure than that seems to me necessary.

If you’re interested in volunteering and willing to dedicate time to this
> work over the next several months, please send me email off-list by May 17,
> 2017 and I’ll sort out the team composition.
>
>
When do you intend to make the design team membership public?

regards,

Ted

> Thanks,
> Alissa
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20
>

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 9 May 2017 15:50:20 -0700

Hi Ted,

Good questions. For a topic like this, I believe it’s premature to charter a working group. The problem list is well defined, but the space of considerations and solutions related to solving those problems is both very wide and potentially includes a number of topics that are outside the scope of your typical IETF working group (e.g., budget, personnel, legal issues). I’d like the design team to spend some time taking all of this under consideration as a means to help structure the next step of the community discussion around a focused approach/solution set. 

That next step might be writing a WG charter. Or it might be more plenary community discussion, or processing a document or two as AD-sponsored, or following some other process. My understanding is that IASA itself was created without a WG being formed, so while in my head it seems like a WG might be useful here down the line, I don’t want to presume at this point that that is the only option.

Also, I’m a big fan of tightly focused WG charters, and I think we need this interim step if we do want to be able to write one, including being able to define precisely what the work of a potential WG would be covering and what its deliverables would be.

The use of a design team was included in Jari’s original project plan, and I agree with him that it’s a useful tool. https://www.ietf.org/blog/2016/11/proposed-project-ietf-administrative-support-2-0/ <https://www.ietf.org/blog/2016/11/proposed-project-ietf-administrative-support-2-0/>
> On May 9, 2017, at 2:53 PM, Ted Hardie <[email-masked]> wrote:
> 
> Howdy,
> 
> On Tue, May 9, 2017 at 1:56 PM, Alissa Cooper <[email-masked] <mailto:[email-masked]>> wrote:
> I think the community is at a point in the IASA 2.0 discussions where we are ready to form a design team to start evaluating options for the path forward. We have a good articulation of the set of problems we are facing in draft-hall-iasa20-workshops-report and draft-daigle-iasa-retrospective. We have some sense of the outcome properties that people are looking for here, based on list discussion. So I'd like to task a design team to go examine potential solutions to the problem set that fit the outcome properties, and come back to the community with recommended solutions.
> 
> So, I find it somewhat surprising that we are the "form a design team" phase, as I would have assumed that the next phase was "charter a working group".  You have an active mailing list, a couple of good -00 drafts, and a problem to solve.  Writing a charter and going to the community with the plan and timelines and getting confirmation seems like the next step.
> 
> https://www.ietf.org/proceedings/98/minutes/minutes-98-iasa20-00.txt <https://www.ietf.org/proceedings/98/minutes/minutes-98-iasa20-00.txt>
> 
> Perhaps I'm totally misunderstanding this.  Is this design team is preparing a 2nd BoF or a charter for consideration at IETF 99? If so, I am very supportive.
> 
> If the design team, to be picked by the middle of next week, is to be working on proposals for substantive changes to the IETF structure based on where the IASA conversations are right now, I think you have to define how the community consideration of those will take place.  A plenary discussion at IETF 99 will take us from 77 people at the last IASA 2.0 meeting to a room of many hundreds; more structure than that seems to me necessary.
> 

I feel like this is a trick question. :-) I would want to announce the membership as soon as it is settled, hopefully not very long after May 17.

Best,
Alissa

> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/iasa20 <https://www.ietf.org/mailman/listinfo/iasa20>
>

---

From: Ted Hardie <[email-masked]>
Date: Tue, 9 May 2017 16:08:09 -0700

Howdy,

On Tue, May 9, 2017 at 3:50 PM, Alissa Cooper <[email-masked]> wrote:

> Hi Ted,
>
> Good questions. For a topic like this, I believe it’s premature to charter
> a working group. The problem list is well defined, but the space of
> considerations and solutions related to solving those problems is both very
> wide and potentially includes a number of topics that are outside the scope
> of your typical IETF working group (e.g., budget, personnel, legal issues).
> I’d like the design team to spend some time taking all of this under
> consideration as a means to help structure the next step of the community
> discussion around a focused approach/solution set.
>
> Ah, I see that I thoroughly misunderstood where you were; looking at the
community discussion you mentioned in IETF 99, I thought you meant
"community discussion to select among alternatives", when you said that the
design team would recommend solutions and the community would discuss next
steps.  I see now that this is a set of recommendations for how to proceed
from there.

> That next step might be writing a WG charter. Or it might be more plenary
> community discussion, or processing a document or two as AD-sponsored, or
> following some other process. My understanding is that IASA itself was
> created without a WG being formed, so while in my head it seems like a WG
> might be useful here down the line, I don’t want to presume at this point
> that that is the only option.
>

> Also, I’m a big fan of tightly focused WG charters, and I think we need
> this interim step if we do want to be able to write one, including being
> able to define precisely what the work of a potential WG would be covering
> and what its deliverables would be.
>
> The use of a design team was included in Jari’s original project plan, and
> I agree with him that it’s a useful tool. https://www.ietf.org/blo
> g/2016/11/proposed-project-ietf-administrative-support-2-0/
>

My mistake here was thinking you were at the design team mentioned in stage
4, not the one mentioned in stage 2; my apologies for the confusion.  I
note that his timeline also presumes that there is a working group set up
in stage 2, but I agree with you that some recommendations from a design
team might not require one ("do nothing" is a mighty short charter).

Thanks for the quick clarification,

Ted

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 25 May 2017 20:42:18 -0400

Many thanks to all those who volunteered to participate on this design team. To keep the group focused and at a somewhat manageable size, I’ve gotten confirmation from the following volunteers to serve on the team:

Brian Haberman
Eric Rescorla
Jari Arkko
Jason Livingood
Joe Hall
Leslie Daigle

They are in the process of getting organized now and I hope/expect they’ll have more info for the community soon about how they plan to work and interface back with this list.

Alissa

> On May 9, 2017, at 4:56 PM, Alissa Cooper <[email-masked]> wrote:
>