Subject: [Iasa20] Diagrams of current vs. Option 2/3

From: Richard Barnes <[email-masked]>
Date: Fri, 16 Feb 2018 13:01:53 -0500

Hey all,

As we're considering the various options available, I thought I would play
cartoonist again (after contributing [1] earlier) and share some diagrams
of how processes might change if we go for one of the subsidiary options
(II or III in the memo from the lawyers).  Based on a whiteboard that
Alissa, Sean, and I sketched out one afternoon:

https://ipv.sx/iasa2.0/IASA-Strawman.pdf

Obviously, the details will need to change as a result of the legal
discussion, but I thought it would be useful to illustrate one possible
realization here.

--Richard

[1] https://ipv.sx/iasa2.0/IASA-org-charts.pdf

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Fri, 16 Feb 2018 13:06:01 -0500

For those of us that are highly-visual learners and thinkers, thank you

On Fri, Feb 16, 2018 at 1:01 PM, Richard Barnes <[email-masked]> wrote:
> cartoonist again (after contributing [1] earlier) and share some diagrams of
> how processes might change if we go for one of the subsidiary options (II or
> III in the memo from the lawyers).  Based on a whiteboard that Alissa, Sean,
> and I sketched out one afternoon:
>
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20
>

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

CDT's Annual Dinner, Tech Prom, is March 29, 2018. Don't miss the tech
event of the year!
Reserve a table today.: https://cdt.org/annual-dinner/

---

From: Ted Hardie <[email-masked]>
Date: Fri, 16 Feb 2018 10:46:40 -0800

Hi Richard,

I note that your diagram includes the IETF Trust, which is not part of this
discussion since it already had a separate legal existence.  I think it
would be cleaner to remove it, especially since the relationship is not
that the IAOC administers the IETF Trust, as this diagram describes it.
The Trustees do; they simply are currently defined in terms of the trust.
I agree that this would need adjustment if the IAOC disappeared, but that's
really a very separate question than the core of the IASA 2.0 work.  On a
related note, the IAD also serves as an ex-officio, non-voting member of
the IAOC (that's why the IAD is a Trustee).

Lastly, this is certainly one way to look at what might get created but it
presumes some structures (like an advisory council and the IETF Admin Org
board having some members selected by the board itself) which have not been
in any of the proposals I've seen.  If the proposals out of the design team
plan to include those, I think having them in drafts before London would be
very useful.

thanks,

Ted

---

From: Richard Barnes <[email-masked]>
Date: Fri, 16 Feb 2018 14:07:02 -0500

Thanks for the clarifications, Ted.  Revised diagram removing Trust and
adding IAD on IAOC:

https://ipv.sx/iasa2.0/IASA-Strawman-NoTrust.pdf

On Fri, Feb 16, 2018 at 1:46 PM, Ted Hardie <[email-masked]> wrote:

> Hi Richard,
>
> I note that your diagram includes the IETF Trust, which is not part of
> this discussion since it already had a separate legal existence.  I think
> it would be cleaner to remove it, especially since the relationship is not
>> As we're considering the various options available, I thought I would
>> play cartoonist again (after contributing [1] earlier) and share some
>> diagrams of how processes might change if we go for one of the subsidiary
>> options (II or III in the memo from the lawyers).  Based on a whiteboard
>> that Alissa, Sean, and I sketched out one afternoon:
>>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 16 Feb 2018 14:22:17 -0500

Richard, that's AWESOME.
Thank you.  Can it go up during the plenary?

Richard Barnes <[email-masked]> wrote:
    > diagrams of how processes might change if we go for one of the
    > subsidiary options (II or III in the memo from the lawyers). Based on a
    > whiteboard that Alissa, Sean, and I sketched out one afternoon:

    > _______________________________________________ iasa20 mailing list
    > [email-masked] https://www.ietf.org/mailman/listinfo/iasa20

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Bob Hinden <[email-masked]>
Date: Fri, 16 Feb 2018 11:27:04 -0800

Richard,

> On Feb 16, 2018, at 11:07 AM, Richard Barnes <[email-masked]> wrote:
> 
> Thanks for the clarifications, Ted.  Revised diagram removing Trust and adding IAD on IAOC:

Better.

I don’t understand the Advisory Council advising both the IETF Admin Org and everything that IETF Admin Org contracts with.  This seems very likely to create conflicts as well as not providing advise to the IETF Admin Org Board.  This also seems to overlap with the IAB oversight of the IANA, RFC Editor, and ISE.

Bob

> I note that your diagram includes the IETF Trust, which is not part of this discussion since it already had a separate legal existence.  I think it would be cleaner to remove it, especially since the relationship is not that the IAOC administers the IETF Trust, as this diagram describes it.  The Trustees do; they simply are currently defined in terms of the trust.   I agree that this would need adjustment if the IAOC disappeared, but that's really a very separate question than the core of the IASA 2.0 work.  On a related note, the IAD also serves as an ex-officio, non-voting member of the IAOC (that's why the IAD is a Trustee).
> 
> Lastly, this is certainly one way to look at what might get created but it presumes some structures (like an advisory council and the IETF Admin Org board having some members selected by the board itself) which have not been in any of the proposals I've seen.  If the proposals out of the design team plan to include those, I think having them in drafts before London would be very useful.
> 
> thanks,
> 
> Ted
> 
> As we're considering the various options available, I thought I would play cartoonist again (after contributing [1] earlier) and share some diagrams of how processes might change if we go for one of the subsidiary options (II or III in the memo from the lawyers).  Based on a whiteboard that Alissa, Sean, and I sketched out one afternoon:
> 
> Obviously, the details will need to change as a result of the legal discussion, but I thought it would be useful to illustrate one possible realization here.
> 
> --Richard
>

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 16 Feb 2018 13:01:03 -0800

> On Feb 16, 2018, at 10:46 AM, Ted Hardie <[email-masked]> wrote:
> 
> Hi Richard,
> 

Agreeing with everything here, but I just wanted to note that in previous discussions folks have said “what about the Trust?” when contemplating various future scenarios. So we were trying to be responsive to that.

Alissa

> On Fri, Feb 16, 2018 at 10:01 AM, Richard Barnes <[email-masked] <mailto:[email-masked]>> wrote:
> Hey all,
> 
> https://ipv.sx/iasa2.0/IASA-Strawman.pdf <https://ipv.sx/iasa2.0/IASA-Strawman.pdf>
> 
> [1] https://ipv.sx/iasa2.0/IASA-org-charts.pdf <https://ipv.sx/iasa2.0/IASA-org-charts.pdf>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/iasa20 <https://www.ietf.org/mailman/listinfo/iasa20>
> 
>

---

From: Lou Berger <[email-masked]>
Date: Fri, 16 Feb 2018 17:09:10 -0500

On 2/16/2018 4:01 PM, Alissa Cooper wrote:
>
>> On Feb 16, 2018, at 10:46 AM, Ted Hardie <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi Richard,
>>
>> I note that your diagram includes the IETF Trust, which is not part 
>> of this discussion since it already had a separate legal existence.  
>> I think it would be cleaner to remove it, especially since the 
>> relationship is not that the IAOC administers the IETF Trust, as this 
>> diagram describes it.  The Trustees do; they simply are currently 
>> defined in terms of the trust.   I agree that this would need 
>> adjustment if the IAOC disappeared, but that's really a very separate 
>> question than the core of the IASA 2.0 work.  On a related note, the 
>> IAD also serves as an ex-officio, non-voting member of the IAOC 
>> (that's why the IAD is a Trustee).
>
> Agreeing with everything here, but I just wanted to note that in 
> previous discussions folks have said “what about the Trust?” when 
> contemplating various future scenarios. So we were trying to be 
> responsive to that.
>

Thanks Alissa,
FWIW I think it's worth keeping in the picture - even if kept in gray...

Lou
> Alissa
>
>>
>> Lastly, this is certainly one way to look at what might get created 
>> but it presumes some structures (like an advisory council and the 
>> IETF Admin Org board having some members selected by the board 
>> itself) which have not been in any of the proposals I've seen.  If 
>> the proposals out of the design team plan to include those, I think 
>> having them in drafts before London would be very useful.
>>
>> thanks,
>>
>> Ted
>>
>>     As we're considering the various options available, I thought I
>>     would play cartoonist again (after contributing [1] earlier) and
>>     share some diagrams of how processes might change if we go for
>>     one of the subsidiary options (II or III in the memo from the
>>     lawyers). Based on a whiteboard that Alissa, Sean, and I sketched
>>     out one afternoon:
>>
>>     <https://ipv.sx/iasa2.0/IASA-Strawman.pdf>
>>
>>     Obviously, the details will need to change as a result of the
>>     legal discussion, but I thought it would be useful to illustrate
>>     one possible realization here.
>>
>>     --Richard
>>
>>     <https://ipv.sx/iasa2.0/IASA-org-charts.pdf>
>>
>>
>>     <https://www.ietf.org/mailman/listinfo/iasa20>
>>
>>