Subject: Re: [Iasa20] -02 I-D: Term Length & Limit

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 15 May 2018 13:27:58 +0000

Thanks for the suggestion on a lifetime limit, Glenn. If others have a viewpoint on this, please feel free to express that.

JL

From: Glenn Deen <[email-masked]>
Date: Monday, May 14, 2018 at 1:58 PM
To: "Livingood, Jason" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [EXTERNAL] [Iasa20] -02 I-D: Term Length & Limit

Both are good with the one comment that I’d still like to see a lifetime limit as this isn’t meant to be a career position and many times were groups have term limits without a lifetime limit you end up with people rotating off then on over and over which still results in ossification

Glenn
Sent from my iPhone

On May 14, 2018, at 10:51 AM, Livingood, Jason <[email-masked]<mailto:[email-masked]>> wrote:
See text in 4.7 and 4.8. https://tools.ietf.org/html/draft-hall-iasa2-struct-02

Any thoughts or reactions?

JL
_______________________________________________
iasa20 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/iasa20

---

From: John Curran <[email-masked]>
Date: Sat, 26 May 2018 12:04:29 -0400

> On 5/15/18 3:02 PM, Bob Hinden wrote:
>  
>  Regarding 4.8.  LLC Board Director Limit:
>  
>  Do we want someone to cycle off for a year and then be put back on?   I think I would prefer a longer time between board positions, like 3 years.
Bob - 

Could you elaborate on the merits of having a longer gap (e.g. 3 years) between serving, as opposed to a 1 year gap?

(I’m having trouble seeing the value of three year gap over one year; i.e. I believe one year gap provides sufficient opportunities to encourage new participants, whereas a three year gap could pose some real downside in times of thin candidates with not being able to bring back someone experienced who remains interested.)

Thanks!
/John