Subject: [Iasa20] Trustee Term Limit

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 8 May 2018 18:44:09 +0000

Earlier discussion led to the potential consensus for 3-year terms. As I noted, however, some of the initial terms may need to be 2 years or we’ll have too much simultaneous turnover in the future. In any case, on the matter of a term limit – do we want to specify one or not? And if so, what shall it be?

For example, ISOC has a two consecutive term limit IIRC. Some external boards will set a limit of between 6 and 10 years, which help regularly bring in new energy and ideas. One approach we might take is similar to ISOC and set it at a maximum of two consecutive terms, or 6 years.

Thoughts?
Jason

P.S. Some helpful reading for opinions on this topic can be found at:
https://www.boardeffect.com/blog/term-limits-for-non-profit-board-members/
https://boardsource.org/wp-content/uploads/2016/08/Term-Limits-Thumbs.pdf
https://trust.guidestar.org/blog/2014/05/23/5-reasons-why-every-npo-board-should-have-term-limits/
http://forsmallnonprofits.com/2015/05/21/lets-have-some-real-talk-about-board-terms-and-term-limits/
https://diligent.com/blog/leaving-board-removing-board-members-term-limits
https://leadingwithintent.org/wp-content/uploads/2017/11/LWI-2017.pdf

---

From: Russ Housley <[email-masked]>
Date: Tue, 8 May 2018 14:55:09 -0400

Jason:

Do we want to indirectly impose a term limit on the IETF Chair?  I do not think so.

We also need to consider someone filing a seat when someone resigns or otherwise steps down.  So, we might want to allow a person to take a partial term and then two more full terms, not to exceed 7 or 8 years.

Russ

> On May 8, 2018, at 2:44 PM, Livingood, Jason <[email-masked]> wrote:
> 
> https://www.boardeffect.com/blog/term-limits-for-non-profit-board-members/ <https://www.boardeffect.com/blog/term-limits-for-non-profit-board-members/>
> https://boardsource.org/wp-content/uploads/2016/08/Term-Limits-Thumbs.pdf <https://boardsource.org/wp-content/uploads/2016/08/Term-Limits-Thumbs.pdf>
> https://trust.guidestar.org/blog/2014/05/23/5-reasons-why-every-npo-board-should-have-term-limits/ <https://trust.guidestar.org/blog/2014/05/23/5-reasons-why-every-npo-board-should-have-term-limits/>
> http://forsmallnonprofits.com/2015/05/21/lets-have-some-real-talk-about-board-terms-and-term-limits/ <http://forsmallnonprofits.com/2015/05/21/lets-have-some-real-talk-about-board-terms-and-term-limits/>
> https://diligent.com/blog/leaving-board-removing-board-members-term-limits <https://diligent.com/blog/leaving-board-removing-board-members-term-limits>
> https://leadingwithintent.org/wp-content/uploads/2017/11/LWI-2017.pdf <https://leadingwithintent.org/wp-content/uploads/2017/11/LWI-2017.pdf>_______________________________________________
> iasa20 mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/iasa20 <https://www.ietf.org/mailman/listinfo/iasa20>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 08 May 2018 15:12:20 -0400

> Do we want to indirectly impose a term limit on the IETF Chair?  I do not think so.

I don't think it would apply to the IETF Chair.

    > We also need to consider someone filing a seat when someone resigns or
    > otherwise steps down.  So, we might want to allow a person to take a
    > partial term and then two more full terms, not to exceed 7 or 8 years.

I was going to say the same thing, so +1 here.

I also was thinking about the situation where the IETF Chair serves a few
terms, and is therefore on the LLC board, and then is appointed via some
process.  How would the term limit apply?  I have many differing opinions about
that.

Does the term limit reset in some fashion?

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [