Subject: [Iasa20] Director Sources - Some Options

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 8 May 2018 15:43:50 +0000

Thanks for the feedback on the sources of the directors (e.g. how they are nominated/appointed). I think we’ve seen a range of views expressed, which makes figuring out which proposals will get good traction a bit difficult. But let me take a run at it and see if any of these options resonate, and of course feel free to comment on the assumptions as well.

Assumptions & Notes:

  1.  I have undoubtedly missed options. There are likely a 10-20 options; I have tried to determine where consensus may lie by narrowing the options based on the discussion I have observed so far.
  2.  Terms will generally be 3 years in length, though some of the initial terms may be set at 2 years so we don’t have too many directors turning over simultaneously in the future. I have started to develop a chart to explain this visually once we converge on one or two of the options below. The initial terms are not a critical decision at the moment.
  3.  One of the directors shall be the acting IETF chairperson.
  4.  The one appointed from the ISOC board is a current trustee. Adding more may over-burden the ISOC trustees, who have enough other work to do.
  5.  Some options include the ability of the LLC board to appoint either up to one or up to two directors.
     *   These would be confirmed by the IAB.
     *   The practical reality is that the board is unlikely to know what they need in the 1st year, and so making it “up to” affords them some level of future flexibility, and it seems unrealistic that they’d be able to quickly appoint one or two people shortly after joining the LLC board and the formation of the LLC itself.
     *   Thus board size will be at least 5 directors and at most 7 directors in the applicable options.

Open Questions:

  1.  Opinions on the options listed below?
  2.  For NomCom selections – will these be confirmed by the IESG or IAB? Perhaps since some are already confirmed by the IAB it is good to have the IESG confirm these?

Option 1:

  *   1 IETF chair
  *   1 Appointed by the ISOC Board of Trustees (who is a Trustee)
  *   2 Appointed by the IETF NomCom, confirmed by the IESG
  *   1 Appointed by the IESG, confirmed by the IAB
  *   Up to 2 Appointed by the LLC board itself, confirmed by IAB

Option 2: (compared to option 1, one shifts from LLC appointment to NomCom)

  *   1 IETF chair
  *   1 Appointed by the ISOC Board of Trustees (who is a Trustee)
  *   3 Appointed by the IETF NomCom, confirmed by the IESG
  *   1 Appointed by the IESG, confirmed by the IAB
  *   Up to 1 Appointed by the LLC board itself, confirmed by IAB

Option 3: (compared to option 1, one shifts from IESG appointment to NomCom)

  *   1 IETF chair
  *   1 Appointed by the ISOC Board of Trustees (who is a Trustee)
  *   3 Appointed by the IETF NomCom, confirmed by the IESG
  *   Up to 2 Appointed by the LLC board itself, confirmed by IAB

Option 4: (compared to option 1, IESG appointment changes to IAB appointment)

  *   1 IETF chair
  *   1 Appointed by the ISOC Board of Trustees (who is a Trustee)
  *   2 Appointed by the IETF NomCom, confirmed by the IESG
  *   1 Appointed by the IAB, confirmed by the IESG
  *   Up to 2 Appointed by the LLC board itself, confirmed by IAB

Thanks in advance for discussion,
Jason

---

From: Michael Richardson <[email-masked]>
Date: Tue, 08 May 2018 13:27:44 -0400

Some clarification questions.

    > 3.  One of the directors shall be the acting IETF chairperson.

As a full voting member?

    > 4.  The one appointed from the ISOC board is a current trustee. Adding
    > more may over-burden the ISOC trustees, who have enough other work to
    > do.

What do you mean, "is a current trustee".
Do you mean, the ISOC board must appoint someone from the ISOC Board?

    > *   These would be confirmed by the IAB.

Why would the IAB confirm these, and the IESG confirm the nomcom appointees?
I'd rather we had the same entity do both.

    > *   The practical reality is that the board is unlikely to know what
    > they need in the 1st year, and so making it “up to” affords them some
    > level of future flexibility, and it seems unrealistic that they’d be
    > able to quickly appoint one or two people shortly after joining the LLC
    > board and the formation of the LLC itself.

okay.
When the board does not appoint the "up to" number, how are the missing
people filled in?

    > 2.  For NomCom selections – will these be confirmed by the IESG or IAB?
    > Perhaps since some are already confirmed by the IAB it is good to have
    > the IESG confirm these?

I feel the opposite. Let one entity become good at it, which ever one you prefer.

    > *   Up to 2 Appointed by the LLC board itself, confirmed by IAB

I prefer this one, except for the confirmed should be identical.
I am agnostic as to IAB vs IESG: there are good reasons for each.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Russ Housley <[email-masked]>
Date: Tue, 8 May 2018 14:01:57 -0400

Jason:
 
> Open Questions:
> Opinions on the options listed below?
> For NomCom selections – will these be confirmed by the IESG or IAB? Perhaps since some are already confirmed by the IAB it is good to have the IESG confirm these? 

None of the options that you offer have zero seats appointed by the LLC board itself.  Sever people spoke in favor of that.

I think IESG confirmation of NomCom appointments is fine.  The IAB is already confirming the IETF Chair appointment anyway.

Russ

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 8 May 2018 14:10:52 -0400

Hi,

>  3. One of the directors shall be the acting IETF chairperson.

I'd seen the option floated "or his/her delgate", and for similar
reasons to the arguments elsewhere
(e.g. draft-hardie-iaoc-iab-update-02), I'd be inclined to support
that, but I'm not willing to argue hard about it.

In decending order, I prefer 4, 3, 1, 2, but I don't feel super
strongly about any of these preferences.

A

-- 
Andrew Sullivan
[email-masked]

---

From: Glenn Deen <[email-masked]>
Date: Wed, 9 May 2018 06:06:17 -0400

> On May 8, 2018, at 11:43 AM, Livingood, Jason <[email-masked]> wrote:
> 
> 1 Appointed by the ISOC Board of Trustees (who is a Trustee)

What’s the rational behind the appointee having to be a trustee?     None of the other appointments have that limitation, meaning that the appointing body can choose any candidate with the right skills.   I’m worried that this limitation would result in too small of a pool of candidates.

And before it’s suggested, I do not think this appointment should ever be the ISOC CEO with the reason that they do not turn over every three years.  If ISOC got into the mode of just appointing the ISOC CEO that would have effect of putting someone on the IETF BoD that lasts well past a 3 year term.  What I mean is you could end up in s situation were you have a seat permanently occupied by the ISOC CEO for as long as they are ISOC CEO.

Term Limits - I think we should have a 9 year lifetime term limit for all regardless of who appoints them, and after they have served a total of 6 years they must have a 6 year cooling off before being eligible again.

So you could maximally serve some any combination of 3 x 3 year terms for 9 lifetime total, and after 6 years of service - regardless of the service terms being back to back or broken up you must be idle for 6.

The purpose of this is to avoid developing a cadre of insiders that get reappointed because the noncom sees them as qualified by the virtue that they did it successfully before, at the expense of other equal or even better candidates.   This behavior has been seen in noncom and appointment processes in a number of similar orgs.

 If we really want fresh ideas and fresh blood to be injected into the system, let’s put in strong term limits up front.

Also, the term limit would be absolute, meaning coming in by a different appointing body doesn’t change anything so we don’t also fall into rotating appointment bodies.

-Glenn Deen (GD)

---

From: Eliot Lear <[email-masked]>
Date: Wed, 9 May 2018 14:25:23 +0200

> that, but I'm not willing to argue hard about it.

Yes- I think the key point goes back to accountability.  That is why I
do not like this business about the IESG or IAB nominating and the other
confirming.  In that way lies zero accountability to the community.  If
the IAB and the IESG want to appoint someone, it should be only from the
pool of people who are already directly held accountable to the NOMCOM.

Eliot

---

From: Eliot Lear <[email-masked]>
Date: Wed, 9 May 2018 14:27:42 +0200

> What’s the rational behind the appointee having to be a trustee?     None of the other appointments have that limitation, meaning that the appointing body can choose any candidate with the right sk…

In this case, I tend to agree.  That might sound like I've just argued
both sides, but I see the ISOC BoT as Those Who Pay The Bills, and thus
the IASA has to be accountable to them in terms of whether the money was
well spent, and not directly to the IETF community.

Eliot

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 9 May 2018 08:47:52 -0400

> well spent, and not directly to the IETF community.

That may not be true in the future, though.  The LLC will possibly
have its own funding source that leaves the LLC without the ongoing
regular contributions from ISOC.  As a disregarded entity of ISOC,
however, it seems pretty clear that the LLC needs to be accountable in
some way to the ISOC BoT.  OTOH, since ISOC will be the only member
and will be able to change any of this at will if it so desires, that
accountability will already exist.

A

-- 
Andrew Sullivan
[email-masked]

---

From: Glenn Deen <[email-masked]>
Date: Wed, 9 May 2018 10:04:19 -0400

> On May 9, 2018, at 8:27 AM, Eliot Lear <[email-masked]> wrote:
> 
> 
> 

To be clear, I agree with ISOC appointing someone, I just don’t want to restrict the pool thry can choose from.  They should be able to chose anyone they want.

Glenn

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 May 2018 10:20:00 +1200

On 09/05/2018 22:06, Glenn Deen wrote:
...
> Also, the term limit would be absolute, meaning coming in by a different appointing body doesn’t change anything so we don’t also fall into rotating appointment bodies.

I think this goes to far, and unduly constrains the pool of candidates. If we settle on 3 year terms, then a limit of two consecutive terms and a 3 year cooling off period seems enough to me. Also, I really don't see the point of a lifetime limit; your formula suggests that someone's "lifetime" in the IETF community will exceed 15 years (3+3+layoff+3). Now it's true that some of us have exceeded that lifetime, but it's relatively rare, and it's even more rare for anyone to want more than 9 years' punishment in a volunteer administrative role.

Regards
    Brian

---

From: "Deen, Glenn" <[email-masked]>
Date: Wed, 9 May 2018 22:53:39 +0000

> I think this goes to far, and unduly constrains the pool of candidates. If we settle on 3 year terms, then a limit of two consecutive terms and a 3 year cooling off period seems enough to me. Also,…

It’s was designed to be limiting.  This isn’t meant to be punitive,  instead it’s saying if you have been able to spend 9 years total on the LLC board including a break , you really need to let some fresh blood into the role.  

Remember this is for an management oversight job , not for being an IETF participant, and it’s never good to have ossification at the management oversight level. 

On a humorous note, if after 9’years and 15 total you want more then we should make them a Transport Area Director. 

Glenn

---

From: Richard Barnes <[email-masked]>
Date: Wed, 09 May 2018 23:44:35 +0000

On Wed, May 9, 2018, 18:53 Deen, Glenn <[email-masked]> wrote:

> >> Term Limits - I think we should have a 9 year lifetime term limit for
> all regardless of who appoints them, and after they have served a total of
> 6 years they must have a 6 year cooling off before being eligible again.
> >>
> >> So you could maximally serve some any combination of 3 x 3 year terms
> for 9 lifetime total, and after 6 years of service - regardless of the
> service terms being back to back or broken up you must be idle for 6.
> >>
> >> The purpose of this is to avoid developing a cadre of insiders that get
> reappointed because the noncom sees them as qualified by the virtue that
> they did it successfully before, at the expense of other equal or even
> better candidates.   This behavior has been seen in noncom and appointment
> processes in a number of similar orgs.
> >>
> >> If we really want fresh ideas and fresh blood to be injected into the
> system, let’s put in strong term limits up front.
> >>
> >> Also, the term limit would be absolute, meaning coming in by a
> different appointing body doesn’t change anything so we don’t also fall
> into rotating appointment bodies.
> >
> > I think this goes to far, and unduly constrains the pool of candidates.
> If we settle on 3 year terms, then a limit of two consecutive terms and a 3
> year cooling off period seems enough to me. Also, I really don't see the
> point of a lifetime limit; your formula suggests that someone's "lifetime"
> in the IETF community will exceed 15 years (3+3+layoff+3). Now it's true
> that some of us have exceeded that lifetime, but it's relatively rare, and
> it's even more rare for anyone to want more than 9 years' punishment in a
> volunteer administrative role.
>
> It’s was designed to be limiting.  This isn’t meant to be punitive,
> instead it’s saying if you have been able to spend 9 years total on the LLC
> board including a break , you really need to let some fresh blood into the
> role.
>
> Remember this is for an management oversight job , not for being an IETF
> participant, and it’s never good to have ossification at the management
> oversight level.
>
> On a humorous note, if after 9’years and 15 total you want more then we
> should make them a Transport Area Director.
>

+1 to all of this, including the TSV part :)

> Glenn
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20
>

---

From: "John Levine" <[email-masked]>
Date: 9 May 2018 20:21:50 -0400

It feels like we're overspecifying things.  How about a convention,
not a rule, of rotating off after six years with the understanding
that there may be reasons to make exceptions.

If it's even a little bit like the IAOC, I don't think the problem
will be people clinging to their seats.

R's,
John

---

From: Richard Barnes <[email-masked]>
Date: Thu, 10 May 2018 00:48:26 +0000

> will be people clinging to their seats.

George Washington's 2-term convention worked fine until it didn't.   If we
have consensus here, let's go ahead and write it down.

--Richard