Subject: Re: [Iasa20] Director Sources - Some Options

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 9 May 2018 16:31:55 +0000

We need to make progress on the structure document and update RFCs 4071 and 4371. What we put together is not something ISOC can unilaterally change; they can only choose to dissolve the entity. But there are many more productive ways to raise issues so I doubt this would occur. 

In any case, let's move back to the other threads...

Thanks
Jason

On 5/9/18, 12:24 PM, "iasa20 on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote:

    Livingood, Jason <[email-masked]> wrote:
        > I'd love to avoid spending time re-visiting charter. Rather, we have an
        > existing structure doc to update and some critical RFCs to update as
    
    Let me explain my question better.
    
    If the number, confirmation, and who appoints things, are *now* in an LLC
    bylaw, but rather are in an operating agreement that is updateable via
    ISOC board motion, then that means we can change things easier.
    I.e. is the amending formula essentially just IETF Consensus?
    
    I think that might make people more willing to experiment.
    
        > well. I've been sending direct questions to the WG list to try to
        > determine what should be in the next structure doc. On some level, what
        > we come up with in the WG will naturally be reflected in the operating
        > agreement, but we have to know what we want first. So if we can, let's
        > focus on some of the key open questions on the source of directors,
        > term length, and so on to help us keep moving the ball forward. There
        > are many more issues to discuss after. Those few as well. __ 
    
        > Thanks
        > Jason
    
        > On 5/9/18, 10:55 AM, "Michael Richardson" <[email-masked]> wrote:

        > Livingood, Jason <[email-masked]> wrote:
        >>> Keeping in mind that the operating agreement we're writing here is
        >> between ISOC and itself, the ISOC board will appoint whoever it wants.
        >> I expect that it will typically be a current board member but it might
        >> be a former board member or someone else with relevant experience
        
        >> [JL] We are not writing the operating agreement; that is outside of the
        >> scope of the WG. We're discussing how to structure the LLC's board, and
        >> we can define it as the community wishes.
        
        > So, how little can we actually say then?
        > How much of what we have been discussing could be left to the operating
        > agreement?   Could we say as little as:
        > The number shall be 7, and the LLC shall determine a method, written in
        > the operating agreement.
        
        > -- 
        > ]               Never tell me the odds!                 | ipv6 mesh networks [ 
        > ]   Michael Richardson, Sandelman Software Works        | network architect  [ 
        > ]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [ 

    -- 
    Michael Richardson <[email-masked]>, Sandelman Software Works
     -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 09 May 2018 12:41:18 -0400

Livingood, Jason <[email-masked]> wrote:
    > We need to make progress on the structure document and update RFCs 4071
    > and 4371. What we put together is not something ISOC can unilaterally
    > change; they can only choose to dissolve the entity. But there are many
    > more productive ways to raise issues so I doubt this would occur.

What I mean, is that the ISOC can easily change it if we update the RFC.
I think it would be useful for consensus on the structure document if we
understood what the amending formula was.

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 10 May 2018 21:19:10 -0400

> On May 9, 2018, at 12:41 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

I checked with our legal counsel Brad on this point. He is subcribed here and can correct me if I have it wrong.

What we are driving towards is an operating agreement between two parties: (1) ISOC and (2) the LLC, a distinct legal entity. From a legal perspective, amending the agreement would require the consent of both parties. Accordingly, once the operating agreement is created, both ISOC and the LLC Board would need to agree to amendments.

In addition, ISOC will retain the right to dissolve the LLC and the operating agreement will contain language describing that. But as Jason says, people should think of this as a last resort, not as the main means of making changes to the arrangements.

So, that is the legal bit. Of course, the law does not speak to which circumstances would require IETF review or IETF consensus. ISTM that the kinds of details that Jason listed earlier today — board appointment processes, responsibilities, term lengths, term limits, removal processes, voting thresholds — are the sorts of things to be documented in the RFC 4071 replacement and are the sorts of things that, if either party desires to amend them, should come back to the IETF for review, at a minimum.

Alissa

> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: "John Levine" <[email-masked]>
Date: 10 May 2018 21:52:09 -0400

In article <[email-masked]> you write:
>What we are driving towards is an operating agreement between two parties: (1) ISOC and (2) the LLC, a distinct
>legal entity. From a legal perspective, amending the agreement would require the consent of both parties.
>Accordingly, once the operating agreement is created, both ISOC and the LLC Board would need to agree to
>amendments.

Sort of.  Assuming it's a DC LLC (since ISOC is a DC corp) the law
says:

  (a) An operating agreement may specify that its amendment requires
  the approval of a person that is not a party to the operating
  agreement or the satisfaction of a condition. An amendment shall be
  ineffective if its adoption does not include the required approval or
  satisfy the specified condition.

I don't think the "person" can be the LLC itself, but it could be some
group of people, or the condition could be affirmation by IETF
consensus.

Having written some LLC operating agreements I beseech this group to
keep it as simple as possible, since every extra sentence is asking
for an argument that will need lawyers resolve.

R's,
John

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 10 May 2018 21:58:04 -0400

Hi John,

> On May 10, 2018, at 9:52 PM, John Levine <[email-masked]> wrote:
> 

Again, it is not this working group’s job to write the operating agreement. That is not within the charter.

Alissa

---

From: "John R Levine" <[email-masked]>
Date: 10 May 2018 22:00:51 -0400

> Again, it is not this working group’s job to write the operating agreement. That is not within the charter.

I'm confused.  If all of the stuff about picking director-like-persons 
doesn't go into the operating agreement, how can it have any effect?

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 10 May 2018 22:17:31 -0400

> On May 10, 2018, at 10:00 PM, John R Levine <[email-masked]> wrote:
> 
> I'm confused.  If all of the stuff about picking director-like-persons doesn't go into the operating agreement, how can it have any effect?

We have two processes going in parallel.

The lawyers are working on the operating agreement. It will have a bunch of terms in it. Some of these terms will need input from the IETF community up front. Other terms will not. Ultimately the WG will have an opportunity to review and comment on a draft of the agreement before it is finalized.

The items that Jason listed out earlier today — board appointment processes, responsibilities, term lengths, term limits, removal processes, and voting thresholds — are the highest priority items where our counsel could benefit from having community input up front. These are also the sorts of items that I would expect the community to want to have documented in an RFC after the operating agreement is finalized.

Alissa

---

From: "John R Levine" <[email-masked]>
Date: 10 May 2018 22:47:27 -0400

> The lawyers are working on the operating agreement. It will have a bunch 
> of terms in it. Some of these terms will need input from the IETF 
> community up front. Other terms will not. Ultimately the WG will have an 
> opportunity to review and comment on a draft of the agreement before it 
> is finalized.

> The items that Jason listed out earlier today — board appointment 
> processes, responsibilities, term lengths, term limits, removal 
> processes, and voting thresholds — are the highest priority items where 
> our counsel could benefit from having community input up front. These 
> are also the sorts of items that I would expect the community to want to 
> have documented in an RFC after the operating agreement is finalized.

This strikes me as a distinction without a difference.  For a 
manager-manged LLC, the operating agreement specifies the rights and 
duties of the manager(s) including how they're selected.  So whatever we 
decide is going to have to be spliced into the agreement.  I suppose we 
could try adding a level of indirection, e.g., the operating agreement 
calls for six people appointed per RFC 9999 and one by ISOC but that seems 
overclever.

In all this I'm assuming that the director-like-persons are the LLC's 
managers (keeping in mind that "manager" has a specific legal meaning for 
an LLC), not a meta-board that will select the manager who would 
be more like the IAD.  A message from Brad a week or two back appeared to 
say that.

R's,
John

---

From: Lou Berger <[email-masked]>
Date: Fri, 11 May 2018 06:21:43 -0400

Alissa

----------

> That is not within the charter.

What is the planned review process for the operating agreement?

Cheers,
Lou