Subject: [Iasa20] WG review: New Version draft-hall-iasa2-struct-04

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 6 Jun 2018 16:53:03 +0000

We have posted a new -04 update, hopefully reflecting recent WG discussion and rough consensus. My perception is we're narrowing the issues down pretty well. So this is a great chance to do a full and close review of this document. After any feedback we get and incorporate into a -05, we can make a few remaining updates, such as adding any necessary RFC 2119 language, updating charts and references as needed, and so on.

Thanks
Jason

On 6/6/18, 11:53 AM, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-hall-iasa2-struct-04.txt
    has been successfully submitted by Brian Haberman and posted to the
    IETF repository.
    
    Name:		draft-hall-iasa2-struct
    Revision:	04
    Title:		Proposed Structure of the IETF Administrative Support Activity (IASA), Version 2.0 (for Discussion)
    Document date:	2018-06-06
    Group:		Individual Submission
    Pages:		17
    URL:            https://www.ietf.org/internet-drafts/draft-hall-iasa2-struct-04.txt
    Status:         https://datatracker.ietf.org/doc/draft-hall-iasa2-struct/
    Htmlized:       https://tools.ietf.org/html/draft-hall-iasa2-struct-04
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-hall-iasa2-struct
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-hall-iasa2-struct-04
    
    Abstract:
       The IETF Administrative Support Activity (IASA) was originally
       established in 2005.  In the 13 years from 2005 to 2018, the needs of
       the IETF have evolved in ways that require changes to its
       administrative structure.  The purpose of this document is to outline
       a proposed new "IASA 2.0" structure.  The proposal is for the work of
       the IETF's administrative and fundraising tasks to be conducted by a
       new administrative organization, the IETF Administration Limited
       Liability Corporation ("LLC").  Under the proposal, the Internet
       Administrative Oversight Committee (IAOC) will be eliminated, and its
       oversight and advising functions transferred to the new LLC Board.

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

---

From: Lucy Lynch <[email-masked]>
Date: Wed, 6 Jun 2018 10:37:53 -0700

On Wed, 6 Jun 2018 16:53:03 +0000
"Livingood, Jason" <[email-masked]> wrote:

> We have posted a new -04 update, hopefully reflecting recent WG
> discussion and rough consensus. My perception is we're narrowing the
> issues down pretty well. So this is a great chance to do a full and
> close review of this document. After any feedback we get and
> incorporate into a -05, we can make a few remaining updates, such as
> adding any necessary RFC 2119 language, updating charts and
> references as needed, and so on.
> 
> Thanks
> Jason

Jason -

Thanks for this - 

I've been following along here and now may be the time to remind folks
that there are updates needed for the NomCom RFCs dating back a couple
of years and this process will push some of those to a critical stage.
The timing within the current proposed appointment cycle for December
'18 as a boot-strap may be do-able but aggressive and the IAOC
appointment process needed up-dating in any case so the LLC Board
process will need to be documented and the cross body appoint problem
will also need to be addressed. 

I'm a little concerned about the additional load on NomCom
participation and time frames - it might be worth thinking about the LLC
appointments as off-cycle with the other two bodies. Delaying the
appoints by one meeting might increase to pool of candidates as well
if folks willing to stand for IAB/IESG but not selected were added in
to the mix.

I'm including the talking points I used for the 2016 NomCom report and
you'll all remember that this included an off-cycle appoint for the ART
AD which also added pressure to the process and may be worth examining
in light of the proposed LLC Board off-cycle appoint options. 

It's also worth mentioning that the NomCom pulls from a smallish pool
of volunteers and as you load up the job and limit the pool (meeting
requirements) this may strain the whole process in unexpected ways.

2 cents

- Lucy

-----------------------------------------------------

NomCom 2016-2017

The Three Stages of the NomCom Process

- Recruit and Select NomCom Members  (March -> July)
  -- Calls for Volunteers
  -- Direct email/Registration tick box volunteers
  -- Random Selection Process
  --- 10 voting members drawn from a pool of 128 volunteers
- Recruit Nominees and Gather Data (July -> November)
  -- Position Descriptions
  -- Call for Nominations
  --- Out of 97 nominations 39 were accepted.
  -- Questionnaires
  -- Community Feedback
  -- Interviews with IAB/IESG/IAOC Chairs
  -- Interviews with exiting IAB/IESG Members
  -- Nominee Interviews (38 on-site in Seoul, 1 by phone)
- Select for Open Positions (November -> March)
  -- NomCom review of all inputs
  -- First order sorting
  -- Discussion of top ranked nominees
  -- Straw Polls/Condorcet ranking/etc.
  -- Up/Down E-Vote to confirm top choices
  -- Submit for approval (IAB/ISOC/IESG)
  -- Announce slates when approved.
  -- Feedback provided to nominees who accepted a nomination on request.

Bonus Round Nominee Process (2016-2017) 

- Recruit/Select/Submit/Announce for short term ART AD vacancy
  -- mandated 6 week time-line start to finish
  -- appointment must run a full year
  -- had to complete before IETF 98
  -- There were 14 nominations and 4 people accepted
  -- Interviews were conducted via WebEX
  -- Selection and Approval process was successful

Areas of Weakness:

- Some Areas have very small leadership pools
  -- OPS/INT/TSV
  --- persistent issue over several NomCom cycles
- Employer support for participation
  -- we are losing good candidates due to lack of support
  -- the value to the IETF and the nominee may be well understood
  -- the value proposition for the employer needs work/promotion
- Clear and distinct position descriptions
  -- The IAOC and IAB material may be too generic for the *randomly
  selected* NomCom members who don't track these bodies closely.
  -- The Operations and Management distinction not always reflected
     in community nominations so may need additional flagging.

IETF Internal Data and Tools:

- Validating status for NomCom volunteers
  -- existing data has some gaps
  -- but this is improving with each round of registrations
- Validating primary email addresses in the data-tracker
  -- some folk don't see their nomination due to stale email in profiles
- Tools and AMS folk provide great support to the NomCom 
  -- The tools depend on good data to function
  -- Tools team was quick to fix issues and small requests
  -- There is a wish list for future features
  -- Still a lot of hand crafted tasks outside the existing tool set

NomCom Lessons Learned (Re-learned):

- We needed a Questionnaire for the IETF Chair position
  -- we used the IESG form but had additional questions
- All of the questionnaires are long but... hard to cut down.
- There is a strong bias toward Two Term appointments
  -- one and three term appointment options engender a lot of discussion
- Nominations and feedback both come from a small sub-set of the
  community -- less then 100 individuals overall
- A "living" NomCom Chairs Best Practices document would be useful

RFC Updates Needed:

- The composition of the IESG has changed (and may again)
  -- document the 3 AD pattern
  -- document the 2 AD (not alike) pattern
- We need to document the process for filling an IESG to IESG move
  --- current text addresses IAB to IESG
  --- additional patterns may also occur

and...

The Elephant in the Room:

- Remote Participation
  -- The NomCom has a 3 of 5 meeting requirement for both
     the Chair and the membership
  -- We had one nominee who has been primarily remote
  -- Visa and meeting location issues

---

From: Ted Hardie <[email-masked]>
Date: Wed, 6 Jun 2018 10:56:04 -0700

I think doing these off-cycle makes a lot of sense; for one thing it lets
folks know who is otherwise booked.  As a side not, that implies that the
IETF chair, if she remains an ex-officio member in the final plan, will be
picked in one cycle and other potential new folks in a different part of
the year.  I think that's a net benefit, but your mileage may vary.

Ted

On Wed, Jun 6, 2018 at 10:37 AM, Lucy Lynch <[email-masked]> wrote:

> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 6 Jun 2018 19:35:05 +0000

Great feedback, Lucy! This is definitely an issue for us to focus on, and lends some urgency to getting some documents out of this WG, including an update to RFC 7437. Timing will be tight but perhaps if we make the changes/updates as narrowly focused as possible it will be easier. We shall see...

Jason

On 6/6/18, 1:39 PM, "iasa20 on behalf of Lucy Lynch" <[email-masked] on behalf of [email-masked]> wrote:

    
    Jason -
    
    Thanks for this - 

    

    2 cents
    
    - Lucy

    NomCom 2016-2017

    

    Areas of Weakness:

    

    
    RFC Updates Needed:

    and...

    - Remote Participation