Subject: [Iasa20] RFC6636bis

From: Bob Hinden <[email-masked]>
Date: Mon, 6 Aug 2018 12:11:50 -0700

Hi,

Jason asked me to take on producing a bis of RFC 6635 "RFC Editor Model (Version 2)”.

I submitted two drafts:

<draft-hinden-iasa2-rfc6635bis-00>

This is an new ID of RFC6635, the only changes were to convert it to an ID.   It is based on the XML that the RFC Editor sent me.  Links are:

   https://www.ietf.org/internet-drafts/draft-hinden-iasa2-rfc6635bis-00.txt
   https://tools.ietf.org/html/draft-hinden-iasa2-rfc6635bis-00
   https://datatracker.ietf.org/doc/draft-hinden-iasa2-rfc6635bis/00/
   https://tools.ietf.org//rfcdiff?url1=https://www.rfc-editor.org/rfc/rfc6635.txt&url2=https://www.ietf.org/archive/id/draft-hinden-iasa2-rfc6635bis-00.txt

<draft-hinden-iasa2-rfc6635bis-01>

Changes are:

      *  Changed occurrences of IASA to IETF Administration Limited
         Liability Corporation ("LLC").
      *  Changed occurrences of IAOC to LLC Board.
      *  Changed occurrences of IAD to LLC Executive Director.
      *  Added paragraph to introduction about purpose of this version
         of the document, and updated Abstract similarly.
      *  Added new editor to acknowledgement section.
      *  Changed document to now oboslete RFC6635.

Links:

   https://www.ietf.org/internet-drafts/draft-hinden-iasa2-rfc6635bis-01.txt
   https://tools.ietf.org/html/draft-hinden-iasa2-rfc6635bis-01
   https://www.ietf.org/rfcdiff?url2=draft-hinden-iasa2-rfc6635bis-01

Please review.  I think it’s pretty close.

Thanks,
Bob

p.s. I will forward the ID emails separately.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 7 Aug 2018 09:01:11 -0700

Make that RFC6635 :-)

Bob

> On Aug 6, 2018, at 12:11 PM, Bob Hinden <[email-masked]> wrote:
> 
> Hi,
>

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 16 Aug 2018 14:49:30 -0400

Hi Bob,

Thanks for taking this up. My one suggestion is to replace “LLC Board” with “LLC” throughout the document. As it is presently structured, the remit of the LLC Board is designed to be quite limited, and the Board has a lot of flexibility to delegate most tasks to the staff, which I think is what the community wants it to do. Using the more generic “LLC” accounts for that flexibility while still being accurate, IMO. It also means that if responsibilities shift between the board and the staff over time (in either or both directions), the document wouldn’t have to be updated.

Thanks,
Alissa

> On Aug 6, 2018, at 3:11 PM, Bob Hinden <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 16 Aug 2018 15:30:39 -0400

Looking at the document, I do not think a simple search and replace will 
work.  While most of the cases can be just the LLC, there seem to be 
exceptions.  For example, the decision to make what would otherwise be 
private financial information public probably needs to be an LLC Board 
decision, not a staff decision.

Yours,
Joel

---

From: Bob Hinden <[email-masked]>
Date: Thu, 16 Aug 2018 15:28:25 -0700

Joel,  Alissa,

> On Aug 16, 2018, at 12:30 PM, Joel M. Halpern <[email-masked]> wrote:
> 
> Looking at the document, I do not think a simple search and replace will work.  While most of the cases can be just the LLC, there seem to be exceptions.  For example, the decision to make what would otherwise be private financial information public probably needs to be an LLC Board decision, not a staff decision.

How about if I add some text to make it clear that the LLC Board can implement what this document specifies in the manner they think is appropriate.   They can direct staff to do it, do it themselves depending on the situation, or something else.

Bob

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 16 Aug 2018 19:06:35 -0400

While I don't really like it, the only alternative seems worse.
That is, we could try to walk through each item in the working group 
deciding which can be left to the LLC, and which need the LLC Board's 
approval.
As that will be veyr painful, and the net benefit comapred with your 
proposal is small, I can live with your proposed text.

Yours,
Joel

---

From: "John Levine" <[email-masked]>
Date: 16 Aug 2018 19:09:23 -0400

>decision, not a staff decision.

I'm with Alissa here.  Put the responsibility on the LLC and let it
decide how to make its decisions.  If the LLC's board is so clueless
it can't figure out what decisions to delegate and what to handle
itself, we've put the wrong people on the board.

As I've said a few times before, I hope we can resist the urge to
micromanage its internal operations.  The more rules we make, the
weirder it'll look to outsiders and the harder it will be to recuit
qualified outside directors.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 16 Aug 2018 19:09:50 -0400

In article <[email-masked]> you write:
>How about if I add some text to make it clear that the LLC Board can implement what this document specifies in the manner they think is
>appropriate.   They can direct staff to do it, do it themselves depending on the situation, or something else.

Just say it's the LLC's responsibility, please.

R's,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 17 Aug 2018 11:29:34 +1200

> Just say it's the LLC's responsibility, please.

I think that works. The LLC Board is a subset of the LLC, not the other
way round. (Yes, we would expect policy decisions to be taken by the
Board, but that is indeed 'cuisine interne' as the French would say.)

   Brian

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 17 Aug 2018 14:47:29 -0400

Joel’s mail prompted me to do a more thorough review. I agree with Brian and John that I do think a straight search and replace would basically work. I identified a couple of areas (below) where a slightly different approach is needed though, and I have a few further comments.

S 1.
>   1.  Introduction
>   
>      This document reflects the experience gained with "RFC Editor Model
>      (Version 1)", documented in [RFC5620], and updates the RFC Editor
>      Model (Version 2) to be aligned with the new IASA 2.0 Model
>      [I-D.ietf-iasa2-struct] that creates a IETF Administration Limited
>      Liability Corporation ("LLC"), and a LLC Board. As part of the IASA

Suggest 'that creates an IETF Administration Limited Liability Company
("LLC") managed by a board of directors ("LLC Board").'

S 1.
>      succession, RFC quality, and RFC document accessibility.  The IAB is
>      also sensitive to the concerns of the IETF Administration Limited
>      Liability Corporation (LLC) about providing the necessary services in

s/IETF Administration Limited Liability Corporation (LLC)/LLC/

S 2.1.1.
>      The RSE is responsible for the performance of the RFC Production
>      Center and Publisher.  The RSE is responsible for issues that go
>      beyond the RFC Production Center or Publisher functions, such as
>      cross-stream coordination of priorities.  Issues that require changes
>      to the budget or contracts shall be brought to the attention of the
>      LLC Executive Director by the RSE.

s/LLC Executive Director/LLC/

(Along the same lines as my prior comment: better not to assume who
will be handling what on the staff of the LLC either.)

S 4.1.
In general this section seems overly prescriptive about the vendor
selection process. Presumably the LLC will have standard procedures
for doing vendor selection. I'm not sure I see the value in specifying
a bespoke process for this particular one, but I do see a downside,
which is that it essentially demands that the LLC enter into a
contract with a particular vendor selected by the committee and take
on the liability associated with doing so. I think it is worth
documenting that the RSE will be involved in the selection process,
but the rest of the detail in this section seems too prescriptive.

S 4.1.
>   
>      As stated earlier, vendor selection is done in cooperation with the
>      streams and under the final authority of the LLC Board.
>   
>      The RSE owns and develops the work definition (the SOW) and
>      participates in the LLC vendor selection process.  The work
>      definition is created within the LLC budget and takes into account
>      the stream managers and community input.

This doesn't seem like it's true now. That is, the work definition of
the RPC is not included in the IETF budget. Perhaps this can be
deleted?

S 4.2.
>   
>      The RFC Series portion of the LLC budget shall include entries for
>      the RSOC, RSE, RFC Production Center, and the RFC Publisher.  The LLC
>      budget shall also include entries for the streams, including the
>      independent stream.

This does not seem true now. There are individual budget line items
for IETF, IRTF, etc., but they don't include any RFC-related expenses
as far as I know. I don't recall ever seeing an RSOC budget line item.

Again I wonder about the value of being this prescriptive, versus
relying on the competence of the administrative staff.

S 4.2.
>      The RSE is responsible for managing the RFC Editor function to
>      operate within those budgets.  If production needs change, the RSE is
>      responsible for working with the Production Center, and where
>      appropriate, other RFC Editor component institutions, relevant
>      streams, and/or the RSOC to determine what the correct response
>      should be.  If they agree that a budgetary change is needed, that

s/LLC Executive Director and the LLC Board/LLC/

S 4.4.
>      to inform future changes to RFC Series policies, including possible
>      updates to this document.
>   
>   4.4.  Issues with Contractual Impact
>   
>      If a disagreement or decision has immediate or future contractual

Not sure what is meant here by "and LLC.”

Thanks,
Alissa

On August 16, 2018 at 3:30:46 PM, Joel M. Halpern ([email-masked]) wrote:

Yours,  
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 17 Aug 2018 14:54:37 -0400

With regard to the degree that 3.4.1 defines the RFP process, the remit 
of these changes makes me doubt we should touch that text.  While I can 
understand Alissa's argument that it is too prescriptive, it is what the 
IETF approved.  The scope of this work is supposed to be ONLY to make 
changes needed for the transition from IAOC to LLC / LLC Board.

With regard to who owns the budget, it has historically been the case 
that tbhe IAD (Ray) did the negotiation on behalf of the IAOC.  Whether 
the budget was actually a separate line item, or was hidden inside other 
budget items to avoid disclosing private details to the public is not my 
concern.  The contract was owned by the IAOC / IAD.
While I rather like the idea of changing that to leave the contract with 
ISOC rather than the LLC, that seems to be a change beyond the scope of 
what we are tasked to do.

Yours,
Joel

PS: The particular example that I found troubling to leave with LLC 
staff was the right to disclose personal information about the 
relationship with the RSE.  It seems to me that if there is a need to 
consider doing so, weighing that is likely a policy matter that belongs 
with the LLC Board.

On 8/17/18 2:47 PM, Alissa Cooper wrote:
> Joel’s mail prompted me to do a more thorough review. I agree with Brian 
> and John that I do think a straight search and replace would basically 
> work. I identified a couple of areas (below) where a slightly different 
> approach is needed though, and I have a few further comments.
> 
> S 1.
>  >   1.  Introduction
>  >
> On August 16, 2018 at 3:30:46 PM, Joel M. Halpern ([email-masked] 
> <mailto:[email-masked]>) wrote:
>

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 17 Aug 2018 15:05:36 -0400

Hi Joel,
On August 17, 2018 at 2:54:46 PM, Joel M. Halpern ([email-masked]) wrote:

With regard to the degree that 3.4.1 defines the RFP process, the remit 
of these changes makes me doubt we should touch that text. While I can 
understand Alissa's argument that it is too prescriptive, it is what the 
IETF approved. 
The IETF will have to approve this bis as well, no doubt. :)

The scope of this work is supposed to be ONLY to make 
changes needed for the transition from IAOC to LLC / LLC Board. 
Maybe this is subtle, but the reason I think the changes I suggested are in scope is because they bear on the difference between the LLC, which is a legal entity, and the IAOC, which is not. We often prescribe rules about how a committee of IETF volunteers does something and that seems perfectly legitimate IMO, but prescribing rules at this level of detail about how a legal entity whose officers are liable for its behavior does that same thing seems inappropriate.

I’m not totally sure which point you are referencing, but my point about the SOW language was just that it makes it sound like the SOW is actually inside the budget document, which it isn’t.

Yours, 
Joel 

If this needs to be documented it seems like a general board policy directive that belongs in draft-ietf-iasa2-struct rather than here.

Thanks,

Alissa

---

From: "John Levine" <[email-masked]>
Date: 17 Aug 2018 15:09:29 -0400

In article <[email-masked]> you write:
>selection process.

I agree that 4.1 and 4.2 are overspecified but since they're copied
verbatim from 6635 other than changing the names, it's probably not
the right time to have this argument.

Your other suggestions look fine.

R's,
John

---

From: Bob Hinden <[email-masked]>
Date: Fri, 17 Aug 2018 15:12:25 -0700

Hi,

> On Aug 17, 2018, at 12:09 PM, John Levine <[email-masked]> wrote:
> 

I agree.   

I will continue to follow this discussion and get ready to produce a new version when the adoption call ends next week.

Bob

---

From: "Livingood, Jason" <[email-masked]>
Date: Sun, 19 Aug 2018 14:05:50 +0000

+1 -- all good points IMO

On 8/16/18, 7:09 PM, "iasa20 on behalf of John Levine" <[email-masked] on behalf of [email-masked]> wrote:

    
    R's,
    John