Subject: [Iasa20] Suresh Krishnan's Yes on draft-ietf-iasa2-trust-update-01: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Wed, 10 Oct 2018 21:03:32 -0700

Suresh Krishnan has entered the following ballot position for
draft-ietf-iasa2-trust-update-01: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-iasa2-trust-update/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

How is the IETF Trust chair picked? I think it might be worth specifying here.
Also, it would be useful to specify what subset the trustees are eligible (e.g.
Nomcom appointees only or all of them) to serve as chair, and how long the
chair's term will be.

(I vaguely remember that the old trust administrative procedures used a 1 year
term and allowed Nomcom, IESG and IAB appointees to the *IAOC* to be chair - so
for sure an update is needed)

---

From: Jari Arkko <[email-masked]>
Date: Thu, 11 Oct 2018 10:18:08 +0300

Thanks for your review, Suresh!

> for sure an update is needed)

Good question.

I’ve been re-reading documents this morning. AFAICT, RFC 7691 is the only place where the chair procedures are talked about (and even that is more focused in IAOC). RFC 4071, 4371, nor the trust founding documents speak about this. 

I *could* add material in the -update document, but I’ll first ask whether there’s a plan to replace 7691, if so, that might be the right place to write these procedures. 

Jari

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 11 Oct 2018 08:51:43 -0400

> On Oct 11, 2018, at 3:18 AM, Jari Arkko <[email-masked]> wrote:
> 

I suspect the simplest thing to do with RFC 7691 is to obsolete it.

For the trust chair we could just add text to trust-update that mirrors the text about the LLC Board chair in iasa2-struct:

Once the initial trustee selections according to the procedures in this document are complete, and at each subsequent annual meeting of the IETF Trust, the trustees shall elect by a majority vote of the IETF Trust one trustee to serve as IETF Trust Chair.  

Alissa

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 11 Oct 2018 13:16:47 +0000

>    I suspect the simplest thing to do with RFC 7691 is to obsolete it.
 
That is our plan - to have the structure draft do so.

>    Once the initial trustee selections according to the procedures in this document are complete, and at each subsequent annual meeting of the IETF Trust, the trustees shall elect by a majority vot…

Thanks for the suggestion - I'll confer w/the other structure editors on this.

Jason

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 11 Oct 2018 09:36:04 -0400

> On Oct 11, 2018, at 9:16 AM, Livingood, Jason <[email-masked]> wrote:
> 

Just to be clear, I meant something like the above text could be added to draft-ietf-iasa2-trust-update. There is already similar language in draft-ietf-iasa2-struct.

Alissa

---

From: Jari Arkko <[email-masked]>
Date: Thu, 11 Oct 2018 17:16:26 +0300

> Once the initial trustee selections according to the procedures in this document are complete, and at each subsequent annual meeting of the IETF Trust, the trustees shall elect by a majority vote o…

Thanks.

I’ve added this text (with some clarifications we discussed offline) to the draft version that will soon appear.

Jari

---

From: "John R Levine" <[email-masked]>
Date: 11 Oct 2018 15:12:36 -0400

> I’ve added this text (with some clarifications we discussed offline) to the draft version that will soon appear.

Neither the current trust document nor the update mentions an annual
meeting.  I think this should do it:

    The trustees shall annually elect by majority vote one trustee to
    serve as IETF Trust Chair.

As usual, I would rather not overspecify things that the trustees can
decide on their own.

R's,
John

---

From: Bob Hinden <[email-masked]>
Date: Thu, 11 Oct 2018 13:59:19 -0700

John,

> On Oct 11, 2018, at 12:12 PM, John R Levine <[email-masked]> wrote:
> 

I agree.  This should be documented at:

https://trustee.ietf.org/trust-administrative-procedures.html

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 12 Oct 2018 11:41:51 +1300

> I’ve added this text (with some clarifications we discussed offline) to the draft version that will soon appear.

For the record, I think this is unnecessary and would be better left to the
Trust's internal procedures document (https://trustee.ietf.org/trust-administrative-procedures.html) which already covers it.

   Brian

---

From: "John R Levine" <[email-masked]>
Date: 12 Oct 2018 00:57:25 -0400

> https://trustee.ietf.org/trust-administrative-procedures.html

I took a look at those procedures.  They're painfully out of date and 
don't describe the way we work now.  I'll talk to the other trustees and 
arrange to update them both to reflect the new way trustees are appointed 
and the way we run the trust.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Bob Hinden <[email-masked]>
Date: Thu, 11 Oct 2018 22:45:08 -0700

> On Oct 11, 2018, at 9:57 PM, John R Levine <[email-masked]> wrote:
> 
> I took a look at those procedures.  They're painfully out of date and don't describe the way we work now.  I'll talk to the other trustees and arrange to update them both to reflect the new way trustees are appointed and the way we run the trust.

Cool, good to hear.

Bob

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 12 Oct 2018 13:16:51 +0000

Hi John/Bob,

> On Oct 12, 2018, at 12:57 AM, John R Levine <[email-masked]> wrote:
> 

Yep. I did remember this was part of the administrative procedures and mentioned it at the end of my comment. That is why I figured an update was needed at least to specify the pool for chair eligibility. Glad that you will look over this and update the procedures to bring them up to date.

Thanks
Suresh

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 12 Oct 2018 09:48:20 -0400

Ok. Suresh, are you fine then with having this documented in the trust procedures and not in the draft?

Thanks,
Alissa

> On Oct 12, 2018, at 9:16 AM, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi John/Bob,
>

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 12 Oct 2018 13:49:23 +0000

Hi Alissa,

> On Oct 12, 2018, at 9:48 AM, Alissa Cooper <[email-masked]> wrote:
> 

Sure. No problems either way.

Thanks
Suresh

---

From: "John R Levine" <[email-masked]>
Date: 12 Oct 2018 09:49:33 -0400

> Yep. I did remember this was part of the administrative procedures and mentioned it at the end of my comment. That is why I figured an update was needed at least to specify the pool for chair eligi…

The procedures currently say that one can appeal a trust decision the same 
way one appeals an IAOC decision in RFC 4071 sec 3.5.  As far as I know 
there has never been an appeal of a trust decision, but we should probably 
have a process.  Is there some other appeals process we can point to?  I 
don't see any for the LLC.

Regards,

---

From: "John R Levine" <[email-masked]>
Date: 13 Oct 2018 16:16:29 -0400

On Fri, 12 Oct 2018, John R Levine wrote:
> way one appeals an IAOC decision in RFC 4071 sec 3.5.  As far as I know there 
> has never been an appeal of a trust decision, but we should probably have a 
> process.  Is there some other appeals process we can point to?  I don't see 
> any for the LLC.

Turns out there is a process in BCP 10 which also happens to be in the 
midst of being updated.  I suggest adding this to trust-update to match 
what's in our draft of the admin procedures.  Keeping in mind that there 
has never been a trust appeal and quite possibly never will be, this is 
the lightest weight process we could think of:

  Any member of the IETF community may appeal a decision of the trust by
  transmitting the appeal to the Chair. The Chair shall present the appeal
  to the Trustees for consideration and possible action, and shall inform
  the appellant of the Trustees’ decision.

  Trustees appointed by the IETF NomCom may be recalled by the member
  recall process described in section 7 of BCP 10. Trustees appointed by the IESG
  or by the ISOC Board of Directors may be recalled by vote of the appointing
  body.

Regards,