Subject: Re: [Iasa20] Last Call: <draft-ietf-iasa2-trust-update-00.txt> (Update to the Selection of Trustees for the IETF Trust) to Best Current Practice

From: "John R Levine" <[email-masked]>
Date: 2 Oct 2018 20:11:02 -0400

>OLD
>The terms of the appointed trustees from IETF NomCom shall be three years.  The initial selection shall be one, two, and three year terms in order to
>initially stagger the terms and thus miminize potential annual Trustee turnover.  The other appointments by the IESG and the ISOC Board of Trustees
>shall be two year terms, with the initial terms being one and two years, respectively.
>
>NEW
>The terms of the appointed trustees from IETF NomCom shall be three years.  The initial selection shall be one, two, and three year terms in order to
>initially stagger the terms and thus miminize potential annual Trustee turnover.  The other appointments by the IESG and the ISOC Board of Trustees
>shall be two year terms, with the initial terms being one and two years, respectively. The term lengths of initial appointees should be measured from
>the First IETF of the year in which they are seated even if they are appointed after the First IETF of the year.

This seems overspecified, and I'd rather leave the language alone.

I presume the goal is that the nomcom shouldn't have to replace all three 
of its people at the same time, which the old text handles.  The two year 
terms of the nomcom and ISOC are already deliberately out of sync with the 
nomcom.  Theoretically if the nomcom and ISOC both decide to pick someone 
new the same year there might be two new people, and possibly one new from 
nomcom if they don't reappoint an incumbent, but that doesn't seem to be 
all that likely nor a big issue.  There will still be at least two 
continuing truetees and almost certainly more.

In practice, people have often resigned from the IAOC mid-term when their 
jobs change, so no matter what the rules say, we're going to have trustees 
appointed at random times.

R's,
John

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 2 Oct 2018 21:06:27 -0400

> On Oct 2, 2018, at 8:11 PM, John R Levine <[email-masked]> wrote:
> 
>> OLD
> I presume the goal is that the nomcom shouldn't have to replace all three of its people at the same time, which the old text handles.  

No. The point of this is that if the current nomcom doesn’t seat people until after IETF 104, those people’s terms will still end at IETF 107, 110, and 113, respectively. Otherwise we could be putting future nomcoms in the weird position of having a different timeline for trust appointments than they have for all their other appointments. The current year’s nomcom is enduring this, but I don’t think we want to make it standard practice. We could do

s/initial appointees/initial NomCom appointees/

in the last sentence if that would help.

This also clarifies that having this year’s nomcom seat the three people by IETF 104 is not a requirement.

Alissa

> The two year terms of the nomcom and ISOC are already deliberately out of sync with the nomcom.  Theoretically if the nomcom and ISOC both decide to pick someone new the same year there might be two new people, and possibly one new from nomcom if they don't reappoint an incumbent, but that doesn't seem to be all that likely nor a big issue.  There will still be at least two continuing truetees and almost certainly more.
> 
> In practice, people have often resigned from the IAOC mid-term when their jobs change, so no matter what the rules say, we're going to have trustees appointed at random times.
> 
> R's,
> John
> 
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: "John R Levine" <[email-masked]>
Date: 2 Oct 2018 21:25:32 -0400

If the goal is to stagger the terms and make them end at the first 
meeting, how about just saying so and let people use their common sense, 
e.g.:

The terms of the trustees shall be from the end of the first IETF meeting 
of a year to the end of the first IETF meeting two or three years later. 
The terms of trustees appointed by the IETF NomCom shall be three years, 
amd those appointmented by the IESG and the ISOC Board of Trustees two 
years. Each appointing body may in its discretion appoint trustees for 
shorter terms to allow the terms to end at at the required time, and/or to 
miminize annual Trustee turnover.

This has the bonus advantage that they don't have to ask for special 
instructions if someone quits at a random time.

R's,
John

---

From: "Leslie Daigle" <[email-masked]>
Date: Thu, 04 Oct 2018 09:41:08 -0400

I understood Alissa’s point to be that the text is clarifying the 
measurement for the initial NomCom appointees, only.  Your comments seem 
to be focused on handling mid-term vacancies, in general.

Talking about both at the same time seems like a confusing conflation.

I think the text update Alissa proposed is good.  I’m less clear on 
whether there is adequate text for handling mid-term vacancies.

Leslie.

On 2 Oct 2018, at 21:25, John R Levine wrote:

> meeting, how about just saying so and let people use their common 
> sense, e.g.:
>
> The terms of the trustees shall be from the end of the first IETF 
> meeting of a year to the end of the first IETF meeting two or three 
> years later. The terms of trustees appointed by the IETF NomCom shall 
> be three years, amd those appointmented by the IESG and the ISOC Board 
> of Trustees two years. Each appointing body may in its discretion 
> appoint trustees for shorter terms to allow the terms to end at at the 
> required time, and/or to miminize annual Trustee turnover.
>

---

From: "John Levine" <[email-masked]>
Date: 4 Oct 2018 12:25:00 -0400

>to be focused on handling mid-term vacancies, in general.

It's about both.  The nomocm isn't a bunch of automatons so it makes
more sense to tell them what result we want rather than how to do it.

Conversely, if we do think that nomcoms are likely to read the rules
overliterally (a plausible concern in view of the recent IAOC
non-appointment) some future nomcom might read Alissa's language to
require that mid-term replacements be for three years rather than to
the end of the existing term.  Yes, that's silly, but we've seen a
fair amount of silly.

R's,
John

---

From: Jari Arkko <[email-masked]>
Date: Fri, 5 Oct 2018 20:47:17 +0300

John, Leslie, Alissa —

I think I have made all the other changes that I needed to make to the draft per comments from the last calls. But your discussion about the staggering text didn’t entirely finish. Alissa wanted text about possible slipping of the initial appointments, John wanted to also deal with mid-term vacancies, and provide more general guidance.

How about this:

      The goal of the staggered initial terms is to minimize potential
      annual Trustee turnover. To maintain the staggered terms, each
      appointing body may in its discretion appoint Trustees for
      shorter terms as needed in exceptional situations, e.g., for
      mid-term vacancies or when an appointment is not ready by
      the time of the first IETF of the year.

Jari

---

From: "John R Levine" <[email-masked]>
Date: 5 Oct 2018 14:08:44 -0400

>      the time of the first IETF of the year.

Looks OK to me.  Let's ship it, so we can go ahead with the changes to the 
trust agreement.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly