Subject: Re: [Iasa20] LLC Board Decision-Making (was: Comments on <draft-ietf-iasa2-rfc4071bis-00>)

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 17 Dec 2018 21:39:18 +0000

(regarding Bob's comment below)
I believe the intent here was to say that the Board would 100% support each decision and if that full consensus / full support was lacking then an individual vote is called. For example, the Board might vote by acclamation on some issues. I guess it depends on the issue. The intent was to use the operation of the ISOC Board's voting as a guide.

What would you suggest in order to address this but not over-specify things. We tried to strike that balance - given the next paragraph makes clear that the LLC Board should establish the details of how voting will work and make that public.

Jason

On 12/13/18, 7:34 PM, "Bob Hinden" <[email-masked]> wrote:
    > 3.7.  IETF LLC Board Decision Making
    > 
    >    The IETF LLC Board attempts to reach consensus on all decisions.  If
    >    the IETF LLC Board cannot achieve a consensus decision, then the IETF
    >    LLC Board may decide by voting.
    
    I would hope that most board decision should be unanimous.  Is that what “concensus” is intended to mean?

---

From: Glenn Deen <[email-masked]>
Date: Mon, 17 Dec 2018 13:46:19 -0800

We should not be specifying how the board does it’s decision making down to this level of detail.   Does this mean that if the board meets,  but has one absent person perhaps due to scheduling conflict that they have to conduct a formal vote with 4 out of the 5,  but if all 5 were present then no vote would be needed?

I suggest we let the board decide and document it’s own procedures for decision making.

Glenn 

Sent from my iPad

> On Dec 17, 2018, at 1:39 PM, Livingood, Jason <[email-masked]> wrote:
> 
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Dec 2018 11:15:59 +1300

> I suggest we let the board decide and document it’s own procedures for decision making.

Yes. This is part of Board of Directors 101, and presumably whatever we write is irrelevant if Maryland law says differently.

   Brian

---

From: Bob Hinden <[email-masked]>
Date: Mon, 17 Dec 2018 14:21:03 -0800

Jason,

> I believe the intent here was to say that the Board would 100% support each decision and if that full consensus / full support was lacking then an individual vote is called. For example, the Board…

Yes, I think that’s a good guide.

> What would you suggest in order to address this but not over-specify things. We tried to strike that balance - given the next paragraph makes clear that the LLC Board should establish the details o…

I think the text would be better if it used words like “unamimous” instead of “concensus”.  That’s the language used by boards I have been involved in.   “Concensus” is something the IETF uses.

Bob

---

From: "John Levine" <[email-masked]>
Date: 17 Dec 2018 22:03:49 -0500

>Yes. This is part of Board of Directors 101, and presumably whatever we write is irrelevant if Maryland law says differently.

I'm confused.  What does Maryland law have to do with anything?

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 17 Dec 2018 22:06:44 -0500

In article <[email-masked]> you write:
>> I believe the intent here was to say that the Board would 100% support each decision and if that full consensus / full
>support was lacking then an individual vote is called. For example, the Board might vote by acclamation on some issues. I guess
>it depends on the issue. The intent was to use the operation of the ISOC Board's voting as a guide.
>
>> What would you suggest in order to address this but not over-specify things. We tried to strike that balance - given the next
>paragraph makes clear that the LLC Board should establish the details of how voting will work and make that public.
>
>I think the text would be better if it used words like “unamimous” instead of “concensus”.  That’s the language used
>by boards I have been involved in.   “Concensus” is something the IETF uses.

I'm with Glenn here -- delete this whole section.  It's overspecified
and unenforcable and will scare away candidates who know how normal
boards work.

R's,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Dec 2018 17:20:21 +1300

> I'm confused.  What does Maryland law have to do with anything?

Nothing whatever. My brain thought "Delaware" and my fingers typed "Maryland." Sorry.

   Brian

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 18 Dec 2018 07:03:24 -0500

On Mon, Dec 17, 2018 at 10:06 PM John Levine <[email-masked]> wrote:

> >> What would you suggest in order to address this but not over-specify
> things. We tried to strike that balance - given the next
> >paragraph makes clear that the LLC Board should establish the details of
> how voting will work and make that public.
> >
> >I think the text would be better if it used words like “unamimous”
> instead of “concensus”.  That’s the language used

John, let me try and turn what you say into a text edit... does this
capture it (remove the first graph and add voting to the second):

OLD

   The IETF LLC Board decides the details about its decision-making
   rules, including its rules for quorum (see Section 5.9), conflict of
   interest (see Section 7.1), and breaking of ties.  These rules are
   expected to be public.

   All IETF LLC Board decisions are expected to be recorded in IETF LLC
   Board minutes, and IETF LLC Board minutes are expected to be
   published in a timely fashion.

NEW

   The IETF LLC Board decides the details about its decision-making
   rules, including its rules for quorum (see Section 5.9), conflict of
   interest (see Section 7.1), voting, and breaking of ties.  These rules
are
   expected to be public.

   All IETF LLC Board decisions are expected to be recorded in IETF LLC
   Board minutes, and IETF LLC Board minutes are expected to be
   published in a timely fashion.

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Glenn Deen <[email-masked]>
Date: Tue, 18 Dec 2018 06:12:00 -0800

Joe,

Sent from my iPad

> On Dec 18, 2018, at 4:03 AM, Joseph Lorenzo Hall <[email-masked]> wrote:
> 
> NEW
> 
>    interest (see Section 7.1), voting, and breaking of ties.  These rules are
>    expected to be public.
> 

I’m concerned about the “All ...decisions are expected to be recorded”.  There are classes of decisions where the decision is confidential these would typically be in areas like personnel, some contracts, legal matters such as lawsuits, and when dealing with individual sponsors and charitable contributors. 

I suggest, “IETF LLC Board decisions that are not confidential are expected to be recorded in the IETF LLC Board minutes.  Board minutes are expected to be published in a timely fashion.”

Glenn

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 18 Dec 2018 14:36:50 +0000

I think perhaps we're confusing keeping confidential who voted (by name) from what was voted on. Recording a vote IMO means we noted for example that the Board voted to approve a motion to hire an IETF Executive Director, by a vote of X in favor, Y opposed, and Z abstaining. 

Anyway, the details of this seem best left to the LLC Board - I don’t think we need this detail in an RFC and it may well be harmful. 

Suggested revision to Joe's proposal:
The IETF LLC Board decides the details about its decision-making
   rules, including its rules for quorum (see Section 5.9), conflict of
   interest (see Section 7.1), voting, and breaking of ties.  These rules are
   expected to be public. 
   
JL

On 12/18/18, 9:12 AM, "iasa20 on behalf of Glenn Deen" <[email-masked] on behalf of [email-masked]> wrote:

    Joe,
    
    Sent from my iPad

    
    
    Glenn

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 18 Dec 2018 10:52:52 -0500

>    published in a timely fashion.

This does not appear to provide for the possibility that the
publication of some decisions need not be immediate.  This was a
constant problem with the IAOC, where minutes used to be delayed for
long periods of time because they contained commercially sensitive
information.  The solution was redactions.  So I'd suggest a friendly
amendment:

    All IETF LLC Board decisions are expected to be recorded in IETF
    LLC Board minutes, and IETF LLC Board minutes are expected to be
    published in a timely fashion, with accommodations for redacting
    commercially- or legally-sensitive information about those
    decisions according to the sole discretion of the IETF LLC Board.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 18 Dec 2018 11:13:07 -0500

For Section 3.7 and all of Section 5 (incidentally, why is the text in Section 3.7 separate from Section 5?), I would encourage people to review Exhibit A of the LLC Agreement and determine whether the text being suggested here is saying something additional to what is there, or whether it is saying something different or inconsistent with what is there. If the text that winds up in this RFC is inconsistent with the LLC Agreement to the point where we need to change the agreement, that should be because the consensus was explicitly to be inconsistent, and not by accident. The text Andrew suggests below, for example, is different enough from Exhibit A #13 to be inconsistent I think. The -02 text in Section 3.7 is IMO inconsistent with Exhibit A #10 which implies that decisions will be made by vote.

Alissa

> On Dec 18, 2018, at 10:52 AM, Andrew Sullivan <[email-masked]> wrote:
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 18 Dec 2018 16:17:13 +0000

Both good points. Let me confer w/Joe on a potential resolution.

On 12/18/18, 11:13 AM, "iasa20 on behalf of Alissa Cooper" <[email-masked] on behalf of [email-masked]> wrote:

    Alissa

---

From: "John R Levine" <[email-masked]>
Date: 18 Dec 2018 11:24:57 -0500

>   interest (see Section 7.1), voting, and breaking of ties.  These rules are

There's nothing particularly wrong with that, but it's obvious (where else 
will the rules come from?) and unenforcable ("no, we won't define a tie 
breaking rule and you can't make us.")

How about:

The IETF LLC Board will publish its operating procedures.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 18 Dec 2018 11:43:18 -0500

Hi,

On Tue, Dec 18, 2018 at 11:13:07AM -0500, Alissa Cooper wrote:
>The text Andrew suggests below, for example, is different enough from Exhibit A #13 to be inconsistent I think.

Hmm.  I didn't think it was.  The text in Exhibit A #13 says, "the
Board must publish a public list of confidential items, describing the
nature of the information and the reason for confidentiality."  But it
doesn't say how the Board makes that decision or on whose authority.
I'm not bothered if the proposed text I offered doesn't get adopted,
but I am worried that the text I was responding to _is_ inconsistent
with Exhibit A #13, precisely because it didn't seem to permit the
carve-out of confidential items that is in Exhibit A.

I share your worry that all of this rewriting by the WG risks creating
subtle inconsistencies that will require amendment, which seems like
work that would be a pity to create by accident (were that to happen).

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 18 Dec 2018 17:37:19 +0000

That is really covered in 3.4, IETF LLC Working Principles, under Transparency. I will add your suggestion of "The IETF LLC Board will publish its operating procedures." to that part. That enables us to remove the problematic 3.7 section entirely, especially since it is generally covered in Section 5 and Exhibit A of the LLC Agreement.

Thanks
Jason

    
    
    How about:

    Regards,

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 18 Dec 2018 16:10:59 -0500

> On Dec 18, 2018, at 11:43 AM, Andrew Sullivan <[email-masked]> wrote:
> 
> Hi,
> 
> nature of the information and the reason for confidentiality.”  

It also says: "whatever doesn't have a specific justification for being kept confidential, should be made public.” But your text said: "IETF LLC Board minutes are expected to be published in a timely fashion, with accommodations for redacting commercially- or legally-sensitive information about those decisions.” Some things are neither commercially nor legally sensitive but should be kept confidential (e.g., some personnel details). So my concern is that we end up with two different standards — one that says “any specific justification” and one that says “the only justifications are commercial or legal sensitivity.” 

Alissa

> But it

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 18 Dec 2018 16:21:07 -0500

Yeah, I agree the text I sent is a bad idea.

A

-- 
Please excuse my clumbsy thums
----------
On December 18, 2018 16:11:06 Alissa Cooper <[email-masked]> wrote:

>>> The text Andrew suggests below, for example, is different enough from 
>>> Exhibit A #13 to be inconsistent I think.
>>
> It also says: "whatever doesn't have a specific justification for being 
> kept confidential, should be made public.” But your text said: "IETF LLC 
> Board minutes are expected to be published in a timely fashion, with 
> accommodations for redacting commercially- or legally-sensitive information 
> about those decisions.” Some things are neither commercially nor legally 
> sensitive but should be kept confidential (e.g., some personnel details). 
> So my concern is that we end up with two different standards — one that 
> says “any specific justification” and one that says “the only 
> justifications are commercial or legal sensitivity.”
>
> Alissa
>
>> But it

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 19 Dec 2018 06:20:38 +0200

On Mon, Dec 17, 2018 at 11:39 PM Livingood, Jason <
[email-masked]> wrote:

> I believe the intent here was to say that the Board would 100% support
> each decision and if that full consensus / full support was lacking then an
> individual vote is called. For example, the Board might vote by acclamation
> on some issues. I guess it depends on the issue. The intent was to use the
> operation of the ISOC Board's voting as a guide.
>

Yes, I support using same as the ISOC board's voting procedure, which may
be modified by the IETF LLC board but the modification should be through an
IETF RFC the board authors.

AB