Subject: Re: [Iasa20] Comments on <draft-ietf-iasa2-rfc4071bis-00>

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 17 Dec 2018 21:53:09 +0000

Selected commets in line below. Note that my responses ended at Bob's feedback up to 5.4. I ran out of time for more review.

JL   

 >    oversight or steering of the standards process as currently conducted
    >    by the Internet Engineering Steering Group (IESG) and Internet
    >    Architecture Board (IAB), the appeals chain, the process for making
    >    and confirming IETF and IAB appointments, the IETF Nominating
    >    Committee (NomCom), the Internet Research Task Force (IRTF), or
    >    ISOC's memberships in or support of other organizations.
    
    I note the NomCom responsibilities are changing, they will now appoint some
    IETF LLC Board members and IETF Trust Trustees.  This text isn't quite
    right.

[JL] Created a PR for Joe's consideration at https://github.com/IASA2/draft-ietf-iasa2-struct/pull/53. 

    >    Although most of the terms, abbreviations, and acronyms used in this
    >    document are reasonably well known, first-time readers may find this
    >    alphabet soup confusing.  This section therefore attempts to provide
    >    a quick summary.
    
    Please rewrite this.   Some of these are well known (IESG, IAB, etc.), but
    the rest (IETF LLC) are not.

[JL] Ack - see PR for Joe at https://github.com/IASA2/draft-ietf-iasa2-struct/pull/54. This depends on another PR that changes "alphabet soup" to "terminology".

>    IASA: The original IETF Administrative Support Activity, defined by
    >    [RFC4071] and obsoleted by this document and the ISOC/IETF LLC
    >    Agreement ([IETF-LLC-A]).

    I disagree.  IASA is the general term that applies to IASA 1.0 and IASA
    2.0.  Perhaps in the future IASA 3.0.

[JL] Ack. See PR for Joe at https://github.com/IASA2/draft-ietf-iasa2-struct/pull/55 

    >    o  The Board of Directors of the IETF LLC - formally a multi-member
    >       "manager" of the IETF LLC on behalf of ISOC - assumed the
    >       oversight responsibilities of the IAOC.
    
    Does [formally a multi-member "manager" of the IETF LLC on behalf of ISOC] need to be here?  Formal part was defined earlier.

[JL] Ack. See PR for Joe at https://github.com/IASA2/draft-ietf-iasa2-struct/pull/56 

    >    The IETF LLC Board is directly accountable to the IETF community for
    >    the performance of the IASA 2.0.  In order to achieve this, the IETF
    >    LLC Board and IETF Executive Director are expected to ensure that
    >    guidelines are developed for regular operational decision making.
    >    Where appropriate, these guidelines should be developed with public
    >    input.  In all cases, they must be made public.
    
    Why is the IETF Executive Director called out here?   Is there a distinction?  Please explain?

[JL] Likely because developing the guidelines for what the IETF Executive Director will decide on a normal basis would be a collaborative development process. I don't see a particular downside here, but certainly speak up if you see one.

    > 3.9.  Community Consensus and Grant of Authority
    > 
    >    The IETF is a consensus-based group, and authority to act on behalf
    >    of the community requires a high degree of consensus and the
    >    continued consent of the community.  After a careful process of
    >    deliberation, a broad-based community consensus emerged to house the
    >    administration of the IETF within the IETF LLC as a disregarded
    >    entity of the Internet Society.  This document reflects that
    >    consensus.
    
    Sorry, when was the IETF Last call to determine "a broad-based community consensus"?
    
    The degree of consensus will be determined when this document is approved via our normal processes (IETF Last Call, IESG review and decision).  This text implies it has already happened.
    
    Please revise.
    
[JL] This text was carried over from RFC 4071. Feel free to propose changes. (also this text does not mention IETF Last call or other process specifics)

    >    o  Obtains appropriate insurance, including commercial general
    >       liability insurance with appropriate limits;
    
    Who will the liability insurance cover?   I believe that we currently have liability insurance down through w.g. chairs.  Will this continue?

[JL] Someone needs to provide insurance - so that is a job for the LLC. This can conceivably cover everything from D&O insurance to general liability insurance. I don't anticipate any changes - which is why we said "obtains appropriate insurance". I don't think it is necessary to get very detailed here in this document unless you want to make a case to the contrary.
    
    >    For the first slot listed above, the presumption is that the IETF
    >    Chair will serve on the board.  At the IESG's discretion, another
    >    area director may serve instead, or exceptionally the IESG may run a
    >    selection process to appoint a director.  The goal of having this
    >    slot on the board is to maintain coordination and communication
    >    between the board and the IESG.
    
    I think it would be good if there was stronger text to encourage the IETF Chair to serve on the board.  Everything will work better if there is closer alignment.

[JL] The WG has had quite a lot of discussion on this issue. You may recall that we initially made it definitely the IETF Chair, then allowed it to be anyone the IESG wanted, then landed on what we have now. This seems to explain the general expectation while providing the IESG with flexibility in the future.
    
    > 5.2.  IETF LLC-Appointed Directors
    
    s/IETF LLC-Appointed Directors/IETF LLC Appointed Directors/
    
    remove the “-“
    
[JL] Not too sure on that one grammatically. JOE: Your thoughts? If we change it, there are a few other places it appears - one of which is a longer sentence that would need to be re-written.

---

From: Bob Hinden <[email-masked]>
Date: Mon, 17 Dec 2018 14:28:33 -0800

Jason,

One comment on your.

Bob

> On Dec 17, 2018, at 1:53 PM, Livingood, Jason <[email-masked]> wrote:
> 
> 
> 

I suggested to Joe that this section should be removed:

> The simplest thing for this document would be to remove the Section entirely.  It’s not needed for what the document is intending to do.  I can’t think of any other document that has text like this.  The IESG can declare a consensus later when it is approved.

Bob

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Mon, 17 Dec 2018 18:28:11 -0500

On Mon, Dec 17, 2018 at 4:53 PM Livingood, Jason <
[email-masked]> wrote:

> Selected commets in line below. Note that my responses ended at Bob's
> feedback up to 5.4. I ran out of time for more review.
> [JL] Not too sure on that one grammatically. JOE: Your thoughts? If we
> change it, there are a few other places it appears - one of which is a
> longer sentence that would need to be re-written.
>

I'm going to leave this as "IETF LLC-appointed" as the adjective modifying
"Directors" here. Happy to be told I am wrong, but I don't think so. best,
Joe

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Mon, 17 Dec 2018 18:30:58 -0500

On Mon, Dec 17, 2018 at 5:28 PM Bob Hinden <[email-masked]> wrote:

> >    The degree of consensus will be determined when this document is
> approved via our normal processes (IETF Last Call, IESG review and
> decision).  This text implies it has already happened.
> >
> >    Please revise.
> >
> > [JL] This text was carried over from RFC 4071. Feel free to propose
> changes. (also this text does not mention IETF Last call or other process
> specifics)
> >
>
> > The simplest thing for this document would be to remove the Section
> entirely.  It’s not needed for what the document is intending to do.  I
> can’t think of any other document that has text like this.  The IESG can
> declare a consensus later when it is approved.
>
>
The point here is that once we get through WGLC and IETF LC that this text
should be accurate on aggregate. I don't think anything in this paragraph
will be incorrect once that happens so I'd like to leave it as is. (I
understand that things have been very different here, but at least Bob
you've been with us the whole IASA2 ride). best, Joe