Subject: [Iasa20] Changes to draft-ietf-iasa2-trust-update wrt relationship to 4071/4371

From: Jari Arkko <[email-masked]>
Date: Thu, 10 Jan 2019 09:35:35 +0100

This draft was approved last year, and is in the RFC Editor’s queue. There’s been a few suggestions about the draft, however, from Brian Carpenter and others. See for instance the thread on RFC 4071bis.

One of the questions relates to whether the draft should now update RFC 4071 given that it is separately being replaced by the 4071bis work. Secondly, there were differing opinions with regards to whether draft-ietf-iasa2-trust-update should entirely replace RFC 4371 or just update it (as the current version does).

I do not personally have a very strong opinion either way on these issues. Originally, when we wrote the update draft its goal was to just change the trustee selection process, nothing else, hence we did not replace RFC 4371 even if it didn’t have much content. And even if the draft updated RFC 4071 I think it is fine for other parts of the overall system change later, including replacing entire 4071, as long as in the end the new work refers to our draft. However, I can also see that less documents and less complex RFC-to-RFC relationships might be good. And I definitely agree with Brian that we need to get the BCP structure and BCP numbers correct.

With that as a background, I have prepared two alternate versions, sending them for your comments here:

* Version “a” (maybe “a" for Alissa as she initially suggested this path forward as one of the options). The is a minimal change to updates, references. This is the least change option.

  See https://arkko.com/ietf/iasa20/draft-ietf-iasa2-trust-update-diff-a.html

* Version “b” (for the Brian Carpenter Extended Edition). This is a more complete draft. This is a slightly bigger change, but results in more self-contained end-result. It still does not change anything about the trust, but copies a paragraph of text from RFC 4371 to the draft.

  See https://arkko.com/ietf/iasa20/draft-ietf-iasa2-trust-update-diff-b.html

Some of this might or might not be doable as RFC Editor instructions rather than re-approval of the changes in the IETF list and at the IESG. Putting that question aside for the moment, lets first figure out what we want first. What would folks prefer?

Jari

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 10 Jan 2019 14:22:13 +0000

Thanks, Jari! Absent substantial WG feedback, I recommend you choose one or the other by the end of this weekend based on your judgement.

Jason

On 1/10/19, 3:35 AM, "iasa20 on behalf of Jari Arkko" <[email-masked] on behalf of [email-masked]> wrote:

    

    

    
    
    Jari
    
    _______________________________________________
    iasa20 mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/iasa20

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 11 Jan 2019 08:19:19 +1300

Strangely enough I prefer the 'b' version, since I think it produces a tidier result by reducing the total number of documents that need to be consulted (by elminating 4371).

I also think this is essentially editorial, and therefore OK to do even after the consensus calls.

Regards
   Brian Carpenter

---

From: Bob Hinden <[email-masked]>
Date: Thu, 10 Jan 2019 12:15:55 -0800

Jari,

> On Jan 10, 2019, at 12:35 AM, Jari Arkko <[email-masked]> wrote:
> 

I have a slight preference for your “b” version because it is, as you wrote, a more complete draft.

I don’t object to this being done in the RFC Editor queue as the changes are being discussed in the w.g..

Thanks,
Bob

---

From: Russ Housley <[email-masked]>
Date: Thu, 10 Jan 2019 15:34:44 -0500

I tend to prefer Choice B.  I think that the context provided by the two additional paragraphs is useful.

Russ

> On Jan 10, 2019, at 9:22 AM, Livingood, Jason <[email-masked]> wrote:
>

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Thu, 10 Jan 2019 17:49:16 -0500

Yes, having just looked at them both, I prefer b too.

On Thu, Jan 10, 2019 at 15:34 Russ Housley <[email-masked]> wrote:

> > Thanks, Jari! Absent substantial WG feedback, I recommend you choose one
> or the other by the end of this weekend based on your judgement.
> >
> > Jason
> >
> > On 1/10/19, 3:35 AM, "iasa20 on behalf of Jari Arkko" <
> [email-masked] on behalf of [email-masked]> wrote:
> >
> >    This draft was approved last year, and is in the RFC Editor’s queue.
> There’s been a few suggestions about the draft, however, from Brian
> Carpenter and others. See for instance the thread on RFC 4071bis.
> >
> >    One of the questions relates to whether the draft should now update
> RFC 4071 given that it is separately being replaced by the 4071bis work.
> Secondly, there were differing opinions with regards to whether
> draft-ietf-iasa2-trust-update should entirely replace RFC 4371 or just
> update it (as the current version does).
> >
> >    I do not personally have a very strong opinion either way on these
> issues. Originally, when we wrote the update draft its goal was to just
> change the trustee selection process, nothing else, hence we did not
> replace RFC 4371 even if it didn’t have much content. And even if the draft
> updated RFC 4071 I think it is fine for other parts of the overall system
> change later, including replacing entire 4071, as long as in the end the
> new work refers to our draft. However, I can also see that less documents
> and less complex RFC-to-RFC relationships might be good. And I definitely
> agree with Brian that we need to get the BCP structure and BCP numbers
> correct.
> >
> >    * Version “a” (maybe “a" for Alissa as she initially suggested this
> path forward as one of the options). The is a minimal change to updates,
> references. This is the least change option.
> >
> >      See
> https://arkko.com/ietf/iasa20/draft-ietf-iasa2-trust-update-diff-a.html
> >
> >    * Version “b” (for the Brian Carpenter Extended Edition). This is a
> more complete draft. This is a slightly bigger change, but results in more
> self-contained end-result. It still does not change anything about the
> trust, but copies a paragraph of text from RFC 4371 to the draft.
> >
> >      See
> https://arkko.com/ietf/iasa20/draft-ietf-iasa2-trust-update-diff-b.html
> >
> >    Some of this might or might not be doable as RFC Editor instructions
> rather than re-approval of the changes in the IETF list and at the IESG.
> Putting that question aside for the moment, lets first figure out what we
> want first. What would folks prefer?
> >
> >    Jari
> >
-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Martin Thomson <[email-masked]>
Date: Fri, 11 Jan 2019 09:56:35 +1100

Nit: HTTPS URIs have a trailing slash rather than a period.  The current form does have the advantage of working with the included period, but perhaps the right way to address that is with <eref target="https://trustee.ietf.org/">.

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 11 Jan 2019 08:05:29 +0200

Thanks, prefer version b,

AB

On Thu, Jan 10, 2019 at 10:35 AM Jari Arkko <[email-masked]> wrote:

> One of the questions relates to whether the draft should now update RFC
> 4071 given that it is separately being replaced by the 4071bis work.
> I do not personally have a very strong opinion either way on these issues.
> Originally, when we wrote the update draft its goal was to just change the
> trustee selection process, nothing else, hence we did not replace RFC 4371
> even if it didn’t have much content. And even if the draft updated RFC 4071
> I think it is fine for other parts of the overall system change later,
> including replacing entire 4071, as long as in the end the new work refers
> to our draft. However, I can also see that less documents and less complex
> RFC-to-RFC relationships might be good. And I definitely agree with Brian
> that we need to get the BCP structure and BCP numbers correct.
>
> * Version “a” (maybe “a" for Alissa as she initially suggested this path
> forward as one of the options). The is a minimal change to updates,
> * Version “b” (for the Brian Carpenter Extended Edition). This is a more
> complete draft. This is a slightly bigger change, but results in more

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Jan 2019 11:30:55 +0100

Thanks for the feedback.

> See https://arkko.com/ietf/iasa20/draft-ietf-iasa2-trust-update-diff-b.html

(There was a slight typo fix based on feedback from Martin).

I will talk to the chairs and ADs offline to figure out the process part, i.e., some kind of an update of an approved draft in AUTH48 or re-approval, or something in between.

Jari

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 17 Jan 2019 15:57:34 +0000

Thanks so much, Jari!

As discussed with the RFC Editor, it appears they have it in a state right now where you can post a doc update that reflects the diff-b changes (unless they provide different direction in that separate off-list email thread). 

Thanks also to the WG for the feedback on this diff and the discussion leading up to it!

Jason

On 1/17/19, 5:31 AM, "iasa20 on behalf of Jari Arkko" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks for the feedback.

    
    
    Jari